gnu: Some cleanup based on lint checkers.
[jackhill/guix/guix.git] / gnu / packages / geeqie.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages geeqie)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module ((guix licenses) #:prefix l:)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages pkg-config)
25 #:use-module (gnu packages glib)
26 #:use-module (gnu packages gtk)
27 #:use-module (gnu packages image)
28 #:use-module ((gnu packages ghostscript)
29 #:select (lcms))
30 #:use-module (gnu packages compression)
31 #:use-module (gnu packages xml))
32
33 (define-public exiv2 ; XXX: move elsewhere?
34 (package
35 (name "exiv2")
36 (version "0.23")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append "http://www.exiv2.org/exiv2-"
40 version ".tar.gz"))
41 (sha256
42 (base32
43 "04bbg2cg6mgcyz435zamx37sp5zw44n2alb59ki1daz71f851yl1"))))
44 (build-system gnu-build-system)
45 (arguments '(#:tests? #f)) ; no `check' target
46 (propagated-inputs
47 `(("expat" ,expat) ("zlib" ,zlib)))
48 (home-page "http://www.exiv2.org/")
49 (synopsis "Library and command-line utility to manage image metadata")
50 (description
51 "Exiv2 is a C++ library and a command line utility to manage image
52 metadata. It provides fast and easy read and write access to the Exif, IPTC
53 and XMP metadata of images in various formats.")
54
55 ;; Files under `xmpsdk' are a copy of Adobe's XMP SDK, licensed under the
56 ;; 3-clause BSD license: <http://www.adobe.com/devnet/xmp/sdk/eula.html>.
57 ;; The core is GPLv2+: <https://launchpad.net/ubuntu/precise/+source/exiv2/+copyright>.
58 (license l:gpl2+)))
59
60 (define-public geeqie
61 (package
62 (name "geeqie")
63 (version "1.1")
64 (source (origin
65 (method url-fetch)
66 (uri (string-append "mirror://sourceforge/geeqie/geeqie-"
67 version ".tar.gz"))
68 (sha256
69 (base32
70 "1kzy39z9505xkayyx7rjj2wda76xy3ch1s5z35zn8yli54ffhi2m"))))
71 (build-system gnu-build-system)
72 (inputs
73 `(;; ("libchamplain" ,libchamplain)
74 ("lcms" ,lcms)
75 ("exiv2" ,exiv2)
76 ("libpng" ,libpng)
77 ("gtk+" ,gtk+-2)))
78 (native-inputs
79 `(("intltool" ,intltool)
80 ("pkg-config" ,pkg-config)))
81 (home-page "http://geeqie.sourceforge.net")
82 (synopsis "Lightweight GTK+ based image viewer")
83 (description
84 "Geeqie is a lightweight GTK+ based image viewer for Unix like operating
85 systems. It features: EXIF, IPTC and XMP metadata browsing and editing
86 interoperability; easy integration with other software; geeqie works on files
87 and directories, there is no need to import images; fast preview for many raw
88 image formats; tools for image comparison, sorting and managing photo
89 collection. Geeqie was initially based on GQview.")
90 (license l:gpl2+)))