gnu: Some cleanup based on lint checkers.
[jackhill/guix/guix.git] / gnu / packages / doxygen.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages doxygen)
20 #:use-module ((guix licenses) #:select (gpl3+))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages bison)
26 #:use-module (gnu packages flex)
27 #:use-module (gnu packages graphviz)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages xml)
30 #:use-module (gnu packages python))
31
32 (define-public doxygen
33 (package
34 (name "doxygen")
35 (version "1.8.7")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "http://ftp.stack.nl/pub/users/dimitri/"
39 name "-" version ".src.tar.gz"))
40 (sha256
41 (base32
42 "1ng3dv5fninhfi2fj75ghkr5jwsl653fxv2sxhaswj11x2vcdsn6"))
43 (patches (list (search-patch "doxygen-tmake.patch")
44 (search-patch "doxygen-test.patch")))))
45 (build-system gnu-build-system)
46 (native-inputs
47 `(("bison" ,bison)
48 ("flex" ,flex)
49 ("libxml2" ,libxml2) ; provides xmllint for the tests
50 ("perl" ,perl) ; for the tests
51 ("python" ,python-2))) ; for creating the documentation
52 (propagated-inputs
53 `(("graphviz" ,graphviz)))
54 (arguments
55 `(#:test-target "test"
56 #:phases
57 (alist-replace
58 'configure
59 (lambda* (#:key outputs #:allow-other-keys)
60 (let ((out (assoc-ref outputs "out")))
61 ;; do not pass "--enable-fast-install", which makes the
62 ;; configure process fail
63 (zero? (system*
64 "./configure"
65 "--prefix" out))))
66 %standard-phases)))
67 (home-page "http://www.stack.nl/~dimitri/doxygen/")
68 (synopsis "Generate documentation from annotated sources")
69 (description "Doxygen is the de facto standard tool for generating
70 documentation from annotated C++ sources, but it also supports other popular
71 programming languages such as C, Objective-C, C#, PHP, Java, Python,
72 IDL (Corba, Microsoft, and UNO/OpenOffice flavors), Fortran, VHDL, Tcl,
73 and to some extent D.")
74 (license gpl3+)))