gnu: Some cleanup based on lint checkers.
[jackhill/guix/guix.git] / gnu / packages / cyrus-sasl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages cyrus-sasl)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages gdbm)
23 #:use-module (gnu packages mit-krb5)
24 #:use-module (gnu packages openssl)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system gnu))
29
30 (define-public cyrus-sasl
31 (package
32 (name "cyrus-sasl")
33 (version "2.1.26")
34 (source (origin
35 (method url-fetch)
36 (uri (list (string-append
37 "http://cyrusimap.org/releases/cyrus-sasl-"
38 version ".tar.gz")
39 (string-append
40 "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
41 version ".tar.gz")))
42 (sha256 (base32
43 "1hvvbcsg21nlncbgs0cgn3iwlnb3vannzwsp6rwvnn9ba4v53g4g"))))
44 (build-system gnu-build-system)
45 (inputs `(("gdbm" ,gdbm)
46 ("mit-krb5" ,mit-krb5)
47 ("openssl" ,openssl)))
48 (arguments
49 '(#:configure-flags (list (string-append "--with-plugindir="
50 (assoc-ref %outputs "out")
51 "/lib/sasl2"))
52
53 ;; The 'plugins' directory has shared source files, such as
54 ;; 'plugin_common.c'. When building the shared libraries there, libtool
55 ;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
56 ;; fail with EEXIST when building things in parallel.
57 #:parallel-build? #f))
58 (synopsis "Simple Authentication Security Layer implementation")
59 (description
60 "SASL (Simple Authentication Security Layer) is an Internet
61 standards-track method for remote computers to authenticate. The Cyrus SASL
62 library makes supporting various SASL mechanisms easy for both client and
63 server writers.")
64 (license (license:bsd-style "file://COPYING"
65 "See COPYING in the distribution."))
66 (home-page "http://cyrusimap.web.cmu.edu/index.php")))