gnu: Some cleanup based on lint checkers.
[jackhill/guix/guix.git] / gnu / packages / avahi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages avahi)
21 #:use-module ((guix licenses) #:select (lgpl2.1+))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages gdbm)
27 #:use-module (gnu packages libdaemon)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages glib)
30 #:use-module (gnu packages xml))
31
32 (define-public avahi
33 (package
34 (name "avahi")
35 (version "0.6.31")
36 (home-page "http://avahi.org")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append home-page "/download/avahi-"
40 version ".tar.gz"))
41 (sha256
42 (base32
43 "0j5b5ld6bjyh3qhd2nw0jb84znq0wqai7fsrdzg7bpg24jdp2wl3"))
44 (patches (list (search-patch "avahi-localstatedir.patch")))))
45 (build-system gnu-build-system)
46 (arguments
47 '(#:configure-flags '("--with-distro=none"
48 "--localstatedir=/var" ; for the DBus socket
49 "--disable-python"
50 "--disable-mono"
51 "--disable-doxygen-doc"
52 "--disable-xmltoman"
53 "--enable-tests"
54 "--disable-qt3" "--disable-qt4"
55 "--disable-gtk" "--disable-gtk3")))
56 (inputs
57 `(("expat" ,expat)
58 ("glib" ,glib)
59 ("dbus" ,dbus)
60 ("gdbm" ,gdbm)
61 ("libdaemon" ,libdaemon)))
62 (native-inputs
63 `(("intltool" ,intltool)
64 ("glib" ,glib "bin")
65 ("pkg-config" ,pkg-config)))
66 (synopsis "Implementation of mDNS/DNS-SD protocols")
67 (description
68 "Avahi is a system which facilitates service discovery on a local
69 network. It is an implementation of the mDNS (for \"Multicast DNS\") and
70 DNS-SD (for \"DNS-Based Service Discovery\") protocols.")
71 (license lgpl2.1+)))
72
73 (define-public nss-mdns
74 (package
75 (name "nss-mdns")
76 (version "0.10")
77 (source (origin
78 (method url-fetch)
79 (uri (list
80 (string-append
81 "mirror://debian/pool/main/n/nss-mdns/nss-mdns_"
82 version ".orig.tar.gz")
83 "http://pkgs.fedoraproject.org/repo/pkgs/nss-mdns/nss-mdns-0.10.tar.gz/03938f17646efbb50aa70ba5f99f51d7/nss-mdns-0.10.tar.gz"
84
85 ;; This used to be the canonical URL but it vanished.
86 ;; See <http://bugs.gnu.org/18704>.
87 ;; (string-append
88 ;; "http://0pointer.de/lennart/projects/nss-mdns/nss-mdns-"
89 ;; version ".tar.gz")
90 ))
91 (sha256
92 (base32
93 "0vgs6j0qsl0mwzh5a0m0bykr7x6bx79vnbyn0r3q289rghp3qs0y"))
94 (file-name (string-append name "-" version ".tar.gz"))))
95 (build-system gnu-build-system)
96
97 ;; XXX: Stale URL, missing replacement. See <http://bugs.gnu.org/18704>.
98 (home-page "http://0pointer.de/lennart/projects/nss-mdns/")
99
100 (synopsis "The mDNS Name Service Switch (NSS) plug-in")
101 (description
102 "Nss-mdns is a plug-in for the Name Service Switch (NSS) functionality
103 of the GNU C Library, providing host name resolution via Multicast DNS (mDNS).
104 It allows for name resolution by programs in the ad-hoc mDNS domain
105 '.local'.")
106 (license lgpl2.1+)))