gnu: libdrm: Switch to meson-build-system.
[jackhill/guix/guix.git] / gnu / packages / python-check.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages python-check)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages check)
23 #:use-module (gnu packages python-web)
24 #:use-module (gnu packages python-xyz)
25 #:use-module (guix utils)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system python))
30
31 (define-public python-coveralls
32 (package
33 (name "python-coveralls")
34 (version "1.6.0")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (pypi-uri "coveralls" version))
39 (sha256
40 (base32
41 "1dswhd2q2412wrldi97hdwlsymj9pm79v7pvjx53z5wh2d33w8bg"))))
42 (build-system python-build-system)
43 (propagated-inputs
44 `(("python-coverage" ,python-coverage)
45 ("python-docopt" ,python-docopt)
46 ("python-pyyaml" ,python-pyyaml)
47 ("python-requests" ,python-requests)
48 ("python-sh" ,python-sh)
49 ("python-urllib3" ,python-urllib3)))
50 (native-inputs
51 `(("python-mock" ,python-mock)
52 ("python-pytest" ,python-pytest)))
53 (home-page "https://github.com/coveralls-clients/coveralls-python")
54 (synopsis "Show coverage stats online via coveralls.io")
55 (description
56 "Coveralls.io is a service for publishing code coverage statistics online.
57 This package provides seamless integration with coverage.py (and thus pytest,
58 nosetests, etc...) in Python projects.")
59 (license license:expat)))