gnu: kdenlive: Add missing dependencies.
[jackhill/guix/guix.git] / gnu / packages / shells.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014, 2015 David Thompson <davet@gnu.org>
4 ;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
5 ;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
6 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2016 Stefan Reichör <stefan@xsteve.at>
8 ;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
9 ;;; Copyright © 2017, 2018 Nikita <nikita@n0.is>
10 ;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
11 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
12 ;;; Copyright © 2019 Meiyo Peng <meiyo.peng@gmail.com>
13 ;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
14 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
15 ;;; Copyright © 2019, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
16 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
17 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
18 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
19 ;;;
20 ;;; This file is part of GNU Guix.
21 ;;;
22 ;;; GNU Guix is free software; you can redistribute it and/or modify it
23 ;;; under the terms of the GNU General Public License as published by
24 ;;; the Free Software Foundation; either version 3 of the License, or (at
25 ;;; your option) any later version.
26 ;;;
27 ;;; GNU Guix is distributed in the hope that it will be useful, but
28 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
29 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
30 ;;; GNU General Public License for more details.
31 ;;;
32 ;;; You should have received a copy of the GNU General Public License
33 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
34
35 (define-module (gnu packages shells)
36 #:use-module (gnu packages)
37 #:use-module (gnu packages autotools)
38 #:use-module (gnu packages base)
39 #:use-module (gnu packages bash)
40 #:use-module (gnu packages bison)
41 #:use-module (gnu packages documentation)
42 #:use-module (gnu packages groff)
43 #:use-module (gnu packages guile)
44 #:use-module (gnu packages libbsd)
45 #:use-module (gnu packages libedit)
46 #:use-module (gnu packages linux)
47 #:use-module (gnu packages ncurses)
48 #:use-module (gnu packages pcre)
49 #:use-module (gnu packages perl)
50 #:use-module (gnu packages pkg-config)
51 #:use-module (gnu packages python)
52 #:use-module (gnu packages python-xyz)
53 #:use-module (gnu packages readline)
54 #:use-module (gnu packages scheme)
55 #:use-module (guix build-system cmake)
56 #:use-module (guix build-system gnu)
57 #:use-module (guix build-system python)
58 #:use-module (guix build-system trivial)
59 #:use-module (guix download)
60 #:use-module (guix git-download)
61 #:use-module (guix licenses)
62 #:use-module (guix packages)
63 #:use-module (guix utils))
64
65 (define-public dash
66 (package
67 (name "dash")
68 (version "0.5.11.2")
69 (source
70 (origin
71 (method url-fetch)
72 (uri (string-append "http://gondor.apana.org.au/~herbert/dash/files/"
73 "dash-" version ".tar.gz"))
74 (sha256
75 (base32 "0pvdpm1cgfbc25ramn4305a0158yq031q1ain4dc972rnxl7vyq0"))
76 (modules '((guix build utils)))
77 (snippet
78 '(begin
79 ;; The man page hails from BSD, where (d)ash is the default shell.
80 ;; This isn't the case on Guix or indeed most other GNU systems.
81 (substitute* "src/dash.1"
82 (("the standard command interpreter for the system")
83 "a command interpreter based on the original Bourne shell"))
84 #t))))
85 (build-system gnu-build-system)
86 (inputs
87 `(("libedit" ,libedit)))
88 (arguments
89 '(#:configure-flags '("--with-libedit")))
90 (home-page "http://gondor.apana.org.au/~herbert/dash")
91 (synopsis "POSIX-compliant shell optimised for size")
92 (description
93 "dash is a POSIX-compliant @command{/bin/sh} implementation that aims to be
94 as small as possible, often without sacrificing speed. It is faster than the
95 GNU Bourne-Again Shell (@command{bash}) at most scripted tasks. dash is a
96 direct descendant of NetBSD's Almquist Shell (@command{ash}).")
97 (license (list bsd-3
98 gpl2+)))) ; mksignames.c
99
100 (define-public fish
101 (package
102 (name "fish")
103 (version "3.1.2")
104 (source
105 (origin
106 (method url-fetch)
107 (uri (string-append "https://github.com/fish-shell/fish-shell/"
108 "releases/download/" version "/"
109 "fish-" version ".tar.gz"))
110 (sha256
111 (base32 "1vblmb3x2k2cb0db5jdyflppnlqsm7i6jjaidyhmvaaw7ch2gffm"))
112 (modules '((guix build utils)))
113 (snippet
114 '(begin
115 (delete-file-recursively "pcre2-10.32") #t))))
116 (build-system cmake-build-system)
117 (inputs
118 `(("fish-foreign-env" ,fish-foreign-env)
119 ("ncurses" ,ncurses)
120 ("pcre2" ,pcre2) ; don't use the bundled PCRE2
121 ("python" ,python))) ; for fish_config and manpage completions
122 (native-inputs
123 `(("doxygen" ,doxygen)
124 ; for 'fish --help'
125 ("groff" ,groff)))
126 (arguments
127 '(#:phases
128 (modify-phases %standard-phases
129 (add-after 'unpack 'set-env
130 (lambda _
131 ;; some tests write to $HOME
132 (setenv "HOME" (getcwd))
133 #t))
134 (add-after 'unpack 'patch-tests
135 (lambda* (#:key inputs #:allow-other-keys)
136 (let ((coreutils (assoc-ref inputs "coreutils"))
137 (bash (assoc-ref inputs "bash")))
138 ;; This test fails
139 (delete-file "tests/checks/pipeline-pgroup.fish")
140 ;; These try to open a terminal
141 (delete-file "tests/checks/interactive.fish")
142 (delete-file "tests/checks/login-interactive.fish")
143 ;; These contain absolute path references
144 (substitute* "src/fish_tests.cpp"
145 (("/bin/echo" echo) (string-append coreutils echo))
146 (("/bin/ca" ca) (string-append coreutils ca))
147 (("\"(/bin/c)\"" _ c) (string-append "\"" coreutils c "\""))
148 (("/bin/ls_not_a_path" ls-not-a-path)
149 (string-append coreutils ls-not-a-path))
150 (("/bin/ls" ls) (string-append coreutils ls))
151 (("(/bin/)\"" _ bin) (string-append coreutils bin "\""))
152 (("/bin -" bin) (string-append coreutils bin))
153 (((string-append
154 "do_test\\(is_potential_path\\("
155 "L\"/usr\", wds, vars, PATH_REQUIRE_DIR\\)\\);"))
156 ""))
157 (substitute*
158 (append (find-files "tests" ".*\\.(in|out|err)$")
159 (find-files "tests/checks" ".*\\.fish"))
160 (("/bin/pwd" pwd) (string-append coreutils pwd))
161 (("/bin/echo" echo) (string-append coreutils echo))
162 (("/bin/sh" sh) (string-append bash sh))
163 (("/bin/ls" ls) (string-append coreutils ls)))
164 (substitute* (find-files "tests" ".*\\.(in|out|err)$")
165 (("/usr/bin") (string-append coreutils "/bin")))
166 #t)))
167 ;; Source /etc/fish/config.fish from $__fish_sysconf_dir/config.fish.
168 (add-after 'patch-tests 'patch-fish-config
169 (lambda _
170 (let ((port (open-file "etc/config.fish" "a")))
171 (display (string-append
172 "\n\n"
173 "# Patched by Guix.\n"
174 "# Source /etc/fish/config.fish.\n"
175 "if test -f /etc/fish/config.fish\n"
176 " source /etc/fish/config.fish\n"
177 "end\n")
178 port)
179 (close-port port))
180 #t))
181 ;; Embed absolute paths.
182 (add-before 'install 'embed-absolute-paths
183 (lambda _
184 (substitute* "share/functions/__fish_print_help.fish"
185 (("nroff") (which "nroff")))
186 #t))
187 ;; Enable completions, functions and configurations in user's and
188 ;; system's guix profiles by adding them to __extra_* variables.
189 (add-before 'install 'patch-fish-extra-paths
190 (lambda _
191 (let ((port (open-file "share/__fish_build_paths.fish" "a")))
192 (display
193 (string-append
194 "\n\n"
195 "# Patched by Guix.\n"
196 "# Enable completions, functions and configurations in user's"
197 " and system's guix profiles by adding them to __extra_*"
198 " variables.\n"
199 "set -l __guix_profile_paths ~/.guix-profile"
200 " /run/current-system/profile\n"
201 "set __extra_completionsdir"
202 " $__guix_profile_paths\"/etc/fish/completions\""
203 " $__guix_profile_paths\"/share/fish/vendor_completions.d\""
204 " $__extra_completionsdir\n"
205 "set __extra_functionsdir"
206 " $__guix_profile_paths\"/etc/fish/functions\""
207 " $__guix_profile_paths\"/share/fish/vendor_functions.d\""
208 " $__extra_functionsdir\n"
209 "set __extra_confdir"
210 " $__guix_profile_paths\"/etc/fish/conf.d\""
211 " $__guix_profile_paths\"/share/fish/vendor_conf.d\""
212 " $__extra_confdir\n")
213 port)
214 (close-port port))
215 #t))
216 ;; Use fish-foreign-env to source /etc/profile.
217 (add-before 'install 'source-etc-profile
218 (lambda* (#:key inputs #:allow-other-keys)
219 (let ((port (open-file "share/__fish_build_paths.fish" "a")))
220 (display
221 (string-append
222 "\n\n"
223 "# Patched by Guix.\n"
224 "# Use fish-foreign-env to source /etc/profile.\n"
225 "if status is-login\n"
226 " set fish_function_path "
227 (assoc-ref inputs "fish-foreign-env") "/share/fish/functions"
228 " $__fish_datadir/functions\n"
229 " fenv source /etc/profile\n"
230 " set -e fish_function_path\n"
231 "end\n")
232 port)
233 (close-port port))
234 #t)))))
235 (synopsis "The friendly interactive shell")
236 (description
237 "Fish (friendly interactive shell) is a shell focused on interactive use,
238 discoverability, and friendliness. Fish has very user-friendly and powerful
239 tab-completion, including descriptions of every completion, completion of
240 strings with wildcards, and many completions for specific commands. It also
241 has extensive and discoverable help. A special @command{help} command gives
242 access to all the fish documentation in your web browser. Other features
243 include smart terminal handling based on terminfo, an easy to search history,
244 and syntax highlighting.")
245 (home-page "https://fishshell.com/")
246 (license gpl2)))
247
248 (define-public fish-foreign-env
249 (package
250 (name "fish-foreign-env")
251 (version "0.20190116")
252 (source
253 (origin
254 (method git-fetch)
255 (uri (git-reference
256 (url "https://github.com/oh-my-fish/plugin-foreign-env")
257 (commit "dddd9213272a0ab848d474d0cbde12ad034e65bc")))
258 (file-name (git-file-name name version))
259 (sha256
260 (base32 "00xqlyl3lffc5l0viin1nyp819wf81fncqyz87jx8ljjdhilmgbs"))))
261 (build-system trivial-build-system)
262 (arguments
263 '(#:modules ((guix build utils))
264 #:builder
265 (begin
266 (use-modules (guix build utils))
267 (let* ((source (assoc-ref %build-inputs "source"))
268 (out (assoc-ref %outputs "out"))
269 (func-path (string-append out "/share/fish/functions")))
270 (mkdir-p func-path)
271 (copy-recursively (string-append source "/functions")
272 func-path)
273
274 ;; Embed absolute paths.
275 (substitute* `(,(string-append func-path "/fenv.fish")
276 ,(string-append func-path "/fenv.apply.fish")
277 ,(string-append func-path "/fenv.main.fish"))
278 (("bash")
279 (string-append (assoc-ref %build-inputs "bash") "/bin/bash"))
280 (("sed")
281 (string-append (assoc-ref %build-inputs "sed") "/bin/sed"))
282 ((" tr ")
283 (string-append " " (assoc-ref %build-inputs "coreutils")
284 "/bin/tr ")))))))
285 (inputs
286 `(("bash" ,bash)
287 ("coreutils" ,coreutils)
288 ("sed" ,sed)))
289 (home-page "https://github.com/oh-my-fish/plugin-foreign-env")
290 (synopsis "Foreign environment interface for fish shell")
291 (description "@code{fish-foreign-env} wraps bash script execution in a way
292 that environment variables that are exported or modified get imported back
293 into fish.")
294 (license expat)))
295
296 (define-public rc
297 (package
298 (name "rc")
299 (version "1.7.4")
300 (source (origin
301 (method git-fetch)
302 (uri (git-reference
303 (url "https://github.com/rakitzis/rc")
304 (commit (string-append "v" version))))
305 (sha256
306 (base32
307 "0vj1h4pcg13vxsiydmmk87dr2sra9h4gwx0c4q6fjsiw4in78rrd"))
308 (file-name (git-file-name name version))))
309 (build-system gnu-build-system)
310 (arguments
311 `(#:configure-flags
312 '("--with-edit=gnu")
313 #:phases
314 (modify-phases %standard-phases
315 (add-before 'bootstrap 'patch-trip.rc
316 (lambda _
317 (substitute* "trip.rc"
318 (("/bin/pwd") (which "pwd"))
319 (("/bin/sh") (which "sh"))
320 (("/bin/rm") (which "rm"))
321 (("/bin\\)") (string-append (dirname (which "rm")) ")")))
322 #t)))))
323 (inputs `(("readline" ,readline)
324 ("perl" ,perl)))
325 (native-inputs `(("autoconf" ,autoconf)
326 ("automake" ,automake)
327 ("libtool" ,libtool)
328 ("pkg-config" ,pkg-config)))
329 (synopsis "Alternative implementation of the rc shell by Byron Rakitzis")
330 (description
331 "This is a reimplementation by Byron Rakitzis of the Plan 9 shell. It
332 has a small feature set similar to a traditional Bourne shell.")
333 (home-page "https://github.com/rakitzis/rc")
334 (license zlib)))
335
336 (define-public es
337 (package
338 (name "es")
339 (version "0.9.1")
340 (source
341 (origin
342 (method url-fetch)
343 (uri (string-append "https://github.com/wryun/es-shell/releases/"
344 "download/v" version "/es-" version ".tar.gz"))
345 (sha256
346 (base32
347 "1fplzxc6lncz2lv2fyr2ig23rgg5j96rm2bbl1rs28mik771zd5h"))
348 (file-name (string-append name "-" version ".tar.gz"))))
349 (build-system gnu-build-system)
350 (arguments
351 `(#:test-target "test"
352 #:phases
353 (modify-phases %standard-phases
354 (add-before 'configure 're-enter-rootdir
355 ;; The tarball has no folder.
356 (lambda _
357 (chdir ".."))))))
358 (inputs
359 `(("readline" ,readline)))
360 (native-inputs
361 `(("bison" ,bison)))
362 (synopsis "Extensible shell with higher-order functions")
363 (description
364 "Es is an extensible shell. The language was derived from the Plan 9
365 shell, rc, and was influenced by functional programming languages, such as
366 Scheme, and the Tcl embeddable programming language. This implementation is
367 derived from Byron Rakitzis's public domain implementation of rc, and was
368 written by Paul Haahr and Byron Rakitzis.")
369 (home-page "https://wryun.github.io/es-shell/")
370 (license public-domain)))
371
372 (define-public tcsh
373 (package
374 (name "tcsh")
375 (version "6.22.02")
376 (source (origin
377 (method url-fetch)
378 ;; Old tarballs are moved to old/.
379 (uri (list (string-append "ftp://ftp.astron.com/pub/tcsh/"
380 "tcsh-" version ".tar.gz")
381 (string-append "ftp://ftp.astron.com/pub/tcsh/"
382 "old/tcsh-" version ".tar.gz")))
383 (sha256
384 (base32
385 "0nw8prz1n0lmr82wnpyhrzmki630afn7p9cfgr3vl00vr9c72a7d"))
386 (patches (search-patches "tcsh-fix-autotest.patch"))
387 (patch-flags '("-p0"))))
388 (build-system gnu-build-system)
389 (native-inputs
390 `(("autoconf" ,autoconf)
391 ("perl" ,perl)))
392 (inputs
393 `(("ncurses" ,ncurses)))
394 (arguments
395 `(#:phases
396 (modify-phases %standard-phases
397 ,@(if (%current-target-system)
398 '((add-before 'configure 'set-cross-cc
399 (lambda _
400 (substitute* "configure"
401 (("CC_FOR_GETHOST=\"cc\"")
402 "CC_FOR_GETHOST=\"gcc\""))
403 #t)))
404 '())
405 (add-before 'check 'patch-test-scripts
406 (lambda _
407 ;; Take care of pwd
408 (substitute* '("tests/commands.at" "tests/variables.at")
409 (("/bin/pwd") (which "pwd")))
410 ;; The .at files create shell scripts without shebangs. Erk.
411 (substitute* "tests/commands.at"
412 (("./output.sh") "/bin/sh output.sh"))
413 (substitute* "tests/syntax.at"
414 (("; other_script.csh") "; /bin/sh other_script.csh"))
415 ;; Now, let's generate the test suite and patch it
416 (invoke "make" "tests/testsuite")
417
418 ;; This file is ISO-8859-1 encoded.
419 (with-fluids ((%default-port-encoding #f))
420 (substitute* "tests/testsuite"
421 (("/bin/sh") (which "sh"))))
422 #t))
423 (add-after 'install 'post-install
424 (lambda* (#:key inputs outputs #:allow-other-keys)
425 (let* ((out (assoc-ref %outputs "out"))
426 (bin (string-append out "/bin")))
427 (with-directory-excursion bin
428 (symlink "tcsh" "csh"))
429 #t))))))
430 (home-page "https://www.tcsh.org/")
431 (synopsis "Unix shell based on csh")
432 (description
433 "Tcsh is an enhanced, but completely compatible version of the Berkeley
434 UNIX C shell (csh). It is a command language interpreter usable both as an
435 interactive login shell and a shell script command processor. It includes a
436 command-line editor, programmable word completion, spelling correction, a
437 history mechanism, job control and a C-like syntax.")
438 (license bsd-4)))
439
440 (define-public zsh
441 (package
442 (name "zsh")
443 (version "5.8")
444 (source (origin
445 (method url-fetch)
446 (uri (list (string-append
447 "https://www.zsh.org/pub/zsh-" version
448 ".tar.xz")
449 (string-append
450 "https://www.zsh.org/pub/old/zsh-" version
451 ".tar.xz")))
452 (sha256
453 (base32
454 "09yyaadq738zlrnlh1hd3ycj1mv3q5hh4xl1ank70mjnqm6bbi6w"))))
455 (build-system gnu-build-system)
456 (arguments `(#:configure-flags
457 `("--with-tcsetpgrp"
458 "--enable-pcre"
459 "--enable-maildir-support"
460 ;; share/zsh/site-functions isn't populated
461 "--disable-site-fndir"
462 ,(string-append
463 "--enable-additional-fpath="
464 "/usr/local/share/zsh/site-functions," ; for foreign OS
465 "/run/current-system/profile/share/zsh/site-functions"))
466 #:phases
467 (modify-phases %standard-phases
468 (add-before 'configure 'fix-sh
469 (lambda _
470 ;; Some of the files are ISO-8859-1 encoded.
471 (with-fluids ((%default-port-encoding #f))
472 (substitute*
473 '("configure"
474 "configure.ac"
475 "Src/exec.c"
476 "Src/mkmakemod.sh"
477 "Config/installfns.sh"
478 "Config/defs.mk.in"
479 "Test/E01options.ztst"
480 "Test/A05execution.ztst"
481 "Test/A01grammar.ztst"
482 "Test/A06assign.ztst"
483 "Test/B02typeset.ztst"
484 "Completion/Unix/Command/_init_d"
485 "Util/preconfig")
486 (("/bin/sh") (which "sh"))))))
487 (add-before 'check 'patch-test
488 (lambda _
489 ;; In Zsh, `command -p` searches a predefined set of
490 ;; paths that don't exist in the build environment. See
491 ;; the assignment of 'path' in Src/init.c'
492 (substitute* "Test/A01grammar.ztst"
493 (("command -pv") "command -v")
494 (("command -p") "command ")
495 (("'command' -p") "'command' "))
496 #t)))))
497 (native-inputs `(("autoconf" ,autoconf)))
498 (inputs `(("ncurses" ,ncurses)
499 ("pcre" ,pcre)
500 ("perl" ,perl)))
501 (synopsis "Powerful shell for interactive use and scripting")
502 (description "The Z shell (zsh) is a Unix shell that can be used
503 as an interactive login shell and as a powerful command interpreter
504 for shell scripting. Zsh can be thought of as an extended Bourne shell
505 with a large number of improvements, including some features of bash,
506 ksh, and tcsh.")
507 (home-page "https://www.zsh.org/")
508
509 ;; The whole thing is under an MIT/X11-style license, but there's one
510 ;; command, 'Completion/Unix/Command/_darcs', which is under GPLv2+.
511 (license gpl2+)))
512
513 (define-public xonsh
514 (package
515 (name "xonsh")
516 (version "0.9.21")
517 (source
518 (origin
519 (method url-fetch)
520 (uri (pypi-uri "xonsh" version))
521 (sha256
522 (base32 "1mih5w73wp57fnf1vcxnfmm5d31vm7pz8fq5a9vw1ch3dv0yczl5"))
523 (modules '((guix build utils)))
524 (snippet
525 `(begin
526 ;; Delete bundled PLY.
527 (delete-file-recursively "xonsh/ply")
528 (substitute* "setup.py"
529 (("\"xonsh\\.ply\\.ply\",") ""))
530 ;; Use our properly packaged PLY instead.
531 (substitute* (list "setup.py"
532 "tests/test_lexer.py"
533 "xonsh/__amalgam__.py"
534 "xonsh/lexer.py"
535 "xonsh/parsers/base.py"
536 "xonsh/xonfig.py")
537 (("from xonsh\\.ply\\.(.*) import" _ module)
538 (format #f "from ~a import" module))
539 (("from xonsh\\.ply import") "import"))
540 #t))))
541 (build-system python-build-system)
542 (arguments
543 '(;; TODO Try running run the test suite.
544 ;; See 'requirements-tests.txt' in the source distribution for more
545 ;; information.
546 #:tests? #f))
547 (inputs
548 `(("python-ply" ,python-ply)))
549 (home-page "https://xon.sh/")
550 (synopsis "Python-ish shell")
551 (description
552 "Xonsh is a Python-ish, BASHwards-looking shell language and command
553 prompt. The language is a superset of Python 3.4+ with additional shell
554 primitives that you are used to from Bash and IPython. It works on all major
555 systems including Linux, Mac OSX, and Windows. Xonsh is meant for the daily
556 use of experts and novices alike.")
557 (license bsd-2)))
558
559 (define-public scsh
560 (let ((commit "114432435e4eadd54334df6b37fcae505079b49f")
561 (revision "1"))
562 (package
563 (name "scsh")
564 (version (string-append "0.0.0-" revision "." (string-take commit 7)))
565 (source
566 (origin
567 (method git-fetch)
568 (uri (git-reference
569 (url "https://github.com/scheme/scsh")
570 (commit commit)))
571 (file-name (string-append name "-" version "-checkout"))
572 (sha256
573 (base32
574 "1ghk08akiz7hff1pndi8rmgamgcrn2mv9asbss9l79d3c2iaav3q"))))
575 (build-system gnu-build-system)
576 (arguments
577 `(#:test-target "test"
578 #:phases
579 (modify-phases %standard-phases
580 (add-before 'configure 'replace-rx
581 (lambda* (#:key inputs #:allow-other-keys)
582 (let* ((rx (assoc-ref inputs "scheme48-rx"))
583 (rxpath (string-append rx "/share/scheme48-"
584 ,(package-version scheme48)
585 "/rx")))
586 (delete-file-recursively "rx")
587 (symlink rxpath "rx"))
588 #t)))))
589 (inputs
590 `(("scheme48" ,scheme48)
591 ("scheme48-rx" ,scheme48-rx)))
592 (native-inputs
593 `(("autoconf" ,autoconf)
594 ("automake" ,automake)))
595 (home-page "https://github.com/scheme/scsh")
596 (synopsis "Unix shell embedded in Scheme")
597 (description
598 "Scsh is a Unix shell embedded in Scheme. Scsh has two main
599 components: a process notation for running programs and setting up pipelines
600 and redirections, and a complete syscall library for low-level access to the
601 operating system.")
602 (license bsd-3))))
603
604 (define-public linenoise
605 (let ((commit "2105ce445821381cf1bca87b6d386d4ea88ee20d")
606 (revision "1"))
607 (package
608 (name "linenoise")
609 (version (string-append "1.0-" revision "." (string-take commit 7)))
610 (source
611 (origin
612 (method git-fetch)
613 (uri (git-reference
614 (url "https://github.com/antirez/linenoise")
615 (commit commit)))
616 (file-name (string-append name "-" version "-checkout"))
617 (sha256
618 (base32
619 "1z16qwix8z6a40fskdgxsibkqgdrp4q6ncp4n6hnv4r9iihy2d8r"))))
620 (build-system gnu-build-system)
621 (arguments
622 `(#:tests? #f ; no tests are included
623 #:make-flags
624 (list ,(string-append "CC=" (cc-for-target)))
625 #:phases
626 (modify-phases %standard-phases
627 (delete 'configure)
628 (replace 'install
629 (lambda* (#:key outputs #:allow-other-keys)
630 ;; At the moment there is no 'make install' in upstream.
631 (let* ((out (assoc-ref outputs "out")))
632 (install-file "linenoise.h"
633 (string-append out "/include/linenoise"))
634 (install-file "linenoise.c"
635 (string-append out "/include/linenoise"))
636 #t))))))
637 (home-page "https://github.com/antirez/linenoise")
638 (synopsis "Minimal zero-config readline replacement")
639 (description
640 "Linenoise is a minimal, zero-config, readline replacement.
641 Its features include:
642
643 @enumerate
644 @item Single and multi line editing mode with the usual key bindings
645 @item History handling
646 @item Completion
647 @item Hints (suggestions at the right of the prompt as you type)
648 @item A subset of VT100 escapes, ANSI.SYS compatible
649 @end enumerate\n")
650 (license bsd-2))))
651
652 (define-public s-shell
653 (let ((commit "da2e5c20c0c5f477ec3426dc2584889a789b1659")
654 (revision "2"))
655 (package
656 (name "s-shell")
657 (version (git-version "0.0.0" revision commit))
658 (source
659 (origin
660 (method git-fetch)
661 (uri (git-reference
662 (url "https://github.com/rain-1/s")
663 (commit commit)))
664 (file-name (string-append name "-" version "-checkout"))
665 (sha256
666 (base32
667 "0qiny71ww5nhzy4mnc8652hn0mlxyb67h333gbdxp4j4qxsi13q4"))))
668 (build-system gnu-build-system)
669 (inputs
670 `(("linenoise" ,linenoise)))
671 (arguments
672 `(#:tests? #f
673 #:make-flags (list "CC=gcc"
674 (string-append "PREFIX="
675 (assoc-ref %outputs "out")))
676 #:phases
677 (modify-phases %standard-phases
678 (add-after 'unpack 'install-directory-fix
679 (lambda* (#:key outputs #:allow-other-keys)
680 (let* ((out (assoc-ref outputs "out"))
681 (bin (string-append out "/bin")))
682 (substitute* "Makefile"
683 (("out") bin))
684 #t)))
685 (add-after 'install 'manpage
686 (lambda* (#:key outputs #:allow-other-keys)
687 (install-file "s.1" (string-append (assoc-ref outputs "out")
688 "/share/man/man1"))))
689 (replace 'configure
690 (lambda* (#:key inputs outputs #:allow-other-keys)
691 ;; At this point linenoise is meant to be included,
692 ;; so we have to really copy it into the working directory
693 ;; of s.
694 (let* ((linenoise (assoc-ref inputs "linenoise"))
695 (noisepath (string-append linenoise "/include/linenoise"))
696 (out (assoc-ref outputs "out")))
697 (copy-recursively noisepath "linenoise")
698 (substitute* "s.c"
699 (("/bin/s") (string-append out "/bin/s")))
700 #t))))))
701 (home-page "https://github.com/rain-1/s")
702 (synopsis "Extremely minimal shell with the simplest syntax possible")
703 (description
704 "S is a new shell that aims to be extremely simple.
705 S does not implemnt the POSIX shell standard.
706 There are no globs or \"splatting\" where a variable $FOO turns into multiple
707 command line arguments. One token stays one token forever.
708 This is a \"no surprises\" straightforward approach.
709
710 There are no redirection operators > in the shell language, they are added as
711 extra programs. > is just another unix command, < is essentially cat(1).
712 A @code{andglob} program is also provided along with s.")
713 (license bsd-3))))
714
715 (define-public oksh
716 (package
717 (name "oksh")
718 (version "0.5.9")
719 (source
720 (origin
721 (method url-fetch)
722 (uri (string-append "https://connochaetos.org/oksh/oksh-"
723 version ".tar.gz"))
724 (sha256
725 (base32
726 "0ln9yf6pxngsviqszv8klnnvn8vcpplvj1njdn8xr2y8frkbw8r3"))))
727 (build-system gnu-build-system)
728 (arguments
729 `(; The test files are not part of the distributed tarball.
730 #:tests? #f))
731 (home-page "https://connochaetos.org/oksh")
732 (synopsis "Port of OpenBSD Korn Shell")
733 (description
734 "Oksh is a port of the OpenBSD Korn Shell.
735 The OpenBSD Korn Shell is a cleaned up and enhanced ksh.")
736 (license gpl3+)))
737
738 (define-public loksh
739 (package
740 (name "loksh")
741 (version "6.6")
742 (source
743 (origin
744 (method git-fetch)
745 (uri (git-reference
746 (url "https://github.com/dimkr/loksh")
747 (commit version)))
748 (file-name (git-file-name name version))
749 (sha256
750 (base32 "1a8s64n97ikvvi7ckirxnnjvcmhr3dd4rnqm2ivapyzb0wp42jk7"))))
751 (build-system gnu-build-system)
752 (inputs
753 `(("libbsd" ,libbsd)
754 ("ncurses" ,ncurses)))
755 (native-inputs
756 `(("pkg-config" ,pkg-config)))
757 (arguments
758 `(#:tests? #f ; no tests included
759 #:make-flags (list "CC=gcc" "HAVE_LIBBSD=1"
760 (string-append "PREFIX="
761 (assoc-ref %outputs "out")))
762 #:phases
763 (modify-phases %standard-phases
764 (delete 'configure)))) ; no configure script
765 (home-page "https://github.com/dimkr/loksh")
766 (synopsis "Korn Shell from OpenBSD")
767 (description
768 "loksh is a Linux port of OpenBSD's @command{ksh}. It is a small,
769 interactive POSIX shell targeted at resource-constrained systems.")
770 ;; The file 'LEGAL' says it is the public domain, and the 2
771 ;; exceptions which are listed are not included in this port.
772 (license public-domain)))
773
774 (define-public mksh
775 (package
776 (name "mksh")
777 (version "58")
778 (source
779 (origin
780 (method url-fetch)
781 (uri (string-append "https://www.mirbsd.org/MirOS/dist/mir/mksh/mksh-R"
782 version ".tgz"))
783 (sha256
784 (base32 "1337zjvzh14yncg9igdry904a3ns52l8rnm1kcq262w7f5xyp2v0"))))
785 (build-system gnu-build-system)
786 (arguments
787 `(#:tests? #f ; tests require access to /dev/tty
788 #:phases
789 (modify-phases %standard-phases
790 (delete 'configure)
791 (replace 'build
792 (lambda _
793 (setenv "CC" "gcc")
794 (invoke (which "sh") "Build.sh")))
795 (replace 'install
796 (lambda* (#:key outputs #:allow-other-keys)
797 (let* ((out (assoc-ref outputs "out"))
798 (bin (string-append out "/bin"))
799 (man (string-append out "/share/man/man1")))
800 (install-file "mksh" bin)
801 (with-directory-excursion bin
802 (symlink "mksh" "ksh"))
803 (install-file "mksh.1" man)
804 #t))))))
805 (home-page "https://www.mirbsd.org/mksh.htm")
806 (synopsis "Korn Shell from MirBSD")
807 (description "mksh is an actively developed free implementation of the
808 Korn Shell programming language and a successor to the Public Domain Korn
809 Shell (pdksh).")
810 (license (list miros
811 isc)))) ; strlcpy.c
812
813 (define-public oil
814 (package
815 (name "oil")
816 ;; https://www.oilshell.org/blog/2020/04/release-0.8.pre4.html#comment-on-version-numbering
817 (version "0.8.pre6")
818 (source
819 (origin
820 (method url-fetch)
821 (uri (string-append "https://www.oilshell.org/download/oil-"
822 version ".tar.gz"))
823 (sha256
824 (base32 "11nfwn5b1w74hv78065jg2zm45mqzi59381b0f649j7n3g7yp3iq"))))
825 (build-system gnu-build-system)
826 (arguments
827 `(#:strip-binaries? #f ; strip breaks the binary
828 #:phases
829 (modify-phases %standard-phases
830 (replace 'configure
831 (lambda* (#:key outputs #:allow-other-keys)
832 (let ((out (assoc-ref outputs "out")))
833 (setenv "CC" "gcc")
834 (substitute* "configure"
835 ((" cc ") " $CC "))
836 (invoke "./configure" (string-append "--prefix=" out)
837 "--with-readline"))))
838 (replace 'check
839 ;; The tests are not distributed in the tarballs but upstream
840 ;; recommends running this smoke test.
841 ;; https://github.com/oilshell/oil/blob/release/0.8.pre6/INSTALL.txt#L38-L48
842 (lambda _
843 (let* ((oil "_bin/oil.ovm"))
844 (invoke/quiet oil "osh" "-c" "echo hi")
845 (invoke/quiet oil "osh" "-n" "configure")))))))
846 (inputs
847 `(("readline" ,readline)))
848 (home-page "https://www.oilshell.org")
849 (synopsis "Programming language and Bash-compatible Unix shell")
850 (description "Oil is a programming language with automatic translation for
851 Bash. It includes osh, a Unix/POSIX shell that runs unmodified Bash
852 scripts.")
853 (license (list psfl ; tarball includes python2.7
854 asl2.0))))
855
856 (define-public oil-shell
857 (deprecated-package "oil-shell" oil))
858
859 (define-public gash
860 (package
861 (name "gash")
862 (version "0.2.0")
863 (source
864 (origin (method url-fetch)
865 (uri (string-append "mirror://savannah/gash/gash-"
866 version ".tar.gz"))
867 (sha256
868 (base32
869 "13m0yz5h9nj3x40mr6wr5xcpq1lscndfwcicw3skrz801025hhgf"))
870 (modules '((guix build utils)))
871 (snippet
872 '(begin
873 ;; Allow builds with Guile 3.0.
874 (substitute* "configure"
875 (("search=\"2\\.2 2\\.0\"")
876 "search=\"3.0 2.2 2.0\""))
877 #t))))
878 (build-system gnu-build-system)
879 (native-inputs
880 `(("pkg-config" ,pkg-config)))
881 (inputs
882 `(("guile" ,guile-3.0)))
883 (arguments
884 '(#:make-flags '("XFAIL_TESTS=tests/redirects.org")))
885 (home-page "https://savannah.nongnu.org/projects/gash/")
886 (synopsis "POSIX-compatible shell written in Guile Scheme")
887 (description "Gash is a POSIX-compatible shell written in Guile
888 Scheme. It provides both the shell interface, as well as a Guile
889 library for parsing shell scripts. Gash is designed to bootstrap Bash
890 as part of the Guix bootstrap process.")
891 (license gpl3+)))
892
893 (define-public gash-utils
894 (package
895 (name "gash-utils")
896 (version "0.1.0")
897 (source (origin
898 (method url-fetch)
899 (uri (string-append "mirror://savannah/gash/gash-utils-"
900 version ".tar.gz"))
901 (sha256
902 (base32
903 "0ib2p52qmbac5n0s5bys4fiwim461ps546976l1n7pwbs0avh7fk"))
904 (patches (search-patches "gash-utils-ls-test.patch"))
905 (modules '((guix build utils)))
906 (snippet
907 '(begin
908 ;; Allow builds with Guile 3.0.
909 (substitute* "configure"
910 (("search=\"2\\.2 2\\.0\"")
911 "search=\"3.0 2.2 2.0\""))
912 #t))))
913 (build-system gnu-build-system)
914 (native-inputs
915 `(("pkg-config" ,pkg-config)))
916 (inputs
917 `(("guile" ,guile-3.0)
918 ("gash" ,gash)))
919 (home-page "https://savannah.nongnu.org/projects/gash/")
920 (synopsis "Core POSIX utilities written in Guile Scheme")
921 (description "Gash-Utils provides Scheme implementations of many
922 common POSIX utilities (there are about 40 of them, ranging in
923 complexity from @command{false} to @command{awk}). The utilities are
924 designed to be capable of bootstrapping their standard GNU counterparts.
925 Underpinning these utilities are many Scheme interfaces for manipulating
926 files and text.")
927 (license gpl3+)))
928