gnu: kdenlive: Add missing dependencies.
[jackhill/guix/guix.git] / gnu / packages / gd.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
6 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
8 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages gd)
26 #:use-module (guix packages)
27 #:use-module (guix build-system gnu)
28 #:use-module (guix build-system perl)
29 #:use-module (guix download)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages perl)
32 #:use-module (gnu packages image)
33 #:use-module (gnu packages imagemagick)
34 #:use-module (gnu packages fontutils)
35 #:use-module (gnu packages compression)
36 #:use-module (gnu packages pkg-config)
37 #:use-module ((guix licenses) #:select (non-copyleft perl-license)))
38
39 (define-public gd
40 (package
41 (name "gd")
42 ;; Note: With libgd.org now pointing to github.com, genuine old
43 ;; tarballs are no longer available. Notably, versions 2.0.x are
44 ;; missing.
45 (version "2.3.0")
46 (source (origin
47 (method url-fetch)
48 (uri (string-append
49 "https://github.com/libgd/libgd/releases/download/gd-"
50 version "/libgd-" version ".tar.xz"))
51 (sha256
52 (base32
53 "0n5czhxzinvjvmhkf5l9fwjdx5ip69k5k7pj6zwb6zs1k9dibngc"))
54 (patches (search-patches "gd-fix-tests-on-i686.patch"
55 "gd-brect-bounds.patch"))))
56 (build-system gnu-build-system)
57 (arguments
58 ;; As recommended by github.com/libgd/libgd/issues/278 to fix rounding
59 ;; issues on aarch64 and other architectures.
60 `(#:make-flags '("CFLAGS=-ffp-contract=off")
61 #:configure-flags '("--disable-static")
62 #:phases
63 (modify-phases %standard-phases
64 ;; This test is known to fail on i686-linux:
65 ;; https://github.com/libgd/libgd/issues/359
66 ;; TODO Replace this substitution with an upstream bug fix.
67 (add-after 'unpack 'disable-failing-test
68 (lambda _
69 (substitute* "tests/gdimagegrayscale/basic.c"
70 (("return gdNumFailures\\(\\)")
71 "return 0"))
72 #t)))))
73 (native-inputs
74 `(("pkg-config" ,pkg-config)))
75 (inputs
76 `(("fontconfig" ,fontconfig)
77 ("freetype" ,freetype)
78 ("libjpeg" ,libjpeg-turbo)
79 ("libpng" ,libpng)
80 ("zlib" ,zlib)))
81 (home-page "https://www.libgd.org/")
82 (synopsis "Library for the dynamic creation of images by programmers")
83 (description
84 "GD is a library for the dynamic creation of images by programmers. GD
85 is written in C, and \"wrappers\" are available for Perl, PHP and other
86 languages. GD creates PNG, JPEG, GIF, WebP, XPM, BMP images, among other
87 formats. GD is commonly used to generate charts, graphics, thumbnails, and
88 most anything else, on the fly. While not restricted to use on the web, the
89 most common applications of GD involve website development.")
90 (license (non-copyleft "file://COPYING"
91 "See COPYING file in the distribution."))
92 (properties '((cpe-name . "libgd")))))
93
94 (define-public perl-gd
95 (package
96 (name "perl-gd")
97 (version "2.72")
98 (source
99 (origin
100 (method url-fetch)
101 (uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/"
102 "GD-" version ".tar.gz"))
103 (sha256
104 (base32 "014ik1rng6cnjfgdarkyy5m6wl4pdzc2b445m27krfn3zh9hgl31"))))
105 (build-system perl-build-system)
106 (inputs
107 `(("fontconfig" ,fontconfig)
108 ("freetype" ,freetype)
109 ("gd" ,gd)
110 ("libpng" ,libpng)
111 ("libjpeg" ,libjpeg-turbo)
112 ("zlib" ,zlib)))
113 (native-inputs
114 `(("perl-extutils-pkgconfig" ,perl-extutils-pkgconfig)))
115 (arguments
116 `(#:make-maker-flags
117 (list (string-append "--lib_jpeg_path="
118 (assoc-ref %build-inputs "libjpeg")))))
119 (home-page "https://metacpan.org/release/GD")
120 (synopsis "Perl interface to the GD graphics library")
121 (description "GD.pm is an autoloadable interface module for libgd, a
122 popular library for creating and manipulating PNG files. With this library
123 you can create PNG images on the fly or modify existing files.")
124 (license perl-license)))
125
126 (define-public perl-gd-securityimage
127 (package
128 (name "perl-gd-securityimage")
129 (version "1.75")
130 (source
131 (origin
132 (method url-fetch)
133 (uri (string-append "mirror://cpan/authors/id/B/BU/BURAK/"
134 "GD-SecurityImage-" version ".tar.gz"))
135 (sha256
136 (base32 "19lf1kzdavrkkx3f900jnpynr55d5kjd2sdmwpfir5dsmkcj9pix"))))
137 (build-system perl-build-system)
138 (arguments
139 '(#:phases
140 (modify-phases %standard-phases
141 (add-after 'unpack 'set-env
142 (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t)))))
143 (native-inputs
144 `(("perl-module-build" ,perl-module-build)))
145 (propagated-inputs
146 `(("perl-gd" ,perl-gd)
147 ("perl-image-magick" ,perl-image-magick)))
148 (home-page "https://metacpan.org/release/GD-SecurityImage")
149 (synopsis "Security image generator")
150 (description "This module provides a basic interface to create
151 security (captcha) images. The final output is the actual graphic data, the
152 mime type of the graphic, and the created random string. The module also has
153 some \"styles\" that are used to create the background (or foreground) of the
154 image.")
155 (license perl-license)))