gnu: Add ruby-commander.
[jackhill/guix/guix.git] / gnu / packages / sagemath.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages sagemath)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system python)
24 #:use-module (gnu packages algebra)
25 #:use-module (gnu packages compression)
26 #:use-module (gnu packages multiprecision)
27 #:use-module (gnu packages python)
28 #:use-module (gnu packages python-xyz))
29
30
31 (define-public python-cypari2
32 (package
33 (name "python-cypari2")
34 (version "2.0.3")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (pypi-uri "cypari2" version))
39 (sha256
40 (base32
41 "0mghbmilmy34xp1d50xdx76sijqxmpkm2bcgx2v1mdji2ff7n0yc"))))
42 (build-system python-build-system)
43 (native-inputs
44 `(("python-cython" ,python-cython)))
45 (propagated-inputs
46 `(("python-cysignals" ,python-cysignals)))
47 (inputs
48 `(("gmp" ,gmp)
49 ("pari-gp", pari-gp)))
50 (home-page "https://cypari2.readthedocs.io/")
51 (synopsis
52 "Python interface to the number theory library libpari")
53 (description
54 "Cypari2 provides a Python interface to the number theory library
55 PARI/GP. It has been spun off from the SageMath mathematics software system,
56 but it can be used independently.")
57 (license license:gpl2+)))
58
59 (define-public python2-cypari2
60 (package-with-python2 python-cypari2))
61
62 ;; The stable version of the following package is not young enough to be
63 ;; used with Sage, since it does not support cython. One would need to
64 ;; use an alpha release. On the other hand, Sage can be built without it.
65 (define-public python-gmpy2
66 (package
67 (name "python-gmpy2")
68 (version "2.0.8")
69 (source (origin
70 (method url-fetch)
71 (uri (pypi-uri "gmpy2" version ".zip"))
72 (sha256
73 (base32
74 "0grx6zmi99iaslm07w6c2aqpnmbkgrxcqjrqpfq223xri0r3w8yx"))))
75 (build-system python-build-system)
76 (native-inputs
77 `(("unzip" ,unzip)))
78 (inputs
79 `(("gmp" ,gmp)
80 ("mpfr" ,mpfr)
81 ("mpc" ,mpc)))
82 (home-page "https://github.com/aleaxit/gmpy")
83 (synopsis
84 "GMP/MPIR, MPFR, and MPC interface to Python 2.6+ and 3.x")
85 (description
86 "This package provides a Python interface to the GNU multiprecision
87 libraries GMO, MPFR and MPC.")
88 (license license:lgpl3+)))
89
90 (define-public python2-gmpy2
91 (package-with-python2 python-gmpy2))