gnu: cryptsetup: Update to 1.7.3.
[jackhill/guix/guix.git] / gnu / packages / cryptsetup.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages cryptsetup)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (guix utils)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages gnupg)
27 #:use-module (gnu packages popt)
28 #:use-module (gnu packages python)
29 #:use-module (gnu packages linux))
30
31 (define-public cryptsetup
32 (package
33 (name "cryptsetup")
34 (version "1.7.3")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://kernel.org/linux/utils/cryptsetup/v"
38 (version-major+minor version)
39 "/" name "-" version ".tar.xz"))
40 (sha256
41 (base32
42 "00nwd96m9yq4k3cayc04i5y7iakkzana35zxky6hpx2w8zl08axg"))))
43 (build-system gnu-build-system)
44 (inputs
45 `(("libgcrypt" ,libgcrypt)
46 ("lvm2" ,lvm2)
47 ("util-linux" ,util-linux)
48 ("popt" ,popt)))
49 (native-inputs
50 `(("python" ,python-wrapper)))
51 (synopsis "Hard disk encryption tool")
52 (description
53 "LUKS (Linux Unified Key Setup)/Cryptsetup provides a standard on-disk
54 encryption format, which does not only facilitate compatibility among
55 distributions, but which also provides secure management of multiple user
56 passwords. In contrast to existing solutions, LUKS stores all setup necessary
57 setup information in the partition header, enabling the users to transport
58 or migrate their data seamlessly.")
59 (license license:gpl2)
60 (home-page "https://gitlab.com/cryptsetup/cryptsetup")))