Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / gd.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gd)
20 #:use-module (guix packages)
21 #:use-module (guix build-system gnu)
22 #:use-module (guix download)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages image)
25 #:use-module (gnu packages fontutils)
26 #:use-module (gnu packages compression)
27 #:use-module ((guix licenses) #:select (bsd-style)))
28
29 (define-public gd
30 (package
31 (name "gd")
32
33 ;; Note: With libgd.org now pointing to bitbucket.org, genuine old
34 ;; tarballs are no longer available. Notably, versions 2.0.34 and .35 are
35 ;; missing.
36 (version "2.0.33")
37
38 (source (origin
39 (method url-fetch)
40 (uri "https://bitbucket.org/libgd/gd-libgd/get/GD_2_0_33.tar.gz")
41 (sha256
42 (base32
43 "0yrbx8mj9pykyzm0zl1q86xlkdvkajcsf5jmg688vhw9yc5wmbbw"))
44 (patches
45 (list (search-patch "gd-mips64-deplibs-fix.patch")))))
46 (build-system gnu-build-system)
47 (arguments
48 '(#:phases (alist-cons-after
49 'unpack 'chdir
50 (lambda _
51 (chdir "src"))
52 %standard-phases)))
53 (inputs
54 `(("freetype" ,freetype)
55 ("libpng" ,libpng)
56 ("zlib" ,zlib)))
57 (propagated-inputs
58 `(("fontconfig" ,fontconfig)
59 ("libjpeg" ,libjpeg)))
60 (home-page "http://www.libgd.org/")
61 (synopsis "Library for the dynamic creation of images by programmers")
62 (description
63 "GD is a library for the dynamic creation of images by programmers. GD
64 is written in C, and \"wrappers\" are available for Perl, PHP and other
65 languages. GD creates PNG, JPEG, GIF, WebP, XPM, BMP images, among other
66 formats. GD is commonly used to generate charts, graphics, thumbnails, and
67 most anything else, on the fly. While not restricted to use on the web, the
68 most common applications of GD involve website development.")
69 (license (bsd-style "file://COPYING"
70 "See COPYING file in the distribution."))))