Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / dc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages dc)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages compression)
22 #:use-module (gnu packages glib)
23 #:use-module (gnu packages gnutls)
24 #:use-module (gnu packages ncurses)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages sqlite)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu)
30 #:use-module ((guix licenses)
31 #:renamer (symbol-prefix-proc 'license:)))
32
33 (define-public ncdc
34 (package
35 (name "ncdc")
36 (version "1.19")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (string-append "http://dev.yorhel.nl/download/ncdc-" version
41 ".tar.gz"))
42 (sha256 (base32
43 "1wgvqwfxq9kc729h2r528n55821w87sfbm4h21mr6pvkpfw30hf2"))))
44 (build-system gnu-build-system)
45 (inputs
46 `(("bzip2" ,bzip2)
47 ("glib" ,glib)
48 ("gnutls" ,gnutls)
49 ("ncurses" ,ncurses)
50 ("sqlite" ,sqlite)
51 ("zlib" ,zlib)))
52 (native-inputs
53 `(("pkg-config" ,pkg-config)))
54 (home-page "http://dev.yorhel.nl/ncdc")
55 (synopsis
56 "Lightweight direct connect client with a friendly ncurses interface")
57 (description
58 "Ncdc is a client for the Direct Connect peer-to-peer protocol implemented
59 using ncurses. It is known for its smaller footprint and ease of use.")
60 (license license:x11)))