Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / rdf.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages rdf)
22 #:use-module ((guix licenses)
23 #:select (non-copyleft isc gpl2 lgpl2.1 lgpl2.1+))
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system cmake)
27 #:use-module (guix build-system gnu)
28 #:use-module (guix build-system python)
29 #:use-module (guix build-system waf)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages autotools)
32 #:use-module (gnu packages databases)
33 #:use-module (gnu packages boost)
34 #:use-module (gnu packages check)
35 #:use-module (gnu packages compression)
36 #:use-module (gnu packages curl)
37 #:use-module (gnu packages cyrus-sasl)
38 #:use-module (gnu packages documentation)
39 #:use-module (gnu packages gnupg)
40 #:use-module (gnu packages linux)
41 #:use-module (gnu packages multiprecision)
42 #:use-module (gnu packages pcre)
43 #:use-module (gnu packages perl)
44 #:use-module (gnu packages pkg-config)
45 #:use-module (gnu packages python)
46 #:use-module (gnu packages python-web)
47 #:use-module (gnu packages qt)
48 #:use-module (gnu packages time)
49 #:use-module (gnu packages tls)
50 #:use-module (gnu packages xml))
51
52 (define-public raptor2
53 (package
54 (name "raptor2")
55 (version "2.0.15")
56 (source (origin
57 (method url-fetch)
58 (uri (string-append "http://download.librdf.org/source/" name
59 "-" version ".tar.gz"))
60 (patches
61 (search-patches "raptor2-heap-overflow.patch"))
62 (sha256
63 (base32
64 "1vc02im4mpc28zxzgli68k6j0dakh0k3s389bm436yvqajxg19xd"))))
65 (build-system gnu-build-system)
66 (inputs
67 `(("curl" ,curl)
68 ("libxml2" ,libxml2)
69 ("libxslt" ,libxslt)
70 ("zlib" ,zlib)))
71 (arguments
72 `(#:parallel-tests? #f))
73 (home-page "http://librdf.org/raptor/")
74 (synopsis "RDF syntax library")
75 (description "Raptor is a C library providing a set of parsers and
76 serialisers that generate Resource Description Framework (RDF) triples
77 by parsing syntaxes or serialise the triples into a syntax. The supported
78 parsing syntaxes are RDF/XML, N-Quads, N-Triples 1.0 and 1.1, TRiG,
79 Turtle 2008 and 2013, RDFa 1.0 and 1.1, RSS tag soup including all versions
80 of RSS, Atom 1.0 and 0.3, GRDDL and microformats for HTML, XHTML and
81 XML. The serialising syntaxes are RDF/XML (regular, abbreviated, XMP),
82 Turtle 2013, N-Quads, N-Triples 1.1, Atom 1.0, RSS 1.0, GraphViz DOT,
83 HTML and JSON.")
84 (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
85
86 (define-public clucene
87 (package
88 (name "clucene")
89 (version "2.3.3.4")
90 (source (origin
91 (method url-fetch)
92 (uri (string-append "mirror://sourceforge/clucene/"
93 "clucene-core-unstable/2.3/clucene-core-"
94 version ".tar.gz"))
95 (sha256
96 (base32
97 "1arffdwivig88kkx685pldr784njm0249k0rb1f1plwavlrw9zfx"))
98 (patches (search-patches "clucene-pkgconfig.patch"
99 "clucene-contribs-lib.patch"))))
100 (build-system cmake-build-system)
101 (inputs
102 `(("boost" ,boost) ; could also use bundled copy
103 ("zlib" ,zlib)))
104 (arguments
105 `(#:test-target "cl_test"
106 #:configure-flags '("-DBUILD_CONTRIBS_LIB=ON")
107 #:tests? #f)) ; Tests do not compile, as TestIndexSearcher.cpp uses
108 ; undeclared usleep. After fixing this, one needs to run
109 ; "make test" in addition to "make cl_test", then
110 ; SimpleTest fails.
111 ; Notice that the library appears to be unmaintained
112 ; with no reaction to bug reports.
113 (home-page "http://clucene.sourceforge.net/")
114 (synopsis "C text indexing and searching library")
115 (description "CLucene is a high-performance, scalable, cross platform,
116 full-featured indexing and searching API. It is a port of the very popular
117 Java Lucene text search engine API to C++.")
118 (license lgpl2.1)))
119
120 (define-public lrdf
121 (package
122 (name "lrdf")
123 (version "0.6.1")
124 (source (origin
125 (method url-fetch)
126 (uri (string-append "https://github.com/swh/LRDF/archive/v"
127 version ".tar.gz"))
128 (file-name (string-append name "-" version ".tar.gz"))
129 (sha256
130 (base32
131 "1vxii4mlcpyi16dizcmnqfl2j9gffgr986yd8ic67hvs8xy42yfm"))))
132 (build-system gnu-build-system)
133 (arguments
134 '(#:phases
135 (modify-phases %standard-phases
136 (add-after 'unpack 'remove-out-of-tree-references
137 (lambda _
138 ;; remove_test depends on an out-of-tree RDF file
139 (substitute* "examples/Makefile.am"
140 (("instances_test remove_test") "instances_test")
141 (("\\$\\(TESTS\\) remove_test") "$(TESTS)"))
142 #t))
143 (add-after 'remove-out-of-tree-references 'autoreconf
144 (lambda _
145 (zero? (system* "autoreconf" "-vfi")))))))
146 (inputs
147 `(("raptor" ,raptor2)
148 ("cyrus-sasl" ,cyrus-sasl)
149 ("zlib" ,zlib)))
150 (native-inputs
151 `(("autoconf" ,autoconf)
152 ("automake" ,automake)
153 ("libtool" ,libtool)
154 ("pkg-config" ,pkg-config)))
155 (home-page "https://github.com/swh/LRDF")
156 (synopsis "Lightweight RDF library for accessing LADSPA plugin metadata")
157 (description
158 "LRDF is a library to make it easy to manipulate RDF files describing
159 LADSPA plugins. It can also be used for general RDF manipulation. It can
160 read RDF/XLM and N3 files and export N3 files, and it also has a light
161 taxonomic inference capability.")
162 (license gpl2)))
163
164 (define-public rasqal
165 (package
166 (name "rasqal")
167 (version "0.9.33")
168 (source (origin
169 (method url-fetch)
170 (uri (string-append "http://download.librdf.org/source/" name
171 "-" version ".tar.gz"))
172 (sha256
173 (base32
174 "0z6rrwn4jsagvarg8d5zf0j352kjgi33py39jqd29gbhcnncj939"))))
175 (build-system gnu-build-system)
176 (native-inputs
177 `(("perl" ,perl)
178 ("perl-xml-dom" ,perl-xml-dom) ; for the tests
179 ("pkg-config" ,pkg-config)))
180 (inputs
181 `(("libgcrypt" ,libgcrypt)
182 ("libxml2" ,libxml2)
183 ("mpfr" ,mpfr)
184 ("pcre" ,pcre)
185 ("util-linux" ,util-linux)))
186 (propagated-inputs
187 `(("raptor2" ,raptor2))) ; stipulated by rasqal.pc
188 (arguments
189 `(#:parallel-tests? #f
190 ; test failure reported upstream, see
191 ; http://bugs.librdf.org/mantis/view.php?id=571
192 #:tests? #f))
193 (home-page "http://librdf.org/rasqal/")
194 (synopsis "RDF query library")
195 (description "Rasqal is a C library that handles Resource Description
196 Framework (RDF) query language syntaxes, query construction and execution
197 of queries returning results as bindings, boolean, RDF graphs/triples or
198 syntaxes. The supported query languages are SPARQL Query 1.0,
199 SPARQL Query 1.1, SPARQL Update 1.1 (no executing) and the Experimental
200 SPARQL extensions (LAQRS). Rasqal can write binding query results in the
201 SPARQL XML, SPARQL JSON, CSV, TSV, HTML, ASCII tables, RDF/XML and
202 Turtle/N3 and read them in SPARQL XML, RDF/XML and Turtle/N3.")
203 (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
204
205 (define-public redland
206 (package
207 (name "redland")
208 (version "1.0.17")
209 (source (origin
210 (method url-fetch)
211 (uri (string-append "http://download.librdf.org/source/" name
212 "-" version ".tar.gz"))
213 (sha256
214 (base32
215 "109n0kp39p966dpiasad2bb7q66rwbcb9avjvimw28chnpvlf66y"))))
216 (build-system gnu-build-system)
217 (native-inputs
218 `(("perl" ,perl) ; needed for installation
219 ("pkg-config" ,pkg-config)))
220 (propagated-inputs
221 `(("rasqal" ,rasqal))) ; in Requires.private field of .pc
222 (inputs
223 `(("bdb" ,bdb)))
224 (home-page "http://librdf.org/")
225 (synopsis "RDF library")
226 (description "The Redland RDF Library (librdf) provides the RDF API
227 and triple stores.")
228 (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
229
230 (define-public serd
231 (package
232 (name "serd")
233 (version "0.28.0")
234 (source (origin
235 (method url-fetch)
236 (uri (string-append "http://download.drobilla.net/serd-"
237 version ".tar.bz2"))
238 (sha256
239 (base32
240 "1v4ai4zyj1q3255nghicns9817jkwb3bh60ssprsjmnjfj41mwhx"))))
241 (build-system waf-build-system)
242 (arguments
243 `(#:tests? #f ; no check target
244 #:phases
245 (modify-phases %standard-phases
246 (add-before
247 'configure 'set-ldflags
248 (lambda* (#:key outputs #:allow-other-keys)
249 (setenv "LDFLAGS"
250 (string-append "-Wl,-rpath="
251 (assoc-ref outputs "out") "/lib"))
252 #t)))))
253 (home-page "http://drobilla.net/software/serd/")
254 (synopsis "Library for RDF syntax supporting Turtle and NTriples")
255 (description
256 "Serd is a lightweight C library for RDF syntax which supports reading
257 and writing Turtle and NTriples. Serd is not intended to be a swiss-army
258 knife of RDF syntax, but rather is suited to resource limited or performance
259 critical applications (e.g. converting many gigabytes of NTriples to Turtle),
260 or situations where a simple reader/writer with minimal dependencies is
261 ideal (e.g. in LV2 implementations or embedded applications).")
262 (license isc)))
263
264 (define-public sord
265 (package
266 (name "sord")
267 (version "0.16.0")
268 (source (origin
269 (method url-fetch)
270 (uri (string-append "http://download.drobilla.net/sord-"
271 version ".tar.bz2"))
272 (sha256
273 (base32
274 "0nh3i867g9z4kdlnk82cg2kcw8r02qgifxvkycvzb4vfjv4v4g4x"))))
275 (build-system waf-build-system)
276 (arguments
277 `(#:tests? #f ; no check target
278 #:phases
279 (modify-phases %standard-phases
280 (add-before
281 'configure 'set-ldflags
282 (lambda* (#:key outputs #:allow-other-keys)
283 (setenv "LDFLAGS"
284 (string-append "-Wl,-rpath="
285 (assoc-ref outputs "out") "/lib"))
286 #t)))))
287 (inputs
288 `(("serd" ,serd)))
289 (native-inputs
290 `(("pkg-config" ,pkg-config)))
291 (home-page "http://drobilla.net/software/sord/")
292 (synopsis "C library for storing RDF data in memory")
293 (description
294 "Sord is a lightweight C library for storing RDF data in memory.")
295 (license isc)))
296
297 (define-public python-rdflib
298 (package
299 (name "python-rdflib")
300 (version "4.1.2")
301 (source
302 (origin
303 (method url-fetch)
304 (uri (string-append
305 "https://pypi.python.org/packages/source/r/rdflib/rdflib-"
306 version
307 ".tar.gz"))
308 (patches
309 ;; The patch has no effect under Python 3.
310 (search-patches "python2-rdflib-drop-sparqlwrapper.patch"))
311 (sha256
312 (base32
313 "0kvaf332cqbi47rqzlpdx4mbkvw12mkrzkj8n9l19wk713d4py9w"))))
314 (build-system python-build-system)
315 (arguments
316 '(;; FIXME: Three test failures. Try uncommenting the below next update.
317 #:tests? #f))
318 ;; #:phases
319 ;; (modify-phases %standard-phases
320 ;; (replace 'check
321 ;; (lambda _
322 ;; ;; Run tests from the build directory so python3 only
323 ;; ;; sees the installed 2to3 version.
324 ;; (zero? (system* "nosetests" "--where=./build/src")))))
325 (native-inputs
326 `(("python-nose" ,python-nose)))
327 (propagated-inputs
328 `(("python-html5lib" ,python-html5lib)
329 ("python-isodate" ,python-isodate)
330 ("python-pyparsing" ,python-pyparsing)))
331 (home-page "https://github.com/RDFLib/rdflib")
332 (synopsis
333 "Python RDF library")
334 (description
335 "RDFLib is a Python library for working with RDF, a simple yet
336 powerful language for representing information.")
337 (license (non-copyleft "file://LICENSE"
338 "See LICENSE in the distribution."))))
339
340 (define-public python2-rdflib
341 (package-with-python2 python-rdflib))