gnu: nghttp2: Update to 1.32.0.
[jackhill/guix/guix.git] / gnu / packages / nutrition.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages nutrition)
21 #:use-module (guix packages)
22 #:use-module (guix licenses)
23 #:use-module (guix download)
24 #:use-module (guix build-system python)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages databases)
27 #:use-module (gnu packages gtk)
28 #:use-module (gnu packages glib)
29 #:use-module (gnu packages image)
30 #:use-module (gnu packages python))
31
32 (define-public gourmet
33 (package
34 (name "gourmet")
35 (version "0.17.4")
36 (source
37 (origin
38 (method url-fetch)
39 (uri (string-append "https://github.com/thinkle/gourmet/archive/"
40 version ".tar.gz"))
41 (file-name (string-append name "-" version ".tar.gz"))
42 (sha256
43 (base32
44 "1qvz175arzqm10lpfx8ffadrgirs3240zzqcp0h7sl53qfwx7v8k"))))
45 (build-system python-build-system)
46 (native-inputs
47 `(("distutils-extra" ,python2-distutils-extra)
48 ("intltool" ,intltool)
49 ("python-pygtk" ,python2-pygtk))) ;for tests
50 ;; TODO: Add python-reportlab and/or python-poppler for printing/pdf
51 ;; export, and python-beautifulsoup for web import plugin.
52 (inputs
53 `(("pygtk" ,python2-pygtk)
54 ("sqlalchemy" ,python2-sqlalchemy)
55 ("python-lxml" ,python2-lxml)
56 ("python-pillow" ,python2-pillow)
57 ("elib.intl" ,python2-elib.intl)))
58 (arguments
59 `(#:python ,python-2 ;exception and print syntax
60 #:tests? #f ;tests look bitrotted
61 #:phases
62 (modify-phases %standard-phases
63 (replace 'install
64 (lambda* (#:key make-flags #:allow-other-keys)
65 (zero? (system* "python" "setup.py" "install" "--prefix"
66 (assoc-ref %outputs "out"))))))))
67 (home-page "http://thinkle.github.io/gourmet/")
68 (synopsis "Recipe organizer")
69 (description
70 "Gourmet Recipe Manager is a recipe organizer that allows you to collect,
71 search, organize, and browse your recipes. Gourmet can also generate shopping
72 lists and calculate nutritional information. It imports Mealmaster,
73 MasterCook and KRecipe files and exports PDFs, webpages, and other formats.")
74 (license gpl2+)))