gnu: nghttp2: Update to 1.32.0.
[jackhill/guix/guix.git] / gnu / packages / jrnl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Eric Bavier <address@hidden>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages jrnl)
22 #:use-module (guix packages)
23 #:use-module (guix licenses)
24 #:use-module (guix download)
25 #:use-module (guix build-system python)
26 #:use-module (gnu packages check)
27 #:use-module (gnu packages python)
28 #:use-module (gnu packages python-crypto)
29 #:use-module (gnu packages time))
30
31 (define-public jrnl
32 (package
33 (name "jrnl")
34 (version "1.9.7")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "https://github.com/maebert/jrnl/archive/"
39 version ".tar.gz"))
40 (file-name (string-append name "-" version ".tar.gz"))
41 (sha256
42 (base32
43 "0mfq7hhw5np2dj9jlxpyyk2cg9i0xgz2brb894d928hczszy97bq"))))
44 (build-system python-build-system)
45 (native-inputs
46 `(("behave" ,behave)))
47 (inputs
48 `(("python" ,python)
49 ("python-keyring" ,python-keyring)
50 ("python-pycrypto" ,python-pycrypto)
51 ("python-pytz" ,python-pytz)
52 ("python-tzlocal" ,python-tzlocal)
53 ("python-six" ,python-six)
54 ("python-dateutil" ,python-dateutil)
55 ("python-parsedatetime" ,python-parsedatetime)))
56 (home-page "http://maebert.github.io/jrnl/")
57 (synopsis "Personal journal application")
58 (description
59 "Jrnl is a command line journal application that stores your journal in a
60 plain text file. Optionally, your journal can be encrypted using 256-bit AES
61 encryption.")
62 (license x11)))