Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / package-management.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
5 ;;; Copyright © 2017, 2018 Oleg Pykhalov <go.wigust@gmail.com>
6 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
7 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
9 ;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
10 ;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
11 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
12 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
13 ;;; Copyright © 2019 Vagrant Cascadian <vagrant@reproducible-builds.org>
14 ;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
15 ;;;
16 ;;; This file is part of GNU Guix.
17 ;;;
18 ;;; GNU Guix is free software; you can redistribute it and/or modify it
19 ;;; under the terms of the GNU General Public License as published by
20 ;;; the Free Software Foundation; either version 3 of the License, or (at
21 ;;; your option) any later version.
22 ;;;
23 ;;; GNU Guix is distributed in the hope that it will be useful, but
24 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
25 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
26 ;;; GNU General Public License for more details.
27 ;;;
28 ;;; You should have received a copy of the GNU General Public License
29 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
30
31 (define-module (gnu packages package-management)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages acl)
34 #:use-module (gnu packages attr)
35 #:use-module (gnu packages avahi)
36 #:use-module (gnu packages autotools)
37 #:use-module (gnu packages backup)
38 #:use-module (gnu packages base)
39 #:use-module (gnu packages bdw-gc)
40 #:use-module (gnu packages bison)
41 #:use-module (gnu packages bootstrap) ;for 'bootstrap-guile-origin'
42 #:use-module (gnu packages check)
43 #:use-module (gnu packages compression)
44 #:use-module (gnu packages cpio)
45 #:use-module (gnu packages crypto)
46 #:use-module (gnu packages curl)
47 #:use-module (gnu packages dbm)
48 #:use-module (gnu packages docbook)
49 #:use-module (gnu packages file)
50 #:use-module (gnu packages gettext)
51 #:use-module (gnu packages glib)
52 #:use-module (gnu packages gnome)
53 #:use-module (gnu packages gnupg)
54 #:use-module (gnu packages graphviz)
55 #:use-module (gnu packages gtk)
56 #:use-module (gnu packages guile)
57 #:use-module (gnu packages guile-xyz)
58 #:use-module (gnu packages linux)
59 #:use-module (gnu packages lisp)
60 #:use-module (gnu packages man)
61 #:use-module (gnu packages nettle)
62 #:use-module (gnu packages nss)
63 #:use-module (gnu packages patchutils)
64 #:use-module (gnu packages perl)
65 #:use-module (gnu packages perl-check)
66 #:use-module (gnu packages pkg-config)
67 #:use-module (gnu packages popt)
68 #:use-module (gnu packages python)
69 #:use-module (gnu packages python-web)
70 #:use-module (gnu packages python-xyz)
71 #:use-module (gnu packages serialization)
72 #:use-module (gnu packages sqlite)
73 #:use-module (gnu packages ssh)
74 #:use-module (gnu packages texinfo)
75 #:use-module (gnu packages time)
76 #:use-module (gnu packages tls)
77 #:use-module (gnu packages vim)
78 #:use-module (gnu packages virtualization)
79 #:use-module (gnu packages web)
80 #:use-module (gnu packages xml)
81 #:use-module (gnu packages xorg)
82 #:use-module (guix build-system glib-or-gtk)
83 #:use-module (guix build-system gnu)
84 #:use-module (guix build-system meson)
85 #:use-module (guix build-system python)
86 #:use-module (guix download)
87 #:use-module (guix gexp)
88 #:use-module (guix git-download)
89 #:use-module ((guix licenses) #:prefix license:)
90 #:use-module (guix packages)
91 #:use-module (guix utils)
92 #:use-module (ice-9 match)
93 #:use-module (srfi srfi-1))
94
95 (define (boot-guile-uri arch)
96 "Return the URI for the bootstrap Guile tarball for ARCH."
97 (cond ((string=? "armhf" arch)
98 (string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
99 arch "-linux"
100 "/20150101/guile-2.0.11.tar.xz"))
101 ((string=? "aarch64" arch)
102 (string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
103 arch "-linux/20170217/guile-2.0.14.tar.xz"))
104 (else
105 (string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
106 arch "-linux"
107 "/20131110/guile-2.0.9.tar.xz"))))
108
109 (define-public guix
110 ;; Latest version of Guix, which may or may not correspond to a release.
111 ;; Note: the 'update-guix-package.scm' script expects this definition to
112 ;; start precisely like this.
113 (let ((version "1.0.1")
114 (commit "4a54ed774913480c0f8dad3caf0cd627e4fa8ebf")
115 (revision 3))
116 (package
117 (name "guix")
118
119 (version (if (zero? revision)
120 version
121 (string-append version "-"
122 (number->string revision)
123 "." (string-take commit 7))))
124 (source (origin
125 (method git-fetch)
126 (uri (git-reference
127 (url "https://git.savannah.gnu.org/r/guix.git")
128 (commit commit)))
129 (sha256
130 (base32
131 "14m4a4bn0d5hav6mrks5d7r223knx9dpswgbsc875wgr2921na2h"))
132 (file-name (string-append "guix-" version "-checkout"))))
133 (build-system gnu-build-system)
134 (arguments
135 `(#:configure-flags (list
136 "--localstatedir=/var"
137 "--sysconfdir=/etc"
138 (string-append "--with-bash-completion-dir="
139 (assoc-ref %outputs "out")
140 "/etc/bash_completion.d")
141
142 ;; Set 'DOT_USER_PROGRAM' to the empty string so
143 ;; we don't keep a reference to Graphviz, whose
144 ;; closure is pretty big (too big for the Guix
145 ;; system installation image.)
146 "ac_cv_path_DOT_USER_PROGRAM=dot"
147
148 ;; To avoid problems with the length of shebangs,
149 ;; choose a fixed-width and short directory name
150 ;; for tests.
151 "ac_cv_guix_test_root=/tmp/guix-tests")
152 #:parallel-tests? #f ;work around <http://bugs.gnu.org/21097>
153
154 #:modules ((guix build gnu-build-system)
155 (guix build utils)
156 (srfi srfi-26)
157 (ice-9 popen)
158 (ice-9 rdelim))
159
160 #:phases (modify-phases %standard-phases
161 (replace 'bootstrap
162 (lambda _
163 ;; Make sure 'msgmerge' can modify the PO files.
164 (for-each (lambda (po)
165 (chmod po #o666))
166 (find-files "." "\\.po$"))
167
168 (patch-shebang "build-aux/git-version-gen")
169
170 (call-with-output-file ".tarball-version"
171 (lambda (port)
172 (display ,version port)))
173
174 (invoke "sh" "bootstrap")))
175 (add-before 'check 'copy-bootstrap-guile
176 (lambda* (#:key system inputs #:allow-other-keys)
177 ;; Copy the bootstrap guile tarball in the store used
178 ;; by the test suite.
179 (define (intern tarball)
180 (let ((base (strip-store-file-name tarball)))
181 (copy-file tarball base)
182 (invoke "./test-env" "guix" "download"
183 (string-append "file://" (getcwd)
184 "/" base))
185 (delete-file base)))
186
187
188 (intern (assoc-ref inputs "boot-guile"))
189
190 ;; On x86_64 some tests need the i686 Guile.
191 ,@(if (and (not (%current-target-system))
192 (string=? (%current-system)
193 "x86_64-linux"))
194 '((intern (assoc-ref inputs "boot-guile/i686")))
195 '())
196 #t))
197 (add-after 'unpack 'disable-failing-tests
198 ;; XXX FIXME: These tests fail within the build container.
199 (lambda _
200 (substitute* "tests/syscalls.scm"
201 (("^\\(test-(assert|equal) \"(clone|setns|pivot-root)\"" all)
202 (string-append "(test-skip 1)\n" all)))
203 (substitute* "tests/containers.scm"
204 (("^\\(test-(assert|equal)" all)
205 (string-append "(test-skip 1)\n" all)))
206 (when (file-exists? "tests/guix-environment-container.sh")
207 (substitute* "tests/guix-environment-container.sh"
208 (("guix environment --version")
209 "exit 77\n")))
210 #t))
211 (add-before 'check 'set-SHELL
212 (lambda _
213 ;; 'guix environment' tests rely on 'SHELL' having a
214 ;; correct value, so set it.
215 (setenv "SHELL" (which "sh"))
216 #t))
217 (add-after 'install 'wrap-program
218 (lambda* (#:key inputs outputs #:allow-other-keys)
219 ;; Make sure the 'guix' command finds GnuTLS,
220 ;; Guile-JSON, and Guile-Git automatically.
221 (let* ((out (assoc-ref outputs "out"))
222 (guile (assoc-ref inputs "guile"))
223 (gcrypt (assoc-ref inputs "guile-gcrypt"))
224 (json (assoc-ref inputs "guile-json"))
225 (sqlite (assoc-ref inputs "guile-sqlite3"))
226 (git (assoc-ref inputs "guile-git"))
227 (bs (assoc-ref inputs
228 "guile-bytestructures"))
229 (ssh (assoc-ref inputs "guile-ssh"))
230 (gnutls (assoc-ref inputs "gnutls"))
231 (locales (assoc-ref inputs "glibc-utf8-locales"))
232 (deps (list gcrypt json sqlite gnutls
233 git bs ssh))
234 (effective
235 (read-line
236 (open-pipe* OPEN_READ
237 (string-append guile "/bin/guile")
238 "-c" "(display (effective-version))")))
239 (path (string-join
240 (map (cut string-append <>
241 "/share/guile/site/"
242 effective)
243 (delete #f deps))
244 ":"))
245 (gopath (string-join
246 (map (cut string-append <>
247 "/lib/guile/" effective
248 "/site-ccache")
249 (delete #f deps))
250 ":"))
251 (locpath (string-append locales "/lib/locale")))
252
253 (wrap-program (string-append out "/bin/guix")
254 `("GUILE_LOAD_PATH" ":" prefix (,path))
255 `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,gopath))
256 `("GUIX_LOCPATH" ":" suffix (,locpath)))
257
258 #t))))))
259 (native-inputs `(("pkg-config" ,pkg-config)
260
261 ;; XXX: Keep the development inputs here even though
262 ;; they're unnecessary, just so that 'guix environment
263 ;; guix' always contains them.
264 ("autoconf" ,autoconf-wrapper)
265 ("automake" ,automake)
266 ("gettext" ,gettext-minimal)
267 ("texinfo" ,texinfo)
268 ("graphviz" ,graphviz)
269 ("help2man" ,help2man)
270 ("po4a" ,po4a)))
271 (inputs
272 `(("bzip2" ,bzip2)
273 ("gzip" ,gzip)
274 ("zlib" ,zlib) ;for 'guix publish'
275 ("lzlib" ,lzlib) ;for 'guix publish' and 'guix substitute'
276
277 ("sqlite" ,sqlite)
278 ("libgcrypt" ,libgcrypt)
279
280 ("guile" ,guile-2.2)
281
282 ;; Many tests rely on the 'guile-bootstrap' package, which is why we
283 ;; have it here.
284 ("boot-guile" ,(bootstrap-guile-origin (%current-system)))
285 ;; Some of the tests use "unshare" when it is available.
286 ("util-linux" ,util-linux)
287 ,@(if (and (not (%current-target-system))
288 (string=? (%current-system) "x86_64-linux"))
289 `(("boot-guile/i686" ,(bootstrap-guile-origin "i686-linux")))
290 '())
291
292 ("glibc-utf8-locales" ,glibc-utf8-locales)))
293 (propagated-inputs
294 `(("gnutls" ,gnutls)
295 ("guile-gcrypt" ,guile-gcrypt)
296 ("guile-json" ,guile-json)
297 ("guile-sqlite3" ,guile-sqlite3)
298 ("guile-ssh" ,guile-ssh)
299 ("guile-git" ,guile-git)))
300
301 (home-page "https://www.gnu.org/software/guix/")
302 (synopsis "Functional package manager for installed software packages and versions")
303 (description
304 "GNU Guix is a functional package manager for the GNU system, and is
305 also a distribution thereof. It includes a virtual machine image. Besides
306 the usual package management features, it also supports transactional
307 upgrades and roll-backs, per-user profiles, and much more. It is based on
308 the Nix package manager.")
309 (license license:gpl3+)
310 (properties '((ftp-server . "alpha.gnu.org"))))))
311
312 (define-public guix-daemon
313 ;; This package is for internal consumption: it allows us to quickly build
314 ;; the 'guix-daemon' program and use that in (guix self), used by 'guix
315 ;; pull'.
316 (package
317 (inherit guix)
318 (properties `((hidden? . #t)))
319 (name "guix-daemon")
320
321 ;; Use a minimum set of dependencies.
322 (native-inputs
323 (fold alist-delete (package-native-inputs guix)
324 '("po4a" "graphviz" "help2man")))
325 (inputs
326 `(("gnutls" ,gnutls)
327 ("guile-git" ,guile-git)
328 ("guile-json" ,guile-json)
329 ("guile-gcrypt" ,guile-gcrypt)
330 ,@(fold alist-delete (package-inputs guix)
331 '("boot-guile" "boot-guile/i686" "util-linux"))))
332
333 (propagated-inputs '())
334
335 (arguments
336 (substitute-keyword-arguments (package-arguments guix)
337 ((#:configure-flags flags '())
338 ;; Pretend we have those libraries; we don't actually need them.
339 `(append ,flags
340 '("guix_cv_have_recent_guile_sqlite3=yes"
341 "guix_cv_have_recent_guile_ssh=yes")))
342 ((#:tests? #f #f)
343 #f)
344 ((#:phases phases '%standard-phases)
345 `(modify-phases ,phases
346 (replace 'build
347 (lambda _
348 (invoke "make" "nix/libstore/schema.sql.hh")
349 (invoke "make" "-j" (number->string
350 (parallel-job-count))
351 "guix-daemon")))
352 (delete 'copy-bootstrap-guile)
353 (replace 'install
354 (lambda* (#:key outputs #:allow-other-keys)
355 (invoke "make" "install-binPROGRAMS"
356 "install-nodist_pkglibexecSCRIPTS")
357
358 ;; We need to tell 'guix-daemon' which 'guix' command to use.
359 ;; Here we use a questionable hack where we hard-code root's
360 ;; current guix, which could be wrong (XXX). Note that scripts
361 ;; like 'guix perform-download' do not run as root so we assume
362 ;; that they have access to /var/guix/profiles/per-user/root.
363 (let ((out (assoc-ref outputs "out")))
364 (substitute* (find-files (string-append out "/libexec"))
365 (("exec \".*/bin/guix\"")
366 "exec \"${GUIX:-/var/guix/profiles/per-user/root/current-guix/bin/guix}\""))
367 #t)))
368 (delete 'wrap-program)))))))
369
370 (define-public guile2.0-guix
371 (deprecated-package "guile2.0-guix" guix))
372
373 (define-public guix-minimal
374 ;; A version of Guix which is built with the minimal set of dependencies, as
375 ;; outlined in the README "Requirements" section. Intended as a CI job, so
376 ;; marked as hidden.
377 (hidden-package
378 (package
379 (inherit guix)
380 (name "guix-minimal")
381 (inputs
382 `(("guile" ,guile-2.2)
383 ,@(alist-delete "guile" (package-inputs guix))))
384 (propagated-inputs
385 (fold alist-delete
386 (package-propagated-inputs guix)
387 '("guile-ssh"))))))
388
389 (define (source-file? file stat)
390 "Return true if FILE is likely a source file, false if it is a typical
391 generated file."
392 (define (wrong-extension? file)
393 (or (string-suffix? "~" file)
394 (member (file-extension file)
395 '("o" "a" "lo" "so" "go"))))
396
397 (match (basename file)
398 ((or ".git" "autom4te.cache" "configure" "Makefile" "Makefile.in" ".libs")
399 #f)
400 ((? wrong-extension?)
401 #f)
402 (_
403 #t)))
404
405 (define-public current-guix-package
406 ;; This parameter allows callers to override the package that 'current-guix'
407 ;; returns. This is useful when 'current-guix' cannot compute it by itself,
408 ;; for instance because it's not running from a source code checkout.
409 (make-parameter #f))
410
411 (define-public current-guix
412 (let* ((repository-root (delay (canonicalize-path
413 (string-append (current-source-directory)
414 "/../.."))))
415 (select? (delay (or (git-predicate (force repository-root))
416 source-file?))))
417 (lambda ()
418 "Return a package representing Guix built from the current source tree.
419 This works by adding the current source tree to the store (after filtering it
420 out) and returning a package that uses that as its 'source'."
421 (or (current-guix-package)
422 (package
423 (inherit guix)
424 (version (string-append (package-version guix) "+"))
425 (source (local-file (force repository-root) "guix-current"
426 #:recursive? #t
427 #:select? (force select?))))))))
428
429 \f
430 ;;;
431 ;;; Other tools.
432 ;;;
433
434 (define-public nix
435 (package
436 (name "nix")
437 (version "2.0.4")
438 (source (origin
439 (method url-fetch)
440 (uri (string-append "http://nixos.org/releases/nix/nix-"
441 version "/nix-" version ".tar.xz"))
442 (sha256
443 (base32
444 "0ss9svxlh1pvrdmnqjvjyqjmbqmrdbyfarvbb14i9d4bggzl0r8n"))))
445 (build-system gnu-build-system)
446 (native-inputs `(("pkg-config" ,pkg-config)))
447 (inputs `(("curl" ,curl)
448 ("bzip2" ,bzip2)
449 ("libgc" ,libgc)
450 ("libseccomp" ,libseccomp)
451 ("libsodium" ,libsodium)
452 ("openssl" ,openssl)
453 ("sqlite" ,sqlite)
454 ("xz" ,xz)))
455 (home-page "https://nixos.org/nix/")
456 (synopsis "The Nix package manager")
457 (description
458 "Nix is a purely functional package manager. This means that it treats
459 packages like values in purely functional programming languages such as
460 Haskell—they are built by functions that don't have side-effects, and they
461 never change after they have been built. Nix stores packages in the Nix
462 store, usually the directory /nix/store, where each package has its own unique
463 sub-directory.")
464 (license license:lgpl2.1+)))
465
466 (define-public stow
467 (package
468 (name "stow")
469 (version "2.2.2")
470 (source (origin
471 (method url-fetch)
472 (uri (string-append "mirror://gnu/stow/stow-"
473 version ".tar.gz"))
474 (sha256
475 (base32
476 "1pvky9fayms4r6fhns8jd0vavszd7d979w62vfd5n88v614pdxz2"))))
477 (build-system gnu-build-system)
478 (inputs
479 `(("perl" ,perl)))
480 (native-inputs
481 `(("perl-test-simple" ,perl-test-simple)
482 ("perl-test-output" ,perl-test-output)
483 ("perl-capture-tiny" ,perl-capture-tiny)
484 ("perl-io-stringy" ,perl-io-stringy)))
485 (home-page "https://www.gnu.org/software/stow/")
486 (synopsis "Managing installed software packages")
487 (description
488 "GNU Stow is a symlink manager. It generates symlinks to directories
489 of data and makes them appear to be merged into the same directory. It is
490 typically used for managing software packages installed from source, by
491 letting you install them apart in distinct directories and then create
492 symlinks to the files in a common directory such as /usr/local.")
493 (license license:gpl2+)))
494
495 (define-public rpm
496 (package
497 (name "rpm")
498 (version "4.14.2.1")
499 (source (origin
500 (method url-fetch)
501 (uri (string-append "http://ftp.rpm.org/releases/rpm-"
502 (version-major+minor version) ".x/rpm-"
503 version ".tar.bz2"))
504 (sha256
505 (base32
506 "1nmck2fq9h85fgs3zhh6w1avlw5y16cbz5khd459ry3jfd5w4f8i"))))
507 (build-system gnu-build-system)
508 (arguments
509 '(#:configure-flags '("--with-external-db" ;use the system's bdb
510 "--enable-python"
511 "--without-lua")
512 #:phases (modify-phases %standard-phases
513 (add-before 'configure 'set-nss-library-path
514 (lambda* (#:key inputs #:allow-other-keys)
515 (let ((nss (assoc-ref inputs "nss")))
516 (setenv "LIBRARY_PATH"
517 (string-append (getenv "LIBRARY_PATH") ":"
518 nss "/lib/nss"))
519 #t))))))
520 (native-inputs
521 `(("pkg-config" ,pkg-config)))
522 (inputs
523 `(("python" ,python)
524 ("xz" ,xz)
525 ("bdb" ,bdb)
526 ("popt" ,popt)
527 ("nss" ,nss)
528 ("nspr" ,nspr)
529 ("libarchive" ,libarchive)
530 ("nettle" ,nettle) ;XXX: actually a dependency of libarchive
531 ("file" ,file)
532 ("bzip2" ,bzip2)
533 ("zlib" ,zlib)
534 ("cpio" ,cpio)))
535 (home-page "https://rpm.org/")
536 (synopsis "The RPM Package Manager")
537 (description
538 "The RPM Package Manager (RPM) is a command-line driven package
539 management system capable of installing, uninstalling, verifying, querying,
540 and updating computer software packages. Each software package consists of an
541 archive of files along with information about the package like its version, a
542 description. There is also a library permitting developers to manage such
543 transactions from C or Python.")
544
545 ;; The whole is GPLv2+; librpm itself is dual-licensed LGPLv2+ | GPLv2+.
546 (license license:gpl2+)))
547
548 (define-public diffoscope
549 (package
550 (name "diffoscope")
551 (version (git-version "115" "1" "7f3416ffd12572b42c814e43ac15cee44ef48155"))
552 (source (origin
553 (method git-fetch)
554 (uri (git-reference
555 (url "https://salsa.debian.org/reproducible-builds/diffoscope.git")
556 (commit "7f3416ffd12572b42c814e43ac15cee44ef48155")))
557 (file-name (git-file-name name version))
558 (sha256
559 (base32
560 "1pn2rwlz5shdx7s63798wx2v7029bl5if6dlq3i2r6zsnpp0laki"))))
561 (build-system python-build-system)
562 (arguments
563 `(#:phases (modify-phases %standard-phases
564 ;; setup.py mistakenly requires python-magic from PyPi, even
565 ;; though the Python bindings of `file` are sufficient.
566 ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815844
567 (add-after 'unpack 'dependency-on-python-magic
568 (lambda _
569 (substitute* "setup.py"
570 (("'python-magic',") ""))))
571 ;; This test is broken because our `file` package has a
572 ;; bug in berkeley-db file type detection.
573 (add-after 'unpack 'remove-berkeley-test
574 (lambda _
575 (delete-file "tests/comparators/test_berkeley_db.py")
576 #t))
577 (add-after 'unpack 'embed-tool-references
578 (lambda* (#:key inputs #:allow-other-keys)
579 (substitute* "diffoscope/comparators/utils/compare.py"
580 (("\\['xxd',")
581 (string-append "['" (which "xxd") "',")))
582 (substitute* "diffoscope/comparators/elf.py"
583 (("@tool_required\\('readelf'\\)") "")
584 (("get_tool_name\\('readelf'\\)")
585 (string-append "'" (which "readelf") "'")))
586 (substitute* "diffoscope/comparators/directory.py"
587 (("@tool_required\\('stat'\\)") "")
588 (("@tool_required\\('getfacl'\\)") "")
589 (("\\['stat',")
590 (string-append "['" (which "stat") "',"))
591 (("\\['getfacl',")
592 (string-append "['" (which "getfacl") "',")))
593 #t))
594 (add-before 'check 'delete-failing-test
595 (lambda _
596 ;; this requires /sbin to be on the path
597 (delete-file "tests/test_tools.py")
598 #t)))))
599 (inputs `(("rpm" ,rpm) ;for rpm-python
600 ("python-file" ,python-file)
601 ("python-debian" ,python-debian)
602 ("python-libarchive-c" ,python-libarchive-c)
603 ("python-tlsh" ,python-tlsh)
604 ("acl" ,acl) ;for getfacl
605 ("colordiff" ,colordiff)
606 ("xxd" ,xxd)))
607 ;; Below are modules used for tests.
608 (native-inputs `(("python-pytest" ,python-pytest)
609 ("python-chardet" ,python-chardet)))
610 (home-page "https://diffoscope.org/")
611 (synopsis "Compare files, archives, and directories in depth")
612 (description
613 "Diffoscope tries to get to the bottom of what makes files or directories
614 different. It recursively unpacks archives of many kinds and transforms
615 various binary formats into more human readable forms to compare them. It can
616 compare two tarballs, ISO images, or PDFs just as easily.")
617 (license license:gpl3+)))
618
619 (define-public trydiffoscope
620 (package
621 (name "trydiffoscope")
622 (version "67.0.1")
623 (source
624 (origin
625 (method git-fetch)
626 (uri (git-reference
627 (url "https://salsa.debian.org/reproducible-builds/trydiffoscope.git")
628 (commit version)))
629 (file-name (git-file-name name version))
630 (sha256
631 (base32
632 "03b66cjii7l2yiwffj6ym6mycd5drx7prfp4j2550281pias6mjh"))))
633 (arguments
634 `(#:phases
635 (modify-phases %standard-phases
636 (add-after 'install 'install-doc
637 (lambda* (#:key outputs #:allow-other-keys)
638 (let* ((share (string-append (assoc-ref outputs "out") "/share/")))
639 (mkdir-p (string-append share "/man/man1/" ))
640 (invoke "rst2man.py"
641 "trydiffoscope.1.rst"
642 (string-append share "/man/man1/trydiffoscope.1"))
643 (mkdir-p (string-append share "/doc/" ,name "-" ,version))
644 (install-file "./README.rst"
645 (string-append share "/doc/" ,name "-" ,version)))
646 #t)))))
647 (propagated-inputs
648 `(("python-requests" ,python-requests)))
649 (native-inputs
650 `(("gzip" ,gzip)
651 ("python-docutils" ,python-docutils)))
652 (build-system python-build-system)
653 (home-page "https://try.diffoscope.org")
654 (synopsis "Client for remote diffoscope service")
655 (description "This is a client for the @url{https://try.diffoscope.org,
656 remote diffoscope service}.
657
658 Diffoscope tries to get to the bottom of what makes files or directories
659 different. It recursively unpacks archives of many kinds and transforms
660 various binary formats into more human readable forms to compare them. It can
661 compare two tarballs, ISO images, or PDFs just as easily.
662
663 Results are displayed by default, stored as local text or html files, or made
664 available via a URL on @url{https://try.diffoscope.org}. Results stored on the
665 server are purged after 30 days.")
666 (license license:gpl3+)))
667
668 (define-public python-anaconda-client
669 (package
670 (name "python-anaconda-client")
671 (version "1.6.3")
672 (source
673 (origin
674 (method url-fetch)
675 (uri (string-append "https://github.com/Anaconda-Platform/"
676 "anaconda-client/archive/" version ".tar.gz"))
677 (file-name (string-append name "-" version ".tar.gz"))
678 (sha256
679 (base32
680 "1wv4wi6k5jz7rlwfgvgfdizv77x3cr1wa2aj0k1595g7fbhkjhz2"))))
681 (build-system python-build-system)
682 (propagated-inputs
683 `(("python-pyyaml" ,python-pyyaml)
684 ("python-requests" ,python-requests)
685 ("python-clyent" ,python-clyent)))
686 (native-inputs
687 `(("python-pytz" ,python-pytz)
688 ("python-dateutil" ,python-dateutil)
689 ("python-mock" ,python-mock)
690 ("python-coverage" ,python-coverage)
691 ("python-pillow" ,python-pillow)))
692 (arguments
693 `(#:phases
694 (modify-phases %standard-phases
695 ;; This is needed for some tests.
696 (add-before 'check 'set-up-home
697 (lambda* _ (setenv "HOME" "/tmp") #t))
698 (add-before 'check 'remove-network-tests
699 (lambda* _
700 ;; Remove tests requiring a network connection
701 (let ((network-tests '("tests/test_upload.py"
702 "tests/test_authorizations.py"
703 "tests/test_login.py"
704 "tests/test_whoami.py"
705 "utils/notebook/tests/test_data_uri.py"
706 "utils/notebook/tests/test_base.py"
707 "utils/notebook/tests/test_downloader.py"
708 "inspect_package/tests/test_conda.py")))
709 (with-directory-excursion "binstar_client"
710 (for-each delete-file network-tests)))
711 #t)))))
712 (home-page "https://github.com/Anaconda-Platform/anaconda-client")
713 (synopsis "Anaconda Cloud command line client library")
714 (description
715 "Anaconda Cloud command line client library provides an interface to
716 Anaconda Cloud. Anaconda Cloud is useful for sharing packages, notebooks and
717 environments.")
718 (license license:bsd-3)))
719
720 (define-public python2-anaconda-client
721 (package-with-python2 python-anaconda-client))
722
723 (define-public python-conda
724 (package
725 (name "python-conda")
726 (version "4.3.16")
727 (source
728 (origin
729 (method url-fetch)
730 (uri (string-append "https://github.com/conda/conda/archive/"
731 version ".tar.gz"))
732 (file-name (string-append name "-" version ".tar.gz"))
733 (sha256
734 (base32
735 "1jq8hyrc5npb5sf4vw6s6by4602yj8f79vzpbwdfgpkn02nfk1dv"))))
736 (build-system python-build-system)
737 (arguments
738 `(#:phases
739 (modify-phases %standard-phases
740 (add-before 'build 'create-version-file
741 (lambda _
742 (with-output-to-file "conda/.version"
743 (lambda () (display ,version)))
744 #t))
745 (add-before 'check 'remove-failing-tests
746 (lambda _
747 ;; These tests require internet/network access
748 (let ((network-tests '("test_cli.py"
749 "test_create.py"
750 "test_export.py"
751 "test_fetch.py"
752 "test_history.py"
753 "test_info.py"
754 "test_install.py"
755 "test_priority.py"
756 "conda_env/test_cli.py"
757 "conda_env/test_create.py"
758 "conda_env/specs/test_notebook.py"
759 "conda_env/utils/test_notebooks.py"
760 "core/test_index.py"
761 "core/test_repodata.py")))
762 (with-directory-excursion "tests"
763 (for-each delete-file network-tests)
764
765 ;; FIXME: This test creates a file, then deletes it and tests
766 ;; that the file was deleted. For some reason it fails when
767 ;; building with guix, but does not when you run it in the
768 ;; directory left when you build with the --keep-failed
769 ;; option
770 (delete-file "gateways/disk/test_delete.py")
771 #t))))
772 (replace 'check
773 (lambda _
774 (setenv "HOME" "/tmp")
775 (invoke "py.test"))))))
776 (native-inputs
777 `(("python-cytoolz" ,python-cytoolz)
778 ("python-ruamel.yaml" ,python-ruamel.yaml)
779 ("python-requests" ,python-requests)
780 ("python-pycosat" ,python-pycosat)
781 ("python-pytest" ,python-pytest)
782 ("python-responses" ,python-responses)
783 ("python-pyyaml" ,python-pyyaml)
784 ("python-anaconda-client" ,python-anaconda-client)))
785 (home-page "https://github.com/conda/conda")
786 (synopsis "Cross-platform, OS-agnostic, system-level binary package manager")
787 (description
788 "Conda is a cross-platform, Python-agnostic binary package manager. It
789 is the package manager used by Anaconda installations, but it may be used for
790 other systems as well. Conda makes environments first-class citizens, making
791 it easy to create independent environments even for C libraries. Conda is
792 written entirely in Python.
793
794 This package provides Conda as a library.")
795 (license license:bsd-3)))
796
797 (define-public python2-conda
798 (let ((base (package-with-python2
799 (strip-python2-variant python-conda))))
800 (package (inherit base)
801 (native-inputs
802 `(("python2-enum34" ,python2-enum34)
803 ,@(package-native-inputs base))))))
804
805 (define-public conda
806 (package (inherit python-conda)
807 (name "conda")
808 (arguments
809 (substitute-keyword-arguments (package-arguments python-conda)
810 ((#:phases phases)
811 `(modify-phases ,phases
812 (replace 'build
813 (lambda* (#:key outputs #:allow-other-keys)
814 ;; This test fails when run before installation.
815 (delete-file "tests/test_activate.py")
816
817 ;; Fix broken defaults
818 (substitute* "conda/base/context.py"
819 (("return sys.prefix")
820 (string-append "return \"" (assoc-ref outputs "out") "\""))
821 (("return (prefix_is_writable\\(self.root_prefix\\))" _ match)
822 (string-append "return False if self.root_prefix == self.conda_prefix else "
823 match)))
824
825 ;; The util/setup-testing.py is used to build conda in
826 ;; application form, rather than the default, library form.
827 ;; With this, we are able to run commands like `conda --help`
828 ;; directly on the command line
829 (invoke "python" "utils/setup-testing.py" "build_py")))
830 (replace 'install
831 (lambda* (#:key inputs outputs #:allow-other-keys)
832 (let* ((out (assoc-ref outputs "out"))
833 (target (string-append out "/lib/python"
834 ((@@ (guix build python-build-system)
835 get-python-version)
836 (assoc-ref inputs "python"))
837 "/site-packages/")))
838 ;; The installer aborts if the target directory is not on
839 ;; PYTHONPATH.
840 (setenv "PYTHONPATH"
841 (string-append target ":" (getenv "PYTHONPATH")))
842
843 ;; And it aborts if the directory doesn't exist.
844 (mkdir-p target)
845 (invoke "python" "utils/setup-testing.py" "install"
846 (string-append "--prefix=" out)))))
847 ;; The "activate" and "deactivate" scripts don't need wrapping.
848 ;; They also break when they are renamed.
849 (add-after 'wrap 'undo-wrap
850 (lambda* (#:key outputs #:allow-other-keys)
851 (with-directory-excursion (string-append (assoc-ref outputs "out") "/bin/")
852 (delete-file "deactivate")
853 (rename-file ".deactivate-real" "deactivate")
854 (delete-file "activate")
855 (rename-file ".activate-real" "activate")
856 #t)))))))
857 (description
858 "Conda is a cross-platform, Python-agnostic binary package manager. It
859 is the package manager used by Anaconda installations, but it may be used for
860 other systems as well. Conda makes environments first-class citizens, making
861 it easy to create independent environments even for C libraries. Conda is
862 written entirely in Python.")))
863
864 (define-public gwl
865 (package
866 (name "gwl")
867 (version "0.1.1")
868 (source (origin
869 (method url-fetch)
870 (uri (string-append "https://www.guixwl.org/releases/gwl-"
871 version ".tar.gz"))
872 (sha256
873 (base32
874 "06pm967mq1wyggx7l0nfapw5s0k5qc5r9lawk2v3db868br779a7"))))
875 (build-system gnu-build-system)
876 (native-inputs
877 `(("autoconf" ,autoconf)
878 ("automake" ,automake)
879 ("pkg-config" ,pkg-config)))
880 (inputs
881 `(("guile" ,guile-2.2)))
882 (propagated-inputs
883 `(("guix" ,guix)
884 ("guile-commonmark" ,guile-commonmark)))
885 (home-page "https://www.guixwl.org")
886 (synopsis "Workflow management extension for GNU Guix")
887 (description "This project provides two subcommands to GNU Guix and
888 introduces two record types that provide a workflow management extension built
889 on top of GNU Guix.")
890 ;; The Scheme modules in guix/ and gnu/ are licensed GPL3+,
891 ;; the web interface modules in gwl/ are licensed AGPL3+,
892 ;; and the fonts included in this package are licensed OFL1.1.
893 (license (list license:gpl3+ license:agpl3+ license:silofl1.1))))
894
895 (define-public gcab
896 (package
897 (name "gcab")
898 (version "1.2")
899 (source (origin
900 (method url-fetch)
901 (uri (string-append "mirror://gnome/sources/gcab/"
902 version "/gcab-" version ".tar.xz"))
903 (sha256
904 (base32
905 "038h5kk41si2hc9d9169rrlvp8xgsxq27kri7hv2vr39gvz9cbas"))))
906 (build-system meson-build-system)
907 (native-inputs
908 `(("glib:bin" ,glib "bin") ; for glib-mkenums
909 ("intltool" ,intltool)
910 ("pkg-config" ,pkg-config)
911 ("vala" ,vala)))
912 (inputs
913 `(("glib" ,glib)
914 ("zlib" ,zlib)))
915 (arguments
916 `(#:configure-flags
917 ;; XXX This ‘documentation’ is for developers, and fails informatively:
918 ;; Error in gtkdoc helper script: 'gtkdoc-mkhtml' failed with status 5
919 (list "-Ddocs=false"
920 "-Dintrospection=false")))
921 (home-page "https://wiki.gnome.org/msitools") ; no dedicated home page
922 (synopsis "Microsoft Cabinet file manipulation library")
923 (description
924 "The libgcab library provides GObject functions to read, write, and modify
925 Microsoft cabinet (.@dfn{CAB}) files.")
926 (license (list license:gpl2+ ; tests/testsuite.at
927 license:lgpl2.1+)))) ; the rest
928
929 (define-public msitools
930 (package
931 (name "msitools")
932 (version "0.99")
933 (source (origin
934 (method url-fetch)
935 (uri (string-append "mirror://gnome/sources/msitools/"
936 version "/msitools-" version ".tar.xz"))
937 (sha256
938 (base32
939 "0d9nidn5zc81bc30w119933rn2g87mrsqyqkndg20srkbsd96xfl"))))
940 (build-system gnu-build-system)
941 (native-inputs
942 `(("bison" ,bison)
943 ("pkg-config" ,pkg-config)))
944 (inputs
945 `(("gcab" ,gcab)
946 ("glib" ,glib)
947 ("libgsf" ,libgsf)
948 ("libxml2" ,libxml2)
949 ("uuid" ,util-linux)))
950 (home-page "https://wiki.gnome.org/msitools")
951 (synopsis "Windows Installer file manipulation tool")
952 (description
953 "msitools is a collection of command-line tools to inspect, extract, build,
954 and sign Windows@tie{}Installer (.@dfn{MSI}) files. It aims to be a solution
955 for packaging and deployment of cross-compiled Windows applications.")
956 (license license:lgpl2.1+)))
957
958 (define-public libostree
959 (package
960 (name "libostree")
961 (version "2018.9.1")
962 (source (origin
963 (method url-fetch)
964 (uri (string-append
965 "https://github.com/ostreedev/ostree/releases/download/v"
966 (version-major+minor version) "/libostree-" version ".tar.xz"))
967 (sha256
968 (base32
969 "01mygpkbl9sk2vr3hjbpih6qlg8lwx0q5lklm09f7jfwfpnwyqzj"))))
970 (build-system gnu-build-system)
971 (arguments
972 '(#:phases
973 (modify-phases %standard-phases
974 (add-before 'check 'pre-check
975 (lambda _
976 ;; Don't try to use the non-existing '/var/tmp' as test
977 ;; directory.
978 (setenv "TEST_TMPDIR" (getenv "TMPDIR"))
979 #t)))
980 ;; XXX: fails with:
981 ;; tap-driver.sh: internal error getting exit status
982 ;; tap-driver.sh: fatal: I/O or internal error
983 #:tests? #f))
984 (native-inputs
985 `(("attr" ,attr) ; for tests
986 ("bison" ,bison)
987 ("glib:bin" ,glib "bin") ; for 'glib-mkenums'
988 ("gobject-introspection" ,gobject-introspection)
989 ("pkg-config" ,pkg-config)
990 ("xsltproc" ,libxslt)))
991 (inputs
992 `(("avahi" ,avahi)
993 ("docbook-xml" ,docbook-xml-4.2)
994 ("docbook-xsl" ,docbook-xsl)
995 ("e2fsprogs" ,e2fsprogs)
996 ("fuse" ,fuse)
997 ("glib" ,glib)
998 ("gpgme" ,gpgme)
999 ("libarchive" ,libarchive)
1000 ("libsoup" ,libsoup)
1001 ("nettle" ,nettle) ; required by 'libarchive.la'
1002 ("util-linux" ,util-linux)))
1003 (home-page "https://ostree.readthedocs.io/en/latest/")
1004 (synopsis "Operating system and container binary deployment and upgrades")
1005 (description
1006 "@code{libostree} is both a shared library and suite of command line
1007 tools that combines a \"git-like\" model for committing and downloading
1008 bootable file system trees, along with a layer for deploying them and managing
1009 the boot loader configuration.")
1010 (license license:lgpl2.0+)))
1011
1012 (define-public flatpak
1013 (package
1014 (name "flatpak")
1015 (version "1.2.4")
1016 (source
1017 (origin
1018 (method url-fetch)
1019 (uri (string-append "https://github.com/flatpak/flatpak/releases/download/"
1020 version "/flatpak-" version ".tar.xz"))
1021 (sha256
1022 (base32
1023 "1qf3ys84fzv11z6f6li59rxjdjbyrv7cyi9539k73r9i9pckjr8v"))))
1024
1025 ;; Wrap 'flatpak' so that GIO_EXTRA_MODULES is set, thereby allowing GIO to
1026 ;; find the TLS backend in glib-networking.
1027 (build-system glib-or-gtk-build-system)
1028
1029 (arguments
1030 '(#:tests? #f ;; Tests fail due to trying to create files where it can't.
1031 #:configure-flags (list
1032 "--enable-documentation=no" ;; FIXME
1033 "--enable-system-helper=no"
1034 "--localstatedir=/var"
1035 (string-append "--with-system-bubblewrap="
1036 (assoc-ref %build-inputs "bubblewrap")
1037 "/bin/bwrap"))))
1038 (native-inputs `(("bison" ,bison)
1039 ("gettext" ,gnu-gettext)
1040 ("glib:bin" ,glib "bin") ; for glib-mkenums + gdbus-codegen
1041 ("gobject-introspection" ,gobject-introspection)
1042 ("libcap" ,libcap)
1043 ("pkg-config" ,pkg-config)))
1044 (propagated-inputs `(("glib-networking" ,glib-networking)
1045 ("gnupg" ,gnupg)
1046 ("gsettings-desktop-schemas"
1047 ,gsettings-desktop-schemas)))
1048 (inputs `(("appstream-glib" ,appstream-glib)
1049 ("bubblewrap" ,bubblewrap)
1050 ("dconf" ,dconf)
1051 ("gdk-pixbuf" ,gdk-pixbuf)
1052 ("gpgme" ,gpgme)
1053 ("json-glib" ,json-glib)
1054 ("libarchive" ,libarchive)
1055 ("libostree" ,libostree)
1056 ("libseccomp" ,libseccomp)
1057 ("libsoup" ,libsoup)
1058 ("libxau" ,libxau)
1059 ("libxml2" ,libxml2)
1060 ("nettle" ,nettle)
1061 ("util-linux" ,util-linux)))
1062 (home-page "https://flatpak.org")
1063 (synopsis "System for building, distributing, and running sandboxed desktop
1064 applications")
1065 (description "Flatpak is a system for building, distributing, and running
1066 sandboxed desktop applications on GNU/Linux.")
1067 (license license:lgpl2.1+)))