gnu: sddm: Use qt-build-system.
[jackhill/guix/guix.git] / gnu / packages / education.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
3 ;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
5 ;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages education)
25 #:use-module (ice-9 regex)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages base)
28 #:use-module (gnu packages bash)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages curl)
31 #:use-module (gnu packages databases)
32 #:use-module (gnu packages fonts)
33 #:use-module (gnu packages freedesktop)
34 #:use-module (gnu packages game-development)
35 #:use-module (gnu packages gettext)
36 #:use-module (gnu packages glib)
37 #:use-module (gnu packages gnome)
38 #:use-module (gnu packages gtk)
39 #:use-module (gnu packages javascript)
40 #:use-module (gnu packages kde)
41 #:use-module (gnu packages kde-frameworks) ; extra-cmake-modules
42 #:use-module (gnu packages perl)
43 #:use-module (gnu packages pkg-config)
44 #:use-module (gnu packages python)
45 #:use-module (gnu packages qt)
46 #:use-module (gnu packages sdl)
47 #:use-module (gnu packages sqlite)
48 #:use-module (gnu packages texinfo)
49 #:use-module (gnu packages tls)
50 #:use-module (gnu packages xorg)
51 #:use-module (gnu packages xml)
52 #:use-module ((guix licenses) #:prefix license:)
53 #:use-module (guix packages)
54 #:use-module (guix download)
55 #:use-module (guix git-download)
56 #:use-module (guix svn-download)
57 #:use-module (guix utils)
58 #:use-module (guix build-system cmake)
59 #:use-module (guix build-system gnu)
60 #:use-module (guix build-system python)
61 #:use-module (guix build-system trivial)
62 #:use-module (srfi srfi-1))
63
64 (define-public gcompris
65 (package
66 (name "gcompris")
67 (version "17.05")
68 (source (origin
69 (method url-fetch)
70 (uri (string-append "http://gcompris.net/download/gtk/src/gcompris-"
71 version ".tar.bz2"))
72 (sha256
73 (base32
74 "18y483alb4r4vfmh80nnl0pah5gv0b8frcm6l1drb9njn5xlcpgc"))))
75 (build-system gnu-build-system)
76 (arguments
77 `(#:configure-flags
78 ;; Use SDL mixer because otherwise GCompris would need an old version
79 ;; of Gstreamer.
80 (list "--enable-sdlmixer"
81 "LDFLAGS=-lgmodule-2.0")
82 #:phases
83 (modify-phases %standard-phases
84 (add-after 'set-paths 'set-sdl-paths
85 (lambda* (#:key inputs #:allow-other-keys)
86 (setenv "CPATH"
87 (string-append (assoc-ref inputs "sdl-mixer")
88 "/include/SDL:"
89 (or (getenv "CPATH") "")))
90 #t)))))
91 (inputs
92 `(("gtk+" ,gtk+-2)
93 ("librsvg" ,librsvg)
94 ("libxml2" ,libxml2)
95 ("sdl-mixer" ,sdl-mixer)
96 ("sqlite" ,sqlite)
97 ("glib:bin" ,glib)
98 ("python" ,python)))
99 (native-inputs
100 `(("intltool" ,intltool)
101 ("texinfo" ,texinfo)
102 ("texi2html" ,texi2html)
103 ("glib:bin" ,glib "bin")
104 ("pkg-config" ,pkg-config)))
105 (home-page "http://gcompris.net")
106 (synopsis "Educational software suite")
107 (description "GCompris is an educational software suite comprising of
108 numerous activities for children aged 2 to 10. Some of the activities are
109 game orientated, but nonetheless still educational. Below you can find a list
110 of categories with some of the activities available in that category.
111
112 @enumerate
113 @item computer discovery: keyboard, mouse, different mouse gestures, ...
114 @item arithmetic: table memory, enumeration, double entry table, mirror image, ...
115 @item science: the canal lock, the water cycle, the submarine, electric simulation ...
116 @item geography: place the country on the map
117 @item games: chess, memory, connect 4, oware, sudoku ...
118 @item reading: reading practice
119 @item other: learn to tell time, puzzle of famous paintings, vector drawing, cartoon making, ...
120 @end enumerate
121 ")
122 (license license:gpl3+)))
123
124 (define-public gcompris-qt
125 (package
126 (name "gcompris-qt")
127 (version "0.96")
128 (source
129 (origin
130 (method url-fetch)
131 (uri (string-append
132 "https://gcompris.net/download/qt/src/gcompris-qt-"
133 version ".tar.xz"))
134 (sha256
135 (base32 "06483il59l46ny2w771sg45dgzjwv1ph7vidzzbj0wb8wbk2rg52"))))
136 (build-system cmake-build-system)
137 (arguments
138 `(#:phases
139 (modify-phases %standard-phases
140 (add-before 'check 'start-xorg-server
141 (lambda* (#:key inputs #:allow-other-keys)
142 ;; The test suite requires a running X server.
143 (system (string-append (assoc-ref inputs "xorg-server")
144 "/bin/Xvfb :1 &"))
145 (setenv "DISPLAY" ":1")
146 #t))
147 (add-after 'install 'wrap-executable
148 (lambda* (#:key inputs outputs #:allow-other-keys)
149 (let ((out (assoc-ref outputs "out")))
150 (wrap-program (string-append out "/bin/gcompris-qt")
151 `("QT_PLUGIN_PATH" ":" prefix
152 ,(map (lambda (label)
153 (string-append (assoc-ref inputs label)
154 "/lib/qt5/plugins"))
155 '("qtbase" "qtdeclarative" "qtmultimedia" "qtsvg")))
156 `("QML2_IMPORT_PATH" ":" prefix
157 ,(map (lambda (label)
158 (string-append (assoc-ref inputs label)
159 "/lib/qt5/qml"))
160 '("qtdeclarative" "qtgraphicaleffects"
161 "qtmultimedia" "qtquickcontrols"))))
162 #t))))
163 #:configure-flags (list "-DQML_BOX2D_MODULE=disabled"
164 "-DBUILD_TESTING=TRUE")))
165 (native-inputs
166 `(("extra-cmake-modules" ,extra-cmake-modules)
167 ("gettext" ,gettext-minimal)
168 ("perl" ,perl)
169 ("qttools" ,qttools)
170 ("xorg-server" ,xorg-server-for-tests)))
171 (inputs
172 `(("openssl" ,openssl)
173 ("python-2" ,python-2)
174 ("qtbase" ,qtbase)
175 ("qtdeclarative" ,qtdeclarative)
176 ("qtgraphicaleffects" ,qtgraphicaleffects)
177 ("qtmultimedia" ,qtmultimedia)
178 ("qtquickcontrols" ,qtquickcontrols)
179 ("qtsensors" ,qtsensors)
180 ("qtsvg" ,qtsvg)
181 ("qtxmlpatterns" ,qtxmlpatterns)))
182 (home-page "https://gcompris.net/index-en.html")
183 (synopsis "Educational games for small children")
184 (description
185 "Gcompris offers a large collection of educational games for small
186 children, designed to be a unified interface to integrate more educational
187 games. Language-oriented games contain vocabulary, sounds, and voices for
188 many different languages.
189 Currently available boards include:
190 @enumerate
191 @item learning how to use a mouse and keyboard
192 @item learning simple arithmetic
193 @item learning how to read an analog clock
194 @item recognize letters after hearing their names
195 @item reading practice
196 @item small games (memory games, jigsaw puzzles, ...)
197 @end enumerate\n")
198 (license license:gpl3+)))
199
200 (define-public tipp10
201 (package
202 (name "tipp10")
203 (version "2.1.0")
204 (source (origin
205 (method url-fetch)
206 ;; guix download is not able to handle the download links on the
207 ;; home-page, which use '<meta http-equiv="refresh" …>'
208 (uri (string-append "mirror://debian/pool/main/"
209 "t/tipp10/tipp10_2.1.0.orig.tar.gz"))
210 (sha256
211 (base32
212 "0d387b404j88gsv6kv0rb7wxr23v5g5vl6s5l7602x8pxf7slbbx"))
213 (patches (search-patches "tipp10-fix-compiling.patch"
214 "tipp10-remove-license-code.patch"))))
215 (build-system cmake-build-system)
216 (arguments
217 `(#:tests? #f ; packages has no tests
218 #:phases
219 (modify-phases %standard-phases
220 (add-after 'unpack 'disable-new-version-check
221 (lambda _
222 ;; Make new version check to default to false.
223 ;; TODO: Remove the checkbox from the dialog and the check itself
224 (substitute* '("widget/settingspages.cpp" "widget/mainwindow.cpp")
225 (("settings.value(\"check_new_version\", true)")
226 "settings.value(\"check_new_version\", false)"))
227 #t))
228 (replace 'configure
229 (lambda* (#:key outputs #:allow-other-keys)
230 (let ((out (assoc-ref outputs "out")))
231 ;; Make program honor $PREFIX
232 (substitute* "tipp10.pro"
233 (("\\.path = /usr/") (string-append ".path = " out "/")))
234 (substitute* "def/defines.h"
235 (("\"/usr/") (string-append "\"" out "/")))
236 ;; Recreate Makefile
237 (invoke "qmake")))))))
238 (inputs
239 `(("qt4" ,qt-4)
240 ("sqlite" ,sqlite)))
241 (home-page "https://www.tipp10.com/")
242 (synopsis "Touch typing tutor")
243 (description "Tipp10 is a touch typing tutor. The ingenious thing about
244 the software is its intelligence feature: characters that are mistyped are
245 repeated more frequently. Beginners will find their way around right away so
246 they can start practicing without a hitch.
247
248 Useful support functions and an extensive progress tracker, topical lessons
249 and the ability to create your own practice lessons make learning to type
250 easy.")
251 (license license:gpl2)))
252
253 (define-public snap
254 (package
255 (name "snap")
256 (version "5.2.5")
257 (source
258 (origin
259 (method git-fetch)
260 (uri (git-reference
261 (url "https://github.com/jmoenig/Snap.git")
262 (commit (string-append "v" version))))
263 (file-name (git-file-name name version))
264 (sha256
265 (base32
266 "0smlqxd8gqy26dlsal197848lhynv74m8myxs6fdlnzgva1f3zzw"))))
267 (build-system trivial-build-system)
268 (arguments
269 `(#:modules ((guix build utils))
270 #:builder
271 (begin
272 (use-modules (guix build utils))
273 (let* ((source (assoc-ref %build-inputs "source"))
274 (out (assoc-ref %outputs "out"))
275 (share (string-append out "/share/snap")))
276 (copy-recursively source share)
277 ;; Replace the sole minified file in the package.
278 (with-directory-excursion (string-append share "/src")
279 (delete-file "FileSaver.min.js")
280 (symlink (string-append (assoc-ref %build-inputs "js-filesaver")
281 "/share/javascript/FileSaver.min.js")
282 "FileSaver.min.js"))
283 ;; Create a "snap" executable.
284 (let* ((bin (string-append out "/bin"))
285 (script (string-append bin "/snap"))
286 (snap (string-append share "/snap.html"))
287 (bash (string-append (assoc-ref %build-inputs "bash")
288 "/bin/sh"))
289 (xdg-open (string-append (assoc-ref %build-inputs "xdg-utils")
290 "/bin/xdg-open")))
291 (mkdir-p bin)
292 (call-with-output-file script
293 (lambda (port)
294 (format port "#!~a\n~a '~a'" bash xdg-open snap)))
295 (chmod script #o555)))
296 #t)))
297 (inputs
298 `(("bash" ,bash-minimal)
299 ("js-filesaver" ,js-filesaver)
300 ("xdg-utils" ,xdg-utils)))
301 (home-page "https://snap.berkeley.edu")
302 (synopsis "Visual, blocks based programming language")
303 (description "Snap! (formerly BYOB) is a visual, drag-and-drop
304 programming language. It is an extended reimplementation of Scratch (a
305 project of the Lifelong Kindergarten Group at the MIT Media Lab) that
306 allows you to Build Your Own Blocks. It also features first class
307 lists, first class procedures, and continuations. These added
308 capabilities make it suitable for a serious introduction to computer
309 science for high school or college students.
310
311 This package provides a @command{snap} executable calling @command{xdg-open}
312 to open the application in a web browser, for offline usage.")
313 (license license:agpl3+)))
314
315 (define-public toutenclic
316 (package
317 (name "toutenclic")
318 (version "7.00")
319 (source
320 (origin
321 (method url-fetch)
322 (uri (string-append "http://www.bipede.fr/downloads/logiciels/"
323 "ToutEnClic-" version "-src.zip"))
324 (sha256
325 (base32 "0xg24p925rl5bfqsq3jb2lrkidb0f3kbmay5iyxxmjsn3ra0blyh"))))
326 (build-system python-build-system)
327 (arguments
328 `(#:tests? #f ; no tests
329 #:phases
330 (modify-phases %standard-phases
331 (delete 'build)
332 (replace 'install
333 (lambda* (#:key outputs #:allow-other-keys)
334 (let* ((out (assoc-ref outputs "out"))
335 (share (string-append out "/share/toutenclic"))
336 (pixmaps (string-append out "/share/pixmaps"))
337 (doc (string-append out "share/doc/" ,name "-" ,version))
338 (bin (string-append out "/bin"))
339 (executable "toutenclic"))
340 ;; Install icon.
341 (install-file "toutenclic.png" pixmaps)
342 ;; Move files into "share/" directory.
343 (for-each (lambda (f) (install-file f share))
344 (find-files "." "\\.py$"))
345 ;; Install documentation.
346 (install-file "ToutEnClic.pdf" doc)
347 ;; Create executable in "bin/".
348 (mkdir-p bin)
349 (with-directory-excursion bin
350 (symlink (string-append share "/" executable ".py")
351 executable)))
352 #t))
353 (add-after 'install 'create-desktop-file
354 (lambda* (#:key outputs #:allow-other-keys)
355 (let* ((out (assoc-ref outputs "out"))
356 (applications (string-append out "/share/applications")))
357 (mkdir-p applications)
358 (call-with-output-file
359 (string-append applications "/toutenclic.desktop")
360 (lambda (file)
361 (format file
362 "[Desktop Entry]~@
363 Name=ToutEnClic~@
364 Comment=For schooling without difference~@
365 Exec=~a/bin/toutenclic~@
366 TryExec=~@*~a/bin/toutenclic~@
367 Terminal=false~@
368 Icon=toutenclic~@
369 Type=Application~%"
370 out)))
371 #t))))))
372 (inputs `(("python-pyqt" ,python-pyqt)))
373 (synopsis "School tools for physically disabled children")
374 (description "ToutEnClic is intended to facilitate the schooling
375 of physically disabled children in ordinary schools. It is both
376 a multi-page virtual exercise book and a kit including pencil,
377 scissors, glue, ruler, compass, protractor and square. A virtual
378 keyboard is also available if the child does not have any other
379 specialized device.")
380 (home-page "https://bipede.fr/contrib/")
381 (license license:gpl3)))
382
383 (define-public childsplay
384 (package
385 (name "childsplay")
386 (version "3.4")
387 (source (origin
388 (method url-fetch)
389 (uri (string-append
390 "mirror://sourceforge/schoolsplay/"
391 "childsplay-" version ".tgz"))
392 (sha256
393 (base32
394 "0z7yp2swjnbz51vn2zyfnjn40jq38l5mbh15yafmx1z3vn2z1m77"))))
395 (build-system python-build-system)
396 (arguments
397 `(#:python ,python-2
398 #:tests? #f
399 #:phases
400 (modify-phases %standard-phases
401 (add-after 'unpack 'unbundle-dejavu-font
402 (lambda* (#:key inputs #:allow-other-keys)
403 (let* ((dejavu-dir
404 (string-append (assoc-ref inputs "font-dejavu")
405 "/share/fonts/truetype"))
406 (dejavu-font
407 (string-append dejavu-dir
408 "/DejaVuSansCondensed-Bold.ttf")))
409 (substitute* "SPConstants.py"
410 (("^(TTF(BOLD)? = ).*" _ prefix)
411 (string-append prefix "'" dejavu-font "'\n")))
412 (for-each (lambda (f) (delete-file f))
413 (find-files "lib/SPData" "DejaVu"))
414 #t)))
415 (delete 'build)
416 (replace 'install
417 (lambda* (#:key outputs #:allow-other-keys)
418 (let* ((out (assoc-ref outputs "out"))
419 (pixmaps (string-append out "/share/pixmaps"))
420 (share (string-append out "/share/childsplay"))
421 (doc (string-append out "/share/doc/" ,name "-",version)))
422 ;; Install icon.
423 (install-file "lib/SPData/themes/childsplay/logo_cp.svg" pixmaps)
424 ;; Install data.
425 (mkdir-p share)
426 (for-each (lambda (f)
427 (copy-recursively f (string-append share "/" f)))
428 '("alphabet-sounds" "lib" "locale" "SPWidgets"))
429 (for-each (lambda (f) (install-file f share))
430 (find-files "." "\\.(py|dev|db)$"))
431 ;; Install documentation.
432 (mkdir-p doc)
433 (copy-recursively "docs" doc)
434 #t)))
435 (add-after 'install 'create-executable
436 (lambda* (#:key outputs inputs #:allow-other-keys)
437 (let* ((python (string-append (assoc-ref inputs "python")
438 "/bin/python"))
439 (out (assoc-ref outputs "out"))
440 (bin (string-append out "/bin"))
441 (executable (string-append bin "/childsplay")))
442 (mkdir-p bin)
443 (call-with-output-file executable
444 (lambda (file)
445 (format file
446 "~a ~a"
447 python
448 (string-append out "/share/childsplay/childsplay.py"))))
449 (chmod executable #o555)
450 #t)))
451 (add-after 'install 'create-desktop-file
452 (lambda* (#:key outputs #:allow-other-keys)
453 (let* ((out (assoc-ref outputs "out"))
454 (applications (string-append out "/share/applications")))
455 (mkdir-p applications)
456 (call-with-output-file
457 (string-append applications "/childsplay.desktop")
458 (lambda (file)
459 (format file
460 "[Desktop Entry]~@
461 Name=Childsplay~@
462 Comment=Suite of educational games for young children~@
463 Comment[ca]=Conjunt de jocs educatius per a xiquets~@
464 Comment[es]=Conjunto de juegos educativos para niños~@
465 Comment[de]=Sammlung mit lehrreichen Spielen für kleine Kinder~@
466 Exec=~a/bin/childsplay.py~@
467 Terminal=false~@
468 Icon=logo_cp.svg~@
469 Type=Application~@
470 Categories=Application;Game;Education;KidsGame;~@
471 Keywords=suite;children;games;young;educational;~%"
472 out)))
473 #t))))))
474 (inputs
475 `(("font-dejavu" ,font-dejavu)
476 ("pygame" ,python2-pygame)
477 ("sqlalchemy" ,python2-sqlalchemy)))
478 (synopsis "Suite of educational games for young children")
479 (description "Childsplay is a collection of educational activities
480 for young children. Childsplay can be used at home, kindergartens and
481 pre-schools. Childsplay is a fun and safe way to let young children
482 use the computer and at the same time teach them a little math,
483 letters of the alphabet, spelling, eye-hand coordination, etc.")
484 (home-page "http://www.schoolsplay.org")
485 (license license:gpl3+)))
486
487 (define-public fet
488 (package
489 (name "fet")
490 (version "5.40.2")
491 (source (origin
492 (method url-fetch)
493 (uri (string-append "https://www.lalescu.ro/liviu/fet/download/"
494 "fet-" version ".tar.bz2"))
495 (sha256
496 (base32
497 "068zdvb3rys7vvkq33i2jh89c7svvdaqp0548k99jmhbd24xnhgh"))))
498 (build-system gnu-build-system)
499 (arguments
500 `(#:phases
501 (modify-phases %standard-phases
502 (add-after 'unpack 'fix-hardcoded-directories
503 (lambda* (#:key outputs #:allow-other-keys)
504 (substitute* (list "fet.pro"
505 "src/src.pro"
506 "src/src-cl.pro"
507 "src/interface/fet.cpp")
508 (("/usr") (assoc-ref outputs "out")))
509 #t))
510 (replace 'configure
511 (lambda _ (invoke "qmake" "fet.pro"))))))
512 (inputs
513 `(("qtbase" ,qtbase)))
514 (home-page "https://www.lalescu.ro/liviu/fet/")
515 (synopsis "Timetabling software")
516 (description "FET is a program for automatically scheduling the
517 timetable of a school, high-school or university. It uses a fast and
518 efficient timetabling algorithm.
519
520 Usually, FET is able to solve a complicated timetable in maximum 5-20
521 minutes. For simpler timetables, it may take a shorter time, under
522 5 minutes (in some cases, a matter of seconds). For extremely
523 difficult timetables, it may take a longer time, a matter of hours.")
524 (license license:agpl3+)))
525
526 (define-public klavaro
527 (package
528 (name "klavaro")
529 (version "3.09")
530 (source
531 (origin
532 (method url-fetch)
533 (uri (string-append "mirror://sourceforge/klavaro/klavaro-"
534 version ".tar.bz2"))
535 (sha256
536 (base32
537 "12gml7h45b1w9s318h0d5wxw92h7pgajn2kh57j0ak9saq0yb0wr"))))
538 (build-system gnu-build-system)
539 (native-inputs
540 `(("intltool" ,intltool)
541 ("pkg-config" ,pkg-config)))
542 (inputs
543 `(("cairo" ,cairo)
544 ("curl" ,curl)
545 ("gtk+" ,gtk+)
546 ("pango" ,pango)))
547 (home-page "https://klavaro.sourceforge.io/en/index.html")
548 (synopsis "Touch typing tutor")
549 (description
550 "Klavaro is a simple tutor to teach correct typing, almost independently of
551 language and very flexible regarding to new or unknown keyboard layouts.")
552 (license license:gpl3+)))
553
554 (define-public ktouch
555 (package
556 (name "ktouch")
557 (version "19.08.1")
558 (source
559 (origin
560 (method url-fetch)
561 (uri (string-append "mirror://kde/stable/applications/"
562 version "/src/ktouch-" version ".tar.xz"))
563 (sha256
564 (base32
565 "19rdk94pls75hdvx11hnfk3qpm6l28p9q45q5f04sknxagrfaznr"))))
566 (build-system cmake-build-system)
567 (arguments
568 `(#:modules ((guix build cmake-build-system)
569 (guix build qt-utils)
570 (guix build utils))
571 #:imported-modules (,@%cmake-build-system-modules
572 (guix build qt-utils))
573 #:phases
574 (modify-phases %standard-phases
575 (add-after 'configure 'patch-makefiles
576 (lambda* (#:key inputs #:allow-other-keys)
577 (let ((qtdec (assoc-ref inputs "qtdeclarative")))
578 (substitute* '("src/CMakeFiles/ktouch_autogen.dir/build.make"
579 "src/CMakeFiles/ktouch.dir/build.make")
580 (("/gnu/store/.*qmlcachegen")
581 (string-append qtdec "/bin/qmlcachegen"))))
582 #t))
583 (add-after 'install 'wrap-executable
584 (lambda* (#:key outputs #:allow-other-keys)
585 (let ((out (assoc-ref outputs "out")))
586 (wrap-qt-program out "ktouch"))
587 #t)))))
588 (native-inputs
589 `(("extra-cmake-modules" ,extra-cmake-modules)
590 ("kdoctools" ,kdoctools)
591 ("pkg-config" ,pkg-config)))
592 (inputs
593 `(("kcmutils" ,kcmutils)
594 ("kcompletion" ,kcompletion)
595 ("kconfig" ,kconfig)
596 ("kconfigwidgets" ,kconfigwidgets)
597 ("kcoreaddons" ,kcoreaddons)
598 ("kdeclarative" ,kdeclarative)
599 ("ki18n" ,ki18n)
600 ("kiconthemes" ,kiconthemes)
601 ("kitemviews" ,kitemviews)
602 ("kqtquickcharts" ,kqtquickcharts)
603 ("ktextwidgets" ,ktextwidgets)
604 ("kwidgetsaddons" ,kwidgetsaddons)
605 ("kwindowsystem" ,kwindowsystem)
606 ("kxmlgui" ,kxmlgui)
607 ("libxcb" ,libxcb)
608 ("libxkbfile" ,libxkbfile)
609 ("qtbase" ,qtbase)
610 ("qtdeclarative" ,qtdeclarative)
611 ("qtgraphicaleffects" ,qtgraphicaleffects)
612 ("qtquickcontrols2" ,qtquickcontrols2)
613 ("qtx11extras" ,qtx11extras)
614 ("qtxmlpatterns" ,qtxmlpatterns)))
615 (home-page "https://edu.kde.org/ktouch/")
616 (synopsis "Touch typing tutor")
617 (description
618 "KTouch is an aid for learning how to type with speed and accuracy. It
619 provides a sample text to type and indicates which fingers should be used for
620 each key. A collection of lessons are included for a wide range of different
621 languages and keyboard layouts, and typing statistics are used to dynamically
622 adjust the level of difficulty.")
623 (license license:gpl2)))