Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / logging.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
5 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
6 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
8 ;;; Copyright © 2019 Meiyo Peng <meiyo@riseup.net>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages logging)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix packages)
28 #:use-module (guix utils)
29 #:use-module (guix download)
30 #:use-module (guix git-download)
31 #:use-module (guix build-system cmake)
32 #:use-module (guix build-system gnu)
33 #:use-module (guix build-system python)
34 #:use-module (gnu packages)
35 #:use-module (gnu packages ncurses)
36 #:use-module (gnu packages perl)
37 #:use-module (gnu packages python)
38 #:use-module (gnu packages python-web)
39 #:use-module (gnu packages python-xyz)
40 #:use-module (gnu packages autotools))
41
42 (define-public log4cpp
43 (package
44 (name "log4cpp")
45 (version "1.1.3")
46 (source (origin
47 (method url-fetch)
48 (uri (string-append "mirror://sourceforge/log4cpp/log4cpp-"
49 (version-major+minor version) ".x%20%28new%29"
50 "/log4cpp-" (version-major+minor version)
51 "/log4cpp-" version ".tar.gz"))
52 (sha256
53 (base32
54 "07gmr3jyaf2239n9sp6h7hwdz1pv7b7aka8n06gmr2fnlmaymfrc"))))
55 (build-system gnu-build-system)
56 (synopsis "Log library for C++")
57 (description
58 "Log4cpp is library of C++ classes for flexible logging to files, syslog,
59 IDSA and other destinations. It is modeled after the Log4j Java library,
60 staying as close to their API as is reasonable.")
61 (home-page "http://log4cpp.sourceforge.net/")
62 (license license:lgpl2.1+)))
63
64 (define-public glog
65 (package
66 (name "glog")
67 (version "0.4.0")
68 (home-page "https://github.com/google/glog")
69 (source (origin
70 (method git-fetch)
71 (uri (git-reference (url home-page)
72 (commit (string-append "v" version))))
73 (sha256
74 (base32
75 "1xd3maiipfbxmhc9rrblc5x52nxvkwxp14npg31y5njqvkvzax9b"))
76 (file-name (git-file-name name version))))
77 (build-system gnu-build-system)
78 (native-inputs
79 `(("perl" ,perl) ;for tests
80 ("autoconf" ,autoconf-wrapper)
81 ("automake" ,automake)
82 ("libtool" ,libtool)))
83 (synopsis "C++ logging library")
84 (description
85 "Google glog is a library that implements application-level logging.
86 This library provides logging APIs based on C++-style streams and various
87 helper macros. You can log a message by simply streaming things to log at a
88 particular severity level. It allows logging to be controlled from the
89 command line.")
90 (license license:bsd-3)))
91
92 (define-public tailon
93 (package
94 (name "tailon")
95 (version "1.3.0")
96 (source
97 (origin
98 (method url-fetch)
99 (uri (pypi-uri name version))
100 (sha256
101 (base32
102 "0wl2wm6p3pc0vkk33s7rzgcfvs9cwxfmlz997pdfhlw72r00l7s5"))))
103 (build-system python-build-system)
104 (inputs
105 `(("python-pyyaml" ,python-pyyaml)
106 ("python-sockjs-tornado" ,python-sockjs-tornado)
107 ("python-tornado-http-auth" ,python-tornado-http-auth)
108 ("python-tornado" ,python-tornado)))
109 (arguments
110 `(#:phases
111 (modify-phases %standard-phases
112 (add-after 'unpack 'patch-commands.py
113 (lambda args
114 (substitute* "tailon/commands.py"
115 (("self\\.first_in_path\\('grep'\\)")
116 (string-append"'" (which "grep") "'"))
117 (("self\\.first_in_path\\('gawk', 'awk'\\)")
118 (string-append"'" (which "gawk") "'"))
119 (("self\\.first_in_path\\('gsed', 'sed'\\)")
120 (string-append"'" (which "sed") "'"))
121 (("self\\.first_in_path\\('gtail', 'tail'\\)")
122 (string-append"'" (which "tail") "'")))
123 #t)))))
124 (home-page "https://tailon.readthedocs.io/")
125 (synopsis
126 "Webapp for looking at and searching through log files")
127 (description
128 "Tailon provides a web interface around the tail, grep, awk and sed
129 commands, displaying the results via a web interface.")
130 (license license:bsd-3)))
131
132 (define-public multitail
133 (package
134 (name "multitail")
135 (version "6.4.2")
136 (source
137 (origin
138 (method url-fetch)
139 (uri (string-append "https://vanheusden.com/multitail/multitail-"
140 version ".tgz"))
141 (sha256
142 (base32
143 "1zd1r89xkxngl1pdrvsc877838nwkfqkbcgfqm3vglwalxc587dg"))))
144 (build-system gnu-build-system)
145 (arguments
146 `(#:make-flags
147 (list "CC=gcc"
148 "PREFIX="
149 (string-append "DESTDIR="
150 (assoc-ref %outputs "out")))
151 #:phases
152 (modify-phases %standard-phases
153 (add-after 'unpack 'patch-curses-lib
154 (lambda* (#:key outputs #:allow-other-keys)
155 (let ((out (assoc-ref outputs "out")))
156 (substitute* "mt.h"
157 (("ncursesw\\/panel.h") "panel.h")
158 (("ncursesw\\/ncurses.h") "ncurses.h")))
159 #t))
160 (delete 'configure))
161 #:tests? #f)) ; no test suite (make check just runs cppcheck)
162 (inputs `(("ncurses" ,ncurses)))
163 (home-page "https://vanheusden.com/multitail/")
164 (synopsis "Monitor multiple logfiles")
165 (description
166 "MultiTail allows you to monitor logfiles and command output in multiple
167 windows in a terminal, colorize, filter and merge.")
168 (license license:gpl2+)))
169
170 (define-public spdlog
171 (package
172 (name "spdlog")
173 (version "1.3.1")
174 (source
175 (origin
176 (method git-fetch)
177 (uri (git-reference
178 (url "https://github.com/gabime/spdlog.git")
179 (commit (string-append "v" version))))
180 (sha256
181 (base32
182 "1rd4zmrlkcdjx0m0wpmjm1g9srj7jak6ai08qkhbn2lsn0niifzd"))))
183 (build-system cmake-build-system)
184 ;; TODO run benchmark. Currently not possible, as adding
185 ;; (gnu packages benchmark) forms a dependency cycle
186 (arguments
187 '(#:configure-flags
188 (list "-DSPDLOG_BUILD_BENCH=OFF")))
189 (home-page "https://github.com/gabime/spdlog")
190 (synopsis "Fast C++ logging library")
191 (description "Spdlog is a very fast header-only/compiled C++ logging
192 library.")
193 ;; spdlog is under Expat license, but the bundled fmt library in
194 ;; "include/spdlog/fmt/bundled" is under BSD 2 clause license.
195 (license (list license:expat license:bsd-2))))