Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / haskell-check.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
3 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
4 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
5 ;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
6 ;;; Copyright © 2016 ng0 <ng0@n0.is>
7 ;;; Copyright © 2016 David Craven <david@craven.ch>
8 ;;; Copyright © 2017 Danny Milosavljevic <dannym@scratchpost.org>
9 ;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
10 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
11 ;;; Copyright © 2018 Tonton <tonton@riseup.net>
12 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages haskell-check)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages haskell)
32 #:use-module (gnu packages haskell-crypto)
33 #:use-module (guix build-system haskell)
34 #:use-module (guix download)
35 #:use-module ((guix licenses) #:prefix license:)
36 #:use-module (guix packages)
37 #:use-module (guix utils))
38
39 (define-public ghc-tasty-ant-xml
40 (package
41 (name "ghc-tasty-ant-xml")
42 (version "1.1.4")
43 (source
44 (origin
45 (method url-fetch)
46 (uri (string-append
47 "https://hackage.haskell.org/package/tasty-ant-xml/tasty-ant-xml-"
48 version
49 ".tar.gz"))
50 (sha256
51 (base32
52 "0v0gsb90kh6hwlgxbclzawsskywc6yf7n8xhiifia97l4y0yx2m8"))))
53 (build-system haskell-build-system)
54 (inputs
55 `(("ghc-generic-deriving" ,ghc-generic-deriving)
56 ("ghc-xml" ,ghc-xml)
57 ("ghc-tagged" ,ghc-tagged)
58 ("ghc-tasty" ,ghc-tasty)))
59 (home-page
60 "https://github.com/ocharles/tasty-ant-xml")
61 (synopsis
62 "Render tasty output to XML for Jenkins")
63 (description
64 "A tasty ingredient to output test results in XML, using the Ant
65 schema. This XML can be consumed by the Jenkins continuous integration
66 framework.")
67 (license license:bsd-3)))
68
69 (define-public ghc-tasty-smallcheck
70 (package
71 (name "ghc-tasty-smallcheck")
72 (version "0.8.1")
73 (source
74 (origin
75 (method url-fetch)
76 (uri (string-append
77 "https://hackage.haskell.org/package/tasty-smallcheck/tasty-smallcheck-"
78 version
79 ".tar.gz"))
80 (sha256
81 (base32
82 "1n66ngzllf3xrlqykwszlkwsi96n5nkm7xbpfq7774vpvfnafjri"))))
83 (build-system haskell-build-system)
84 (inputs
85 `(("ghc-tasty" ,ghc-tasty)
86 ("ghc-smallcheck" ,ghc-smallcheck)
87 ("ghc-async" ,ghc-async)
88 ("ghc-tagged" ,ghc-tagged)))
89 (home-page "https://documentup.com/feuerbach/tasty")
90 (synopsis "SmallCheck support for the Tasty test framework")
91 (description "This package provides SmallCheck support for the Tasty
92 Haskell test framework.")
93 (license license:bsd-3)))
94
95 (define-public ghc-tasty-quickcheck
96 (package
97 (name "ghc-tasty-quickcheck")
98 (version "0.10")
99 (source
100 (origin
101 (method url-fetch)
102 (uri (string-append
103 "https://hackage.haskell.org/package/tasty-quickcheck/"
104 "tasty-quickcheck-" version ".tar.gz"))
105 (sha256
106 (base32
107 "0vr6szbbz3s5461i0zr8zpq347zfvidfzv5gf3xwxhm0yk731z8h"))))
108 (build-system haskell-build-system)
109 (inputs
110 `(("ghc-quickcheck" ,ghc-quickcheck)
111 ("ghc-tagged" ,ghc-tagged)
112 ("ghc-tasty" ,ghc-tasty)
113 ("ghc-random" ,ghc-random)
114 ("ghc-ansi-terminal" ,ghc-ansi-terminal)
115 ("ghc-tasty-hunit" ,ghc-tasty-hunit)
116 ("ghc-pcre-light" ,ghc-pcre-light)))
117 (home-page "http://documentup.com/feuerbach/tasty")
118 (synopsis "QuickCheck support for the Tasty test framework")
119 (description "This package provides QuickCheck support for the Tasty
120 Haskell test framework.")
121 (license license:expat)))
122
123 (define-public ghc-tasty-golden
124 (package
125 (name "ghc-tasty-golden")
126 (version "2.3.2")
127 (source
128 (origin
129 (method url-fetch)
130 (uri (string-append
131 "https://hackage.haskell.org/package/tasty-golden/tasty-golden-"
132 version
133 ".tar.gz"))
134 (sha256
135 (base32
136 "0k3ibjhjc9vcwzrjnl4rnwvfm8l81q347nb7dgvcib6n5wm3s404"))))
137 (build-system haskell-build-system)
138 (inputs
139 `(("ghc-temporary" ,ghc-temporary)
140 ("ghc-tasty" ,ghc-tasty)
141 ("ghc-optparse-applicative" ,ghc-optparse-applicative)
142 ("ghc-tagged" ,ghc-tagged)
143 ("ghc-async" ,ghc-async)
144 ("ghc-tasty-hunit" ,ghc-tasty-hunit)
145 ("ghc-temporary-rc" ,ghc-temporary-rc)))
146 (home-page
147 "https://github.com/feuerbach/tasty-golden")
148 (synopsis "Golden tests support for tasty")
149 (description
150 "This package provides support for @code{golden testing}. A @dfn{golden
151 test} is an IO action that writes its result to a file. To pass the test, this
152 output file should be identical to the corresponding @code{golden} file, which
153 contains the correct result for the test.")
154 (license license:expat)))
155
156 (define-public ghc-tasty
157 (package
158 (name "ghc-tasty")
159 (version "1.1.0.3")
160 (source
161 (origin
162 (method url-fetch)
163 (uri (string-append
164 "https://hackage.haskell.org/package/tasty/tasty-"
165 version
166 ".tar.gz"))
167 (sha256
168 (base32
169 "14riid753hjqr6lca1kgxpnvq0wykf0k3qc5jpag42hh8bszav22"))))
170 (build-system haskell-build-system)
171 (inputs
172 `(("ghc-tagged" ,ghc-tagged)
173 ("ghc-regex-tdfa" ,ghc-regex-tdfa)
174 ("ghc-optparse-applicative" ,ghc-optparse-applicative)
175 ("ghc-unbounded-delays" ,ghc-unbounded-delays)
176 ("ghc-async" ,ghc-async)
177 ("ghc-ansi-terminal" ,ghc-ansi-terminal)
178 ("ghc-clock-bootstrap" ,ghc-clock-bootstrap)
179 ("ghc-wcwidth" ,ghc-wcwidth-bootstrap)))
180 (home-page "http://documentup.com/feuerbach/tasty")
181 (synopsis "Modern and extensible testing framework")
182 (description "Tasty is a modern testing framework for Haskell. It lets
183 you combine your unit tests, golden tests, QuickCheck/SmallCheck properties,
184 and any other types of tests into a single test suite.")
185 (license license:expat)))
186
187 (define-public ghc-tasty-hunit
188 (package
189 (name "ghc-tasty-hunit")
190 (version "0.10.0.1")
191 (source
192 (origin
193 (method url-fetch)
194 (uri (string-append
195 "https://hackage.haskell.org/package/tasty-hunit/tasty-hunit-"
196 version
197 ".tar.gz"))
198 (sha256
199 (base32
200 "0j3hgga6c3s8h5snzivb8a75h96207ia2rlbxzj07xbf4zpkp44g"))))
201 (build-system haskell-build-system)
202 (inputs
203 `(("ghc-call-stack" ,ghc-call-stack-boot)
204 ("ghc-tasty" ,ghc-tasty)))
205 (home-page "http://documentup.com/feuerbach/tasty")
206 (synopsis "HUnit support for the Tasty test framework")
207 (description "This package provides HUnit support for the Tasty Haskell
208 test framework.")
209 (license license:expat)))
210
211 (define-public ghc-tasty-kat
212 (package
213 (name "ghc-tasty-kat")
214 (version "0.0.3")
215 (source (origin
216 (method url-fetch)
217 (uri (string-append "https://hackage.haskell.org/package/"
218 "tasty-kat/tasty-kat-" version ".tar.gz"))
219 (sha256
220 (base32
221 "14yvlpli6cv6bn3kh8mlfp4x1l6ns4fvmfv6hmj75cvxyzq029d7"))))
222 (build-system haskell-build-system)
223 (inputs
224 `(("ghc-tasty" ,ghc-tasty)
225 ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
226 ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
227 (home-page "https://github.com/vincenthz/tasty-kat")
228 (synopsis "Known Answer Tests (KAT) framework for tasty")
229 (description
230 "This package provides a @dfn{Known Answer Tests} (KAT) framework for
231 tasty.")
232 (license license:expat)))
233
234 (define-public ghc-tasty-th
235 (package
236 (name "ghc-tasty-th")
237 (version "0.1.7")
238 (source
239 (origin
240 (method url-fetch)
241 (uri (string-append
242 "https://hackage.haskell.org/package/tasty-th/tasty-th-"
243 version ".tar.gz"))
244 (sha256
245 (base32
246 "0b2ivrw2257m4cy4rjnkwqlarh83j1y3zywnmaqqqbvy667sqnj3"))))
247 (build-system haskell-build-system)
248 (inputs
249 `(("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
250 ("ghc-tasty" ,ghc-tasty)
251 ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
252 (home-page "https://github.com/bennofs/tasty-th")
253 (synopsis "Automatically generate tasty TestTrees")
254 (description
255 "Tasty-th automatically generates tasty TestTrees from functions of the
256 current module, using TemplateHaskell. This is a fork the original
257 test-framework-th package, modified to work with tasty instead of
258 test-framework.")
259 (license license:bsd-3)))
260
261 (define-public ghc-tasty-rerun
262 (package
263 (name "ghc-tasty-rerun")
264 (version "1.1.12")
265 (source (origin
266 (method url-fetch)
267 (uri (string-append
268 "https://hackage.haskell.org/package/tasty-rerun/"
269 "tasty-rerun-" version ".tar.gz"))
270 (sha256
271 (base32
272 "05lp4zy6lwd916snq6hs43848n62j9vdfl3s8sfivqydrax0vvd8"))))
273 (build-system haskell-build-system)
274 (inputs
275 `(("ghc-optparse-applicative" ,ghc-optparse-applicative)
276 ("ghc-reducers" ,ghc-reducers)
277 ("ghc-split" ,ghc-split)
278 ("ghc-tagged" ,ghc-tagged)
279 ("ghc-tasty" ,ghc-tasty)))
280 (home-page "https://github.com/ocharles/tasty-rerun")
281 (synopsis "Run tests by filtering the test tree")
282 (description "This package adds the ability to run tests by filtering the
283 test tree based on the result of a previous test run. You can use this to run
284 only those tests that failed in the last run, or to only run the tests that have
285 been added since previous test run.")
286 (license license:bsd-3)))
287
288 (define-public ghc-tasty-expected-failure
289 (package
290 (name "ghc-tasty-expected-failure")
291 (version "0.11.1.1")
292 (source
293 (origin
294 (method url-fetch)
295 (uri (string-append "https://hackage.haskell.org/package/"
296 "tasty-expected-failure/tasty-expected-failure-"
297 version ".tar.gz"))
298 (sha256
299 (base32
300 "1i2s809m644b7hgiblqay9j364r3fjj1rwbrahsn1pgr5q6mr6ji"))))
301 (build-system haskell-build-system)
302 (inputs
303 `(("ghc-tagged" ,ghc-tagged)
304 ("ghc-tasty" ,ghc-tasty)))
305 (home-page "http://github.com/nomeata/tasty-expected-failure")
306 (synopsis "Mark tasty tests as failure expected")
307 (description
308 "With the function @code{Test.Tasty.ExpectedFailure.expectFail} in the
309 provided module @code{Test.Tasty.ExpectedFailure}, you can mark that you
310 expect test cases to fail, and not to pass. This can be used for test-driven
311 development.")
312 (license license:expat)))
313
314 (define-public ghc-quickcheck-instances
315 (package
316 (name "ghc-quickcheck-instances")
317 (version "0.3.18")
318 (source
319 (origin
320 (method url-fetch)
321 (uri (string-append
322 "https://hackage.haskell.org/package/"
323 "quickcheck-instances/quickcheck-instances-"
324 version ".tar.gz"))
325 (sha256
326 (base32
327 "1bh1pzz5fdcqvzdcirqxna6fnjms02min5md716299g5niz46w55"))))
328 (build-system haskell-build-system)
329 (arguments
330 `(#:cabal-revision
331 ("1" "1sngfq3v71bvgjsl8cj5kh65m3fziwy8dkvwjzs0kxfrzr87faly")))
332 (inputs
333 `(("ghc-quickcheck" ,ghc-quickcheck)
334 ("ghc-base-compat" ,ghc-base-compat)
335 ("ghc-case-insensitive" ,ghc-case-insensitive)
336 ("ghc-hashable" ,ghc-hashable)
337 ("ghc-old-time" ,ghc-old-time)
338 ("ghc-scientific" ,ghc-scientific)
339 ("ghc-tagged" ,ghc-tagged)
340 ("ghc-transformers-compat" ,ghc-transformers-compat)
341 ("ghc-unordered-containers" ,ghc-unordered-containers)
342 ("ghc-uuid-types" ,ghc-uuid-types)
343 ("ghc-vector" ,ghc-vector)))
344 (home-page "https://github.com/aslatter/qc-instances")
345 (synopsis "Common quickcheck instances")
346 (description "This package provides QuickCheck instances for types
347 provided by the Haskell Platform.")
348 (license license:bsd-3)))
349
350 (define-public ghc-quickcheck-unicode
351 (package
352 (name "ghc-quickcheck-unicode")
353 (version "1.0.1.0")
354 (source
355 (origin
356 (method url-fetch)
357 (uri (string-append
358 "https://hackage.haskell.org/package/quickcheck-unicode/"
359 "quickcheck-unicode-" version ".tar.gz"))
360 (sha256
361 (base32
362 "0s43s1bzbg3gwsjgm7fpyksd1339f0m26dlw2famxwyzgvm0a80k"))))
363 (build-system haskell-build-system)
364 (inputs `(("ghc-quickcheck" ,ghc-quickcheck)))
365 (home-page
366 "https://github.com/bos/quickcheck-unicode")
367 (synopsis "Generator functions Unicode-related tests")
368 (description "This package provides generator and shrink functions for
369 testing Unicode-related software.")
370 (license license:bsd-3)))
371
372 (define-public ghc-quickcheck-io
373 (package
374 (name "ghc-quickcheck-io")
375 (version "0.2.0")
376 (source
377 (origin
378 (method url-fetch)
379 (uri (string-append
380 "https://hackage.haskell.org/package/quickcheck-io/quickcheck-io-"
381 version
382 ".tar.gz"))
383 (sha256
384 (base32
385 "08k4v7pkgjf30pv5j2dfv1gqv6hclxlniyq2sps8zq4zswcr2xzv"))))
386 (build-system haskell-build-system)
387 (inputs
388 `(("ghc-quickcheck" ,ghc-quickcheck)
389 ("ghc-hunit" ,ghc-hunit)))
390 (home-page
391 "https://github.com/hspec/quickcheck-io#readme")
392 (synopsis "Use HUnit assertions as QuickCheck properties")
393 (description "This package provides an orphan instance that allows you to
394 use HUnit assertions as QuickCheck properties.")
395 (license license:expat)))
396
397 (define-public ghc-quickcheck
398 (package
399 (name "ghc-quickcheck")
400 (version "2.11.3")
401 (outputs '("out" "doc"))
402 (source
403 (origin
404 (method url-fetch)
405 (uri (string-append
406 "https://hackage.haskell.org/package/QuickCheck/QuickCheck-"
407 version
408 ".tar.gz"))
409 (sha256
410 (base32
411 "0xhqk35fkzlbjcqbabg6962jkv8d688nzmz7ng4bm84x2d95d328"))))
412 (build-system haskell-build-system)
413 (arguments
414 `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
415 (inputs
416 `(("ghc-random" ,ghc-random)
417 ("ghc-tf-random" ,ghc-tf-random)))
418 (home-page "https://github.com/nick8325/quickcheck")
419 (synopsis "Automatic testing of Haskell programs")
420 (description
421 "QuickCheck is a library for random testing of program properties. The
422 programmer provides a specification of the program, in the form of properties
423 which functions should satisfy, and QuickCheck then tests that the properties
424 hold in a large number of randomly generated cases. Specifications are
425 expressed in Haskell, using combinators defined in the QuickCheck library.")
426 (license license:bsd-3)))
427
428 (define-public ghc-test-framework
429 (package
430 (name "ghc-test-framework")
431 (version "0.8.2.0")
432 (source
433 (origin
434 (method url-fetch)
435 (uri (string-append "https://hackage.haskell.org/package/test-framework/"
436 "test-framework-" version ".tar.gz"))
437 (sha256
438 (base32
439 "1hhacrzam6b8f10hyldmjw8pb7frdxh04rfg3farxcxwbnhwgbpm"))))
440 (build-system haskell-build-system)
441 (arguments
442 `(#:tests? #f ; FIXME: Tests do not build.
443 #:phases
444 (modify-phases %standard-phases
445 (add-before 'configure 'update-constraints
446 (lambda _
447 (substitute* "test-framework.cabal"
448 (("QuickCheck >= 2\\.3 && < 2\\.10")
449 "QuickCheck >= 2.3 && < 2.12")))))))
450 (native-inputs
451 `(("ghc-hunit" ,ghc-hunit)
452 ("ghc-quickcheck" ,ghc-quickcheck)))
453 (inputs
454 `(("ghc-ansi-terminal" ,ghc-ansi-terminal)
455 ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
456 ("ghc-hostname" ,ghc-hostname)
457 ("ghc-old-locale" ,ghc-old-locale)
458 ("ghc-random" ,ghc-random)
459 ("ghc-regex-posix" ,ghc-regex-posix)
460 ("ghc-xml" ,ghc-xml)
461 ("ghc-libxml" ,ghc-libxml)
462 ("ghc-semigroups" ,ghc-semigroups-bootstrap)))
463 (home-page "https://batterseapower.github.io/test-framework/")
464 (synopsis "Framework for running and organising tests")
465 (description
466 "This package allows tests such as QuickCheck properties and HUnit test
467 cases to be assembled into test groups, run in parallel (but reported in
468 deterministic order, to aid diff interpretation) and filtered and controlled
469 by command line options. All of this comes with colored test output, progress
470 reporting and test statistics output.")
471 (license license:bsd-3)))
472
473 (define-public ghc-test-framework-hunit
474 (package
475 (name "ghc-test-framework-hunit")
476 (version "0.3.0.2")
477 (source
478 (origin
479 (method url-fetch)
480 (uri (string-append "https://hackage.haskell.org/package/"
481 "test-framework-hunit/test-framework-hunit-"
482 version ".tar.gz"))
483 (sha256
484 (base32
485 "1y0b6vg8nfm43v90lxxcydhi6qlxhfy4vpxbzm5ic2w55bh8xjwm"))))
486 (build-system haskell-build-system)
487 (arguments
488 `(#:cabal-revision
489 ("3" "0i9mlalv7cl1iq43ld5myrnpszq5rxmd79hk495dcb08rglhgl3z")))
490 (inputs
491 `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
492 ("ghc-hunit" ,ghc-hunit)
493 ("ghc-test-framework" ,ghc-test-framework)))
494 (home-page "https://batterseapower.github.io/test-framework/")
495 (synopsis "HUnit support for test-framework")
496 (description
497 "This package provides HUnit support for the test-framework package.")
498 (license license:bsd-3)))
499
500 (define-public ghc-test-framework-quickcheck2
501 (package
502 (name "ghc-test-framework-quickcheck2")
503 (version "0.3.0.4")
504 (source
505 (origin
506 (method url-fetch)
507 (uri (string-append "https://hackage.haskell.org/package/"
508 "test-framework-quickcheck2/"
509 "test-framework-quickcheck2-" version ".tar.gz"))
510 (sha256
511 (base32
512 "0vj834337r6jzr3258cv68ly2sv5999mklpsrfngyk51kywsyqyp"))))
513 (build-system haskell-build-system)
514 (arguments
515 `(#:cabal-revision
516 ("1" "147ngmfdkskyg7mwsp5w73a4dbx3rp5s38bci3z03kn1m093lxff")))
517 (inputs
518 `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
519 ("ghc-quickcheck" ,ghc-quickcheck)
520 ("ghc-random" ,ghc-random)
521 ("ghc-test-framework" ,ghc-test-framework)))
522 (home-page "https://batterseapower.github.io/test-framework/")
523 (synopsis "QuickCheck2 support for test-framework")
524 (description
525 "This package provides QuickCheck2 support for the test-framework
526 package.")
527 (license license:bsd-3)))
528
529 (define-public ghc-test-framework-th
530 (package
531 (name "ghc-test-framework-th")
532 (version "0.2.4")
533 (source
534 (origin
535 (method url-fetch)
536 (uri (string-append "https://hackage.haskell.org/package/"
537 "test-framework-th-" version "/"
538 "test-framework-th-" version ".tar.gz"))
539 (sha256
540 (base32
541 "12lw7yj02jb9s0i7rb98jjam43j2h0gzmnbj9zi933fx7sg0sy4b"))))
542 (build-system haskell-build-system)
543 (inputs
544 `(("ghc-test-framework" ,ghc-test-framework)
545 ("ghc-language-haskell-extract" ,ghc-language-haskell-extract)
546 ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
547 ("ghc-regex-posix" ,ghc-regex-posix)))
548 (home-page "https://github.com/finnsson/test-generator")
549 (synopsis "Auto generate the HUnit- and Quickcheck-bulk-code
550 using Template Haskell")
551 (description "This library contains two functions:
552 @code{defaultMainGenerator} and @code{testGroupGenerator}.
553
554 @code{defaultMainGenerator} will extract all functions beginning with
555 @code{case_}, @code{prop_}, or @code{test_} in the module and put them in a
556 @code{testGroup}.
557
558 @code{testGroupGenerator} is like @code{defaultMainGenerator} but without
559 @code{defaultMain}. It is useful if you need a function for the testgroup
560 \(e.g. if you want to be able to call the testgroup from another module).")
561 (license license:bsd-3)))
562
563 (define-public ghc-hunit
564 (package
565 (name "ghc-hunit")
566 (version "1.6.0.0")
567 (outputs '("out" "doc"))
568 (source
569 (origin
570 (method url-fetch)
571 (uri (string-append "https://hackage.haskell.org/package/HUnit/"
572 "HUnit-" version ".tar.gz"))
573 (sha256
574 (base32
575 "1pnhwqq5v8h48gbp3ibv3skfj25mf4zs5svxcavq93p9cswycj3l"))))
576 (build-system haskell-build-system)
577 (inputs
578 ;; We cannot use ghc-call-stack there, because it depends on
579 ;; ghc-nanospec, which depends on ghc-hunit.
580 `(("ghc-call-stack" ,ghc-call-stack-boot)))
581 (home-page "http://hunit.sourceforge.net/")
582 (synopsis "Unit testing framework for Haskell")
583 (description
584 "HUnit is a unit testing framework for Haskell, inspired by the
585 JUnit tool for Java.")
586 (license license:bsd-3)))
587
588 (define-public hspec-discover
589 (package
590 (name "hspec-discover")
591 (version "2.5.5")
592 (source
593 (origin
594 (method url-fetch)
595 (uri (string-append "https://hackage.haskell.org/package/"
596 "hspec-discover/hspec-discover-"
597 version ".tar.gz"))
598 (sha256
599 (base32
600 "04aidzi91ccr9bygmfkjzshz34z9vh8wvqj4zinx2clxq6r7gqfz"))))
601 (build-system haskell-build-system)
602 (native-inputs
603 `(("ghc-quickcheck" ,ghc-quickcheck)
604 ("ghc-hspec-meta" ,ghc-hspec-meta)))
605 (home-page "https://hspec.github.io/")
606 (synopsis "Automatically discover and run Hspec tests")
607 (description "hspec-discover is a tool which automatically discovers and
608 runs Hspec tests.")
609 (license license:expat)))
610
611 (define-public ghc-hspec-core
612 (package
613 (name "ghc-hspec-core")
614 (version "2.5.5")
615 (source
616 (origin
617 (method url-fetch)
618 (uri (string-append "https://hackage.haskell.org/package/hspec-core/"
619 "hspec-core-" version ".tar.gz"))
620 (sha256
621 (base32
622 "1vfrqlpn32s9wiykmkxbnrnd5p56yznw20pf8fwzw78ar4wpz55x"))))
623 (build-system haskell-build-system)
624 (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
625 (inputs
626 `(("ghc-setenv" ,ghc-setenv)
627 ("ghc-ansi-terminal" ,ghc-ansi-terminal)
628 ("ghc-async" ,ghc-async)
629 ("ghc-clock" ,ghc-clock)
630 ("ghc-quickcheck-io" ,ghc-quickcheck-io)
631 ("ghc-hunit" ,ghc-hunit)
632 ("ghc-quickcheck" ,ghc-quickcheck)
633 ("ghc-hspec-expectations" ,ghc-hspec-expectations)
634 ("ghc-silently" ,ghc-silently)))
635 (home-page "https://hspec.github.io/")
636 (synopsis "Testing framework for Haskell")
637 (description "This library exposes internal types and functions that can
638 be used to extend Hspec's functionality.")
639 (license license:expat)))
640
641 (define-public ghc-hspec-meta
642 (package
643 (name "ghc-hspec-meta")
644 (version "2.4.6")
645 (source
646 (origin
647 (method url-fetch)
648 (uri (string-append "https://hackage.haskell.org/package/hspec-meta/"
649 "hspec-meta-" version ".tar.gz"))
650 (sha256
651 (base32
652 "0qmvk01n79j6skn79r6zalg2pd0x0nqqn9qn8mhg0pgyzcdnfc9b"))))
653 (build-system haskell-build-system)
654 (inputs
655 `(("ghc-quickcheck" ,ghc-quickcheck)
656 ("ghc-hunit" ,ghc-hunit)
657 ("ghc-ansi-terminal" ,ghc-ansi-terminal)
658 ("ghc-async" ,ghc-async)
659 ("ghc-hspec-expectations" ,ghc-hspec-expectations)
660 ("ghc-setenv" ,ghc-setenv)
661 ("ghc-random" ,ghc-random)
662 ("ghc-quickcheck-io" ,ghc-quickcheck-io)))
663 (home-page "https://hspec.github.io/")
664 (synopsis "Version of Hspec to test Hspec itself")
665 (description "This library provides a stable version of Hspec which is
666 used to test the in-development version of Hspec.")
667 (license license:expat)))
668
669 (define-public ghc-hspec
670 (package
671 (name "ghc-hspec")
672 (version "2.5.5")
673 (source
674 (origin
675 (method url-fetch)
676 (uri (string-append "https://hackage.haskell.org/package/hspec/"
677 "hspec-" version ".tar.gz"))
678 (sha256
679 (base32
680 "1yv4k5b5kkig2q3waj28587sq28wms7wfav5a3lq4dra6jybimfm"))))
681 (build-system haskell-build-system)
682 (inputs
683 `(("ghc-hspec-core" ,ghc-hspec-core)
684 ("hspec-discover" ,hspec-discover)
685 ("ghc-hspec-expectations" ,ghc-hspec-expectations)
686 ("ghc-quickcheck" ,ghc-quickcheck)
687 ("ghc-hunit" ,ghc-hunit)
688 ("ghc-stringbuilder" ,ghc-stringbuilder)
689 ("ghc-hspec-meta" ,ghc-hspec-meta)))
690 (home-page "https://hspec.github.io/")
691 (synopsis "Testing Framework for Haskell")
692 (description "This library provides the Hspec testing framework for
693 Haskell, inspired by the Ruby library RSpec.")
694 (license license:expat)))
695
696 (define-public ghc-hspec-contrib
697 (package
698 (name "ghc-hspec-contrib")
699 (version "0.5.0")
700 (source (origin
701 (method url-fetch)
702 (uri (string-append "https://hackage.haskell.org/package/"
703 "hspec-contrib/hspec-contrib-"
704 version ".tar.gz"))
705 (sha256
706 (base32
707 "13579xdqwbsy8k0vxdcvgy932d4p76mij1rzkzbpqbspfn7399yv"))))
708 (build-system haskell-build-system)
709 (inputs
710 `(("ghc-hspec-core" ,ghc-hspec-core)
711 ("ghc-hunit" ,ghc-hunit)
712 ("ghc-hspec" ,ghc-hspec)
713 ("ghc-quickcheck" ,ghc-quickcheck)))
714 (native-inputs
715 `(("hspec-discover" ,hspec-discover)))
716 (home-page "https://hspec.github.io/")
717 (synopsis "Contributed functionality for Hspec")
718 (description
719 "This package provides contributed Hspec extensions.")
720 (license license:expat)))
721
722 (define-public ghc-hspec-expectations
723 (package
724 (name "ghc-hspec-expectations")
725 (version "0.8.2")
726 (source
727 (origin
728 (method url-fetch)
729 (uri (string-append "https://hackage.haskell.org/package/"
730 "hspec-expectations/hspec-expectations-"
731 version ".tar.gz"))
732 (sha256
733 (base32
734 "1vxl9zazbaapijr6zmcj72j9wf7ka1pirrjbwddwwddg3zm0g5l1"))))
735 (build-system haskell-build-system)
736 ;; Tests depend on ghc-nanospec.
737 (arguments '(#:tests? #f))
738 (inputs `(("ghc-hunit" ,ghc-hunit)))
739 (home-page "https://github.com/sol/hspec-expectations")
740 (synopsis "Catchy combinators for HUnit")
741 (description "This library provides catchy combinators for HUnit, see
742 @uref{https://github.com/sol/hspec-expectations#readme, the README}.")
743 (license license:expat)))
744
745 (define-public ghc-nanospec
746 (package
747 (name "ghc-nanospec")
748 (version "0.2.2")
749 (source
750 (origin
751 (method url-fetch)
752 (uri (string-append "https://hackage.haskell.org/package/"
753 "nanospec/nanospec-"
754 version ".tar.gz"))
755 (sha256
756 (base32
757 "1rcmhl9bhyfvanalnf1r86wkx6rq6wdvagnw1h011jcnnb1cq56g"))))
758 (build-system haskell-build-system)
759 (inputs
760 `(("ghc-hspec" ,ghc-hspec)
761 ("ghc-silently" ,ghc-silently)))
762 (home-page "https://github.com/hspec/nanospec#readme")
763 (synopsis "Lightweight implementation of a subset of Hspec's API")
764 (description
765 "Nanospec is a lightweight implementation of a subset of Hspec's API with
766 minimal dependencies.")
767 (license license:expat)))
768
769 (define-public ghc-crypto-cipher-tests
770 (package
771 (name "ghc-crypto-cipher-tests")
772 (version "0.0.11")
773 (source
774 (origin
775 (method url-fetch)
776 (uri (string-append "https://hackage.haskell.org/package/"
777 "crypto-cipher-tests-" version "/"
778 "crypto-cipher-tests-" version ".tar.gz"))
779 (sha256
780 (base32
781 "19wqignlq90qwpam01hnmmrxaxh5lkax9l1l6rlbi4a07nvp1dnz"))))
782 (build-system haskell-build-system)
783 (inputs `(("ghc-quickcheck" ,ghc-quickcheck)
784 ("ghc-hunit" ,ghc-hunit)
785 ("ghc-test-framework" ,ghc-test-framework)
786 ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
787 ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
788 ("ghc-byteable" ,ghc-byteable)
789 ("ghc-securemem" ,ghc-securemem)
790 ("ghc-crypto-cipher-types" ,ghc-crypto-cipher-types)))
791 (home-page "https://github.com/vincenthz/hs-crypto-cipher")
792 (synopsis "Generic cryptography cipher tests for Haskell")
793 (description " This Haskell package contains generic tests for
794 cryptographic ciphers, and is used by the test runners of various Haskell
795 implementations of cryptographic ciphers.")
796 (license license:bsd-3)))
797
798 (define-public ghc-hedgehog
799 (package
800 (name "ghc-hedgehog")
801 (version "0.6.1")
802 (source
803 (origin
804 (method url-fetch)
805 (uri (string-append
806 "mirror://hackage/package/hedgehog/hedgehog-"
807 version
808 ".tar.gz"))
809 (sha256
810 (base32
811 "0xz10ycdm5vk9nrcym1fi83k19frfwqz18bz8bnpzwvaj0j41yfj"))))
812 (build-system haskell-build-system)
813 (inputs
814 `(("ghc-ansi-terminal" ,ghc-ansi-terminal-0.8)
815 ("ghc-async" ,ghc-async)
816 ("ghc-concurrent-output" ,ghc-concurrent-output)
817 ("ghc-exceptions" ,ghc-exceptions)
818 ("ghc-lifted-async" ,ghc-lifted-async)
819 ("ghc-mmorph" ,ghc-mmorph)
820 ("ghc-monad-control" ,ghc-monad-control)
821 ("ghc-pretty-show" ,ghc-pretty-show)
822 ("ghc-primitive" ,ghc-primitive)
823 ("ghc-random" ,ghc-random)
824 ("ghc-resourcet" ,ghc-resourcet)
825 ("ghc-semigroups" ,ghc-semigroups)
826 ("ghc-th-lift" ,ghc-th-lift)
827 ("ghc-transformers-base" ,ghc-transformers-base)
828 ("ghc-wl-pprint-annotated"
829 ,ghc-wl-pprint-annotated)))
830 (home-page "https://hedgehog.qa")
831 (synopsis "Property-based testing in the spirt of QuickCheck")
832 (description
833 "Hedgehog is a property-based testing system, in the spirit of
834 QuickCheck. Hedgehog uses integrated shrinking, so shrinks obey the invariants
835 of generated values by construction.
836
837 To get started quickly, see the examples:
838 @uref{https://github.com/hedgehogqa/haskell-hedgehog/tree/master/hedgehog-example}")
839 (license license:bsd-3)))