gnu: idutils: Add Emacs as an input so idutils.el gets compiled and installed.
[jackhill/guix/guix.git] / gnu / packages / idutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages idutils)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages emacs)
25 #:use-module (gnu packages))
26
27 (define-public idutils
28 (package
29 (name "idutils")
30 (version "4.6")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/idutils/idutils-"
34 version ".tar.xz"))
35 (sha256
36 (base32
37 "1hmai3422iaqnp34kkzxdnywl7n7pvlxp11vrw66ybxn9wxg90c1"))
38 (patches (list
39 (search-patch "diffutils-gets-undeclared.patch")))))
40 (build-system gnu-build-system)
41 (native-inputs `(("emacs" ,emacs)))
42 (home-page "http://www.gnu.org/software/idutils/")
43 (synopsis "Identifier database utilities")
44 (description
45 "The GNU idutils package includes tools to create an index of textual
46 tokens used in a list of file names and then to query that index. Thus, it
47 allows the user to, for example, find all the uses of a particular function
48 in a large programming project. In addition to handling textual tokens, it
49 can also handle numeric constants and the contents of character strings.")
50 (license gpl3+)))