Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / libunistring.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
6 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
7 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages libunistring)
25 #:use-module (guix licenses)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system gnu)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages base))
31
32 (define-public libunistring
33 (package
34 (name "libunistring")
35 (version "0.9.7")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append
39 "mirror://gnu/libunistring/libunistring-"
40 version ".tar.xz"))
41 (sha256
42 (base32
43 "15z76qrmrvkc3c6hfq2lzzqysgd21s682f2smycfab5g598n8drf"))
44 (modules '((guix build utils)))
45 (snippet
46 '(begin
47 ;; The gnulib test-lock test is prone to writer starvation
48 ;; with our glibc@2.25, which prefers readers, so disable it.
49 ;; The gnulib commit b20e8afb0b2 should fix this once
50 ;; incorporated here.
51 (substitute* "tests/Makefile.in"
52 (("test-lock\\$\\(EXEEXT\\) ") ""))
53 #t))))
54 (propagated-inputs (libiconv-if-needed))
55 (build-system gnu-build-system)
56 (arguments
57 ;; Work around parallel build issue whereby C files may be compiled before
58 ;; config.h is built: see <http://hydra.gnu.org/build/59381/nixlog/2/raw> and
59 ;; <http://lists.openembedded.org/pipermail/openembedded-core/2012-April/059850.html>.
60 '(#:parallel-build? #f))
61 (synopsis "C library for manipulating Unicode strings")
62 (description
63 "GNU libunistring is a library providing functions to manipulate
64 Unicode strings and for manipulating C strings according to the Unicode
65 standard.")
66 (home-page "https://www.gnu.org/software/libunistring/")
67 (license (list lgpl3+ gpl2))))