gnu: exfat-tools: Update to 1.2.7.
[jackhill/guix/guix.git] / gnu / packages / mtools.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages mtools)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public mtools
27 (package
28 (name "mtools")
29 (version "4.0.18")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/mtools/mtools-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "1hxciksv7av5ilnkvwbidyxxr1gzn24lr0mz9z8drkml7780im1h"))))
38 (build-system gnu-build-system)
39 (home-page "https://www.gnu.org/software/mtools/")
40 (synopsis "Access MS-DOS disks without mounting")
41 (description
42 "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
43 or Unix system. It supports long file names and multiple disk formats. It
44 also supports some FAT-specific features such as volume labels and
45 FAT-specific file attributes.")
46 (license gpl3+)))
47
48 (define-public exfat-utils
49 (package
50 (name "exfat-utils")
51 (version "1.2.7")
52 (source (origin
53 (method url-fetch)
54 (uri (string-append
55 "https://github.com/relan/exfat/releases/download/v"
56 version "/" name "-" version ".tar.gz"))
57 (sha256
58 (base32
59 "1r7z3n1zxkvlqf1wv7pg0jwlr1144wznd0slfckpsb5rap8k4q9q"))))
60 (build-system gnu-build-system)
61 (home-page "https://github.com/relan/exfat")
62 (synopsis "Utilities to manipulate exFAT file systems")
63 (description
64 "This package provides an implementation of the exFAT file system,
65 including command-line tools to validate exFAT file systems and to create new
66 ones.")
67 (license gpl2+)))