gnu: miniupnpc: Update to 2.0.
[jackhill/guix/guix.git] / gnu / packages / syndication.scm
1 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
2 ;;;
3 ;;; GNU Guix is free software; you can redistribute it and/or modify it
4 ;;; under the terms of the GNU General Public License as published by
5 ;;; the Free Software Foundation; either version 3 of the License, or (at
6 ;;; your option) any later version.
7 ;;;
8 ;;; GNU Guix is distributed in the hope that it will be useful, but
9 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
10 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
11 ;;; GNU General Public License for more details.
12 ;;;
13 ;;; You should have received a copy of the GNU General Public License
14 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
15
16 (define-module (gnu packages syndication)
17 #:use-module ((guix licenses) #:prefix license:)
18 #:use-module (guix download)
19 #:use-module (guix packages)
20 #:use-module (guix build-system gnu)
21 #:use-module (gnu packages curl)
22 #:use-module (gnu packages databases)
23 #:use-module (gnu packages gettext)
24 #:use-module (gnu packages ncurses)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages ruby)
28 #:use-module (gnu packages xml)
29 #:use-module (gnu packages web))
30
31 (define-public newsbeuter
32 (package
33 (name "newsbeuter")
34 (version "2.9")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "https://newsbeuter.org/downloads/newsbeuter-"
39 version ".tar.gz"))
40 (sha256
41 (base32
42 "1j1x0hgwxz11dckk81ncalgylj5y5fgw5bcmp9qb5hq9kc0vza3l"))))
43 (build-system gnu-build-system)
44 (arguments
45 '(#:phases
46 (modify-phases %standard-phases
47 (replace 'configure
48 (lambda _
49 (substitute* "config.sh"
50 ;; try to remove this at the next release
51 (("ncursesw5") "ncursesw6"))
52 #t)))
53 #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out")))
54 #:test-target "test"))
55 (native-inputs
56 `(("gettext" ,gettext-minimal)
57 ("perl" ,perl)
58 ("pkg-config" ,pkg-config)
59 ("ruby" ,ruby))) ; for tests
60 (inputs
61 `(("curl" ,curl)
62 ("json-c" ,json-c)
63 ("ncurses" ,ncurses)
64 ("stfl" ,stfl)
65 ("sqlite" ,sqlite)
66 ("libxml2" ,libxml2)))
67 (home-page "https://newsbeuter.org/")
68 (synopsis "Text mode rss feed reader with podcast support")
69 (description "Newsbeuter is an innovative RSS feed reader for the text
70 console. It supports OPML import/exports, HTML rendering, podcast (podbeuter),
71 offline reading, searching and storing articles to your filesystem, and many
72 more features. Its user interface is coherent, easy to use, and might look
73 common to users of @command{mutt} and @command{slrn}.")
74 (license (list license:gpl2+ ; filter/*
75 license:x11))))