gnu: miniupnpc: Update to 2.0.
[jackhill/guix/guix.git] / gnu / packages / openstack.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages openstack)
22 #:use-module (gnu packages python)
23 #:use-module (gnu packages ssh)
24 #:use-module (gnu packages tls)
25 #:use-module (gnu packages version-control)
26 #:use-module (guix build-system python)
27 #:use-module (guix download)
28 #:use-module ((guix licenses)
29 #:select (asl2.0))
30 #:use-module (guix packages)
31 #:use-module (srfi srfi-1))
32
33 (define-public python-bandit
34 (package
35 (name "python-bandit")
36 (version "0.13.2")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (string-append
41 "https://pypi.python.org/packages/source/b/bandit/bandit-"
42 version ".tar.gz"))
43 (sha256
44 (base32
45 "03g3cflvrc99ncjd611iy5nnnscsc2vgnrx4mjaqyx8glbfw8y7g"))))
46 (build-system python-build-system)
47 (propagated-inputs
48 `(("python-appdirs" ,python-appdirs)
49 ("python-pyyaml" ,python-pyyaml)
50 ("python-six" ,python-six)
51 ("python-stevedore" ,python-stevedore)))
52 (inputs
53 `(("python-pbr" ,python-pbr)
54 ("python-setuptools" ,python-setuptools)
55 ;; Tests
56 ("python-fixtures" ,python-fixtures)
57 ("python-mock" ,python-mock)
58 ("python-testrepository" ,python-testrepository)
59 ("python-testscenarios" ,python-testscenarios)
60 ("python-testtools" ,python-testtools)))
61 (home-page "https://wiki.openstack.org/wiki/Security/Projects/Bandit")
62 (synopsis "Security oriented static analyser for python code")
63 (description
64 "Bandit is a tool designed to find common security issues in Python code.
65 To do this Bandit processes each file, builds an AST from it, and runs
66 appropriate plugins against the AST nodes. Once Bandit has finished scanning
67 all the files it generates a report.")
68 (license asl2.0)))
69
70 (define-public python2-bandit
71 (package-with-python2 python-bandit))
72
73 (define-public python-debtcollector
74 (package
75 (name "python-debtcollector")
76 (version "1.0.0")
77 (source
78 (origin
79 (method url-fetch)
80 (uri (pypi-uri "debtcollector" version))
81 (sha256
82 (base32
83 "0g4dfskaiy47rhsh4gh66l5vmdsrgq0qk68pl3ix1cj3ffvfndzv"))))
84 (build-system python-build-system)
85 (propagated-inputs
86 `(("python-six" ,python-six)
87 ("python-wrapt" ,python-wrapt)))
88 (inputs
89 `(("python-babel" ,python-babel)
90 ("python-pbr" ,python-pbr)
91 ("python-setuptools" ,python-setuptools)
92 ;; Tests.
93 ("python-oslotest" ,python-oslotest)))
94 (home-page "http://www.openstack.org/")
95 (synopsis
96 "Find deprecated patterns and strategies in Python code")
97 (description
98 "This package provides a collection of Python deprecation patterns and
99 strategies that help you collect your technical debt in a non-destructive
100 manner.")
101 (license asl2.0)))
102
103 (define-public python2-debtcollector
104 (package-with-python2 python-debtcollector))
105
106 (define-public python-hacking
107 (package
108 (name "python-hacking")
109 (version "0.10.2")
110 (source
111 (origin
112 (method url-fetch)
113 (uri (pypi-uri "hacking" version))
114 (sha256
115 (base32
116 "1a310k3dv04jg7zvmk37h2ql7y9kf4hvdxb74bjlwdxgmy6h4wap"))))
117 (build-system python-build-system)
118 (propagated-inputs
119 `(("python-flake8-2.2.4" ,python-flake8-2.2.4)
120 ("python-mccabe-0.2.1" ,python-mccabe-0.2.1)
121 ("python-pbr" ,python-pbr)
122 ("python-pep8-1.5.7" ,python-pep8-1.5.7)
123 ("python-pyflakes-0.8.1" ,python-pyflakes-0.8.1)
124 ("python-six" ,python-six)))
125 (inputs
126 `(("python-setuptools" ,python-setuptools)
127 ;; Tests
128 ("python-testscenarios" ,python-testscenarios)))
129 (home-page "http://github.com/openstack-dev/hacking")
130 (synopsis "OpenStack hacking guideline enforcement")
131 (description
132 "Python-hacking is a set of flake8 plugins that test and enforce the
133 @uref{http://docs.openstack.org/developer/hacking/, OpenStack style
134 guidelines}.")
135 (license asl2.0)))
136
137 (define-public python2-hacking
138 (package-with-python2 python-hacking))
139
140 (define-public python-mox3
141 (package
142 (name "python-mox3")
143 (version "0.14.0")
144 (source
145 (origin
146 (method url-fetch)
147 (uri (pypi-uri "mox3" version))
148 (sha256
149 (base32
150 "0njmh40i1lg5mzn9hc2ax83adj6dli455j6xifilrw27c4wlkjzx"))))
151 (build-system python-build-system)
152 (native-inputs
153 `(("python-fixtures" ,python-fixtures)
154 ("python-pbr" ,python-pbr)
155 ("python-setuptools" ,python-setuptools)
156 ("python-six" ,python-six)
157 ("python-testtools" ,python-testtools)))
158 (home-page "http://www.openstack.org/")
159 (synopsis "Mock object framework for Python")
160 (description
161 "Mox3 is an unofficial port of the Google mox framework
162 (http://code.google.com/p/pymox/) to Python 3. It was meant to be as compatible
163 with mox as possible, but small enhancements have been made. The library was
164 tested on Python version 3.2, 2.7 and 2.6.")
165 (license asl2.0)))
166
167 (define-public python2-mox3
168 (package-with-python2 python-mox3))
169
170 (define-public python-os-client-config
171 (package
172 (name "python-os-client-config")
173 (version "1.12.0")
174 (source
175 (origin
176 (method url-fetch)
177 (uri (pypi-uri "os-client-config" version))
178 (sha256
179 (base32
180 "1vjn7667pswnmpqv6ngwyqm2xn46w90hi5b4pv2grwfz751cn1lf"))))
181 (build-system python-build-system)
182 (arguments
183 `(#:tests? #f)) ;; Circular dependency with python-oslotest
184 (inputs
185 `(("python-appdirs" ,python-appdirs)
186 ("python-fixtures" ,python-fixtures)
187 ("python-mimeparse" ,python-mimeparse)
188 ("python-pbr" ,python-pbr)
189 ("python-pyyaml" ,python-pyyaml)
190 ("python-testrepository" ,python-testrepository)
191 ("python-setuptools" ,python-setuptools)
192 ("python-testscenarios" ,python-testscenarios)
193 ("python-testtools" ,python-testtools)))
194 (home-page "http://www.openstack.org/")
195 (synopsis
196 "OpenStack Client Configuration Library")
197 (description
198 "The OpenStack Client Configuration Library is a library for collecting
199 client configuration for using an OpenStack cloud in a consistent and
200 comprehensive manner.")
201 (license asl2.0)))
202
203 (define-public python2-os-client-config
204 (package-with-python2 python-os-client-config))
205
206 (define-public python-os-testr
207 (package
208 (name "python-os-testr")
209 (version "0.8.0")
210 (source
211 (origin
212 (method url-fetch)
213 (uri (pypi-uri "os-testr" version))
214 (sha256
215 (base32
216 "0mknd9hlmxmihr755gjkxyjp180380jajq5i3zm34q7y7bi62lss"))))
217 (build-system python-build-system)
218 (arguments
219 ;; os-testr uses itself to run the tests. It seems like pbr writes the
220 ;; exectuable in the virtualenv when using tox. Not sure how to do this
221 ;; when building the package. Skip the tests for now.
222 `(#:tests? #f))
223 (propagated-inputs
224 `(("python-pbr" ,python-pbr)
225 ("python-subunit" ,python-subunit)
226 ("python-testtools" ,python-testtools)))
227 (inputs
228 `(("python-babel" ,python-babel)
229 ("python-setuptools" ,python-setuptools)))
230 (home-page "https://www.openstack.org/")
231 (synopsis "Testr wrapper to provide functionality for OpenStack projects")
232 (description
233 "Os-testr provides developers with a testr wrapper and an output filter
234 for subunit.")
235 (license asl2.0)))
236
237 (define-public python2-os-testr
238 (package-with-python2 python-os-testr))
239
240 (define-public python-requests-mock
241 (package
242 (name "python-requests-mock")
243 (version "1.0.0")
244 (source
245 (origin
246 (method url-fetch)
247 (uri (pypi-uri "requests-mock" version))
248 (sha256
249 (base32
250 "0gcjjwsckhqixyffflc54i59x41jnbb37bli077vabii1bjmkin6"))))
251 (build-system python-build-system)
252 (propagated-inputs
253 `(("python-requests" ,python-requests)
254 ("python-six" ,python-six)))
255 (inputs
256 `(("python-pbr" ,python-pbr)))
257 (native-inputs
258 `(("python-discover" ,python-discover)
259 ("python-docutils" ,python-docutils)
260 ("python-fixtures" ,python-fixtures)
261 ("python-mock" ,python-mock)
262 ("python-sphinx" ,python-sphinx)
263 ("python-testrepository" ,python-testrepository)
264 ("python-testtools" ,python-testtools)))
265 (home-page "https://requests-mock.readthedocs.org/")
266 (synopsis "Mock out responses from the requests package")
267 (description
268 "This module provides a building block to stub out the HTTP requests
269 portions of your testing code.")
270 (license asl2.0)
271 (properties `((python2-variant . ,(delay python2-requests-mock))))))
272
273 (define-public python2-requests-mock
274 (let ((base (package-with-python2
275 (strip-python2-variant python-requests-mock))))
276 (package (inherit base)
277 (native-inputs
278 `(("python2-setuptools" ,python2-setuptools)
279 ,@(package-native-inputs base))))))
280
281 (define-public python-stevedore
282 (package
283 (name "python-stevedore")
284 (version "1.12.0")
285 (source
286 (origin
287 (method url-fetch)
288 (uri (pypi-uri "stevedore" version))
289 (sha256
290 (base32
291 "0999zvawaapzg6givjhn7vjscdwblcs73wf28wq1wb4g5mbb5phv"))))
292 (build-system python-build-system)
293 (propagated-inputs
294 `(("python-six" ,python-six)))
295 (inputs
296 `(("python-pbr" ,python-pbr)))
297 (native-inputs
298 `(("python-setuptools" ,python-setuptools)
299 ;; Tests
300 ("python-docutils" ,python-docutils)
301 ("python-mock" ,python-mock)
302 ("python-oslotest" ,python-oslotest)
303 ("python-sphinx" ,python-sphinx)))
304 (home-page "https://github.com/dreamhost/stevedore")
305 (synopsis "Manage dynamic plugins for Python applications")
306 (description
307 "Python makes loading code dynamically easy, allowing you to configure
308 and extend your application by discovering and loading extensions (\"plugins\")
309 at runtime. Many applications implement their own library for doing this,
310 using __import__ or importlib. Stevedore avoids creating yet another extension
311 mechanism by building on top of setuptools entry points. The code for managing
312 entry points tends to be repetitive, though, so stevedore provides manager
313 classes for implementing common patterns for using dynamically loaded
314 extensions.")
315 (license asl2.0)))
316
317 (define-public python2-stevedore
318 (package-with-python2 python-stevedore))
319
320 (define-public python-tempest-lib
321 (package
322 (name "python-tempest-lib")
323 (version "1.0.0")
324 (source
325 (origin
326 (method url-fetch)
327 (uri (pypi-uri "tempest-lib" version))
328 (sha256
329 (base32
330 "1cpp2vwmawpd29hjsklsps181lq2ah91cl412qvpnz228nf9sqn5"))))
331 (build-system python-build-system)
332 (arguments
333 `(#:phases
334 (modify-phases %standard-phases
335 (add-before
336 'check 'pre-check
337 (lambda _
338 (substitute* "tempest_lib/tests/cli/test_execute.py"
339 (("/bin/ls") (which "ls"))))))))
340 (propagated-inputs
341 `(("python-fixtures" ,python-fixtures)
342 ("python-httplib2" ,python-httplib2)
343 ("python-iso8601" ,python-iso8601)
344 ("python-jsonschema" ,python-jsonschema)
345 ("python-oslo.log" ,python-oslo.log)
346 ("python-paramiko" ,python-paramiko)
347 ("python-pbr" ,python-pbr)
348 ("python-six" ,python-six)))
349 (inputs
350 `(("python-babel" ,python-babel)
351 ("python-mock" ,python-mock)
352 ("python-os-testr" ,python-os-testr)
353 ("python-oslotest" ,python-oslotest)
354 ("python-setuptools" ,python-setuptools)))
355 (home-page "https://www.openstack.org/")
356 (synopsis "OpenStack functional testing library")
357 (description
358 "Tempest-lib is a functional testing library for OpenStack. It provides
359 common features used in Tempest.")
360 (license asl2.0)))
361
362 (define-public python2-tempest-lib
363 (package-with-python2 python-tempest-lib))
364
365 ;; Packages from the Oslo library
366 (define-public python-oslo.config
367 (package
368 (name "python-oslo.config")
369 (version "2.4.0")
370 (source
371 (origin
372 (method url-fetch)
373 (uri (string-append
374 "https://pypi.python.org/packages/source/o/oslo.config/oslo.config-"
375 version
376 ".tar.gz"))
377 (sha256
378 (base32
379 "13r778jfb0fhna37c2pd1f2xipnsbd7zli7qhn96acrzymrwj5k1"))))
380 (build-system python-build-system)
381 (propagated-inputs
382 `(("python-netaddr" ,python-netaddr)
383 ("python-six" ,python-six)
384 ("python-stevedore" ,python-stevedore)))
385 (inputs
386 `(("python-pbr" ,python-pbr)
387 ("python-setuptools" ,python-setuptools)
388 ;; Tests
389 ("python-oslo.i18n" ,python-oslo.i18n)
390 ("python-mock" ,python-mock)
391 ("python-oslotest" ,python-oslotest)
392 ("python-testscenarios" ,python-testscenarios)))
393 (home-page "https://launchpad.net/oslo")
394 (synopsis "Oslo Configuration API")
395 (description
396 "The Oslo configuration API supports parsing command line arguments and
397 .ini style configuration files.")
398 (license asl2.0)))
399
400 (define-public python2-oslo.config
401 (package-with-python2 python-oslo.config))
402
403 (define-public python-oslo.context
404 (package
405 (name "python-oslo.context")
406 (version "1.0.0")
407 (source
408 (origin
409 (method url-fetch)
410 (uri (pypi-uri "oslo.context" version))
411 (sha256
412 (base32
413 "0kvha0rs9295njyl2z6n6zm5dapi5mrl5zwjm0m6ldqrvccyf8c3"))))
414 (build-system python-build-system)
415 (inputs
416 `(("python-babel" ,python-babel)
417 ("python-pbr" ,python-pbr)
418 ("python-setuptools" ,python-setuptools)
419 ;; Tests.
420 ("python-oslotest" ,python-oslotest)))
421 (home-page "http://launchpad.net/oslo")
422 (synopsis "Oslo context library")
423 (description
424 "The Oslo context library has helpers to maintain useful information
425 about a request context. The request context is usually populated in the WSGI
426 pipeline and used by various modules such as logging.")
427 (license asl2.0)))
428
429 (define-public python2-oslo.context
430 (package-with-python2 python-oslo.context))
431
432 (define-public python-oslo.i18n
433 (package
434 (name "python-oslo.i18n")
435 (version "3.0.0")
436 (source
437 (origin
438 (method url-fetch)
439 (uri (pypi-uri "oslo.i18n" version))
440 (sha256
441 (base32
442 "0bpb1c20sm8my650gl824nzaip83bfn8hr91s65k5ncmyh8hb6pl"))))
443 (build-system python-build-system)
444 (propagated-inputs
445 `(("python-babel" ,python-babel)
446 ("python-six" ,python-six)))
447 (inputs
448 `(("python-pbr" ,python-pbr)
449 ("python-setuptools" ,python-setuptools)
450 ;; Tests
451 ("python-mock" ,python-mock)
452 ("python-mox3" ,python-mox3)
453 ("python-oslotest" ,python-oslotest)
454 ("python-testscenarios" ,python-testscenarios)))
455 (home-page "http://launchpad.net/oslo")
456 (synopsis "Oslo internationalization (i18n) library")
457 (description
458 "The oslo.i18n library contain utilities for working with
459 internationalization (i18n) features, especially translation for text strings
460 in an application or library.")
461 (license asl2.0)))
462
463 (define-public python2-oslo.i18n
464 (package-with-python2 python-oslo.i18n))
465
466 (define-public python-oslo.log
467 (package
468 (name "python-oslo.log")
469 (version "1.6.0")
470 (source
471 (origin
472 (method url-fetch)
473 (uri (string-append
474 "https://pypi.python.org/packages/source/o/oslo.log/oslo.log-"
475 version
476 ".tar.gz"))
477 (sha256
478 (base32
479 "1fhy6yvbd565nv4x4i3ppyrlbmz3yy9d0xsvw5nkqsa7g43nmf8z"))))
480 (build-system python-build-system)
481 (propagated-inputs
482 `(("python-debtcollector" ,python-debtcollector)
483 ("python-oslo.config" ,python-oslo.config)
484 ("python-oslo.context" ,python-oslo.context)
485 ("python-oslo.i18n" ,python-oslo.i18n)
486 ("python-oslo.utils" ,python-oslo.utils)
487 ("python-oslo.serialization" ,python-oslo.serialization)
488 ("python-six" ,python-six)))
489 (inputs
490 `(("python-babel" ,python-babel)
491 ("python-iso8601" ,python-iso8601)
492 ("python-mock" ,python-mock)
493 ("python-oslotest" ,python-oslotest)
494 ("python-pbr" ,python-pbr)
495 ("python-setuptools" ,python-setuptools)))
496 (home-page "http://launchpad.net/oslo")
497 (synopsis "Python logging library of the Oslo project")
498 (description
499 "The oslo.log (logging) configuration library provides standardized
500 configuration for all OpenStack projects. It also provides custom formatters,
501 handlers and support for context specific logging (like resource id’s etc).")
502 (license asl2.0)))
503
504 (define-public python2-oslo.log
505 (package-with-python2 python-oslo.log))
506
507 (define-public python-oslo.serialization
508 (package
509 (name "python-oslo.serialization")
510 (version "2.2.0")
511 (source
512 (origin
513 (method url-fetch)
514 (uri (pypi-uri "oslo.serialization" version))
515 (sha256
516 (base32
517 "00s03krhf833gs76aw5ns32w9m1i4hx6x6d9g82m0j5wyqk0sci4"))))
518 (build-system python-build-system)
519 (propagated-inputs
520 `(("python-iso8601" ,python-iso8601)
521 ("python-netaddr" ,python-netaddr)
522 ("python-oslo.utils" ,python-oslo.utils)
523 ("python-simplejson" ,python-simplejson)
524 ("python-six" ,python-six)
525 ("python-pytz" ,python-pytz)))
526 (inputs
527 `(("python-babel" ,python-babel)
528 ("python-pbr" ,python-pbr)
529 ("python-setuptools" ,python-setuptools)
530 ;; Tests.
531 ("python-mock" ,python-mock)
532 ("python-oslo.i18n" ,python-oslo.i18n)
533 ("python-oslotest" ,python-oslotest)))
534 (home-page "http://launchpad.net/oslo")
535 (synopsis "Oslo serialization library")
536 (description
537 "The oslo.serialization library provides support for representing objects
538 in transmittable and storable formats, such as JSON and MessagePack.")
539 (license asl2.0)))
540
541 (define-public python2-oslo.serialization
542 (package-with-python2 python-oslo.serialization))
543
544 (define-public python-oslosphinx
545 (package
546 (name "python-oslosphinx")
547 (version "4.3.0")
548 (source
549 (origin
550 (method url-fetch)
551 (uri (pypi-uri "oslosphinx" version))
552 (sha256
553 (base32
554 "0cz8ym4i1n4rgljlqhyhfkpgdmid7nkb909k8r8nk186m9cmpla2"))))
555 (build-system python-build-system)
556 (propagated-inputs
557 `(("python-requests" ,python-requests)))
558 (inputs
559 `(("python-pbr" ,python-pbr)
560 ("python-docutils" ,python-docutils)
561 ("python-hacking" ,python-hacking)
562 ("python-setuptools" ,python-setuptools)
563 ("python-sphinx" ,python-sphinx)))
564 (home-page "http://www.openstack.org/")
565 (synopsis "OpenStack sphinx extensions and theme")
566 (description
567 "This package provides themes and extensions for Sphinx documentation
568 from the OpenStack project.")
569 (license asl2.0)))
570
571 (define-public python2-oslosphinx
572 (package-with-python2 python-oslosphinx))
573
574 (define-public python-oslotest
575 (package
576 (name "python-oslotest")
577 (version "1.10.0")
578 (source
579 (origin
580 (method url-fetch)
581 (uri (string-append
582 "https://pypi.python.org/packages/source/o/oslotest/oslotest-"
583 version
584 ".tar.gz"))
585 (sha256
586 (base32
587 "0l3ny48ddz5xbf0v4r0jv1yhbdzinc2vy0lybhdkmx3xy0b886fs"))))
588 (build-system python-build-system)
589 (propagated-inputs
590 `(("python-fixtures" ,python-fixtures)
591 ("python-mock" ,python-mock)
592 ("python-mox3" ,python-mox3)
593 ("python-six" ,python-six)))
594 (inputs
595 `(("python-pbr" ,python-pbr)
596 ("python-os-client-config" ,python-os-client-config)
597 ("python-setuptools" ,python-setuptools)
598 ("python-subunit" ,python-subunit)
599 ("python-testrepository" ,python-testrepository)
600 ("python-testscenarios" ,python-testscenarios)
601 ("python-testtools" ,python-testtools)))
602 (home-page "http://launchpad.net/oslo")
603 (synopsis "Oslo test framework")
604 (description
605 "The Oslo Test framework provides common fixtures, support for debugging,
606 and better support for mocking results.")
607 (license asl2.0)))
608
609 (define-public python2-oslotest
610 (package-with-python2 python-oslotest))
611
612 (define-public python-oslo.utils
613 (package
614 (name "python-oslo.utils")
615 (version "3.0.0")
616 (source
617 (origin
618 (method url-fetch)
619 (uri (pypi-uri "oslo.utils" version))
620 (sha256
621 (base32
622 "1c4jrbvfs4hs37fics8frqlyhmsv7v92ncv2cpbm0av9x0ic6pnj"))
623 (snippet
624 '(begin
625 ;; FIXME: setuptools fails to import this file during the test
626 ;; phase.
627 (delete-file "oslo_utils/tests/test_netutils.py")))))
628 (build-system python-build-system)
629 (propagated-inputs
630 `(("python-debtcollector" ,python-debtcollector)
631 ("python-oslo.i18n" ,python-oslo.i18n)
632 ("python-iso8601" ,python-iso8601)
633 ("python-monotonic" ,python-monotonic)
634 ("python-netaddr" ,python-netaddr)
635 ("python-netifaces" ,python-netifaces)
636 ("python-pytz" ,python-pytz)
637 ("python-six" ,python-six)))
638 (inputs
639 `(("python-babel" ,python-babel)
640 ("python-pbr" ,python-pbr)
641 ("python-setuptools" ,python-setuptools)
642 ;; Tests.
643 ("python-oslotest" ,python-oslotest)
644 ("python-mock" ,python-mock)
645 ("python-mox3" ,python-mox3)
646 ("python-testscenarios" ,python-testscenarios)))
647 (home-page "http://launchpad.net/oslo")
648 (synopsis "Oslo utility library")
649 (description
650 "The @code{oslo.utils} library provides support for common utility type
651 functions, such as encoding, exception handling, string manipulation, and time
652 handling.")
653 (license asl2.0)))
654
655 (define-public python2-oslo.utils
656 (package-with-python2 python-oslo.utils))
657
658 (define-public python-keystoneclient
659 (package
660 (name "python-keystoneclient")
661 (version "1.8.1")
662 (source
663 (origin
664 (method url-fetch)
665 (uri (pypi-uri "python-keystoneclient" version))
666 (sha256
667 (base32
668 "1w4csvkah67rfpxylxnvs2s3594i0f9isy8pf4gnsqs5zirvjaa4"))))
669 (build-system python-build-system)
670 (native-inputs
671 `(("python-setuptools" ,python-setuptools)
672 ("python-sphinx" ,python-sphinx)
673 ;; and some packages for the tests
674 ("openssl" ,openssl)
675 ("python-coverage" ,python-coverage)
676 ("python-discover" ,python-discover)
677 ("python-fixtures" ,python-fixtures)
678 ("python-hacking" ,python-hacking)
679 ("python-keyring" ,python-keyring)
680 ("python-lxml" ,python-lxml)
681 ("python-mock" ,python-mock)
682 ("python-mox3" ,python-mox3)
683 ("python-oauthlib" ,python-oauthlib)
684 ("python-oslosphinx" ,python-oslosphinx)
685 ("python-oslotest" ,python-oslotest)
686 ("python-pycrypto" ,python-pycrypto)
687 ("python-requests-mock" ,python-requests-mock)
688 ("python-temptest-lib" ,python-tempest-lib)
689 ("python-testrepository" ,python-testrepository)
690 ("python-testresources" ,python-testresources)
691 ("python-testtools" ,python-testtools)
692 ("python-webob" ,python-webob)))
693 (propagated-inputs
694 `(("python-babel" ,python-babel)
695 ("python-debtcollector" ,python-debtcollector)
696 ("python-iso8601" ,python-iso8601)
697 ("python-netaddr" ,python-netaddr)
698 ("python-oslo.config" ,python-oslo.config)
699 ("python-oslo.i18n" ,python-oslo.i18n)
700 ("python-oslo.serialization" ,python-oslo.serialization)
701 ("python-oslo.utils" ,python-oslo.utils)
702 ("python-pbr" ,python-pbr)
703 ("python-prettytable" ,python-prettytable)
704 ("python-requests" ,python-requests)
705 ("python-six" ,python-six)
706 ("python-stevedore" ,python-stevedore)))
707 (home-page "http://www.openstack.org/")
708 (synopsis "Client Library for OpenStack Identity")
709 (description
710 "Python-keystoneclient is the identity service used by OpenStack for
711 authentication (authN) and high-level authorization (authZ). It currently
712 supports token-based authN with user/service authZ, and is scalable to support
713 OAuth, SAML, and OpenID in future versions. Out of the box, Keystone uses
714 SQLite for its identity store database, with the option to connect to external
715 LDAP.")
716 (license asl2.0)))
717
718 (define-public python2-keystoneclient
719 (let ((keystoneclient (package-with-python2 python-keystoneclient)))
720 (package (inherit keystoneclient)
721 (propagated-inputs
722 `(("python2-requests" ,python2-requests)
723 ,@(alist-delete "python-requests"
724 (package-propagated-inputs keystoneclient))))
725 (native-inputs
726 `(("python2-oauthlib" ,python2-oauthlib)
727 ("python2-oslosphinx" ,python2-oslosphinx)
728 ("python2-requests-mock" ,python2-requests-mock)
729 ("python2-tempest-lib" ,python2-tempest-lib)
730 ,@(fold alist-delete (package-native-inputs keystoneclient)
731 '("python-oauthlib" "python-oslosphinx" "python-requests-mock" "python-tempest-lib")))))))
732
733 (define-public python-swiftclient
734 (package
735 (name "python-swiftclient")
736 (version "2.6.0")
737 (source
738 (origin
739 (method url-fetch)
740 (uri (pypi-uri "python-swiftclient" version))
741 (sha256
742 (base32
743 "1j33l4z9vqh0scfncl4fxg01zr1hgqxhhai6gvcih1gccqm4nd7p"))))
744 (build-system python-build-system)
745 (native-inputs
746 `(("python-pbr" ,python-pbr)
747 ("python-setuptools" ,python-setuptools)
748 ("python-sphinx" ,python-sphinx)
749 ;; The folloing packages are needed for the tests.
750 ("python-coverage" ,python-coverage)
751 ("python-discover" ,python-discover)
752 ("python-hacking" ,python-hacking)
753 ("python-mock" ,python-mock)
754 ("python-oslosphinx" ,python-oslosphinx)
755 ("python-keystoneclient" ,python-keystoneclient)
756 ("python-testrepository" ,python-testrepository)
757 ("python-testtools" ,python-testtools)))
758 (propagated-inputs
759 `(("python-requests" ,python-requests)
760 ("python-six" ,python-six)))
761 (home-page "http://www.openstack.org/")
762 (synopsis "OpenStack Object Storage API Client Library")
763 (description
764 "OpenStack Object Storage (code-named Swift) creates redundant, scalable
765 object storage using clusters of standardized servers to store petabytes of
766 accessible data. It is not a file system or real-time data storage system, but
767 rather a long-term storage system for a more permanent type of static data that
768 can be retrieved, leveraged, and then updated if necessary. Primary examples of
769 data that best fit this type of storage model are virtual machine images, photo
770 storage, email storage and backup archiving. Having no central \"brain\" or
771 master point of control provides greater scalability, redundancy and
772 permanence.")
773 (license asl2.0)))
774
775 (define-public python2-swiftclient
776 (let ((swiftclient (package-with-python2 python-swiftclient)))
777 (package (inherit swiftclient)
778 (propagated-inputs
779 `(("python2-futures" ,python2-futures)
780 ("python2-requests" ,python2-requests)
781 ,@(alist-delete "python-requests"
782 (package-propagated-inputs swiftclient))))
783 (native-inputs
784 `(("python2-keystoneclient" ,python2-keystoneclient)
785 ("python2-oslosphinx" ,python2-oslosphinx)
786 ,@(fold alist-delete (package-native-inputs swiftclient)
787 '("python-keystoneclient" "python-oslosphinx")))))))
788
789 (define-public python-git-review
790 (package
791 (name "python-git-review")
792 (version "1.25.0")
793 (source
794 (origin
795 (method url-fetch)
796 (uri (pypi-uri "git-review" version))
797 (sha256
798 (base32
799 "07d1jn9ryff5j5ic6qj5pbk10m1ccmpllj0wyalrcms1q9yhlzh8"))))
800 (build-system python-build-system)
801 (arguments
802 '(#:tests? #f ; tests require a running Gerrit server
803 #:phases
804 (modify-phases %standard-phases
805 (add-after 'install 'wrap-program
806 (lambda* (#:key inputs outputs #:allow-other-keys)
807 (let* ((out (assoc-ref outputs "out"))
808 (git (assoc-ref inputs "git"))
809 (openssh (assoc-ref inputs "openssh")))
810 (wrap-program (string-append out "/bin/git-review")
811 `("PATH" ":" prefix
812 ,(map (lambda (dir)
813 (string-append dir "/bin"))
814 (list git openssh))))))))))
815 (native-inputs
816 `(("python-pbr" ,python-pbr)))
817 (inputs
818 `(("python-requests" ,python-requests)
819 ("git" ,git)
820 ("openssh" ,openssh)))
821 (home-page "http://docs.openstack.org/infra/git-review/")
822 (synopsis "Command-line tool for Gerrit")
823 (description
824 "Git-review is a command-line tool that helps submitting Git branches to
825 Gerrit for review, or fetching existing ones.")
826 (license asl2.0)))
827
828 (define-public python2-git-review
829 (let ((base (package-with-python2 (strip-python2-variant python-git-review))))
830 (package (inherit base)
831 (native-inputs
832 `(("python2-setuptools" ,python2-setuptools)
833 ,@(package-native-inputs base))))))