gnu: vlc: Fix build and clean up expression.
[jackhill/guix/guix.git] / gnu / packages / patches / metabat-fix-boost-issue.patch
1 This patch fixes the issue described at
2 https://bitbucket.org/berkeleylab/metabat/issues/28/compilation-fail-with-boost-164
3
4 diff --git a/src/metabat.h b/src/metabat.h
5 index 32ae94c..2292c04 100644
6 --- a/src/metabat.h
7 +++ b/src/metabat.h
8 @@ -35,6 +35,7 @@ KSEQ_INIT(gzFile, gzread)
9
10 #include <boost/program_options.hpp>
11 #include <boost/algorithm/string.hpp>
12 +#include <boost/serialization/array_wrapper.hpp>
13 #include <boost/numeric/ublas/matrix.hpp>
14 #include <boost/math/distributions.hpp>
15 #include <boost/serialization/serialization.hpp>
16 diff --git a/src/metabat2.h b/src/metabat2.h
17 index 60a9998..19fa815 100644
18 --- a/src/metabat2.h
19 +++ b/src/metabat2.h
20 @@ -41,6 +41,7 @@ KSEQ_INIT(gzFile, gzread)
21
22 #include <boost/program_options.hpp>
23 #include <boost/algorithm/string.hpp>
24 +#include <boost/serialization/array_wrapper.hpp>
25 #include <boost/numeric/ublas/matrix.hpp>
26 #include <boost/numeric/ublas/matrix_sparse.hpp>
27 #include <boost/numeric/ublas/matrix_proxy.hpp>