gnu: youtube-dl: Update to 2020.09.14.
[jackhill/guix/guix.git] / gnu / packages / ssh.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
5 ;;; Copyright © 2015, 2016, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016, 2019 Leo Famulari <leo@famulari.name>
7 ;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
8 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
9 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
10 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
11 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
12 ;;; Copyright © 2017 Nikita <nikita@n0.is>
13 ;;; Copyright © 2018 Manuel Graf <graf@init.at>
14 ;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
15 ;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
16 ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
17 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
18 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
19 ;;;
20 ;;; This file is part of GNU Guix.
21 ;;;
22 ;;; GNU Guix is free software; you can redistribute it and/or modify it
23 ;;; under the terms of the GNU General Public License as published by
24 ;;; the Free Software Foundation; either version 3 of the License, or (at
25 ;;; your option) any later version.
26 ;;;
27 ;;; GNU Guix is distributed in the hope that it will be useful, but
28 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
29 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
30 ;;; GNU General Public License for more details.
31 ;;;
32 ;;; You should have received a copy of the GNU General Public License
33 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
34
35 (define-module (gnu packages ssh)
36 #:use-module (gnu packages)
37 #:use-module (gnu packages autotools)
38 #:use-module (gnu packages base)
39 #:use-module (gnu packages boost)
40 #:use-module (gnu packages compression)
41 #:use-module (gnu packages crypto)
42 #:use-module (gnu packages elf)
43 #:use-module (gnu packages gnupg)
44 #:use-module (gnu packages gperf)
45 #:use-module (gnu packages groff)
46 #:use-module (gnu packages guile)
47 #:use-module (gnu packages libedit)
48 #:use-module (gnu packages linux)
49 #:use-module (gnu packages logging)
50 #:use-module (gnu packages m4)
51 #:use-module (gnu packages multiprecision)
52 #:use-module (gnu packages ncurses)
53 #:use-module (gnu packages nettle)
54 #:use-module (gnu packages kerberos)
55 #:use-module (gnu packages perl)
56 #:use-module (gnu packages pkg-config)
57 #:use-module (gnu packages popt)
58 #:use-module (gnu packages protobuf)
59 #:use-module (gnu packages python)
60 #:use-module (gnu packages python-xyz)
61 #:use-module (gnu packages readline)
62 #:use-module (gnu packages texinfo)
63 #:use-module (gnu packages tls)
64 #:use-module (gnu packages xorg)
65 #:use-module (guix build-system cmake)
66 #:use-module (guix build-system gnu)
67 #:use-module (guix build-system python)
68 #:use-module (guix download)
69 #:use-module (guix git-download)
70 #:use-module ((guix licenses) #:prefix license:)
71 #:use-module (guix packages)
72 #:use-module (guix utils)
73 #:use-module (srfi srfi-1))
74
75 (define-public hss
76 (package
77 (name "hss")
78 (version "1.8")
79 (source (origin
80 (method git-fetch)
81 (uri (git-reference
82 (url "https://github.com/six-ddc/hss")
83 (commit (string-append "v" version))))
84 (file-name (git-file-name name version))
85 (sha256
86 (base32
87 "1rpysj65j9ls30bf2c5k5hykzzjfknrihs58imp178bx1wqzw4jl"))))
88 (inputs
89 `(("readline" ,readline)))
90 (arguments
91 `(#:make-flags
92 (list ,(string-append "CC=" (cc-for-target))
93 (string-append "INSTALL_BIN=" (assoc-ref %outputs "out") "/bin"))
94 #:tests? #f ; no tests
95 #:phases
96 (modify-phases %standard-phases
97 (add-after 'unpack 'patch-file-names
98 (lambda* (#:key inputs outputs #:allow-other-keys)
99 (substitute* "Makefile"
100 (("/usr/local/opt/readline")
101 (assoc-ref inputs "readline")))
102 #t))
103 (delete 'configure)))) ; no configure script
104 (build-system gnu-build-system)
105 (home-page "https://github.com/six-ddc/hss/")
106 (synopsis "Interactive SSH client for multiple servers")
107 (description
108 "@command{hss} is an interactive SSH client for multiple servers. Commands
109 are executed on all servers in parallel. Execution on one server does not need
110 to wait for that on another server to finish before starting. One can run a
111 command on hundreds of servers at the same time, with almost the same experience
112 as a local Bash shell.
113
114 It supports:
115 @itemize @bullet
116 @item interactive input: based on GNU readline.
117 @item history: responding to the @kbd{C-r} key.
118 @item auto-completion: @key{TAB}-completion from remote servers for commands and
119 file names.
120 @end itemize\n")
121 (license license:expat)))
122
123 (define-public libssh
124 (package
125 (name "libssh")
126 (version "0.9.4")
127 (source (origin
128 (method git-fetch)
129 (uri (git-reference
130 (url "https://git.libssh.org/projects/libssh.git")
131 (commit (string-append "libssh-" version))))
132 (sha256
133 (base32
134 "0qr4vi3k1wv69c95d9j26fiv78pzyksaq8ccd76b8nxar5z1fbj6"))
135 (file-name (git-file-name name version))))
136 (build-system cmake-build-system)
137 (outputs '("out" "debug"))
138 (arguments
139 '(#:configure-flags '("-DWITH_GCRYPT=ON")
140
141 ;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
142 #:tests? #f))
143 (inputs `(("zlib" ,zlib)
144 ("libgcrypt" ,libgcrypt)
145 ("mit-krb5" ,mit-krb5)))
146 (synopsis "SSH client library")
147 (description
148 "libssh is a C library implementing the SSHv2 and SSHv1 protocol for client
149 and server implementations. With libssh, you can remotely execute programs,
150 transfer files, and use a secure and transparent tunnel for your remote
151 applications.")
152 (home-page "https://www.libssh.org")
153 (license license:lgpl2.1+)))
154
155 (define-public libssh2
156 (package
157 (name "libssh2")
158 (version "1.9.0")
159 (source (origin
160 (method url-fetch)
161 (uri (string-append
162 "https://www.libssh2.org/download/libssh2-"
163 version ".tar.gz"))
164 (sha256
165 (base32
166 "1zfsz9nldakfz61d2j70pk29zlmj7w2vv46s9l3x2prhcgaqpyym"))))
167 (build-system gnu-build-system)
168 ;; The installed libssh2.pc file does not include paths to libgcrypt and
169 ;; zlib libraries, so we need to propagate the inputs.
170 (propagated-inputs `(("libgcrypt" ,libgcrypt)
171 ("zlib" ,zlib)))
172 (arguments `(#:configure-flags `("--with-libgcrypt")))
173 (synopsis "Client-side C library implementing the SSH2 protocol")
174 (description
175 "libssh2 is a library intended to allow software developers access to
176 the SSH-2 protocol in an easy-to-use self-contained package. It can be built
177 into an application to perform many different tasks when communicating with
178 a server that supports the SSH-2 protocol.")
179 (license license:bsd-3)
180 (home-page "https://www.libssh2.org/")))
181
182 (define-public openssh
183 (package
184 (name "openssh")
185 (version "8.3p1")
186 (source (origin
187 (method url-fetch)
188 (uri (string-append "mirror://openbsd/OpenSSH/portable/"
189 "openssh-" version ".tar.gz"))
190 (patches (search-patches "openssh-hurd.patch"))
191 (sha256
192 (base32
193 "1cl74ghi9y21dc3f4xa0qamb7dhwacbynh1ks9syprrg8zhgpgpj"))))
194 (build-system gnu-build-system)
195 (native-inputs `(("groff" ,groff)
196 ("pkg-config" ,pkg-config)))
197 (inputs `(("libedit" ,libedit)
198 ("openssl" ,openssl)
199 ("pam" ,linux-pam)
200 ("mit-krb5" ,mit-krb5)
201 ("zlib" ,zlib)
202 ("xauth" ,xauth))) ; for 'ssh -X' and 'ssh -Y'
203 (arguments
204 `(#:test-target "tests"
205 ;; Otherwise, the test scripts try to use a nonexistent directory and
206 ;; fail.
207 #:make-flags '("REGRESSTMP=\"$${BUILDDIR}/regress\"")
208 #:configure-flags `("--sysconfdir=/etc/ssh"
209
210 ;; Default value of 'PATH' used by sshd.
211 "--with-default-path=/run/current-system/profile/bin"
212
213 ;; configure needs to find krb5-config.
214 ,(string-append "--with-kerberos5="
215 (assoc-ref %build-inputs "mit-krb5")
216 "/bin")
217
218 ;; libedit is needed for sftp completion.
219 "--with-libedit"
220
221 ;; Enable PAM support in sshd.
222 "--with-pam"
223
224 ;; "make install" runs "install -s" by default,
225 ;; which doesn't work for cross-compiled binaries
226 ;; because it invokes 'strip' instead of
227 ;; 'TRIPLET-strip'. Work around this.
228 ,,@(if (%current-target-system)
229 '("--disable-strip")
230 '()))
231
232 #:phases
233 (modify-phases %standard-phases
234 (add-after 'configure 'reset-/var/empty
235 (lambda* (#:key outputs #:allow-other-keys)
236 (let ((out (assoc-ref outputs "out")))
237 (substitute* "Makefile"
238 (("PRIVSEP_PATH=/var/empty")
239 (string-append "PRIVSEP_PATH=" out "/var/empty")))
240 #t)))
241 (add-before 'check 'patch-tests
242 (lambda _
243 (substitute* "regress/test-exec.sh"
244 (("/bin/sh") (which "sh")))
245
246 ;; Remove 't-exec' regress target which requires user 'sshd'.
247 (substitute* (list "Makefile"
248 "regress/Makefile")
249 (("^(tests:.*) t-exec(.*)" all pre post)
250 (string-append pre post)))
251 #t))
252 (replace 'install
253 (lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
254 ;; Install without host keys and system configuration files.
255 (apply invoke "make" "install-nosysconf" make-flags)
256 (install-file "contrib/ssh-copy-id"
257 (string-append (assoc-ref outputs "out")
258 "/bin/"))
259 (chmod (string-append (assoc-ref outputs "out")
260 "/bin/ssh-copy-id") #o555)
261 (install-file "contrib/ssh-copy-id.1"
262 (string-append (assoc-ref outputs "out")
263 "/share/man/man1/"))
264 #t)))))
265 (synopsis "Client and server for the secure shell (ssh) protocol")
266 (description
267 "The SSH2 protocol implemented in OpenSSH is standardised by the
268 IETF secsh working group and is specified in several RFCs and drafts.
269 It is composed of three layered components:
270
271 The transport layer provides algorithm negotiation and a key exchange.
272 The key exchange includes server authentication and results in a
273 cryptographically secured connection: it provides integrity, confidentiality
274 and optional compression.
275
276 The user authentication layer uses the established connection and relies on
277 the services provided by the transport layer. It provides several mechanisms
278 for user authentication. These include traditional password authentication
279 as well as public-key or host-based authentication mechanisms.
280
281 The connection layer multiplexes many different concurrent channels over the
282 authenticated connection and allows tunneling of login sessions and
283 TCP-forwarding. It provides a flow control service for these channels.
284 Additionally, various channel-specific options can be negotiated.")
285 (license (license:non-copyleft "file://LICENSE"
286 "See LICENSE in the distribution."))
287 (home-page "https://www.openssh.com/")))
288
289 ;; OpenSSH without X support. This allows to use OpenSSH without dragging X
290 ;; libraries to the closure.
291 (define-public openssh-sans-x
292 (package
293 (inherit openssh)
294 (name "openssh-sans-x")
295 (inputs (alist-delete "xauth" (package-inputs openssh)))
296 (synopsis "OpenSSH client and server without X11 support")))
297
298 (define-public guile-ssh
299 (package
300 (name "guile-ssh")
301 (version "0.13.1")
302 (home-page "https://github.com/artyom-poptsov/guile-ssh")
303 (source (origin
304 (method git-fetch)
305 (uri (git-reference
306 (url home-page)
307 (commit (string-append "v" version))))
308 (file-name (string-append name "-" version ".tar.gz"))
309 (sha256
310 (base32
311 "1xpxkvgj7wgcl450djkcrmrf957mcy2f36hfs5g6kpla1gax2d1g"))
312 (modules '((guix build utils)))))
313 (build-system gnu-build-system)
314 (outputs '("out" "debug"))
315 (arguments
316 `(;; It makes no sense to build libguile-ssh.a.
317 #:configure-flags '("--disable-static")
318
319 #:phases (modify-phases %standard-phases
320 (add-before 'build 'fix-libguile-ssh-file-name
321 (lambda* (#:key outputs #:allow-other-keys)
322 ;; Build and install libguile-ssh.so so that we can use
323 ;; its absolute file name in .scm files, before we build
324 ;; the .go files.
325 (let* ((out (assoc-ref outputs "out"))
326 (lib (string-append out "/lib")))
327 (invoke "make" "install"
328 "-C" "libguile-ssh"
329 "-j" (number->string
330 (parallel-job-count)))
331 (substitute* (find-files "." "\\.scm$")
332 (("\"libguile-ssh\"")
333 (string-append "\"" lib "/libguile-ssh\"")))
334 #t)))
335 ,@(if (%current-target-system)
336 '()
337 '((add-before 'check 'fix-guile-path
338 (lambda* (#:key inputs #:allow-other-keys)
339 (let ((guile (assoc-ref inputs "guile")))
340 (substitute* "tests/common.scm"
341 (("/usr/bin/guile")
342 (string-append guile "/bin/guile")))
343 #t)))))
344 (add-after 'install 'remove-bin-directory
345 (lambda* (#:key outputs #:allow-other-keys)
346 (let* ((out (assoc-ref outputs "out"))
347 (bin (string-append out "/bin"))
348 (examples (string-append
349 out "/share/guile-ssh/examples")))
350 (mkdir-p examples)
351 (rename-file (string-append bin "/ssshd.scm")
352 (string-append examples "/ssshd.scm"))
353 (rename-file (string-append bin "/sssh.scm")
354 (string-append examples "/sssh.scm"))
355 (delete-file-recursively bin)
356 #t))))))
357 (native-inputs `(("autoconf" ,autoconf)
358 ("automake" ,automake)
359 ("libtool" ,libtool)
360 ("texinfo" ,texinfo)
361 ("pkg-config" ,pkg-config)
362 ("which" ,which)
363 ("guile" ,guile-3.0))) ;needed when cross-compiling.
364 (inputs `(("guile" ,guile-3.0)
365 ("libssh" ,libssh)
366 ("libgcrypt" ,libgcrypt)))
367 (synopsis "Guile bindings to libssh")
368 (description
369 "Guile-SSH is a library that provides access to the SSH protocol for
370 programs written in GNU Guile interpreter. It is a wrapper to the underlying
371 libssh library.")
372 (license license:gpl3+)))
373
374 (define-public guile2.0-ssh
375 (package
376 (inherit guile-ssh)
377 (name "guile2.0-ssh")
378 (native-inputs
379 `(("guile" ,guile-2.0) ;needed when cross-compiling.
380 ,@(alist-delete "guile" (package-native-inputs guile-ssh))))
381 (inputs `(("guile" ,guile-2.0)
382 ,@(alist-delete "guile" (package-inputs guile-ssh))))))
383
384 (define-public guile2.2-ssh
385 (package
386 (inherit guile-ssh)
387 (name "guile2.2-ssh")
388 (native-inputs
389 `(("guile" ,guile-2.2) ;needed when cross-compiling.
390 ,@(alist-delete "guile" (package-native-inputs guile-ssh))))
391 (inputs `(("guile" ,guile-2.2)
392 ,@(alist-delete "guile" (package-inputs guile-ssh))))))
393
394 (define-public guile3.0-ssh
395 (deprecated-package "guile3.0-ssh" guile-ssh))
396
397 (define-public corkscrew
398 (package
399 (name "corkscrew")
400 (version "2.0")
401 (source
402 (origin
403 (method git-fetch)
404 (uri (git-reference
405 (url "https://github.com/patpadgett/corkscrew")
406 (commit (string-append "v" version))))
407 (sha256
408 (base32 "0g4pkczrc1zqpnxyyjwcjmyzdj5qqcpzwf1bm3965zdwp94bpppf"))
409 (file-name (git-file-name name version))))
410 (build-system gnu-build-system)
411 (arguments
412 `(#:phases
413 (modify-phases %standard-phases
414 (replace 'configure
415 ;; Replace configure phase as the ./configure script does not like
416 ;; CONFIG_SHELL and SHELL passed as parameters.
417 (lambda* (#:key outputs build target #:allow-other-keys)
418 (let* ((out (assoc-ref outputs "out"))
419 (bash (which "bash"))
420 ;; Set --build and --host flags as the provided config.guess
421 ;; is not able to detect them.
422 (flags `(,(string-append "--prefix=" out)
423 ,(string-append "--build=" build)
424 ,(string-append "--host=" (or target build)))))
425 (setenv "CONFIG_SHELL" bash)
426 (apply invoke bash "./configure" flags))))
427 (add-after 'install 'install-documentation
428 (lambda* (#:key outputs #:allow-other-keys)
429 (let* ((out (assoc-ref outputs "out"))
430 (doc (string-append out "/share/doc/" ,name "-" ,version)))
431 (install-file "README.markdown" doc)
432 #t))))))
433 (home-page "https://github.com/patpadgett/corkscrew")
434 (synopsis "SSH tunneling through HTTP(S) proxies")
435 (description
436 "Corkscrew tunnels SSH connections through most HTTP and HTTPS proxies.
437 Proxy authentication is only supported through the plain-text HTTP basic
438 authentication scheme.")
439 (license license:gpl2+)))
440
441 (define-public mosh
442 (package
443 (name "mosh")
444 (version "1.3.2")
445 (source (origin
446 (method url-fetch)
447 (uri (string-append "https://mosh.org/mosh-" version ".tar.gz"))
448 (sha256
449 (base32
450 "05hjhlp6lk8yjcy59zywpf0r6s0h0b9zxq0lw66dh9x8vxrhaq6s"))))
451 (build-system gnu-build-system)
452 (arguments
453 '(#:phases
454 (modify-phases %standard-phases
455 (add-after 'unpack 'patch-FHS-file-names
456 (lambda _
457 (substitute* "scripts/mosh.pl"
458 (("/bin/sh")
459 (which "sh")))
460 #t))
461 (add-after 'install 'wrap
462 (lambda* (#:key outputs #:allow-other-keys)
463 ;; Make sure 'mosh' can find 'mosh-client' and
464 ;; 'mosh-server'.
465 (let* ((out (assoc-ref outputs "out"))
466 (bin (string-append out "/bin")))
467 (wrap-program (string-append bin "/mosh")
468 `("PATH" ":" prefix (,bin)))))))))
469 (native-inputs
470 `(("pkg-config" ,pkg-config)))
471 (inputs
472 `(("openssl" ,openssl)
473 ("perl" ,perl)
474 ("perl-io-tty" ,perl-io-tty)
475 ("zlib" ,zlib)
476 ("ncurses" ,ncurses)
477 ("protobuf" ,protobuf)
478 ("boost-headers" ,boost)))
479 (home-page "https://mosh.org/")
480 (synopsis "Remote shell tolerant to intermittent connectivity")
481 (description
482 "Mosh is a remote terminal application that allows client roaming, supports
483 intermittent connectivity, and provides intelligent local echo and line editing
484 of user keystrokes. It's a replacement for SSH that's more robust and
485 responsive, especially over Wi-Fi, cellular, and long-distance links.")
486 (license license:gpl3+)))
487
488 (define-public et
489 (package
490 (name "et")
491 (version "3.1.0")
492 (source
493 (origin
494 (method git-fetch)
495 (uri (git-reference
496 (url "https://github.com/MisterTea/EternalTCP")
497 (commit (string-append "et-v" version))))
498 (file-name (git-file-name name version))
499 (sha256
500 (base32 "1m5caxckn2ihwp9s2pbyh5amxlpwr7yc54q8s0kb10fr52w2vfnm"))))
501 (build-system cmake-build-system)
502 (arguments `(#:tests? #f))
503 (native-inputs
504 `(("pkg-config" ,pkg-config)))
505 (inputs `(("glog" ,glog)
506 ("gflags" ,gflags)
507 ("libsodium" ,libsodium)
508 ("protobuf" ,protobuf)))
509 (synopsis "Remote shell that automatically reconnects")
510 (description
511 "Eternal Terminal (ET) is a remote shell that automatically reconnects
512 without interrupting the session. Unlike SSH sessions, ET sessions will
513 survive even network outages and IP changes. ET uses a custom protocol over
514 TCP, not the SSH protocol.")
515 (home-page "https://eternalterminal.dev/")
516 (license license:asl2.0)))
517
518 (define-public dropbear
519 (package
520 (name "dropbear")
521 (version "2020.80")
522 (source
523 (origin
524 (method url-fetch)
525 (uri (string-append
526 "https://matt.ucc.asn.au/dropbear/releases/"
527 "dropbear-" version ".tar.bz2"))
528 (sha256
529 (base32 "0jbrbpdzyv11x5rkljdimzq9p6a7da5siw9k405ibnpjj4dr89yr"))))
530 (build-system gnu-build-system)
531 (arguments `(#:tests? #f)) ; there is no "make check" or anything similar
532 ;; TODO: Investigate unbundling libtommath and libtomcrypt or at least
533 ;; cherry-picking important bug fixes from them. See <bugs.gnu.org/24674>
534 ;; for more information.
535 (inputs `(("zlib" ,zlib)))
536 (synopsis "Small SSH server and client")
537 (description "Dropbear is a relatively small SSH server and
538 client. It runs on a variety of POSIX-based platforms. Dropbear is
539 particularly useful for embedded systems, such as wireless routers.")
540 (home-page "https://matt.ucc.asn.au/dropbear/dropbear.html")
541 (license (license:x11-style "" "See file LICENSE."))))
542
543 (define-public liboop
544 (package
545 (name "liboop")
546 (version "1.0.1")
547 (source
548 (origin
549 (method url-fetch)
550 (uri (string-append "http://ftp.lysator.liu.se/pub/liboop/"
551 name "-" version ".tar.gz"))
552 (sha256
553 (base32
554 "1q0p1l72pq9k3bi7a366j2rishv7dzzkg3i6r2npsfg7cnnidbsn"))))
555 (build-system gnu-build-system)
556 (home-page "https://www.lysator.liu.se/liboop/")
557 (synopsis "Event loop library")
558 (description "Liboop is a low-level event loop management library for
559 POSIX-based operating systems. It supports the development of modular,
560 multiplexed applications which may respond to events from several sources. It
561 replaces the \"select() loop\" and allows the registration of event handlers
562 for file and network I/O, timers and signals. Since processes use these
563 mechanisms for almost all external communication, liboop can be used as the
564 basis for almost any application.")
565 (license license:lgpl2.1+)))
566
567 (define-public lsh
568 (package
569 (name "lsh")
570 (version "2.1")
571 (source (origin
572 (method url-fetch)
573 (uri (string-append "mirror://gnu/lsh/lsh-"
574 version ".tar.gz"))
575 (sha256
576 (base32
577 "1qqjy9zfzgny0rkb27c8c7dfsylvb6n0ld8h3an2r83pmaqr9gwb"))
578 (modules '((guix build utils)))
579 (snippet
580 '(begin
581 (substitute* "src/testsuite/functions.sh"
582 (("localhost")
583 ;; Avoid host name lookups since they don't work in
584 ;; chroot builds.
585 "127.0.0.1")
586 (("set -e")
587 ;; Make tests more verbose.
588 "set -e\nset -x"))
589
590 (substitute* (find-files "src/testsuite" "-test$")
591 (("localhost") "127.0.0.1"))
592
593 (substitute* "src/testsuite/login-auth-test"
594 (("/bin/cat") "cat"))
595 #t))))
596 (build-system gnu-build-system)
597 (native-inputs
598 `(("m4" ,m4)
599 ("guile" ,guile-2.0)
600 ("gperf" ,gperf)
601 ("psmisc" ,psmisc))) ; for `killall'
602 (inputs
603 `(("nettle" ,nettle-2)
604 ("linux-pam" ,linux-pam)
605
606 ;; 'rl.c' uses the 'CPPFunction' type, which is no longer in
607 ;; Readline 6.3.
608 ("readline" ,readline-6.2)
609
610 ("liboop" ,liboop)
611 ("zlib" ,zlib)
612 ("gmp" ,gmp)
613
614 ;; The server (lshd) invokes xauth when X11 forwarding is requested.
615 ;; This adds 24 MiB (or 27%) to the closure of lsh.
616 ("xauth" ,xauth)))
617 (arguments
618 '(;; Skip the `configure' test that checks whether /dev/ptmx &
619 ;; co. work as expected, because it relies on impurities (for
620 ;; instance, /dev/pts may be unavailable in chroots.)
621 #:configure-flags '("lsh_cv_sys_unix98_ptys=yes"
622
623 ;; Use glibc's argp rather than the bundled one.
624 "--with-system-argp"
625
626 ;; 'lsh_argp.h' checks HAVE_ARGP_PARSE but nothing
627 ;; defines it.
628 "CPPFLAGS=-DHAVE_ARGP_PARSE")
629
630 ;; FIXME: Tests won't run in a chroot, presumably because
631 ;; /etc/profile is missing, and thus clients get an empty $PATH
632 ;; and nothing works.
633 #:tests? #f
634
635 #:phases
636 (modify-phases %standard-phases
637 (add-before 'configure 'pre-configure
638 (lambda* (#:key inputs #:allow-other-keys)
639 (let* ((nettle (assoc-ref inputs "nettle"))
640 (sexp-conv (string-append nettle "/bin/sexp-conv")))
641 ;; Remove argp from the list of sub-directories; we don't want
642 ;; to build it, really.
643 (substitute* "src/Makefile.in"
644 (("^SUBDIRS = argp")
645 "SUBDIRS ="))
646
647 ;; Make sure 'lsh' and 'lshd' pick 'sexp-conv' in the right place
648 ;; by default.
649 (substitute* "src/environ.h.in"
650 (("^#define PATH_SEXP_CONV.*")
651 (string-append "#define PATH_SEXP_CONV \""
652 sexp-conv "\"\n")))
653
654 ;; Same for the 'lsh-authorize' script.
655 (substitute* "src/lsh-authorize"
656 (("=sexp-conv")
657 (string-append "=" sexp-conv)))
658
659 ;; Tell lshd where 'xauth' lives. Another option would be to
660 ;; hardcode "/run/current-system/profile/bin/xauth", thereby
661 ;; reducing the closure size, but that wouldn't work on foreign
662 ;; distros.
663 (with-fluids ((%default-port-encoding "ISO-8859-1"))
664 (substitute* "src/server_x11.c"
665 (("define XAUTH_PROGRAM.*")
666 (string-append "define XAUTH_PROGRAM \""
667 (assoc-ref inputs "xauth")
668 "/bin/xauth\"\n")))))
669
670 ;; Tests rely on $USER being set.
671 (setenv "USER" "guix"))))))
672 (home-page "https://www.lysator.liu.se/~nisse/lsh/")
673 (synopsis "GNU implementation of the Secure Shell (ssh) protocols")
674 (description
675 "GNU lsh is a free implementation of the SSH version 2 protocol. It is
676 used to create a secure line of communication between two computers,
677 providing shell access to the server system from the client. It provides
678 both the server daemon and the client application, as well as tools for
679 manipulating key files.")
680 (license license:gpl2+)))
681
682 (define-public sshpass
683 (package
684 (name "sshpass")
685 (version "1.06")
686 (synopsis "Non-interactive password authentication with SSH")
687 (home-page "https://sourceforge.net/projects/sshpass/")
688 (source
689 (origin
690 (method url-fetch)
691 (uri (string-append "mirror://sourceforge/sshpass/sshpass/"
692 version "/sshpass-" version ".tar.gz"))
693 (sha256
694 (base32
695 "0q7fblaczb7kwbsz0gdy9267z0sllzgmf0c7z5c9mf88wv74ycn6"))))
696 (build-system gnu-build-system)
697 (description "sshpass is a tool for non-interactivly performing password
698 authentication with SSH's so-called @dfn{interactive keyboard password
699 authentication}.")
700 (license license:gpl2+)))
701
702 (define-public autossh
703 (package
704 (name "autossh")
705 (version "1.4g")
706 (source
707 (origin
708 (method url-fetch)
709 (uri (string-append
710 "https://www.harding.motd.ca/autossh/autossh-"
711 version ".tgz"))
712 (sha256
713 (base32 "0xqjw8df68f4kzkns5gcah61s5wk0m44qdk2z1d6388w6viwxhsz"))))
714 (build-system gnu-build-system)
715 (arguments `(#:tests? #f)) ; There is no "make check" or anything similar
716 (inputs `(("openssh" ,openssh)))
717 (synopsis "Automatically restart SSH sessions and tunnels")
718 (description "autossh is a program to start a copy of @command{ssh} and
719 monitor it, restarting it as necessary should it die or stop passing traffic.")
720 (home-page "https://www.harding.motd.ca/autossh/")
721 (license
722 ;; Why point to a source file? Well, all the individual files have a
723 ;; copy of this license in their headers, but there's no separate file
724 ;; with that information.
725 (license:non-copyleft "file://autossh.c"))))
726
727 (define-public pdsh
728 (package
729 (name "pdsh")
730 (version "2.34")
731 (source
732 (origin
733 (method url-fetch)
734 (uri (string-append "https://github.com/chaos/pdsh/"
735 "releases/download/pdsh-" version
736 "/pdsh-" version ".tar.gz"))
737 (sha256
738 (base32 "1s91hmhrz7rfb6h3l5k97s393rcm1ww3svp8dx5z8vkkc933wyxl"))))
739 (build-system gnu-build-system)
740 (arguments
741 `(#:configure-flags
742 (list "--with-ssh")
743 #:phases
744 (modify-phases %standard-phases
745 (add-after 'unpack 'patch-/bin/sh
746 (lambda _
747 (substitute* '("tests/t0006-pdcp.sh"
748 "tests/t0004-module-loading.sh"
749 "tests/t2001-ssh.sh"
750 "tests/t1003-slurm.sh"
751 "tests/t6036-long-output-lines.sh"
752 "tests/aggregate-results.sh"
753 "tests/t2000-exec.sh"
754 "tests/t0002-internal.sh"
755 "tests/t1002-dshgroup.sh"
756 "tests/t5000-dshbak.sh"
757 "tests/t0001-basic.sh"
758 "tests/t0005-rcmd_type-and-user.sh"
759 "tests/test-lib.sh"
760 "tests/t2002-mrsh.sh"
761 "tests/t0003-wcoll.sh"
762 "tests/test-modules/pcptest.c")
763 (("/bin/sh") (which "bash")))
764 #t))
765 (add-after 'unpack 'patch-tests
766 (lambda _
767 (substitute* "tests/t6036-long-output-lines.sh"
768 (("which") (which "which")))
769 #t)))))
770 (inputs
771 `(("openssh" ,openssh)
772 ("mit-krb5" ,mit-krb5)
773 ("perl" ,perl)))
774 (native-inputs
775 `(("which" ,which)))
776 (home-page "https://github.com/chaos/pdsh")
777 (synopsis "Parallel distributed shell")
778 (description "Pdsh is a an efficient, multithreaded remote shell client
779 which executes commands on multiple remote hosts in parallel. Pdsh implements
780 dynamically loadable modules for extended functionality such as new remote
781 shell services and remote host selection.")
782 (license license:gpl2+)))
783
784 (define-public clustershell
785 (package
786 (name "clustershell")
787 (version "1.8.3")
788 (source
789 (origin
790 (method url-fetch)
791 (uri (string-append "https://github.com/cea-hpc/clustershell/releases"
792 "/download/v" version
793 "/ClusterShell-" version ".tar.gz"))
794 (sha256
795 (base32 "1qdcgh733szwj9r1gambrgfkizvbjci0bnnkds9a8mnyb3sasnan"))))
796 (build-system python-build-system)
797 (inputs `(("openssh" ,openssh)))
798 (propagated-inputs `(("python-pyyaml" ,python-pyyaml)))
799 (arguments
800 `(#:phases (modify-phases %standard-phases
801 (add-before 'build 'record-openssh-file-name
802 (lambda* (#:key inputs #:allow-other-keys)
803 (let ((ssh (assoc-ref inputs "openssh")))
804 (substitute* "lib/ClusterShell/Worker/Ssh.py"
805 (("info\\(\"ssh_path\"\\) or \"ssh\"")
806 (string-append "info(\"ssh_path\") or \""
807 ssh "/bin/ssh\"")))
808 #t))))))
809 (home-page "https://cea-hpc.github.io/clustershell/")
810 (synopsis "Scalable event-driven Python framework for cluster administration")
811 (description
812 "ClusterShell is an event-driven Python framework, designed to run local
813 or distant commands in parallel on server farms or on large GNU/Linux
814 clusters. It will take care of common issues encountered on HPC clusters,
815 such as operating on groups of nodes, running distributed commands using
816 optimized execution algorithms, as well as gathering results and merging
817 identical outputs, or retrieving return codes. ClusterShell takes advantage
818 of existing remote shell facilities such as SSH.")
819 (license license:lgpl2.1+)))
820
821 (define-public endlessh
822 (package
823 (name "endlessh")
824 (version "1.1")
825 (source
826 (origin
827 (method git-fetch)
828 (uri (git-reference
829 (url "https://github.com/skeeto/endlessh")
830 (commit version)))
831 (file-name (git-file-name name version))
832 (sha256
833 (base32 "0ziwr8j1frsp3dajr8h5glkm1dn5cci404kazz5w1jfrp0736x68"))))
834 (build-system gnu-build-system)
835 (arguments
836 '(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
837 "CC=gcc")
838 #:tests? #f ; no test target
839 #:phases
840 (modify-phases %standard-phases
841 (delete 'configure)))) ; no configure script
842 (home-page "https://github.com/skeeto/endlessh")
843 (synopsis "SSH tarpit that slowly sends an endless banner")
844 (description
845 "Endlessh is an SSH tarpit that very slowly sends an endless, random SSH
846 banner. It keeps SSH clients locked up for hours or even days at a time. The
847 purpose is to put your real SSH server on another port and then let the script
848 kiddies get stuck in this tarpit instead of bothering a real server.
849
850 Since the tarpit is in the banner before any cryptographic exchange occurs, this
851 program doesn't depend on any cryptographic libraries. It's a simple,
852 single-threaded, standalone C program. It uses @code{poll()} to trap multiple
853 clients at a time.")
854 (license license:unlicense)))