gnu: gettext: Upgrade to 0.18.3.
[jackhill/guix/guix.git] / gnu / packages / bison.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages bison)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages m4)
25 #:use-module (gnu packages perl))
26
27 (define-public bison
28 (package
29 (name "bison")
30 (version "2.7.1")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/bison/bison-"
35 version ".tar.xz"))
36 (sha256
37 (base32
38 "1yx7isx67sdmyijvihgyra1f59fwdz7sqriginvavfj5yb5ss2dl"))))
39 (build-system gnu-build-system)
40 (inputs `(("perl" ,perl)))
41 (propagated-inputs `(("m4" ,m4)))
42 (home-page "http://www.gnu.org/software/bison/")
43 (synopsis "Parser generator")
44 (description
45 "Bison is a general-purpose parser generator that converts an
46 annotated context-free grammar into an LALR(1) or GLR parser for
47 that grammar. Once you are proficient with Bison, you can use
48 it to develop a wide range of language parsers, from those used
49 in simple desk calculators to complex programming languages.
50
51 Bison is upward compatible with Yacc: all properly-written Yacc
52 grammars ought to work with Bison with no change. Anyone
53 familiar with Yacc should be able to use Bison with little
54 trouble. You need to be fluent in C or C++ programming in order
55 to use Bison.")
56 (license gpl3+)))