gnu: Sync synopses with the Womb.
[jackhill/guix/guix.git] / gnu / packages / bazaar.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages bazaar)
20 #:use-module ((guix licenses) #:select (gpl2+))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system python)
24 #:use-module (guix build utils)
25 #:use-module ((gnu packages gettext)
26 #:renamer (symbol-prefix-proc 'guix:)))
27
28 (define-public bazaar
29 (package
30 (name "bazaar")
31 (version "2.5.1")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "https://launchpad.net/bzr/2.5/" version
36 "/+download/bzr-" version ".tar.gz"))
37 (sha256
38 (base32
39 "10krjbzia2avn09p0cdlbx2wya0r5v11w5ymvyl72af5dkx4cwwn"))))
40 (build-system python-build-system)
41 (inputs
42 ;; Note: 'tools/packaging/lp-upload-release' and 'tools/weavemerge.sh'
43 ;; require Zsh.
44 `(("gettext" ,guix:gettext)))
45 (arguments
46 `(#:tests? #f)) ; no test target
47 (home-page "https://gnu.org/software/bazaar")
48 (synopsis "Decentralized revision control system")
49 (description
50 "GNU Bazaar is a distributed version control system, which supports both
51 central version control and distributed version control. Developers can
52 organize their workspace in whichever way they want. It is possible to work
53 from a command line or use a GUI application.")
54 (license gpl2+)))