Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / storage.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
3 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages storage)
21 #:use-module (guix download)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix utils)
25 #:use-module (guix build-system cmake)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages admin)
28 #:use-module (gnu packages assembly)
29 #:use-module (gnu packages authentication)
30 #:use-module (gnu packages bdw-gc)
31 #:use-module (gnu packages boost)
32 #:use-module (gnu packages check)
33 #:use-module (gnu packages compression)
34 #:use-module (gnu packages crypto)
35 #:use-module (gnu packages cryptsetup)
36 #:use-module (gnu packages curl)
37 #:use-module (gnu packages databases)
38 #:use-module (gnu packages disk)
39 #:use-module (gnu packages gcc)
40 #:use-module (gnu packages gnuzilla)
41 #:use-module (gnu packages gperf)
42 #:use-module (gnu packages jemalloc)
43 #:use-module (gnu packages linux)
44 #:use-module (gnu packages lua)
45 #:use-module (gnu packages openldap)
46 #:use-module (gnu packages perl)
47 #:use-module (gnu packages pkg-config)
48 #:use-module (gnu packages python)
49 #:use-module (gnu packages tls)
50 #:use-module (gnu packages web)
51 #:use-module (gnu packages xml))
52
53 (define-public ceph
54 (package
55 (name "ceph")
56 (version "13.2.2")
57 (source (origin
58 (method url-fetch)
59 (uri (string-append "https://download.ceph.com/tarballs/ceph-"
60 version ".tar.gz"))
61 (sha256
62 (base32
63 "0h483n9iy0fkbqrhf7k0dzspwdpcaswkjwmc5n5c600fr6s1v9pk"))
64 (patches
65 (search-patches "ceph-skip-unittest_blockdev.patch"
66 "ceph-skip-collect-sys-info-test.patch"
67 "ceph-detect-rocksdb.patch"
68 "ceph-volume-respect-PATH.patch"
69 "ceph-disable-cpu-optimizations.patch"))
70 (modules '((guix build utils)))
71 (snippet
72 '(begin
73 (for-each delete-file-recursively
74 '(;; TODO: Unbundle these:
75 ;"src/isa-l"
76 ;"src/lua"
77 ;"src/googletest"
78 ;"src/xxHash"
79 ;"src/zstd"
80 ;"src/civetweb"
81 "src/test/downloads"
82 "src/rapidjson"
83 "src/spdk"
84 "src/rocksdb"
85 "src/boost"))
86 #t))))
87 (build-system cmake-build-system)
88 (arguments
89 `(#:configure-flags
90 (let* ((out (assoc-ref %outputs "out"))
91 (lib (assoc-ref %outputs "lib"))
92 (libdir (string-append lib "/lib")))
93 (list (string-append "-DCMAKE_INSTALL_PREFIX=" out)
94 (string-append "-DCMAKE_INSTALL_LIBDIR=" libdir)
95 ;; We need both libdir and libdir/ceph in RUNPATH.
96 (string-append "-DCMAKE_INSTALL_RPATH="
97 libdir ";" libdir "/ceph")
98 (string-append "-DCMAKE_INSTALL_SYSCONFDIR=" out "/etc")
99 (string-append "-DCMAKE_INSTALL_MANDIR=" out "/share/man")
100 (string-append "-DCMAKE_INSTALL_DOCDIR=" out "/share/ceph/doc")
101 (string-append "-DCMAKE_INSTALL_LIBEXECDIR=" out "/libexec")
102 (string-append "-DKEYUTILS_INCLUDE_DIR="
103 (assoc-ref %build-inputs "keyutils") "/include")
104 "-DCMAKE_INSTALL_LOCALSTATEDIR=/var"
105 "-DENABLE_SHARED=ON"
106 "-DWITH_SYSTEM_ROCKSDB=ON"
107 "-DWITH_SYSTEM_BOOST=ON"
108 "-DWITH_PYTHON3=ON"
109 ;; TODO: Enable these when available in Guix.
110 "-DWITH_MGR_DASHBOARD_FRONTEND=OFF" ;requires node + nodeenv
111 "-DWITH_BABELTRACE=OFF"
112 "-DWITH_LTTNG=OFF"
113 "-DWITH_SPDK=OFF"
114 "-DWITH_XFS=OFF"
115 "-DWITH_XIO=OFF"
116 ;; Use jemalloc instead of tcmalloc.
117 "-DALLOCATOR=jemalloc"))
118 ;; FIXME: Some of the tests leak Btrfs subvolumes on Btrfs. See
119 ;; <https://bugs.gnu.org/29674> for details. Disable tests until
120 ;; resolved.
121 #:tests? #f
122 #:phases
123 (modify-phases %standard-phases
124 (add-after 'unpack 'patch-source
125 (lambda* (#:key outputs #:allow-other-keys)
126 (let ((out (assoc-ref outputs "out"))
127 (lib (assoc-ref outputs "lib")))
128
129 ;; Make header files follow the dynamic libraries.
130 (substitute* "src/include/CMakeLists.txt"
131 (("DESTINATION include")
132 (string-append "DESTINATION " lib "/include")))
133
134 (substitute* "cmake/modules/Distutils.cmake"
135 ;; Prevent creation of Python eggs.
136 (("setup.py install")
137 "setup.py install --single-version-externally-managed --root=/"))
138
139 (substitute* (find-files "src/pybind" "^setup\\.py$")
140 ;; Here we inject an extra line to the `setup.py' of the
141 ;; Python C libraries so RUNPATH gets set up correctly.
142 (("^([[:blank:]]+)extra_compile_args=(.*)$" _ indent args)
143 (string-append indent "extra_compile_args=" args
144 indent "extra_link_args=['-Wl,-rpath="
145 lib "/lib'],\n")))
146
147 (substitute* "src/ceph-disk/tox.ini"
148 ;; Disable flake8 test since it complains about too long lines.
149 (("envlist = flake8,py27") "envlist = py27"))
150
151 (substitute* "src/ceph-detect-init/tox.ini"
152 ;; Disable python3 tests until we at least get py2 working.
153 (("envlist = pep8,py27,py3") "envlist = pep8,py27"))
154
155 (substitute* "src/key_value_store/kv_flat_btree_async.cc"
156 (("/usr/include/") ""))
157
158 (substitute* "src/test/test_subprocess.cc"
159 (("/bin/sh") (which "sh")))
160 (substitute* "qa/standalone/special/ceph_objectstore_tool.py"
161 (("/bin/rm") (which "rm")))
162 (substitute* "src/ceph-disk/ceph_disk/main.py"
163 (("/bin/mount") "mount")
164 (("/bin/umount") "umount")
165 (("/sbin/blkid") (which "blkid"))
166 (("'cryptsetup'") (string-append "'" (which "cryptsetup") "'"))
167 (("'sgdisk'") (string-append "'" (which "sgdisk") "'"))
168 (("'parted'") (string-append "'" (which "parted") "'"))
169 (("'udevadm'") (string-append "'" (which "udevadm") "'")))
170
171 (substitute* "udev/50-rbd.rules"
172 (("/usr/bin/ceph-rbdnamer")
173 (string-append out "/bin/ceph-rbdnamer")))
174 (substitute* "udev/60-ceph-by-parttypeuuid.rules"
175 (("/sbin/blkid") (which "blkid")))
176 (substitute* "udev/95-ceph-osd.rules"
177 (("/usr/sbin/ceph-disk")
178 (string-append out "/bin/ceph-disk")))
179
180 (substitute* "src/test/run-cli-tests"
181 ;; Use our python-cram instead of the (un)bundled one.
182 (("CRAM_BIN=.*$")
183 (string-append "CRAM_BIN=" (which "cram") "\n")))
184
185 ;; Disable tests that are known to fail.
186 ;; TODO: The majority of these fail because
187 ;; 'qa/workunits/ceph-helpers.sh' expects to find
188 ;; /tmp/ceph-disk-virtualenv/bin/ceph-disk, but somehow
189 ;; src/ceph-disk/CMakeLists.txt fails to create it.
190 (substitute* "src/test/CMakeLists.txt"
191 ;; FIXME: These tests fails because `ceph-disk'
192 ;; is not available.
193 (("^add_ceph_test\\(test-ceph-helpers\\.sh.*$") "\n")
194 (("^add_ceph_test\\(test_pidfile\\.sh.*$") "\n")
195 ;; XXX Why does this fail.
196 (("^add_ceph_test\\(cephtool-test-mon\\.sh.*$") "\n")
197 ;; This fails due to missing '/etc/fstab'.
198 (("^add_ceph_test\\(cephtool-test-rados\\.sh.*$") "\n")
199 ;; `Bad messages to stderr: OSD has the store locked'
200 (("^add_ceph_test\\(ceph_objectstore_tool\\.py.*$") "\n")
201 ;; The bundled python-cram fork needs patching to work on
202 ;; guix, and the system version does not support --error-dir.
203 ;; https://bitbucket.org/brodie/cram/issues/9
204 (("^add_ceph_test\\(run-cli-tests.*$") "\n")
205 ;; FIXME: tox/virtualenv/pip does not discover the
206 ;; required packages and tries to go online.
207 (("^add_test\\(NAME run-tox-ceph-disk.*$") "\n")
208 (("^add_test\\(NAME run-tox-ceph-detect-init.*$") "\n")
209 ;; Also remove from the set_property block.
210 (("run-tox-ceph-disk") "")
211 (("run-tox-ceph-detect-init") ""))
212 ;; TODO: This also seems to fail because of /etc/os-release.
213 ;; How to make src/common/util.cc behave without it.
214 (substitute* "src/test/crush/CMakeLists.txt"
215 (("^add_ceph_test\\(crush-classes\\.sh.*$") "\n"))
216 ;; More 'ceph-disk' issues here.. :-(
217 (substitute* "src/test/erasure-code/CMakeLists.txt"
218 (("^add_ceph_test\\(test-erasure-code-plugins\\.sh.*$") "\n")
219 (("^add_ceph_test\\(test-erasure-code\\.sh.*$") "\n")
220 (("^add_ceph_test\\(test-erasure-eio\\.sh.*$") "\n"))
221 (substitute* "src/test/libradosstriper/CMakeLists.txt"
222 (("^add_ceph_test\\(rados-striper\\.sh.*$") "\n"))
223 (substitute* "src/test/mon/CMakeLists.txt"
224 (("^add_ceph_test\\(osd-crush\\.sh.*$") "\n")
225 (("^add_ceph_test\\(test_pool_quota\\.sh.*$") "\n")
226 (("^add_ceph_test\\(osd-pool-create\\.sh.*$") "\n"))
227 (substitute* "src/test/osd/CMakeLists.txt"
228 (("^add_ceph_test\\(osd-bench\\.sh.*$") "\n")
229 (("^add_ceph_test\\(osd-config\\.sh.*$") "\n")
230 (("add_ceph_test\\(osd-dup\\.sh.*$") "\n")
231 (("^add_ceph_test\\(osd-markdown\\.sh.*$") "\n")
232 (("^add_ceph_test\\(osd-reactivate\\.sh.*$") "\n")
233 (("^add_ceph_test\\(osd-reuse-id\\.sh.*$") "\n")
234 (("^add_ceph_test\\(osd-scrub-repair\\.sh.*$") "\n")
235 (("^add_ceph_test\\(osd-scrub-snaps\\.sh.*$") "\n")
236 (("^add_ceph_test\\(osd-copy-from\\.sh.*$") "\n")
237 (("^add_ceph_test\\(osd-fast-mark-down\\.sh.*$") "\n"))
238 #t)))
239 (add-before 'configure 'gcc-workaround
240 (lambda _
241 (unsetenv "C_INCLUDE_PATH")
242 (unsetenv "CPLUS_INCLUDE_PATH")
243 #t))
244 (add-before 'check 'set-check-environment
245 (lambda _
246 ;; Run tests in parallel.
247 (setenv "CTEST_PARALLEL_LEVEL"
248 (number->string (parallel-job-count)))
249 ;; `pip' requires write access in $HOME.
250 (setenv "HOME" "/tmp")
251 #t))
252 (add-before 'install 'set-install-environment
253 (lambda* (#:key outputs #:allow-other-keys)
254 (let* ((out (assoc-ref outputs "out"))
255 (py2sitedir
256 (string-append out "/lib/python2.7/site-packages"))
257 (py3sitedir
258 (string-append out "/lib/python"
259 ,(version-major+minor
260 (package-version python))
261 "/site-packages")))
262 ;; The Python install scripts refuses to function if
263 ;; the install directory is not on PYTHONPATH.
264 (setenv "PYTHONPATH"
265 (string-append py2sitedir ":" py3sitedir ":"
266 (getenv "PYTHONPATH")))
267 #t)))
268 (add-after 'install 'wrap-python-scripts
269 (lambda* (#:key inputs outputs #:allow-other-keys)
270 (let* ((out (assoc-ref outputs "out"))
271 (scripts '("ceph" "ceph-mgr" "ceph-volume"
272 "ceph-detect-init"
273 "ceph-disk")) ;deprecated
274 (prettytable (assoc-ref inputs "python2-prettytable"))
275 (six (assoc-ref inputs "python2-six"))
276 (sitedir (lambda (package)
277 (string-append package
278 "/lib/python2.7/site-packages")))
279 (PYTHONPATH (string-append
280 (sitedir out) ":"
281 (sitedir six) ":"
282 (sitedir prettytable))))
283 (for-each (lambda (executable)
284 (wrap-program (string-append out "/bin/" executable)
285 `("PYTHONPATH" ":" prefix (,PYTHONPATH))))
286 scripts)
287 #t))))))
288 (outputs
289 '("out" "lib"))
290 (native-inputs
291 `(("gcc" ,gcc-7) ;7 or later is required
292 ("gperf" ,gperf)
293 ("pkg-config" ,pkg-config)
294 ("python-cython" ,python-cython)
295 ("python-sphinx" ,python-sphinx)
296 ("yasm" ,yasm)
297
298 ;; For tests.
299 ("inetutils" ,inetutils)
300 ("jq" ,jq)
301 ("perl" ,perl)
302 ("xmlstarlet" ,xmlstarlet)
303 ("python2-cram" ,python2-cram)
304 ("python2-virtualenv" ,python2-virtualenv)
305
306 ;; These dependencies are taken from test-requirements.txt
307 ;; of ceph-disk and ceph-detect-init. The latter can also
308 ;; test against python3, but let's try to get python2 tests
309 ;; working first since that is the default.
310 ("python2-configobj" ,python2-configobj)
311 ("python2-coverage" ,python2-coverage)
312 ("python2-discover" ,python2-discover)
313 ("python2-fixtures" ,python2-fixtures)
314 ("python2-flake8" ,python2-flake8)
315 ("python2-mock" ,python2-mock)
316 ("python2-nose" ,python2-nose)
317 ("python2-pip" ,python2-pip)
318 ("python2-pytest" ,python2-pytest)
319 ("python2-subunit" ,python2-subunit)
320 ("python2-testrepository" ,python2-testrepository)
321 ("python2-testtools" ,python2-testtools)
322 ("python2-tox" ,python2-tox)))
323 (inputs
324 `(("boost" ,boost)
325 ("curl" ,curl)
326 ("cryptsetup" ,cryptsetup)
327 ("expat" ,expat)
328 ("fcgi" ,fcgi)
329 ("fuse" ,fuse)
330 ("gptfdisk" ,gptfdisk)
331 ("jemalloc" ,jemalloc)
332 ("keyutils" ,keyutils)
333 ("leveldb" ,leveldb)
334 ("libaio" ,libaio)
335 ("libatomic-ops" ,libatomic-ops)
336 ("lua" ,lua)
337 ("lz4" ,lz4)
338 ("oath-toolkit" ,oath-toolkit)
339 ("openldap" ,openldap)
340 ("openssl" ,openssl)
341 ("nss" ,nss)
342 ("parted" ,parted)
343 ("python@2" ,python-2)
344 ("python2-prettytable" ,python2-prettytable) ;used by ceph_daemon.py
345 ("python2-six" ,python2-six) ;for ceph-mgr + plugins
346 ("python@3" ,python-3)
347 ("rapidjson" ,rapidjson)
348 ("rocksdb" ,rocksdb)
349 ("snappy" ,snappy)
350 ("udev" ,eudev)
351 ("util-linux" ,util-linux)
352 ("zlib" ,zlib)))
353 (home-page "https://ceph.com/")
354 (synopsis "Distributed object store and file system")
355 (description
356 "Ceph is a distributed storage system designed for reliability and
357 performance. It provides network-based block devices (RBD), a POSIX
358 compliant file system (CephFS), and offers compatibility with various
359 storage protocols (S3, NFS, and others) through the RADOS gateway.")
360 ;; The Ceph libraries are LGPL2.1 and most of the utilities fall under
361 ;; GPL2. The installed erasure code plugins are BSD-3 licensed and do
362 ;; not use the GPL code. The source archive includes a number of files
363 ;; carrying other licenses; consult COPYING for more information. Note
364 ;; that COPYING does not cover third-party bundled software.
365 (license (list license:lgpl2.1 license:gpl2 ;some files are 'or later'
366 license:cc-by-sa3.0 ;documentation
367 license:bsd-3 ;isa-l,jerasure,++
368 license:expat)))) ;civetweb,java bindings