gnu: r-rtracklayer: Update to 1.38.2.
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
4 ;;; Copyright © 2017 Mark Meyer <mark@ofosos.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages kde)
22 #:use-module (guix build-system cmake)
23 #:use-module (guix download)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix packages)
26 #:use-module (guix utils)
27 #:use-module (gnu packages algebra)
28 #:use-module (gnu packages apr)
29 #:use-module (gnu packages boost)
30 #:use-module (gnu packages compression)
31 #:use-module (gnu packages curl)
32 #:use-module (gnu packages documentation)
33 #:use-module (gnu packages gettext)
34 #:use-module (gnu packages ghostscript)
35 #:use-module (gnu packages gl)
36 #:use-module (gnu packages gnome)
37 #:use-module (gnu packages graphics)
38 #:use-module (gnu packages image)
39 #:use-module (gnu packages kde-frameworks)
40 #:use-module (gnu packages llvm)
41 #:use-module (gnu packages maths)
42 #:use-module (gnu packages pdf)
43 #:use-module (gnu packages perl)
44 #:use-module (gnu packages photo)
45 #:use-module (gnu packages pkg-config)
46 #:use-module (gnu packages tls)
47 #:use-module (gnu packages qt)
48 #:use-module (gnu packages version-control)
49 #:use-module (gnu packages xorg))
50
51 (define-public kdevelop
52 (package
53 (name "kdevelop")
54 (version "5.1.2")
55 (source
56 (origin
57 (method url-fetch)
58 (uri (string-append "mirror://kde/stable/kdevelop"
59 "/" version "/src/kdevelop-"
60 version ".tar.xz"))
61 (sha256
62 (base32
63 "1iqaq0ilijjigqb34v5wq9in6bnjs0p9cmgbygjmy53xhh3yhm5g"))))
64 (build-system cmake-build-system)
65 (native-inputs
66 `(("extra-cmake-modules" ,extra-cmake-modules)
67 ("pkg-config" ,pkg-config)
68 ("qttools" ,qttools)))
69 (inputs
70 `(("kdevplatform" ,kdevplatform)
71 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
72 ("qtbase" ,qtbase)
73 ("qtdeclarative" ,qtdeclarative)
74 ("qtquickcontrols" ,qtquickcontrols)
75 ("qtwebkit" ,qtwebkit)
76 ("karchive" ,karchive)
77 ("kcmutils" ,kcmutils)
78 ("kconfig" ,kconfig)
79 ("kdeclarative" ,kdeclarative)
80 ("kdoctools" ,kdoctools)
81 ("kguiaddons" ,kguiaddons)
82 ("ki18n" ,ki18n)
83 ("kio" ,kio)
84 ("kiconthemes" ,kiconthemes)
85 ("kitemmodels" ,kitemmodels)
86 ("kitemviews" ,kitemviews)
87 ("kjobwidgets" ,kjobwidgets)
88 ("knotifyconfig" ,knotifyconfig)
89 ("knotifications" ,knotifications)
90 ("kparts" ,kparts)
91 ("kcrash" ,kcrash)
92 ("knewstuff" ,knewstuff)
93 ("krunner" ,krunner)
94 ("kxmlgui" ,kxmlgui)
95 ("libksysguard" ,libksysguard)
96 ("threadweaver" ,threadweaver)
97 ("ktexteditor" ,ktexteditor)
98 ("kwindowsystem" ,kwindowsystem)
99 ("plasma" ,plasma-framework)
100 ("grantlee" ,grantlee)
101 ("libepoxy" ,libepoxy)
102 ("clang" ,clang)
103 ("shared-mime-info" ,shared-mime-info)))
104 (arguments
105 `(#:phases
106 (modify-phases %standard-phases
107 (delete 'check) ;; there are some issues with the test suite
108 (add-after 'install 'wrap-executable
109 (lambda* (#:key inputs outputs #:allow-other-keys)
110 (let* ((out (assoc-ref outputs "out"))
111 (kdevplatform (assoc-ref inputs "kdevplatform"))
112 (kio (assoc-ref inputs "kio"))
113 (kcmutils (assoc-ref inputs "kcmutils"))
114 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
115 (qtbase (assoc-ref inputs "qtbase"))
116 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
117 (qml "/qml"))
118 (wrap-program (string-append out "/bin/kdevelop")
119 `("XDG_DATA_DIRS" ":" prefix
120 ,(map (lambda (s) (string-append s "/share"))
121 (list out kdevplatform kcmutils)))
122 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
123 (,(string-append qtbase "/plugins/platforms")))
124 `("QT_PLUGIN_PATH" ":" prefix
125 ,(map (lambda (s) (string-append s "/lib/plugins"))
126 (list out kdevplatform kio)))
127 `("QML2_IMPORT_PATH" ":" prefix
128 (,(string-append qtquickcontrols qml)
129 ,(string-append qtdeclarative qml))))))))))
130 (home-page "https://kdevelop.org")
131 (synopsis "IDE for C, C++, Python, Javascript and PHP")
132 (description "The KDevelop IDE provides semantic syntax highlighting, as
133 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
134 JavaScript, Python and PHP. It also integrates with a debugger, different
135 build systems (CMake, QMake, custom Makefiles) and version control
136 software (Git, Subversion, Mercurial, CVS and Bazaar).")
137 (license license:lgpl2.1+)))
138
139 (define-public kdevelop-pg-qt
140 (package
141 (name "kdevelop-pg-qt")
142 (version "2.0.0")
143 (source
144 (origin
145 (method url-fetch)
146 (uri (string-append "https://github.com/KDE/kdevelop-pg-qt/archive/v"
147 version ".tar.gz"))
148 (file-name (string-append name "-" version ".tar.gz"))
149 (sha256
150 (base32 "1av8plqz7hyhrd07avnmn6ryslqlarmxn0pw7swzvb6ddiqp59j4"))))
151 (native-inputs
152 `(("extra-cmake-modules" ,extra-cmake-modules)))
153 (inputs
154 `(("qtbase" ,qtbase)))
155 (build-system cmake-build-system)
156 (home-page "https://kde.org")
157 (synopsis "Parser generator library for KDevplatform")
158 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
159 for some KDevelop language plugins (Ruby, PHP, CSS...).")
160 (license license:lgpl2.0+)))
161
162 (define-public kdevplatform
163 (package
164 (name "kdevplatform")
165 (version "5.1.2")
166 (source (origin
167 (method url-fetch)
168 (uri (string-append "mirror://kde/stable/kdevelop"
169 "/" version "/src/kdevplatform-"
170 version ".tar.xz"))
171 (sha256
172 (base32
173 "0jk6g1kiqpyjy8pca0236b9944gxqnymqv8ny6m8nrraannxs8p6"))))
174 (build-system cmake-build-system)
175 (native-inputs
176 `(("extra-cmake-modules" ,extra-cmake-modules)
177 ("pkg-config" ,pkg-config)))
178 (inputs
179 `(("apr" ,apr)
180 ("apr-util" ,apr-util)
181 ("boost" ,boost)
182 ("karchive" ,karchive)
183 ("kconfigwidgets" ,kconfigwidgets)
184 ("kcmutils" ,kcmutils)
185 ("kiconthemes" ,kiconthemes)
186 ("kdeclarative" ,kdeclarative)
187 ("kdoctools" ,kdoctools)
188 ("kguiaddons" ,kguiaddons)
189 ("kinit" ,kinit)
190 ("kitemmodels" ,kitemmodels)
191 ("knewstuff" ,knewstuff)
192 ("knotifications" ,knotifications)
193 ("knotifyconfig" ,knotifyconfig)
194 ("kwindowsystem" ,kwindowsystem)
195 ("kio" ,kio)
196 ("ki18n" ,ki18n)
197 ("kparts" ,kparts)
198 ("kservice" ,kservice)
199 ("grantlee" ,grantlee)
200 ("libkomparediff2" ,libkomparediff2)
201 ("sonnet" ,sonnet)
202 ("threadweaver" ,threadweaver)
203 ("ktexteditor" ,ktexteditor)
204 ("qtbase" ,qtbase)
205 ("qtdeclarative" ,qtdeclarative)
206 ("qtscript" ,qtscript)
207 ("qtwebkit" ,qtwebkit)
208 ("qtx11extras" ,qtx11extras)
209 ("plasma" ,plasma-framework)
210 ("subversion" ,subversion)
211 ("zlib" ,zlib)))
212 (arguments
213 `(#:phases
214 (modify-phases %standard-phases
215 (delete 'check)
216 (add-after 'install 'check ;; add-after 'install
217 (lambda* (#:key outputs #:allow-other-keys)
218 (let ((out (assoc-ref outputs "out")))
219 (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
220 (setenv "QT_PLUGIN_PATH"
221 (string-append out "/lib/plugins:"
222 (getenv "QT_PLUGIN_PATH")))
223 (setenv "XDG_DATA_DIRS"
224 (string-append out "/share:"
225 (getenv "XDG_DATA_DIRS")))
226 (zero?
227 (system* "ctest" "-R" ;; almost all tests require a display
228 "filteringstrategy|kdevvarlengtharray|kdevhash"))))))))
229 (home-page "https://github.com/KDE/kdevplatform")
230 (synopsis "Framework to build integrated development environments (IDEs)")
231 (description "KDevPlatform is the basis of KDevelop and contains some
232 plugins, as well as code to create plugins, or complete applications.")
233 (license license:gpl3+)))
234
235 (define-public krita
236 (package
237 (name "krita")
238 (version "3.3.2.1")
239 (source (origin
240 (method url-fetch)
241 (uri (string-append
242 "mirror://kde/stable/krita/"
243 "3.3.2/" name "-" version ".tar.xz"))
244 (sha256
245 (base32
246 "0i3l27cfi1h486m74xf4ynk0pwx32xaqraa91a0g1bpj1jxf2mg5"))))
247 (build-system cmake-build-system)
248 (arguments
249 `(#:tests? #f
250 #:configure-flags
251 (list "-DBUILD_TESTING=OFF" "-DKDE4_BUILD_TESTS=OFF"
252 (string-append "-DWITH_FFTW3="
253 (assoc-ref %build-inputs "fftw"))
254 (string-append "-DWITH_GSL="
255 (assoc-ref %build-inputs "gsl"))
256 (string-append "-DWITH_LibRaw="
257 (assoc-ref %build-inputs "libraw"))
258 (string-append "-DWITH_TIFF="
259 (assoc-ref %build-inputs "libtiff"))
260 (string-append "-DCMAKE_CXX_FLAGS=-I"
261 (assoc-ref %build-inputs "ilmbase")
262 "/include/OpenEXR"))))
263 (native-inputs
264 `(("curl" ,curl)
265 ("eigen" ,eigen)
266 ("extra-cmake-modules" ,extra-cmake-modules)
267 ("gettext-minimal" ,gettext-minimal)
268 ("kitemmodels" ,kitemmodels)
269 ("qwt" ,qwt)
270 ("vc" ,vc)))
271 (inputs
272 `(("qtbase" ,qtbase)
273 ("qtdeclarative" ,qtdeclarative)
274 ("qtmultimedia" ,qtmultimedia)
275 ("qtx11extras" ,qtx11extras)
276 ("qtsvg" ,qtsvg)
277 ("karchive" ,karchive)
278 ("kcompletion" ,kcompletion)
279 ("kconfig" ,kconfig)
280 ("kcoreaddons" ,kcoreaddons)
281 ("kcrash" ,kcrash)
282 ("kguiaddons" ,kguiaddons)
283 ("ki18n" ,ki18n)
284 ("kiconthemes" ,kiconthemes)
285 ("kio" ,kio)
286 ("kitemviews" ,kitemviews)
287 ("kwidgetsaddons" ,kwidgetsaddons)
288 ("kwindowsystem" ,kwindowsystem)
289 ("kxmlgui" ,kxmlgui)
290 ("boost" ,boost)
291 ("exiv2" ,exiv2)
292 ("lcms" ,lcms)
293 ("libpng" ,libpng)
294 ("libjpeg-turbo" ,libjpeg-turbo)
295 ("zlib" ,zlib)
296 ("libx11" ,libx11)
297 ("libxcb" ,libxcb)
298 ("libxi" ,libxi)
299 ("fftw" ,fftw)
300 ("gsl" ,gsl)
301 ("poppler-qt5" ,poppler-qt5)
302 ("libraw" ,libraw)
303 ("libtiff" ,libtiff)
304 ("perl" ,perl)
305 ("ilmbase" ,ilmbase)
306 ("openexr" ,openexr)))
307 (home-page "https://krita.org")
308 (synopsis "Digital painting application")
309 (description
310 "Krita is a professional painting tool designed for concept artists,
311 illustrators, matte and texture artists, and the VFX industry. Notable
312 features include brush stabilizers, brush engines and wrap-around mode.")
313 (license license:gpl2+)))
314
315 (define-public libkomparediff2
316 (package
317 (name "libkomparediff2")
318 (version "16.08.2")
319 (source
320 (origin
321 (method url-fetch)
322 (uri (string-append "https://github.com/KDE/libkomparediff2/archive/v"
323 version ".tar.gz"))
324 (file-name (string-append name "-" version ".tar.gz"))
325 (sha256
326 (base32
327 "1lafifrwfxvn0jwhz67kwv7m38lm4syips3fq77rwcvfhmkiijmh"))))
328 (native-inputs
329 `(("extra-cmake-modules" ,extra-cmake-modules)
330 ("pkg-config" ,pkg-config)))
331 (inputs
332 `(("kcodecs" ,kcodecs)
333 ("kconfig" ,kconfig)
334 ("kcoreaddons" ,kcoreaddons)
335 ("ki18n" ,ki18n)
336 ("kio" ,kio)
337 ("kxmlgui" ,kxmlgui)
338 ("qtbase" ,qtbase)))
339 (build-system cmake-build-system)
340 (home-page "https://kde.org")
341 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
342 (description "Libkomparediff2 is a library to work with diffs and patches,
343 used in KDE development tools Kompare and KDevelop.")
344
345 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
346 ;; source archive
347 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
348
349 (define-public libksysguard
350 (package
351 (name "libksysguard")
352 (version "5.11.2")
353 (source
354 (origin
355 (method url-fetch)
356 (uri (string-append "mirror://kde//stable/plasma/" version
357 "/libksysguard-" version ".tar.xz"))
358 (sha256
359 (base32
360 "12d0r4rilydbqdgkm256khvkb9m0hya3p27xqvv3hg77wgxzdl3f"))))
361 (native-inputs
362 `(("extra-cmake-modules" ,extra-cmake-modules)
363 ("pkg-config" ,pkg-config)))
364 (inputs
365 `(("kconfigwidgets" ,kconfigwidgets)
366 ("kiconthemes" ,kiconthemes)
367 ("kwindowsystem" ,kwindowsystem)
368 ("ki18n" ,ki18n)
369 ("kauth" ,kauth)
370 ("kcompletion" ,kcompletion)
371 ("kconfig" ,kconfig)
372 ("kcoreaddons" ,kcoreaddons)
373 ("kwidgetsaddons" ,kwidgetsaddons)
374 ("kservice" ,kservice)
375 ("qtbase" ,qtbase)
376 ("qtscript" ,qtscript)
377 ("qtwebkit" ,qtwebkit)
378 ("qtx11extras" ,qtx11extras)
379 ("plasma" ,plasma-framework)
380 ("zlib" ,zlib)))
381 (build-system cmake-build-system)
382 (arguments
383 `(#:configure-flags
384 `(,(string-append "-DKDE_INSTALL_DATADIR="
385 (assoc-ref %outputs "out") "/share"))
386 #:phases
387 (modify-phases %standard-phases
388 (add-before 'configure 'patch-cmakelists
389 (lambda _
390 ;; TODO: Verify: This should no longer be necessary, since
391 ;; KF5AuthConfig.cmake.in contains this already.
392 (substitute* "processcore/CMakeLists.txt"
393 (("KAUTH_HELPER_INSTALL_DIR") "KDE_INSTALL_LIBEXECDIR"))))
394 (add-before 'check 'check-setup
395 (lambda _
396 ;; make Qt render "offscreen", required for tests
397 (setenv "QT_QPA_PLATFORM" "offscreen")))
398 (replace 'check
399 (lambda _
400 ;; TODO: Fix this failing test-case
401 (zero? (system* "ctest" "-E" "processtest")))))))
402 (home-page "https://www.kde.org/info/plasma-5.11.2.php")
403 (synopsis "Network enabled task and system monitoring")
404 (description "KSysGuard can obtain information on system load and
405 manage running processes. It obtains this information by interacting
406 with a ksysguardd daemon, which may also run on a remote system.")
407 (license license:gpl3+)))
408
409 (define-public qca
410 (package
411 (name "qca")
412 (version "2.1.3")
413 (source
414 (origin
415 (method url-fetch)
416 (uri (string-append "http://download.kde.org/stable/qca/" version
417 "/src/qca-" version ".tar.xz"))
418 (sha256
419 (base32
420 "0lz3n652z208daxypdcxiybl0a9fnn6ida0q7fh5f42269mdhgq0"))))
421 (build-system cmake-build-system)
422 (native-inputs
423 `(("pkg-config" ,pkg-config)))
424 (inputs
425 `(("openssl" ,openssl)
426 ("qtbase" ,qtbase)))
427 (home-page "https://userbase.kde.org/QCA")
428 (synopsis "Libraries for the Qt Cryptographic Architecture")
429 (description "The Qt Cryptographic Architecture (QCA) provides a
430 straightforward and cross-platform API for a range of cryptographic features,
431 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
432 cards.")
433 (license license:lgpl2.1)))
434
435 (define-public snorenotify
436 (package
437 (name "snorenotify")
438 (version "0.7.0")
439 (source
440 (origin
441 (method url-fetch)
442 (uri (string-append "http://download.kde.org/stable/snorenotify/"
443 version "/src/snorenotify-" version ".tar.xz"))
444 (sha256
445 (base32
446 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
447 (build-system cmake-build-system)
448 (arguments
449 `(#:tests? #f)) ; both tests fail, require display
450 (inputs
451 `(("extra-cmake-modules" ,extra-cmake-modules)
452 ("qtbase" ,qtbase)
453 ("qttools" ,qttools)))
454 (home-page "https://techbase.kde.org/Projects/Snorenotify")
455 (synopsis "Qt notification framework")
456 (description "Snorenotify is a multi platform Qt notification framework.
457 Using a plugin system it is possible to create notifications with many
458 different notification systems.")
459 (license license:lgpl3)))