gnu: ccid: Update to 1.4.32.
[jackhill/guix/guix.git] / gnu / packages / syndication.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages syndication)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix download)
23 #:use-module (guix packages)
24 #:use-module (guix build-system gnu)
25 #:use-module (guix build-system python)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages check)
28 #:use-module (gnu packages curl)
29 #:use-module (gnu packages documentation)
30 #:use-module (gnu packages gettext)
31 #:use-module (gnu packages ncurses)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages python-check)
34 #:use-module (gnu packages python-xyz)
35 #:use-module (gnu packages python-web)
36 #:use-module (gnu packages sqlite)
37 #:use-module (gnu packages web)
38 #:use-module (gnu packages xml))
39
40 (define-public newsboat
41 (package
42 (name "newsboat")
43 (version "2.13")
44 (source
45 (origin
46 (method url-fetch)
47 (uri (string-append "https://newsboat.org/releases/" version
48 "/newsboat-" version ".tar.xz"))
49 (sha256
50 (base32
51 "0pik1d98ydzqi6055vdbkjg5krwifbk2hy2f5jp5p1wcy2s16dn7"))))
52 (build-system gnu-build-system)
53 (native-inputs
54 `(("gettext" ,gettext-minimal)
55 ("pkg-config" ,pkg-config)
56 ;; For building documentation.
57 ("asciidoc" ,asciidoc)))
58 (inputs
59 `(("curl" ,curl)
60 ("json-c" ,json-c)
61 ("libxml2" ,libxml2)
62 ("ncurses" ,ncurses)
63 ("stfl" ,stfl)
64 ("sqlite" ,sqlite)))
65 (arguments
66 '(#:phases
67 (modify-phases %standard-phases
68 (delete 'configure) ; no configure script
69 (add-after 'build 'build-documentation
70 (lambda _
71 (invoke "make" "doc"))))
72 #:make-flags
73 (list (string-append "prefix=" (assoc-ref %outputs "out")))
74 #:test-target "test"))
75 (native-search-paths
76 ;; Newsboat respects CURL_CA_BUNDLE.
77 (package-native-search-paths curl))
78 (home-page "https://newsboat.org/")
79 (synopsis "Text-mode RSS and Atom feed reader with podcast support")
80 (description "Newsboat is a feed reader for @dfn{RSS} and @dfn{Atom}, XML
81 formats widely used to transmit, publish, and syndicate news or blog articles.
82 It's designed for use on text terminals, and to have a coherent and easy-to-use
83 interface that might look familiar to @command{mutt} or @command{slrn} users.
84
85 Newsboat supports OPML import/exports, HTML rendering, podcasts (with
86 @command{podboat}), off-line reading, searching and storing articles to your
87 file system, and many more features.")
88 (license (list license:gpl2+ ; filter/*
89 license:expat)))) ; everything else
90
91 (define-public rtv
92 (package
93 (name "rtv")
94 (version "1.27.0")
95 (source
96 (origin
97 (method url-fetch)
98 (uri (pypi-uri "rtv" version))
99 (sha256
100 (base32 "0hvw426y09l3yzwv2zkb9hifpfbg9wd1gg0y3z3pxcli6n3ii2wl"))))
101 (build-system python-build-system)
102 (arguments
103 '(#:phases
104 (modify-phases %standard-phases
105 (add-before 'check 'set-environment-variables
106 (lambda* (#:key inputs #:allow-other-keys)
107 (setenv "HOME" (getcwd))
108 (setenv "TERM" "linux")
109 (setenv "TERMINFO" (string-append (assoc-ref inputs "ncurses")
110 "/share/terminfo"))
111 #t)))
112 #:tests? #f)) ; tests fail: _curses.error: nocbreak() returned ERR
113 (propagated-inputs
114 `(("python-beautifulsoup4" ,python-beautifulsoup4)
115 ("python-decorator" ,python-decorator)
116 ("python-kitchen" ,python-kitchen)
117 ("python-requests" ,python-requests)
118 ("python-six" ,python-six)))
119 (native-inputs
120 `(("ncurses" ,ncurses)
121 ("python-coveralls" ,python-coveralls)
122 ("python-coverage" ,python-coverage)
123 ("python-mock" ,python-mock)
124 ("python-pylint" ,python-pylint)
125 ("python-pytest" ,python-pytest)
126 ("python-vcrpy" ,python-vcrpy)))
127 (home-page "https://github.com/michael-lazar/rtv")
128 (synopsis "Terminal viewer for Reddit (Reddit Terminal Viewer)")
129 (description
130 "RTV provides a text-based interface to view and interact with Reddit.")
131 (license (list license:expat
132 license:gpl3+)))) ; rtv/packages/praw
133
134 (define-public tuir
135 (package
136 (name "tuir")
137 (version "1.28.3")
138 (source
139 (origin
140 (method url-fetch)
141 (uri (pypi-uri "tuir" version))
142 (sha256
143 (base32
144 "1gpyjrl7jdfjq30m32nzh59ajv91gq19l93jjri2wsv5yrf90hdr"))))
145 (build-system python-build-system)
146 (arguments
147 `(#:phases
148 (modify-phases %standard-phases
149 (replace 'check
150 (lambda* (#:key inputs outputs #:allow-other-keys)
151 (add-installed-pythonpath inputs outputs)
152 (invoke "pytest"))))))
153 (inputs
154 `(("python-beautifulsoup4" ,python-beautifulsoup4)
155 ("python-decorator" ,python-decorator)
156 ("python-kitchen" ,python-kitchen)
157 ("python-requests" ,python-requests)
158 ("python-six" ,python-six)))
159 (native-inputs
160 `(("python-coverage" ,python-coverage)
161 ("python-coveralls" ,python-coveralls)
162 ("python-mock" ,python-mock)
163 ("python-pylint" ,python-pylint)
164 ("python-pytest" ,python-pytest)
165 ("python-vcrpy" ,python-vcrpy)))
166 (home-page "https://gitlab.com/ajak/tuir")
167 (synopsis "Terminal viewer for Reddit (Terminal UI for Reddit)")
168 (description
169 "Tuir provides a simple terminal viewer for Reddit (Terminal UI for Reddit).")
170 (license (list license:expat
171 license:gpl3+)))) ; tuir/packages/praw