gnu: deutex: Update to 5.2.1.
[jackhill/guix/guix.git] / gnu / packages / rsync.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages rsync)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages acl)
26 #:use-module (gnu packages base)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages popt)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix packages)
32 #:use-module (guix download)
33 #:use-module (guix git-download)
34 #:use-module (guix build-system cmake)
35 #:use-module (guix build-system gnu))
36
37
38 (define-public rsync
39 (package
40 (name "rsync")
41 (version "3.1.3")
42 (source (origin
43 (method url-fetch)
44 (uri (string-append "http://rsync.samba.org/ftp/rsync/src/rsync-"
45 version ".tar.gz"))
46 (sha256
47 (base32
48 "1h0011dj6jgqpgribir4anljjv7bbrdcs8g91pbsmzf5zr75bk2m"))))
49 (build-system gnu-build-system)
50 (inputs `(("perl" ,perl)
51 ("acl" ,acl)))
52 (synopsis "Remote (and local) file copying tool")
53 (description
54 "Rsync is a fast and versatile file copying tool. It can copy locally,
55 to/from another host over any remote shell, or to/from a remote rsync daemon.
56 Its delta-transfer algorithm reduces the amount of data sent over the network
57 by sending only the differences between the source files and the existing
58 files in the destination.")
59 (license license:gpl3+)
60 (home-page "http://rsync.samba.org/")))
61
62 (define-public librsync
63 (package
64 (name "librsync")
65 (version "2.2.1")
66 (source (origin
67 (method git-fetch)
68 (uri (git-reference
69 (url "https://github.com/librsync/librsync.git")
70 (commit (string-append "v" version))))
71 (file-name (git-file-name name version))
72 (sha256
73 (base32
74 "08wdlxsa9zg2pyasz1lwg70d5psi4amv81v4yxwffx67ndzb9yp5"))))
75 (build-system cmake-build-system)
76 (inputs
77 `(("popt" ,popt)))
78 (native-inputs
79 `(("which" ,which)
80 ("perl" ,perl)))
81 (home-page "http://librsync.sourceforge.net/")
82 (synopsis "Implementation of the rsync remote-delta algorithm")
83 (description
84 "Librsync is a free software library that implements the rsync
85 remote-delta algorithm. This algorithm allows efficient remote updates of a
86 file, without requiring the old and new versions to both be present at the
87 sending end. The library uses a \"streaming\" design similar to that of zlib
88 with the aim of allowing it to be embedded into many different applications.")
89 (license license:lgpl2.1+)))
90
91 (define-public librsync-0.9
92 (package
93 (inherit librsync)
94 (version "0.9.7")
95 (source (origin
96 (method url-fetch)
97 (uri (string-append "mirror://sourceforge/librsync/librsync/"
98 version "/librsync-" version ".tar.gz"))
99 (sha256
100 (base32
101 "1mj1pj99mgf1a59q9f2mxjli2fzxpnf55233pc1klxk2arhf8cv6"))))
102 (build-system gnu-build-system)
103 (arguments '(#:configure-flags '("--enable-shared")))
104 (inputs '())))