gnu: deutex: Update to 5.2.1.
[jackhill/guix/guix.git] / gnu / packages / gd.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
6 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
8 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages gd)
26 #:use-module (guix packages)
27 #:use-module (guix build-system gnu)
28 #:use-module (guix build-system perl)
29 #:use-module (guix download)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages perl)
32 #:use-module (gnu packages image)
33 #:use-module (gnu packages imagemagick)
34 #:use-module (gnu packages fontutils)
35 #:use-module (gnu packages compression)
36 #:use-module (gnu packages pkg-config)
37 #:use-module ((guix licenses) #:select (non-copyleft perl-license)))
38
39 (define-public gd
40 (package
41 (name "gd")
42 ;; Note: With libgd.org now pointing to github.com, genuine old
43 ;; tarballs are no longer available. Notably, versions 2.0.x are
44 ;; missing.
45 (version "2.2.5")
46 (source (origin
47 (method url-fetch)
48 (uri (string-append
49 "https://github.com/libgd/libgd/releases/download/gd-"
50 version "/libgd-" version ".tar.xz"))
51 (sha256
52 (base32
53 "0lfy5f241sbv8s3splm2zqiaxv7lxrcshh875xryryk7yk5jqc4c"))
54
55 (patches (search-patches "gd-CVE-2018-5711.patch"
56 "gd-CVE-2018-1000222.patch"
57 "gd-CVE-2019-6977.patch"
58 "gd-CVE-2019-6978.patch"
59 "gd-fix-tests-on-i686.patch"
60 "gd-freetype-test-failure.patch"))))
61 (build-system gnu-build-system)
62 (arguments
63 ;; As recommended by github.com/libgd/libgd/issues/278 to fix rounding
64 ;; issues on aarch64 and other architectures.
65 `(#:make-flags '("CFLAGS=-ffp-contract=off")
66 #:phases
67 (modify-phases %standard-phases
68 ;; This test is known to fail on i686-linux:
69 ;; https://github.com/libgd/libgd/issues/359
70 ;; TODO Replace this substitution with an upstream bug fix.
71 (add-after 'unpack 'disable-failing-test
72 (lambda _
73 (substitute* "tests/gdimagegrayscale/basic.c"
74 (("return gdNumFailures\\(\\)")
75 "return 0"))
76 #t)))))
77 (native-inputs
78 `(("pkg-config" ,pkg-config)))
79 (inputs
80 `(("freetype" ,freetype)
81 ("libpng" ,libpng)
82 ("zlib" ,zlib)))
83 (propagated-inputs
84 `(("fontconfig" ,fontconfig)
85 ("libjpeg" ,libjpeg)))
86 (home-page "http://www.libgd.org/")
87 (synopsis "Library for the dynamic creation of images by programmers")
88 (description
89 "GD is a library for the dynamic creation of images by programmers. GD
90 is written in C, and \"wrappers\" are available for Perl, PHP and other
91 languages. GD creates PNG, JPEG, GIF, WebP, XPM, BMP images, among other
92 formats. GD is commonly used to generate charts, graphics, thumbnails, and
93 most anything else, on the fly. While not restricted to use on the web, the
94 most common applications of GD involve website development.")
95 (license (non-copyleft "file://COPYING"
96 "See COPYING file in the distribution."))
97 (properties '((cpe-name . "libgd")))))
98
99 (define-public perl-gd
100 (package
101 (name "perl-gd")
102 (version "2.71")
103 (source
104 (origin
105 (method url-fetch)
106 (uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/"
107 "GD-" version ".tar.gz"))
108 (sha256
109 (base32 "1ivskdb4nwy7ky37369hwkfxp11fkp6ri5k7qlf2dmra7f3y86s5"))))
110 (build-system perl-build-system)
111 (inputs
112 `(("fontconfig" ,fontconfig)
113 ("freetype" ,freetype)
114 ("gd" ,gd)
115 ("libpng" ,libpng)
116 ("libjpeg" ,libjpeg)
117 ("zlib" ,zlib)))
118 (arguments
119 `(#:make-maker-flags
120 (list (string-append "--lib_jpeg_path="
121 (assoc-ref %build-inputs "libjpeg")))))
122 (home-page "https://metacpan.org/release/GD")
123 (synopsis "Perl interface to the GD graphics library")
124 (description "GD.pm is an autoloadable interface module for libgd, a
125 popular library for creating and manipulating PNG files. With this library
126 you can create PNG images on the fly or modify existing files.")
127 (license perl-license)))
128
129 (define-public perl-gd-securityimage
130 (package
131 (name "perl-gd-securityimage")
132 (version "1.75")
133 (source
134 (origin
135 (method url-fetch)
136 (uri (string-append "mirror://cpan/authors/id/B/BU/BURAK/"
137 "GD-SecurityImage-" version ".tar.gz"))
138 (sha256
139 (base32 "19lf1kzdavrkkx3f900jnpynr55d5kjd2sdmwpfir5dsmkcj9pix"))))
140 (build-system perl-build-system)
141 (arguments
142 '(#:phases
143 (modify-phases %standard-phases
144 (add-after 'unpack 'set-env
145 (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t)))))
146 (native-inputs
147 `(("perl-module-build" ,perl-module-build)))
148 (propagated-inputs
149 `(("perl-gd" ,perl-gd)
150 ("perl-image-magick" ,perl-image-magick)))
151 (home-page "https://metacpan.org/release/GD-SecurityImage")
152 (synopsis "Security image generator")
153 (description "This module provides a basic interface to create
154 security (captcha) images. The final output is the actual graphic data, the
155 mime type of the graphic, and the created random string. The module also has
156 some \"styles\" that are used to create the background (or foreground) of the
157 image.")
158 (license perl-license)))