gnu: deutex: Update to 5.2.1.
[jackhill/guix/guix.git] / gnu / packages / enlightenment.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
3 ;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
4 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2017 ng0 <ng0@n0.is>
6 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Timo Eisenmann <eisenmann@fn.de>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages enlightenment)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix utils)
29 #:use-module (guix build-system gnu)
30 #:use-module (guix build-system meson)
31 #:use-module (guix build-system python)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages algebra)
34 #:use-module (gnu packages avahi)
35 #:use-module (gnu packages bash)
36 #:use-module (gnu packages check)
37 #:use-module (gnu packages code)
38 #:use-module (gnu packages compression)
39 #:use-module (gnu packages curl)
40 #:use-module (gnu packages fontutils)
41 #:use-module (gnu packages freedesktop)
42 #:use-module (gnu packages fribidi)
43 #:use-module (gnu packages game-development)
44 #:use-module (gnu packages gettext)
45 #:use-module (gnu packages ghostscript)
46 #:use-module (gnu packages gl)
47 #:use-module (gnu packages glib)
48 #:use-module (gnu packages gnome)
49 #:use-module (gnu packages gstreamer)
50 #:use-module (gnu packages gtk)
51 #:use-module (gnu packages ibus)
52 #:use-module (gnu packages image)
53 #:use-module (gnu packages linux)
54 #:use-module (gnu packages llvm)
55 #:use-module (gnu packages lua)
56 #:use-module (gnu packages pdf)
57 #:use-module (gnu packages perl)
58 #:use-module (gnu packages photo)
59 #:use-module (gnu packages pkg-config)
60 #:use-module (gnu packages pulseaudio)
61 #:use-module (gnu packages python)
62 #:use-module (gnu packages python-xyz)
63 #:use-module (gnu packages tls)
64 #:use-module (gnu packages video)
65 #:use-module (gnu packages xdisorg)
66 #:use-module (gnu packages xorg)
67 #:use-module (ice-9 match))
68
69 (define-public efl
70 (package
71 (name "efl")
72 (version "1.23.3")
73 (source (origin
74 (method url-fetch)
75 (uri (string-append
76 "https://download.enlightenment.org/rel/libs/efl/efl-"
77 version ".tar.xz"))
78 (sha256
79 (base32
80 "00b9lp3h65254kdb1ys15fv7p3ln7qsvf15jkw4kli5ymagadkjk"))))
81 (build-system meson-build-system)
82 (native-inputs
83 `(("check" ,check)
84 ("gettext" ,gettext-minimal)
85 ("pkg-config" ,pkg-config)))
86 (inputs
87 `(("curl" ,curl)
88 ("giflib" ,giflib)
89 ("gstreamer" ,gstreamer)
90 ("gst-plugins-base" ,gst-plugins-base)
91 ("ibus" ,ibus)
92 ("mesa" ,mesa)
93 ("libraw" ,libraw)
94 ("librsvg" ,librsvg)
95 ("libspectre" ,libspectre)
96 ("libxau" ,libxau)
97 ("libxcomposite" ,libxcomposite)
98 ("libxcursor" ,libxcursor)
99 ("libxdamage" ,libxdamage)
100 ("libxdmcp" ,libxdmcp)
101 ("libxext" ,libxext)
102 ("libxi" ,libxi)
103 ("libxfixes" ,libxfixes)
104 ("libxinerama" ,libxinerama)
105 ("libxp" ,libxp)
106 ("libxrandr" ,libxrandr)
107 ("libxrender" ,libxrender)
108 ("libxss" ,libxscrnsaver)
109 ("libxtst" ,libxtst)
110 ("poppler" ,poppler)
111 ("wayland-protocols" ,wayland-protocols)))
112 (propagated-inputs
113 ;; All these inputs are in package config files in section
114 ;; Requires.private.
115 `(("avahi" ,avahi)
116 ("bullet" ,bullet)
117 ("dbus" ,dbus)
118 ("elogind" ,elogind)
119 ("eudev" ,eudev)
120 ("fontconfig" ,fontconfig)
121 ("freetype" ,freetype)
122 ("fribidi" ,fribidi)
123 ("glib" ,glib)
124 ("harfbuzz" ,harfbuzz)
125 ("luajit" ,luajit)
126 ("libinput" ,libinput-minimal)
127 ("libjpeg" ,libjpeg)
128 ("libpng" ,libpng)
129 ("libsndfile" ,libsndfile)
130 ("libtiff" ,libtiff)
131 ("libwebp" ,libwebp)
132 ("libx11" ,libx11)
133 ("libxkbcommon" ,libxkbcommon)
134 ("lz4" ,lz4)
135 ("openssl" ,openssl)
136 ("pulseaudio" ,pulseaudio)
137 ("util-linux" ,util-linux)
138 ("wayland" ,wayland)
139 ("zlib" ,zlib)))
140 (arguments
141 `(#:configure-flags '("-Dsystemd=false"
142 "-Dembedded-lz4=false"
143 "-Devas-loaders-disabler=json"
144 "-Dbuild-examples=false"
145 ;(string-append "-Ddictionaries-hyphen-dir="
146 ; (assoc-ref %build-inputs "hyphen")
147 ; "/share/hyphen")
148 "-Delogind=true"
149 "-Dnetwork-backend=connman"
150 ,@(match (%current-system)
151 ("armhf-linux"
152 '("-opengl=es-egl"))
153 (_
154 '("-Dopengl=full")))
155 ;; for wayland
156 "-Dwl-deprecated=true" ; ecore_wayland
157 "-Ddrm-deprecated=true" ; ecore_drm
158 "-Dwl=true"
159 "-Ddrm=true")
160 #:tests? #f ; Many tests fail due to timeouts and network requests.
161 #:phases
162 (modify-phases %standard-phases
163 ;; If we don't hardcode the location of libcurl.so then we
164 ;; have to wrap the outputs of efl's dependencies in curl.
165 (add-after 'unpack 'hardcode-libcurl-location
166 (lambda* (#:key inputs #:allow-other-keys)
167 (let* ((curl (assoc-ref inputs "curl"))
168 (lib (string-append curl "/lib/")))
169 (substitute* "src/lib/ecore_con/ecore_con_url_curl.c"
170 (("libcurl.so.?" libcurl) ; libcurl.so.[45]
171 (string-append lib libcurl)))
172 #t)))
173 (add-after 'unpack 'fix-install-paths
174 (lambda _
175 (substitute* "dbus-services/meson.build"
176 (("install_dir.*")
177 "install_dir: join_paths(dir_data, 'dbus-1', 'services'))\n"))
178 (substitute* "src/tests/elementary/meson.build"
179 (("dir_data") "meson.source_root(), 'test-output'"))
180 #t))
181 (add-after 'unpack 'set-home-directory
182 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
183 (lambda _ (setenv "HOME" "/tmp") #t)))))
184 (home-page "https://www.enlightenment.org/about-efl")
185 (synopsis "Enlightenment Foundation Libraries")
186 (description
187 "Enlightenment Foundation Libraries is a set of libraries developed
188 for Enlightenment. Libraries covers data serialization, wide support for
189 graphics rendering, UI layout and themes, interaction with OS, access to
190 removable devices or support for multimedia.")
191 ;; Different parts are under different licenses.
192 (license (list license:bsd-2 license:lgpl2.1 license:zlib))))
193
194 (define-public terminology
195 (package
196 (name "terminology")
197 (version "1.6.0")
198 (source (origin
199 (method url-fetch)
200 (uri
201 (string-append "https://download.enlightenment.org/rel/apps/"
202 "terminology/terminology-" version ".tar.xz"))
203 (sha256
204 (base32
205 "0xxx4xyhis6fy3frgb34ip0aj0kc4zashf60gzbxmq5gadbb0p5r"))
206 (modules '((guix build utils)))
207 ;; Remove the bundled fonts.
208 (snippet
209 '(begin
210 (delete-file-recursively "data/fonts")
211 (substitute* "data/meson.build"
212 (("subdir\\('fonts'\\)") ""))
213 #t))))
214 (build-system meson-build-system)
215 (arguments
216 `(#:configure-flags (list "-Dtests=true"
217 (string-append "-Dedje-cc="
218 (assoc-ref %build-inputs "efl")
219 "/bin/edje_cc"))
220 #:phases
221 (modify-phases %standard-phases
222 (add-after 'unpack 'set-home-directory
223 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
224 (lambda _ (setenv "HOME" "/tmp") #t))
225 (replace 'check
226 (lambda _
227 (with-directory-excursion
228 (string-append "../" ,name "-" ,version "/tests")
229 (invoke "sh" "run_tests.sh" "--verbose"
230 "-t" "../../build/src/bin/tytest"))))
231 (add-after 'install 'remove-test-binary
232 (lambda* (#:key outputs #:allow-other-keys)
233 ;; This file is not meant to be installed.
234 (delete-file (string-append (assoc-ref outputs "out")
235 "/bin/tytest"))
236 #t)))))
237 (native-inputs
238 `(("gettext" ,gettext-minimal)
239 ("perl" ,perl)
240 ("pkg-config" ,pkg-config)))
241 (inputs
242 `(("efl" ,efl)))
243 (home-page "https://www.enlightenment.org/about-terminology")
244 (synopsis "Powerful terminal emulator based on EFL")
245 (description
246 "Terminology is fast and feature rich terminal emulator. It is solely
247 based on Enlightenment Foundation Libraries. It supports multiple tabs, UTF-8,
248 URL and local path detection, themes, popup based content viewer for non-text
249 contents and more.")
250 (license license:bsd-2)))
251
252 (define-public rage
253 (package
254 (name "rage")
255 (version "0.3.1")
256 (source (origin
257 (method url-fetch)
258 (uri
259 (string-append
260 "https://download.enlightenment.org/rel/apps/rage/rage-"
261 version ".tar.xz"))
262 (sha256
263 (base32
264 "04fdk23bbgvni212zrfy4ndg7vmshbsjgicrhckdvhay87pk9i75"))))
265 (build-system meson-build-system)
266 (arguments
267 '(#:phases
268 (modify-phases %standard-phases
269 (add-after 'unpack 'set-home-directory
270 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
271 (lambda _ (setenv "HOME" "/tmp") #t)))))
272 (native-inputs
273 `(("pkg-config" ,pkg-config)))
274 (inputs
275 `(("efl" ,efl)))
276 (home-page "https://www.enlightenment.org/about-rage")
277 (synopsis "Video and audio player based on EFL")
278 (description
279 "Rage is a video and audio player written with Enlightenment Foundation
280 Libraries with some extra bells and whistles.")
281 (license license:bsd-2)))
282
283 (define-public enlightenment
284 (package
285 (name "enlightenment")
286 (version "0.23.1")
287 (source (origin
288 (method url-fetch)
289 (uri
290 (string-append "https://download.enlightenment.org/rel/apps/"
291 "enlightenment/enlightenment-" version ".tar.xz"))
292 (sha256
293 (base32
294 "0d1cyl07w9pvi2pf029kablazks2q9aislzl46b6fq5m1465jc75"))
295 (patches (search-patches "enlightenment-fix-setuid-path.patch"))))
296 (build-system meson-build-system)
297 (arguments
298 `(#:configure-flags '("-Dsystemd=false")
299 #:phases
300 (modify-phases %standard-phases
301 (delete 'bootstrap) ; We don't want to run the autogen script.
302 (add-after 'unpack 'fix-dot-desktop-creation
303 (lambda _
304 (substitute* "data/session/meson.build"
305 (("HAVE_WAYLAND'.*") "HAVE_WAYLAND') == true\n"))
306 #t))
307 (add-before 'configure 'set-system-actions
308 (lambda* (#:key inputs #:allow-other-keys)
309 (setenv "HOME" "/tmp")
310 (let ((xkeyboard (assoc-ref inputs "xkeyboard-config"))
311 (setxkbmap (assoc-ref inputs "setxkbmap"))
312 (utils (assoc-ref inputs "util-linux"))
313 (libc (assoc-ref inputs "libc"))
314 (bluez (assoc-ref inputs "bluez"))
315 (bc (assoc-ref inputs "bc"))
316 (efl (assoc-ref inputs "efl")))
317 ;; We need to patch the path to 'base.lst' to be able
318 ;; to switch the keyboard layout in E.
319 (substitute* (list "src/modules/xkbswitch/e_mod_parse.c"
320 "src/modules/wizard/page_011.c")
321 (("/usr/share/X11/xkb/rules/xorg.lst")
322 (string-append xkeyboard
323 "/share/X11/xkb/rules/base.lst")))
324 (substitute* "src/bin/e_xkb.c"
325 (("\"setxkbmap \"")
326 (string-append "\"" setxkbmap "/bin/setxkbmap \"")))
327 (substitute* (list "src/bin/e_intl.c"
328 "src/modules/conf_intl/e_int_config_intl.c"
329 "src/modules/wizard/page_010.c")
330 (("locale -a") (string-append libc "/bin/locale -a")))
331 (substitute* "src/bin/e_import_config_dialog.c"
332 (("%s/edje_cc -v %s %s %s\", e_prefix_bin_get\\(\\)")
333 (string-append efl "/bin/edje_cc -v %s %s %s\"")))
334 (substitute* "src/modules/everything/evry_plug_apps.c"
335 (("/usr/bin/") ""))
336 (substitute* "src/modules/everything/evry_plug_calc.c"
337 (("bc -l") (string-append bc "/bin/bc -l")))
338 (substitute* "data/etc/meson.build"
339 (("/bin/mount") (string-append utils "/bin/mount"))
340 (("/bin/umount") (string-append utils "/bin/umount"))
341 (("/usr/bin/eject") (string-append utils "/bin/eject"))
342 (("/usr/bin/l2ping") (string-append bluez "/bin/l2ling"))
343 (("/bin/rfkill") (string-append utils "/sbin/rfkill"))
344 (("SUSPEND = ''") "SUSPEND = '/run/current-system/profile/bin/loginctl suspend'")
345 (("HIBERNATE = ''") "HIBERNATE = '/run/current-system/profile/bin/loginctl hibernate'")
346 (("/sbin/shutdown -h now") "/run/current-system/profile/bin/loginctl poweroff now")
347 (("/sbin/shutdown -r now") "/run/current-system/profile/bin/loginctl reboot now"))
348 #t))))))
349 (native-inputs
350 `(("gettext" ,gettext-minimal)
351 ("pkg-config" ,pkg-config)
352 ("util-linux" ,util-linux)))
353 (inputs
354 `(("alsa-lib" ,alsa-lib)
355 ("bc" ,bc)
356 ("bluez" ,bluez)
357 ("dbus" ,dbus)
358 ("efl" ,efl)
359 ("freetype" ,freetype)
360 ("libxcb" ,libxcb)
361 ("libxext" ,libxext)
362 ("linux-pam" ,linux-pam)
363 ("puleseaudio" ,pulseaudio)
364 ("setxkbmap" ,setxkbmap)
365 ("xcb-util-keysyms" ,xcb-util-keysyms)
366 ("xkeyboard-config" ,xkeyboard-config)))
367 (home-page "https://www.enlightenment.org/about-enlightenment")
368 (synopsis "Lightweight desktop environment")
369 (description
370 "Enlightenment is resource friendly desktop environment with integrated
371 file manager, wide range of configuration options, plugin system allowing to
372 unload unused functionality, with support for touchscreen and suitable for
373 embedded systems.")
374 (license license:bsd-2)))
375
376 (define-public enlightenment-wayland
377 (package
378 (inherit enlightenment)
379 (name "enlightenment-wayland")
380 (arguments
381 (substitute-keyword-arguments (package-arguments enlightenment)
382 ((#:configure-flags flags)
383 `(cons* "-Dwl=true" ,flags))))
384 (inputs
385 `(("wayland-protocols" ,wayland-protocols)
386 ("xorg-server-xwayland" ,xorg-server-xwayland)
387 ,@(package-inputs enlightenment)))))
388
389 (define-public python-efl
390 (package
391 (name "python-efl")
392 (version "1.23.0")
393 (source
394 (origin
395 (method url-fetch)
396 (uri (string-append "https://download.enlightenment.org/rel/bindings/"
397 "python/python-efl-" version ".tar.xz"))
398 (sha256
399 (base32
400 "16yn6a1b9167nfmryyi44ma40m20ansfpwgrvqzfvwix7qaz9pib"))
401 (modules '((guix build utils)))
402 ;; Remove files generated by Cython
403 (snippet
404 '(begin
405 (copy-file "efl/dbus_mainloop/e_dbus.c" "efl/dbus_mainloop/e_dbus.q")
406 (for-each delete-file (find-files "efl" ".*\\.c$"))
407 (delete-file "efl/eo/efl.eo_api.h")
408 (copy-file "efl/dbus_mainloop/e_dbus.q" "efl/dbus_mainloop/e_dbus.c")
409 (delete-file "efl/dbus_mainloop/e_dbus.q")
410 #t))))
411 (build-system python-build-system)
412 (arguments
413 '(#:phases
414 (modify-phases %standard-phases
415 (replace 'build
416 (lambda _
417 (setenv "ENABLE_CYTHON" "1")
418 (invoke "python" "setup.py" "build")))
419 (add-before 'build 'set-flags
420 (lambda _
421 (setenv "CFLAGS"
422 (string-append "-I" (assoc-ref %build-inputs "python-dbus")
423 "/include/dbus-1.0"))
424 #t))
425 (add-before 'check 'set-environment
426 (lambda _
427 ;; Some tests require write access to HOME.
428 (setenv "HOME" "/tmp")
429 ;; These tests try to connect to the internet.
430 (delete-file "tests/ecore/test_09_file_download.py")
431 (delete-file "tests/ecore/test_11_con.py")
432 #t)))))
433 (native-inputs
434 `(("pkg-config" ,pkg-config)
435 ("python-cython" ,python-cython)))
436 (inputs
437 `(("efl" ,efl)
438 ("python-dbus" ,python-dbus)))
439 (home-page "https://www.enlightenment.org/")
440 (synopsis "Python bindings for EFL")
441 (description
442 "PYTHON-EFL are the python bindings for the whole Enlightenment Foundation
443 Libraries stack (eo, evas, ecore, edje, emotion, ethumb and elementary).")
444 (license license:lgpl3)))
445
446 (define-public python2-efl
447 (package-with-python2 python-efl))
448
449 (define-public edi
450 (package
451 (name "edi")
452 (version "0.6.0")
453 (source
454 (origin
455 (method url-fetch)
456 (uri (string-append "https://download.enlightenment.org/rel/apps/edi/"
457 name "-" version ".tar.xz"))
458 (sha256
459 (base32
460 "0iqkah327ms5m7k054hcik2l9v68i4mg9yy52brprfqpd5jk7pw8"))))
461 (build-system gnu-build-system)
462 (arguments
463 '(#:phases
464 (modify-phases %standard-phases
465 (add-after 'unpack 'set-home-directory
466 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
467 (lambda _ (setenv "HOME" "/tmp") #t)))
468 #:tests? #f)) ; tests require running dbus service
469 (native-inputs
470 `(("pkg-config" ,pkg-config)))
471 (inputs
472 `(("clang" ,clang)
473 ("efl" ,efl)))
474 (home-page "https://www.enlightenment.org/about-edi")
475 (synopsis "Development environment for Enlightenment")
476 (description "EDI is a development environment designed for and built using
477 the EFL. It's aim is to create a new, native development environment for Linux
478 that tries to lower the barrier to getting involved in Enlightenment development
479 and in creating applications based on the Enlightenment Foundation Library suite.")
480 (license (list license:public-domain ; data/extra/skeleton
481 license:gpl2)))) ; edi
482
483 (define-public lekha
484 (package
485 (name "lekha")
486 (version "0.2.1")
487 (source (origin
488 (method url-fetch)
489 (uri (pypi-uri "Lekha" version))
490 (sha256
491 (base32
492 "0zr6i74ik58pbzrd7r9l7sawqbdv0r2c1a9927qkqzwga27x8j15"))))
493 (build-system python-build-system)
494 (arguments
495 `(#:tests? #f ; no test target
496 #:python ,python-2
497 #:phases
498 (modify-phases %standard-phases
499 (add-after 'unpack 'fix-data-location
500 (lambda _ (substitute* "setup.py"
501 (("'/usr/")"'"))
502 #t)))))
503 (propagated-inputs
504 `(("python2-efl" ,python2-efl)
505 ("python2-pypdf2" ,python2-pypdf2)
506 ("python2-pyxdg" ,python2-pyxdg)))
507 (synopsis "Simple PDF viewer")
508 (description
509 "Simple PDF viewer based on the Enlightenment Foundation Libraries.")
510 (home-page "https://github.com/kaihu/lekha")
511 (license license:gpl3+)))
512
513 (define-public ephoto
514 (package
515 (name "ephoto")
516 (version "1.5")
517 (source
518 (origin
519 (method url-fetch)
520 (uri (list (string-append "http://www.smhouston.us/stuff/ephoto-"
521 version ".tar.xz")
522 (string-append "https://download.enlightenment.org/rel/"
523 "apps/ephoto/ephoto-" version ".tar.xz")))
524 (sha256
525 (base32
526 "1q7v9abjp9jrs08xc7pqaac64yzax24dk1snjb9rciarzzh3mlzy"))))
527 (build-system gnu-build-system)
528 (arguments
529 '(#:phases
530 (modify-phases %standard-phases
531 (add-after 'unpack 'set-home-directory
532 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
533 (lambda _ (setenv "HOME" "/tmp") #t)))))
534 (native-inputs
535 `(("check" ,check)
536 ("pkg-config" ,pkg-config)))
537 (inputs
538 `(("efl" ,efl)))
539 (home-page "http://smhouston.us/ephoto/")
540 (synopsis "EFL image viewer/editor/manipulator/slideshow creator")
541 (description "Ephoto is an image viewer and editor written using the
542 @dfn{Enlightenment Foundation Libraries} (EFL). It focuses on simplicity and
543 ease of use, while taking advantage of the speed and small footprint the EFL
544 provide.
545
546 Ephoto’s features include:
547 @enumerate
548 @item Browsing the file system and displaying images in an easy-to-use grid view.
549 @item Browsing images in a single image view format.
550 @item Viewing images in a slideshow.
551 @item Editing your image with features such as cropping, auto enhance,
552 blurring, sharpening, brightness/contrast/gamma adjustments, hue/saturation/value
553 adjustments, and color level adjustment.
554 @item Applying artistic filters to your image such as black and white and old
555 photo.
556 @item Drag And Drop along with file operations to easily maintain your photo
557 directories.
558 @end enumerate\n")
559 (license (list
560 license:bsd-2 ; Ephoto's thumbnailing code
561 license:bsd-3))))
562
563 (define-public evisum
564 (package
565 (name "evisum")
566 (version "0.2.6")
567 (source
568 (origin
569 (method url-fetch)
570 (uri (string-append "https://download.enlightenment.org/rel/apps/"
571 "evisum/evisum-" version ".tar.xz"))
572 (sha256
573 (base32
574 "1rg3kri6j8nmab0kdljnmcc096c8ibgwzvbhqr0b25xpmrq8bcac"))))
575 (build-system gnu-build-system)
576 (arguments
577 '(#:tests? #f ; no tests
578 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
579 #:phases
580 (modify-phases %standard-phases
581 (delete 'configure) ; no configure phase
582 (add-after 'unpack 'set-environmental-variables
583 (lambda _ (setenv "CC" (which "gcc")) #t)))))
584 (native-inputs
585 `(("pkg-config" ,pkg-config)))
586 (inputs
587 `(("alsa-lib" ,alsa-lib)
588 ("efl" ,efl)
589 ("perl" ,perl)))
590 (home-page "https://www.enlightenment.org")
591 (synopsis "EFL process viewer")
592 (description
593 "This is a process monitor and system monitor using the
594 @dfn{Enlightenment Foundation Libraries} (EFL).")
595 (license license:bsd-2)))