gnu: deutex: Update to 5.2.1.
[jackhill/guix/guix.git] / gnu / packages / backup.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
4 ;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
7 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
8 ;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
9 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
10 ;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
11 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
12 ;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
13 ;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
14 ;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
15 ;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
16 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
17 ;;;
18 ;;; This file is part of GNU Guix.
19 ;;;
20 ;;; GNU Guix is free software; you can redistribute it and/or modify it
21 ;;; under the terms of the GNU General Public License as published by
22 ;;; the Free Software Foundation; either version 3 of the License, or (at
23 ;;; your option) any later version.
24 ;;;
25 ;;; GNU Guix is distributed in the hope that it will be useful, but
26 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
27 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
28 ;;; GNU General Public License for more details.
29 ;;;
30 ;;; You should have received a copy of the GNU General Public License
31 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
32
33 (define-module (gnu packages backup)
34 #:use-module (guix packages)
35 #:use-module ((guix licenses) #:prefix license:)
36 #:use-module (guix git-download)
37 #:use-module (guix download)
38 #:use-module (guix utils)
39 #:use-module (guix build-system gnu)
40 #:use-module (guix build-system go)
41 #:use-module (guix build-system python)
42 #:use-module (gnu packages)
43 #:use-module (gnu packages acl)
44 #:use-module (gnu packages autotools)
45 #:use-module (gnu packages base)
46 #:use-module (gnu packages check)
47 #:use-module (gnu packages compression)
48 #:use-module (gnu packages crypto)
49 #:use-module (gnu packages databases)
50 #:use-module (gnu packages datastructures)
51 #:use-module (gnu packages dbm)
52 #:use-module (gnu packages dejagnu)
53 #:use-module (gnu packages ftp)
54 #:use-module (gnu packages glib)
55 #:use-module (gnu packages gnupg)
56 #:use-module (gnu packages golang)
57 #:use-module (gnu packages gperf)
58 #:use-module (gnu packages guile)
59 #:use-module (gnu packages linux)
60 #:use-module (gnu packages mcrypt)
61 #:use-module (gnu packages nettle)
62 #:use-module (gnu packages pcre)
63 #:use-module (gnu packages perl)
64 #:use-module (gnu packages pkg-config)
65 #:use-module (gnu packages python)
66 #:use-module (gnu packages python-crypto)
67 #:use-module (gnu packages python-web)
68 #:use-module (gnu packages python-xyz)
69 #:use-module (gnu packages rsync)
70 #:use-module (gnu packages ssh)
71 #:use-module (gnu packages tls)
72 #:use-module (gnu packages xml))
73
74 (define-public duplicity
75 (package
76 (name "duplicity")
77 (version "0.7.19")
78 (source
79 (origin
80 (method url-fetch)
81 (uri (string-append "https://code.launchpad.net/duplicity/"
82 (version-major+minor version)
83 "-series/" version "/+download/duplicity-"
84 version ".tar.gz"))
85 (sha256
86 (base32 "0ag9dknslxlasslwfjhqgcqbkb1mvzzx93ry7lch2lfzcdd91am6"))))
87 (build-system python-build-system)
88 (native-inputs
89 `(("util-linux" ,util-linux) ; setsid command, for the tests
90 ("par2cmdline" ,par2cmdline)
91 ("python-pexpect" ,python2-pexpect)
92 ("python-fasteners" ,python2-fasteners)
93 ("mock" ,python2-mock)))
94 (propagated-inputs
95 `(("lockfile" ,python2-lockfile)
96 ("urllib3" ,python2-urllib3)))
97 (inputs
98 `(("librsync" ,librsync-0.9)
99 ("lftp" ,lftp)
100 ("gnupg" ,gnupg) ; gpg executable needed
101 ("util-linux" ,util-linux) ; for setsid
102 ("tzdata" ,tzdata)))
103 (arguments
104 `(#:python ,python-2 ; setup assumes Python 2
105 #:test-target "test"
106 #:phases
107 (modify-phases %standard-phases
108 (add-before 'build 'use-store-file-names
109 (lambda* (#:key inputs #:allow-other-keys)
110 (substitute* "duplicity/gpginterface.py"
111 (("self.call = 'gpg'")
112 (string-append "self.call = '" (assoc-ref inputs "gnupg") "/bin/gpg'")))
113
114 (substitute* '("testing/functional/__init__.py"
115 "testing/overrides/bin/lftp")
116 (("/bin/sh") (which "sh")))
117 #t))
118 (add-before 'check 'check-setup
119 (lambda* (#:key inputs #:allow-other-keys)
120 (setenv "HOME" (getcwd)) ; gpg needs to write to $HOME
121 (setenv "TZDIR" ; some timestamp checks need TZDIR
122 (string-append (assoc-ref inputs "tzdata")
123 "/share/zoneinfo"))
124 #t)))))
125 (home-page "http://duplicity.nongnu.org/index.html")
126 (synopsis "Encrypted backup using rsync algorithm")
127 (description
128 "Duplicity backs up directories by producing encrypted tar-format volumes
129 and uploading them to a remote or local file server. Because duplicity uses
130 librsync, the incremental archives are space efficient and only record the
131 parts of files that have changed since the last backup. Because duplicity
132 uses GnuPG to encrypt and/or sign these archives, they will be safe from
133 spying and/or modification by the server.")
134 (license license:gpl2+)))
135
136 (define-public par2cmdline
137 (package
138 (name "par2cmdline")
139 (version "0.8.0")
140 (source (origin
141 (method git-fetch)
142 (uri (git-reference
143 (url "https://github.com/Parchive/par2cmdline.git")
144 (commit (string-append "v" version))))
145 (file-name (git-file-name name version))
146 (sha256
147 (base32
148 "0f1jsd5sw2wynjzi7yjqjaf13yhyjfdid91p8yh0jn32y03kjyrz"))))
149 (native-inputs
150 `(("automake" ,automake)
151 ("autoconf" ,autoconf)))
152 (build-system gnu-build-system)
153 (synopsis "File verification and repair tools")
154 (description "Par2cmdline uses Reed-Solomon error-correcting codes to
155 generate and verify PAR2 recovery files. These files can be distributed
156 alongside the source files or stored together with back-ups to protect against
157 transmission errors or @dfn{bit rot}, the degradation of storage media over
158 time.
159 Unlike a simple checksum, PAR2 doesn't merely detect errors: as long as the
160 damage isn't too extensive (and smaller than the size of the recovery file), it
161 can even repair them.")
162 (home-page "https://github.com/Parchive/par2cmdline")
163 (license license:gpl3+)))
164
165 (define-public hdup
166 (package
167 (name "hdup")
168 (version "2.0.14")
169 (source
170 (origin
171 (method url-fetch)
172 (uri "https://fossies.org/linux/privat/old/hdup-2.0.14.tar.bz2")
173 (sha256
174 (base32
175 "02bnczg01cyhajmm4rhbnc0ja0dd9ikv9fwv28asxh1rlx9yr0b7"))))
176 (build-system gnu-build-system)
177 (native-inputs `(("pkg-config" ,pkg-config)))
178 (inputs
179 `(("glib" ,glib)
180 ("tar" ,tar)
181 ("lzop" ,lzop)
182 ("mcrypt" ,mcrypt)
183 ("openssh" ,openssh)
184 ("gnupg" ,gnupg-1)))
185 (arguments
186 `(#:configure-flags
187 `(,(string-append "--sbindir=" (assoc-ref %outputs "out") "/bin"))
188 #:tests? #f))
189 (home-page (string-append "http://web.archive.org/web/20150925223424/"
190 "http://archive.miek.nl/projects/hdup/index.html"))
191 (synopsis "Simple incremental backup tool")
192 (description
193 "Hdup2 is a backup utility, its aim is to make backup really simple. The
194 backup scheduling is done by means of a cron job. It supports an
195 include/exclude mechanism, remote backups, encrypted backups and split
196 backups (called chunks) to allow easy burning to CD/DVD.")
197 (license license:gpl2)))
198
199 (define-public libarchive
200 (package
201 (name "libarchive")
202 (version "3.4.0")
203 (source
204 (origin
205 (method url-fetch)
206 (uri (list (string-append "https://libarchive.org/downloads/libarchive-"
207 version ".tar.gz")
208 (string-append "https://github.com/libarchive/libarchive"
209 "/releases/download/v" version "/libarchive-"
210 version ".tar.gz")))
211 (sha256
212 (base32
213 "0pl25mmz1b1cnwf35kxmygyy9g7z7hslxbx329a9yx8csh7dahw6"))))
214 (build-system gnu-build-system)
215 (inputs
216 `(("bzip2" ,bzip2)
217 ("libxml2" ,libxml2)
218 ("lzo" ,lzo)
219 ("nettle" ,nettle)
220 ("xz" ,xz)
221 ("zlib" ,zlib)
222 ("zstd" ,zstd "lib")))
223 (arguments
224 `(#:configure-flags '("--disable-static")
225 #:phases
226 (modify-phases %standard-phases
227 (add-before 'build 'patch-pwd
228 (lambda _
229 (substitute* "Makefile"
230 (("/bin/pwd") (which "pwd")))
231 #t))
232 (replace 'check
233 (lambda _
234 ;; XXX: The test_owner_parse, test_read_disk, and
235 ;; test_write_disk_lookup tests expect user 'root' to exist, but
236 ;; the chroot's /etc/passwd doesn't have it. Turn off those tests.
237 ;;
238 ;; XXX: Adjust test that fails with zstd 1.4.1 because the default
239 ;; options compresses two bytes better than this test expects.
240 ;; https://github.com/libarchive/libarchive/issues/1226
241 (substitute* "libarchive/test/test_write_filter_zstd.c"
242 (("compression-level\", \"6\"")
243 "compression-level\", \"7\""))
244
245 ;; The tests allow one to disable tests matching a globbing pattern.
246 (invoke "make" "libarchive_test" "bsdcpio_test" "bsdtar_test")
247 ;; XXX: This glob disables too much.
248 (invoke "./libarchive_test" "^test_*_disk*")
249 (invoke "./bsdcpio_test" "^test_owner_parse")
250 (invoke "./bsdtar_test")))
251 (add-after 'install 'add--L-in-libarchive-pc
252 (lambda* (#:key inputs outputs #:allow-other-keys)
253 (let* ((out (assoc-ref outputs "out"))
254 (lib (string-append out "/lib"))
255 (nettle (assoc-ref inputs "nettle"))
256 (libxml2 (assoc-ref inputs "libxml2"))
257 (xz (assoc-ref inputs "xz"))
258 (zlib (assoc-ref inputs "zlib"))
259 (zstd (assoc-ref inputs "zstd"))
260 (bzip2 (assoc-ref inputs "bzip2")))
261 ;; Embed absolute references to these inputs to avoid propagation.
262 (substitute* (list (string-append lib "/pkgconfig/libarchive.pc")
263 (string-append lib "/libarchive.la"))
264 (("-lnettle")
265 (string-append "-L" nettle "/lib -lnettle"))
266 (("-lxml2")
267 (string-append "-L" libxml2 "/lib -lxml2"))
268 (("-llzma")
269 (string-append "-L" xz "/lib -llzma"))
270 (("-lz")
271 (string-append "-L" zlib "/lib -lz"))
272 (("-lzstd")
273 (string-append "-L" zstd "/lib -lzstd"))
274 (("-lbz2")
275 (string-append "-L" bzip2 "/lib -lbz2")))
276 #t))))))
277 (home-page "https://libarchive.org/")
278 (synopsis "Multi-format archive and compression library")
279 (description
280 "Libarchive provides a flexible interface for reading and writing
281 archives in various formats such as tar and cpio. Libarchive also supports
282 reading and writing archives compressed using various compression filters such
283 as gzip and bzip2. The library is inherently stream-oriented; readers
284 serially iterate through the archive, writers serially add things to the
285 archive. In particular, note that there is currently no built-in support for
286 random access nor for in-place modification.")
287 (license license:bsd-2)))
288
289 (define-public rdup
290 (package
291 (name "rdup")
292 (version "1.1.15")
293 (source
294 (origin
295 (method git-fetch)
296 (uri (git-reference
297 (url "https://github.com/miekg/rdup.git")
298 (commit version)))
299 (file-name (git-file-name name version))
300 (sha256
301 (base32 "0bzyv6qmnivxnv9nw7lnfn46k0m1dlxcjj53zcva6v8y8084l1iw"))))
302 (build-system gnu-build-system)
303 (native-inputs
304 `(("autoconf" ,autoconf)
305 ("automake" ,automake)
306 ("pkg-config" ,pkg-config)
307
308 ;; For tests.
309 ("dejagnu" ,dejagnu)))
310 (inputs
311 ;; XXX Compiling with nettle (encryption) support requires patching out
312 ;; -Werror from GNUmakefile.in. Then, rdup-tr-{en,de}crypt tests fail:
313 ;; free(): invalid pointer
314 ;; ** rdup-tr: SIGPIPE received, exiting
315 `(("glib" ,glib)
316 ("pcre" ,pcre)
317 ("libarchive" ,libarchive)
318 ("mcrypt" ,mcrypt)))
319 (arguments
320 `(#:parallel-build? #f ;race conditions
321 #:phases
322 (modify-phases %standard-phases
323 (add-before 'build 'qualify-inputs
324 (lambda* (#:key inputs #:allow-other-keys)
325 ;; This script is full of pitfalls. Fix some that particularly
326 ;; affect Guix users & leave the rest as reader excercises.
327 (substitute* "rdup-simple"
328 ;; Use the input ‘mcrypt’, not whatever's in $PATH at run time.
329 (("([' ])mcrypt " all delimiter)
330 (string-append delimiter (which "mcrypt") " "))
331 ;; Avoid frivolous dependency on ‘which’ with a shell builtin.
332 (("which") "command -v"))
333 #t))
334 (add-before 'check 'disable-encryption-tests
335 (lambda _
336 (for-each delete-file
337 (list "testsuite/rdup/rdup.rdup-tr-crypt.exp"
338 "testsuite/rdup/rdup.rdup-tr-decrypt.exp"
339 "testsuite/rdup/rdup.rdup-tr-encrypt.exp"))
340 #t))
341 (add-before 'check 'pre-check
342 (lambda _
343 (setenv "HOME" (getcwd))
344 (substitute* "testsuite/rdup/rdup.rdup-up-t-with-file.exp"
345 (("/bin/cat") (which "cat")))
346 #t)))))
347 (home-page "https://github.com/miekg/rdup")
348 (synopsis "Provide a list of files to backup")
349 (description
350 "Rdup is a utility inspired by rsync and the plan9 way of doing backups.
351 Rdup itself does not backup anything, it only print a list of absolute
352 file names to standard output. Auxiliary scripts are needed that act on this
353 list and implement the backup strategy.")
354 (license license:gpl3+)))
355
356 (define-public btar
357 (package
358 (name "btar")
359 (version "1.1.1")
360 (source
361 (origin
362 (method url-fetch)
363 (uri (string-append "http://vicerveza.homeunix.net/~viric/soft/btar/"
364 "btar-" version ".tar.gz"))
365 (sha256
366 (base32
367 "0miklk4bqblpyzh1bni4x6lqn88fa8fjn15x1k1n8bxkx60nlymd"))))
368 (build-system gnu-build-system)
369 (inputs
370 `(("librsync" ,librsync-0.9)))
371 (arguments
372 `(#:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out"))
373 "CC=gcc")
374 #:tests? #f ;test input not distributed
375 #:phases
376 ;; no configure phase
377 (modify-phases %standard-phases
378 (delete 'configure))))
379 (home-page "http://viric.name/cgi-bin/btar/doc/trunk/doc/home.wiki")
380 (synopsis "Tar-compatible archiver")
381 (description
382 "Btar is a tar-compatible archiver which allows arbitrary compression and
383 ciphering, redundancy, differential backup, indexed extraction, multicore
384 compression, input and output serialisation, and tolerance to partial archive
385 errors.")
386 (license license:gpl3+)))
387
388 (define-public rdiff-backup
389 (package
390 (name "rdiff-backup")
391 (version "1.2.8")
392 (source
393 (origin
394 (method url-fetch)
395 (uri (string-append "mirror://savannah/rdiff-backup/rdiff-backup-"
396 version ".tar.gz"))
397 (sha256
398 (base32
399 "1nwmmh816f96h0ff1jxk95ad38ilbhbdl5dgibx1d4cl81dsi48d"))))
400 (build-system python-build-system)
401 (inputs
402 `(("python" ,python-2)
403 ("librsync" ,librsync-0.9)))
404 (arguments
405 `(#:python ,python-2
406 #:tests? #f))
407 (home-page "https://www.nongnu.org/rdiff-backup/")
408 (synopsis "Local/remote mirroring+incremental backup")
409 (description
410 "Rdiff-backup backs up one directory to another, possibly over a network.
411 The target directory ends up a copy of the source directory, but extra reverse
412 diffs are stored in a special subdirectory of that target directory, so you
413 can still recover files lost some time ago. The idea is to combine the best
414 features of a mirror and an incremental backup. Rdiff-backup also preserves
415 subdirectories, hard links, dev files, permissions, uid/gid ownership,
416 modification times, extended attributes, acls, and resource forks. Also,
417 rdiff-backup can operate in a bandwidth efficient manner over a pipe, like
418 rsync. Thus you can use rdiff-backup and ssh to securely back a hard drive up
419 to a remote location, and only the differences will be transmitted. Finally,
420 rdiff-backup is easy to use and settings have sensible defaults.")
421 (license license:gpl2+)))
422
423 (define-public rsnapshot
424 (package
425 (name "rsnapshot")
426 (version "1.4.2")
427 (source
428 (origin
429 (method url-fetch)
430 (uri (string-append
431 "https://github.com/rsnapshot/rsnapshot/releases/download/"
432 version "/rsnapshot-" version ".tar.gz"))
433 (sha256
434 (base32
435 "05jfy99a0xs6lvsjfp3wz21z0myqhmwl2grn3jr9clijbg282ah4"))))
436 (build-system gnu-build-system)
437 (arguments
438 `(#:phases
439 (modify-phases %standard-phases
440 (replace 'check
441 (lambda _
442 (substitute* '("t/cmd-post_pre-exec/conf/pre-true-post-true.conf"
443 "t/backup_exec/conf/backup_exec_fail.conf"
444 "t/backup_exec/conf/backup_exec.conf")
445 (("/bin/true") (which "true"))
446 (("/bin/false") (which "false")))
447 (invoke "make" "test"))))))
448 (inputs
449 `(("perl" ,perl)
450 ("rsync" ,rsync)))
451 (home-page "http://rsnapshot.org")
452 (synopsis "Deduplicating snapshot backup utility based on rsync")
453 (description "rsnapshot is a file system snapshot utility based on rsync.
454 rsnapshot makes it easy to make periodic snapshots of local machines, and
455 remote machines over SSH. To reduce the disk space required for each backup,
456 rsnapshot uses hard links to deduplicate identical files.")
457 (license license:gpl2+)))
458
459 (define-public libchop
460 (package
461 (name "libchop")
462 (version "0.5.2")
463 (source (origin
464 (method url-fetch)
465 (uri (string-append "mirror://savannah/libchop/libchop-"
466 version ".tar.gz"))
467 (sha256
468 (base32
469 "0fpdyxww41ba52d98blvnf543xvirq1v9xz1i3x1gm9lzlzpmc2g"))
470 (patches (search-patches "diffutils-gets-undeclared.patch"))))
471 (build-system gnu-build-system)
472 (arguments
473 '(#:phases (modify-phases %standard-phases
474 (add-before 'configure 'adjust-configure-script
475 (lambda _
476 ;; Mimic upstream commit
477 ;; 25750ab5ef82fd3cfce5205d5f1ef07b47098091.
478 (substitute* "configure"
479 (("GUILE=(.*)--variable bindir`" _ middle)
480 (string-append "GUILE=" middle
481 "--variable bindir`/guile")))
482 #t))
483 (add-before 'check 'skip-test
484 (lambda _
485 ;; XXX: This test fails (1) because current GnuTLS no
486 ;; longer supports OpenPGP authentication, and (2) for
487 ;; some obscure reason. Better skip it.
488 (setenv "XFAIL_TESTS" "utils/block-server")
489 #t)))))
490 (native-inputs
491 `(("guile" ,guile-2.0)
492 ("gperf" ,gperf-3.0) ;see <https://bugs.gnu.org/32382>
493 ("pkg-config" ,pkg-config)))
494 (inputs
495 `(("guile" ,guile-2.0)
496 ("util-linux" ,util-linux)
497 ("gnutls" ,gnutls)
498 ("tdb" ,tdb)
499 ("bdb" ,bdb)
500 ("gdbm" ,gdbm)
501 ("libgcrypt" ,libgcrypt)
502 ("lzo" ,lzo)
503 ("bzip2" ,bzip2)
504 ("zlib" ,zlib)))
505 (home-page "https://nongnu.org/libchop/")
506 (synopsis "Tools & library for data backup and distributed storage")
507 (description
508 "Libchop is a set of utilities and library for data backup and
509 distributed storage. Its main application is @command{chop-backup}, an
510 encrypted backup program that supports data integrity checks, versioning,
511 distribution among several sites, selective sharing of stored data, adaptive
512 compression, and more. The library itself implements storage techniques such
513 as content-addressable storage, content hash keys, Merkle trees, similarity
514 detection, and lossless compression.")
515 (license license:gpl3+)))
516
517 (define-public borg
518 (package
519 (name "borg")
520 (version "1.1.10")
521 (source
522 (origin
523 (method url-fetch)
524 (uri (pypi-uri "borgbackup" version))
525 (sha256
526 (base32 "1pp70p4n5kamvcbl4d8021ggrxhyykmg9isjg4yd3wags8b19d7g"))
527 (modules '((guix build utils)))
528 (snippet
529 '(begin
530 ;; Delete files generated by Cython. We used to have a regex
531 ;; that created the list of generated files but Borg has
532 ;; added new non-generated C files that cause the regex to
533 ;; generate the wrong list.
534 (for-each delete-file
535 '("src/borg/algorithms/checksums.c"
536 "src/borg/chunker.c"
537 "src/borg/compress.c"
538 "src/borg/crypto/low_level.c"
539 "src/borg/hashindex.c"
540 "src/borg/item.c"
541 "src/borg/platform/darwin.c"
542 "src/borg/platform/freebsd.c"
543 "src/borg/platform/linux.c"
544 "src/borg/platform/posix.c"))
545 ;; Remove bundled shared libraries.
546 (with-directory-excursion "src/borg/algorithms"
547 (for-each delete-file-recursively
548 (list "blake2" "lz4" "msgpack" "zstd")))
549 ;; Purge some msgpack references from setup.py or the resulting
550 ;; sources will be unbuildable.
551 (substitute* "setup.py"
552 ((".*Extension\\('borg\\.algorithms\\.msgpack\\..*") "")
553 (("msgpack_packer_source, msgpack_unpacker_source") ""))
554 #t))))
555 (build-system python-build-system)
556 (arguments
557 `(#:modules ((srfi srfi-26) ; for cut
558 (guix build utils)
559 (guix build python-build-system))
560 #:phases
561 (modify-phases %standard-phases
562 (add-after 'unpack 'set-env
563 (lambda* (#:key inputs #:allow-other-keys)
564 (let ((openssl (assoc-ref inputs "openssl"))
565 (libb2 (assoc-ref inputs "libb2"))
566 (lz4 (assoc-ref inputs "lz4"))
567 (zstd (assoc-ref inputs "zstd")))
568 (setenv "BORG_OPENSSL_PREFIX" openssl)
569 (setenv "BORG_LIBB2_PREFIX" libb2)
570 (setenv "BORG_LIBLZ4_PREFIX" lz4)
571 (setenv "BORG_LIBZSTD_PREFIX" zstd)
572 (setenv "PYTHON_EGG_CACHE" "/tmp")
573 ;; The test 'test_return_codes[python]' fails when
574 ;; HOME=/homeless-shelter.
575 (setenv "HOME" "/tmp")
576 #t)))
577 (add-after 'unpack 'use-system-msgpack
578 (lambda _
579 (substitute* "src/borg/helpers.py"
580 (("prefer_system_msgpack = False")
581 "prefer_system_msgpack = True"))
582 #t))
583 ;; The tests need to be run after Borg is installed.
584 (delete 'check)
585 (add-after 'install 'check
586 (lambda* (#:key inputs outputs #:allow-other-keys)
587 ;; Make the installed package available for the test suite.
588 (add-installed-pythonpath inputs outputs)
589 ;; The tests should be run in an empty directory.
590 (mkdir-p "tests")
591 (with-directory-excursion "tests"
592 (invoke "py.test" "-v" "--pyargs" "borg.testsuite" "-k"
593 (string-append
594 ;; These tests need to write to '/var'.
595 "not test_get_cache_dir "
596 "and not test_get_config_dir "
597 "and not test_get_keys_dir "
598 "and not test_get_security_dir "
599 ;; These tests assume there is a root user in
600 ;; '/etc/passwd'.
601 "and not test_access_acl "
602 "and not test_default_acl "
603 "and not test_non_ascii_acl "
604 ;; This test needs the unpackaged pytest-benchmark.
605 "and not benchmark "
606 ;; These tests assume the kernel supports FUSE.
607 "and not test_fuse "
608 "and not test_fuse_allow_damaged_files "
609 "and not test_mount_hardlinks")))))
610 (add-after 'install 'install-doc
611 (lambda* (#:key inputs outputs #:allow-other-keys)
612 (let* ((out (assoc-ref outputs "out"))
613 (man (string-append out "/share/man/man1"))
614 (misc (string-append out "/share/borg/misc")))
615 (for-each (cut install-file <> misc)
616 '("docs/misc/create_chunker-params.txt"
617 "docs/misc/internals-picture.txt"
618 "docs/misc/prune-example.txt"))
619 (copy-recursively "docs/man" man)
620 #t))))))
621 (native-inputs
622 `(("python-cython" ,python-cython)
623 ("python-setuptools-scm" ,python-setuptools-scm)
624 ("python-pytest" ,python-pytest)))
625 (inputs
626 `(("acl" ,acl)
627 ("libb2" ,libb2)
628 ("lz4" ,lz4)
629 ("openssl" ,openssl)
630 ("python-llfuse" ,python-llfuse)
631 ;; The Python msgpack library changed its name so Borg requires this
632 ;; transitional package for now:
633 ;; <https://bugs.gnu.org/30662>
634 ("python-msgpack" ,python-msgpack-transitional)
635 ("zstd" ,zstd "lib")))
636 (synopsis "Deduplicated, encrypted, authenticated and compressed backups")
637 (description "Borg is a deduplicating backup program. Optionally, it
638 supports compression and authenticated encryption. The main goal of Borg is to
639 provide an efficient and secure way to backup data. The data deduplication
640 technique used makes Borg suitable for daily backups since only changes are
641 stored. The authenticated encryption technique makes it suitable for backups
642 to not fully trusted targets. Borg is a fork of Attic.")
643 (home-page "https://www.borgbackup.org/")
644 (license license:bsd-3)))
645
646 (define-public attic
647 (package
648 (name "attic")
649 (version "0.16")
650 (source (origin
651 (method url-fetch)
652 (uri (pypi-uri "Attic" version))
653 (sha256
654 (base32
655 "0b5skd36r4c0915lwpkqg5hxm49gls9pprs1b7hc40910wlcsl36"))))
656 (build-system python-build-system)
657 (arguments
658 `(;; The tests assume they are run as root:
659 ;; https://github.com/jborg/attic/issues/7
660 #:tests? #f
661 #:phases
662 (modify-phases %standard-phases
663 (add-before
664 'build 'set-openssl-prefix
665 (lambda* (#:key inputs #:allow-other-keys)
666 (setenv "ATTIC_OPENSSL_PREFIX" (assoc-ref inputs "openssl"))
667 #t)))))
668 (inputs
669 `(("acl" ,acl)
670 ("openssl" ,openssl)
671 ("python-msgpack" ,python-msgpack)
672
673 ;; Attic is probably incompatible with llfuse > 0.41.
674 ;; These links are to discussions of llfuse compatibility from
675 ;; the borg project. Borg is a recent fork of attic, and attic
676 ;; has not been updated since the fork, so it's likely that
677 ;; llfuse compatibility requirements are still the same.
678 ;; https://github.com/borgbackup/borg/issues/642
679 ;; https://github.com/borgbackup/borg/issues/643
680 ("python-llfuse" ,python-llfuse-0.41)))
681 (synopsis "Deduplicating backup program")
682 (description "Attic is a deduplicating backup program. The main goal of
683 Attic is to provide an efficient and secure way to backup data. The data
684 deduplication technique used makes Attic suitable for daily backups since only
685 changes are stored.")
686 (home-page "https://attic-backup.org/")
687 (license license:bsd-3)
688 (properties `((superseded . ,borg)))))
689
690 (define-public wimlib
691 (package
692 (name "wimlib")
693 (version "1.13.1")
694 (source (origin
695 (method url-fetch)
696 (uri (string-append "https://wimlib.net/downloads/"
697 "wimlib-" version ".tar.gz"))
698 (sha256
699 (base32
700 "0pxgrpr3dr81rcf2jh71aiiq3v4anc5sj1nld18f2vhvbijbrx27"))))
701 (build-system gnu-build-system)
702 (native-inputs
703 `(("pkg-config" ,pkg-config)))
704 (inputs
705 `(("fuse" ,fuse)
706 ("libxml2" ,libxml2)
707 ("ntfs-3g" ,ntfs-3g)
708 ("openssl" ,openssl)))
709 (arguments
710 `(#:configure-flags (list "--enable-test-support")))
711 (home-page "https://wimlib.net/")
712 (synopsis "WIM file manipulation library and utilities")
713 (description "wimlib is a C library and set of command-line utilities for
714 creating, modifying, extracting, and mounting archives in the Windows Imaging
715 Format (@dfn{WIM files}). It can capture and apply WIMs directly from and to
716 NTFS volumes using @code{ntfs-3g}, preserving NTFS-specific attributes.")
717 ;; wimlib is dual-licenced under version 3 or later of either the GPL or
718 ;; LGPL, except those files explicitly marked as being released into the
719 ;; public domain (CC0) in their headers.
720 (license (list license:gpl3+
721 license:lgpl3+
722 license:cc0))))
723
724 (define-public dirvish
725 (package
726 (name "dirvish")
727 (version "1.2.1")
728 (build-system gnu-build-system)
729 (source (origin
730 (method url-fetch)
731 (uri (string-append
732 "http://dirvish.org/dirvish-" version ".tgz"))
733 (sha256
734 (base32
735 "1kbxa1irszp2zw8hd5qzqnrrzb4vxfivs1vn64yxnj0lak1jjzvb"))))
736 (arguments
737 `(#:modules ((ice-9 match) (ice-9 rdelim)
738 ,@%gnu-build-system-modules)
739 #:phases
740 ;; This mostly mirrors the steps taken in the install.sh that ships
741 ;; with dirvish, but simplified because we aren't prompting interactively
742 (modify-phases %standard-phases
743 (delete 'configure)
744 (delete 'build)
745 (delete 'check)
746 (replace 'install
747 (lambda* (#:key inputs outputs #:allow-other-keys)
748 ;; These are mostly the same steps the install.sh that comes with
749 ;; dirvish does
750 (let* (;; Files we'll be copying
751 (executables
752 '("dirvish" "dirvish-runall"
753 "dirvish-expire" "dirvish-locate"))
754 (man-pages
755 '(("dirvish" "8") ("dirvish-runall" "8")
756 ("dirvish-expire" "8") ("dirvish-locate" "8")
757 ("dirvish.conf" "5")))
758
759 (output-dir
760 (assoc-ref outputs "out"))
761
762 ;; Just a default... not so useful on guixsd though
763 ;; You probably want to a service with file(s) to point to.
764 (confdir "/etc/dirvish")
765
766 (perl (string-append (assoc-ref %build-inputs "perl")
767 "/bin/perl"))
768 (loadconfig.pl (call-with-input-file "loadconfig.pl"
769 read-string)))
770
771
772 (define (write-pl filename)
773 (define pl-header
774 (string-append "#!" perl "\n\n"
775 "$CONFDIR = \"" confdir "\";\n\n"))
776 (define input-file-location
777 (string-append filename ".pl"))
778 (define target-file-location
779 (string-append output-dir "/bin/" filename ".pl"))
780 (define text-to-write
781 (string-append pl-header
782 (call-with-input-file input-file-location
783 read-string)
784 "\n" loadconfig.pl))
785 (with-output-to-file target-file-location
786 (lambda ()
787 (display text-to-write)))
788 (chmod target-file-location #o755)
789 (wrap-program target-file-location
790 `("PERL5LIB" ":" prefix
791 ,(map (lambda (l) (string-append (assoc-ref %build-inputs l)
792 "/lib/perl5/site_perl"))
793 '("perl-libtime-period"
794 "perl-libtime-parsedate")))))
795
796 (define write-man
797 (match-lambda
798 ((file-base man-num)
799 (let* ((filename
800 (string-append file-base "." man-num))
801 (output-path
802 (string-append output-dir
803 "/share/man/man" man-num
804 "/" filename)))
805 (copy-file filename output-path)))))
806
807 ;; Make directories
808 (mkdir-p (string-append output-dir "/bin/"))
809 (mkdir-p (string-append output-dir "/share/man/man8/"))
810 (mkdir-p (string-append output-dir "/share/man/man5/"))
811
812 ;; Write out executables
813 (for-each write-pl executables)
814 ;; Write out man pages
815 (for-each write-man man-pages)
816 #t))))))
817 (inputs
818 `(("perl" ,perl)
819 ("rsync" ,rsync)
820 ("perl-libtime-period" ,perl-libtime-period)
821 ("perl-libtime-parsedate" ,perl-libtime-parsedate)))
822 (home-page "http://dirvish.org/")
823 (synopsis "Fast, disk based, rotating network backup system")
824 (description
825 "With dirvish you can maintain a set of complete images of your
826 file systems with unattended creation and expiration. A dirvish backup vault
827 is like a time machine for your data. ")
828 (license (license:fsf-free "file://COPYING"
829 "Open Software License 2.0"))))
830
831 (define-public restic
832 (package
833 (name "restic")
834 (version "0.9.6")
835 ;; TODO Try packaging the bundled / vendored dependencies in the 'vendor/'
836 ;; directory.
837 (source (origin
838 (method url-fetch)
839 (uri (string-append
840 "https://github.com/restic/restic/releases/download/"
841 "v" version "/restic-" version ".tar.gz"))
842 (file-name (string-append name "-" version ".tar.gz"))
843 (sha256
844 (base32
845 "1zmh42aah32ah8w5n6ilz9bci0y2xrf8p7qshy3yf1lzm5gnbj0w"))))
846 (build-system go-build-system)
847 (arguments
848 `(#:import-path "github.com/restic/restic"
849 ;; We don't need to install the source code for end-user applications.
850 #:install-source? #f
851 #:phases
852 (modify-phases %standard-phases
853 (replace 'build
854 (lambda* (#:key inputs #:allow-other-keys)
855 (with-directory-excursion "src/github.com/restic/restic"
856 ;; Disable 'restic self-update'. It makes little sense in Guix.
857 (substitute* "build.go" (("selfupdate") ""))
858 (setenv "HOME" (getcwd)) ; for $HOME/.cache/go-build
859 (invoke "go" "run" "build.go"))))
860
861 (replace 'check
862 (lambda _
863 (with-directory-excursion "src/github.com/restic/restic"
864 ;; Disable FUSE tests.
865 (setenv "RESTIC_TEST_FUSE" "0")
866 (invoke "go" "run" "build.go" "--test"))))
867
868 (replace 'install
869 (lambda* (#:key outputs #:allow-other-keys)
870 (let ((out (assoc-ref outputs "out"))
871 (src "src/github.com/restic/restic"))
872 (install-file (string-append src "/restic")
873 (string-append out "/bin"))
874 #t)))
875
876 (add-after 'install 'install-docs
877 (lambda* (#:key outputs #:allow-other-keys)
878 (let* ((out (assoc-ref outputs "out"))
879 (man "/share/man")
880 (man-section (string-append man "/man"))
881 (src "src/github.com/restic/restic/doc/man/"))
882 ;; Install all the man pages to "out".
883 (for-each
884 (lambda (file)
885 (install-file file
886 (string-append out man-section
887 (string-take-right file 1))))
888 (find-files src "\\.[1-9]"))
889 #t)))
890
891 (add-after 'install-docs 'install-shell-completion
892 (lambda* (#:key outputs #:allow-other-keys)
893 (let* ((out (assoc-ref outputs "out"))
894 (bin (string-append out "/bin"))
895 (etc (string-append out "/etc"))
896 (share (string-append out "/share")))
897 (for-each
898 (lambda (shell)
899 (let* ((shell-name (symbol->string shell))
900 (dir (string-append "etc/completion/" shell-name)))
901 (mkdir-p dir)
902 (invoke (string-append bin "/restic") "generate"
903 (string-append "--" shell-name "-completion")
904 (string-append dir "/"
905 (case shell
906 ((bash) "restic")
907 ((zsh) "_restic"))))))
908 '(bash zsh))
909 (with-directory-excursion "etc/completion"
910 (install-file "bash/restic"
911 (string-append etc "/bash_completion.d"))
912 (install-file "zsh/_restic"
913 (string-append share "/zsh/site-functions")))
914 #t))))))
915 (home-page "https://restic.net/")
916 (synopsis "Backup program with multiple revisions, encryption and more")
917 (description "Restic is a program that does backups right and was designed
918 with the following principles in mind:
919
920 @itemize
921 @item Easy: Doing backups should be a frictionless process, otherwise you
922 might be tempted to skip it. Restic should be easy to configure and use, so
923 that, in the event of a data loss, you can just restore it. Likewise,
924 restoring data should not be complicated.
925
926 @item Fast: Backing up your data with restic should only be limited by your
927 network or hard disk bandwidth so that you can backup your files every day.
928 Nobody does backups if it takes too much time. Restoring backups should only
929 transfer data that is needed for the files that are to be restored, so that
930 this process is also fast.
931
932 @item Verifiable: Much more important than backup is restore, so restic
933 enables you to easily verify that all data can be restored. @item Secure:
934 Restic uses cryptography to guarantee confidentiality and integrity of your
935 data. The location the backup data is stored is assumed not to be a trusted
936 environment (e.g. a shared space where others like system administrators are
937 able to access your backups). Restic is built to secure your data against
938 such attackers.
939
940 @item Efficient: With the growth of data, additional snapshots should only
941 take the storage of the actual increment. Even more, duplicate data should be
942 de-duplicated before it is actually written to the storage back end to save
943 precious backup space.
944 @end itemize")
945 (license license:bsd-2)))
946
947 (define-public burp
948 (package
949 (name "burp")
950 (version "2.3.6")
951 (source (origin
952 (method url-fetch)
953 (uri (string-append "mirror://sourceforge/burp/burp-" version
954 "/burp-" version ".tar.bz2"))
955 (sha256
956 (base32
957 "101nn30apcbmy9k0wksdf8d4ccw7sfcqzkasgg17a5y332x2imr9"))))
958 (build-system gnu-build-system)
959 (inputs
960 `(("librsync" ,librsync)
961 ("openssl" ,openssl)
962 ("uthash" ,uthash)
963 ("zlib" ,zlib)))
964 (native-inputs
965 `(("check" ,check)
966 ("pkg-config" ,pkg-config)))
967 (home-page "https://burp.grke.org")
968 (synopsis "Differential backup and restore")
969 (description "Burp is a network backup and restore program. It attempts
970 to reduce network traffic and the amount of space that is used by each
971 backup.")
972 (license license:agpl3)))