gnu: Add stellarium.
[jackhill/guix/guix.git] / gnu / packages / education.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages education)
20 #:use-module (ice-9 regex)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages qt)
23 #:use-module (gnu packages compression)
24 #:use-module (gnu packages gettext)
25 #:use-module (gnu packages perl)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix svn-download)
30 #:use-module (guix utils)
31 #:use-module (guix build-system gnu)
32 #:use-module (guix build-system cmake)
33 #:use-module (srfi srfi-1))
34
35 (define-public stellarium
36 (package
37 (name "stellarium")
38 (version "0.14.2")
39 (source (origin
40 (method url-fetch)
41 (uri (string-append "mirror://sourceforge/stellarium/"
42 "Stellarium-sources/"
43 version "/stellarium-" version ".tar.gz"))
44 (sha256 (base32
45 "1xxil0rv61zc08znfv83cpsc47y1gjl2f3njhz0pn5zd8jpaa15a"))))
46 (build-system cmake-build-system)
47 (inputs
48 `(("qtbase" ,qtbase)
49 ("zlib" ,zlib)
50 ("qtserialport" ,qtserialport)
51 ("qtscript" ,qtscript)
52 ("gettext" ,gnu-gettext)))
53 (native-inputs
54 `(("qtbase" ,qtbase) ;Qt MOC is needed at compile time
55 ("qttools" ,qttools)
56 ("perl" ,perl))) ;for 'pod2man'
57 (arguments
58 `(#:test-target "tests"
59 #:phases (modify-phases %standard-phases
60 (add-before 'check 'set-offscreen-display
61 (lambda _
62 (setenv "QT_QPA_PLATFORM" "offscreen")
63 (setenv "HOME" "/tmp")
64 #t)))))
65 (home-page "http://www.stellarium.org/")
66 (synopsis "3D sky viewer")
67 (description "Stellarium is a planetarium. It shows a realistic sky in
68 3D, just like what you see with the naked eye, binoculars, or a telescope.")
69 (license license:gpl2+)))