gnu: gettext: Fix non-deterministic msgunfmt behavior.
[jackhill/guix/guix.git] / gnu / packages / moe.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages moe)
20 #:use-module ((guix licenses) #:select (gpl3+))
21 #:use-module (gnu packages ncurses)
22 #:use-module (gnu packages compression)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public moe
28 (package
29 (name "moe")
30 (version "1.7")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/moe/moe-"
35 version ".tar.lz"))
36 (sha256
37 (base32
38 "1fzimk1qpmsm7wzfnjzzrp4dvdn7ipdb5j7969910g1m93wndfik"))))
39 (build-system gnu-build-system)
40 (native-inputs `(("lzip" ,lzip)))
41 (inputs `(("ncurses" ,ncurses)))
42 (home-page "https://www.gnu.org/software/moe/moe.html")
43 (synopsis "Modeless, multiple-buffer, user-friendly 8-bit text editor")
44 (description
45 "GNU Moe is a powerful-but-simple-to-use text editor. It works in a
46 modeless manner, and features an intuitive set of key-bindings that
47 assign a degree of severity to each key; for example, key
48 combinations with the Alt key are for harmless commands like cursor
49 movements while combinations with the Control key are for commands
50 that will modify the text. Moe features multiple windows, unlimited
51 undo/redo, unlimited line length, global search and replace, and
52 more.")
53 (license gpl3+)))