gnu: gettext: Fix non-deterministic msgunfmt behavior.
[jackhill/guix/guix.git] / gnu / packages / aidc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darringon <jmd@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages aidc)
20 #:use-module (gnu packages)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (gnu packages pkg-config)
25 #:use-module (gnu packages image)
26 #:use-module (guix build-system gnu))
27
28
29 (define-public barcode
30 (package
31 (name "barcode")
32 (version "0.99")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "mirror://gnu/barcode/barcode-"
36 version ".tar.xz"))
37 (sha256 (base32
38 "1indapql5fjz0bysyc88cmc54y8phqrbi7c76p71fgjp45jcyzp8"))))
39 (build-system gnu-build-system)
40 (synopsis "Convert text strings to printed bars in various standards")
41 (description "GNU Barcode is a flexible tool to produce printed barcodes
42 from text strings. It supports a variety of encoding standards and sizing
43 measurements. Barcodes can be output in PostScript or Encapsulated PostScript
44 formats.")
45 (license license:gpl3+)
46 (home-page "http://www.gnu.org/software/barcode/")))
47
48 (define-public qrencode
49 (package
50 (name "qrencode")
51 (version "3.4.3")
52 (source (origin
53 (method url-fetch)
54 (uri (string-append
55 "http://fukuchi.org/works/qrencode/qrencode-" version
56 ".tar.bz2"))
57 (sha256 (base32
58 "163sb580p570p27imc6jhkfdw15kzp8vy1jq92nip1rwa63i9myz"))))
59 (build-system gnu-build-system)
60 (inputs `(("libpng" ,libpng)))
61 (native-inputs `(("pkg-config" ,pkg-config)))
62 (synopsis "Encode data into a QR Code symbol")
63 (description "Libqrencode is a C library for encoding data in a QR Code
64 symbol, a kind of 2D symbology that can be scanned by handy terminals such as
65 a mobile phone with CCD. The capacity of QR Code is up to 7000 digits or 4000
66 characters, and is highly robust.")
67 (license license:lgpl2.1+)
68 (home-page "http://fukuchi.org/works/qrencode")))