gnu: Move dbm databases to new module.
[jackhill/guix/guix.git] / gnu / packages / cyrus-sasl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages cyrus-sasl)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages dbm)
24 #:use-module (gnu packages kerberos)
25 #:use-module (gnu packages tls)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu))
30
31 (define-public cyrus-sasl
32 (package
33 (name "cyrus-sasl")
34 (version "2.1.26")
35 (source (origin
36 (method url-fetch)
37 (uri (list (string-append
38 "https://cyrusimap.org/releases/cyrus-sasl-"
39 version ".tar.gz")
40 (string-append
41 "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
42 version ".tar.gz")))
43 (patches (search-patches "cyrus-sasl-CVE-2013-4122.patch"))
44 (sha256 (base32
45 "1hvvbcsg21nlncbgs0cgn3iwlnb3vannzwsp6rwvnn9ba4v53g4g"))))
46 (build-system gnu-build-system)
47 (inputs `(("gdbm" ,gdbm)
48 ("mit-krb5" ,mit-krb5)
49 ("openssl" ,openssl)))
50 (arguments
51 '(#:configure-flags (list (string-append "--with-plugindir="
52 (assoc-ref %outputs "out")
53 "/lib/sasl2"))
54
55 ;; The 'plugins' directory has shared source files, such as
56 ;; 'plugin_common.c'. When building the shared libraries there, libtool
57 ;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
58 ;; fail with EEXIST when building things in parallel.
59 #:parallel-build? #f))
60 (synopsis "Simple Authentication Security Layer implementation")
61 (description
62 "SASL (Simple Authentication Security Layer) is an Internet
63 standards-track method for remote computers to authenticate. The Cyrus SASL
64 library makes supporting various SASL mechanisms easy for both client and
65 server writers.")
66 (license (license:non-copyleft "file://COPYING"
67 "See COPYING in the distribution."))
68 (home-page "https://cyrusimap.org/sasl/")))