Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / iso-codes.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages iso-codes)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix git-download)
26 #:use-module (guix build-system gnu)
27 #:use-module (guix build-system python)
28 #:use-module (gnu packages gettext)
29 #:use-module (gnu packages perl)
30 #:use-module (gnu packages python))
31
32 (define-public iso-codes
33 (package
34 (name "iso-codes")
35 (version "4.5.0")
36 (home-page "https://salsa.debian.org/iso-codes-team/iso-codes")
37 (source (origin
38 (method git-fetch)
39 (uri (git-reference
40 (url home-page)
41 (commit (string-append "iso-codes-" version))))
42 (file-name (git-file-name name version))
43 (sha256
44 (base32
45 "1q6x9c5x4x0x4q11iygldsmxdyzhz1mb4n8im76glwsgqsqyjs80"))))
46 (build-system gnu-build-system)
47 (inputs
48 `(("gettext" ,gettext-minimal)
49 ("perl" ,perl)
50 ("python" ,python-wrapper)))
51 (synopsis "Various ISO standards")
52 (description
53 "This package provides lists of various ISO standards (e.g. country,
54 language, language scripts, and currency names) in one place, rather
55 than repeated in many programs throughout the system.
56
57 Currently there are lists of languages and countries embedded in
58 several different programs, which leads to dozens of lists of
59 200 languages, translated into more than 30 languages... not
60 very efficient.
61
62 With this package, we create a single \"gettext domain\" for every
63 supported ISO standard which contains the translations of
64 that domain. It is easy for a programmer to re-use those
65 translations instead of maintaining their own translation
66 infrastructure. Moreover, the programmer does not need to follow
67 changes in the ISO standard and will not work with outdated
68 information.")
69 (license license:gpl2+))) ; some bits use the lgpl2
70
71 (define-public python-iso639
72 (package
73 (name "python-iso639")
74 (version "0.4.5")
75 (source
76 (origin
77 (method url-fetch)
78 (uri (pypi-uri "iso-639" version))
79 (sha256
80 (base32
81 "0jffmh4m20q8j27xb2fqbnlghjj0cx8pgsbzqisdg65qh2wd976w"))))
82 (build-system python-build-system)
83 (home-page "https://github.com/noumar/iso639")
84 (synopsis "Python library for ISO 639 standard")
85 (description "This package provides a Python library for ISO 639 standard
86 that is concerned with representation of names for languages and language
87 groups.")
88 (license license:agpl3+)))
89
90 (define-public python2-iso639
91 (package-with-python2 python-iso639))
92
93 (define-public python-iso3166
94 (package
95 (name "python-iso3166")
96 (version "0.9")
97 (source
98 (origin
99 (method url-fetch)
100 (uri (pypi-uri "iso3166" version))
101 (sha256
102 (base32
103 "0hm0xm30sprk1jssmn4cqks0x3nx5fp8r5ypvahcysmmayzrsnjl"))))
104 (build-system python-build-system)
105 (home-page "https://github.com/deactivated/python-iso3166")
106 (synopsis "Self-contained ISO 3166-1 country definitions")
107 (description "This package provides the ISO 3166-1 country definitions.")
108 (license license:expat)))
109
110 (define-public python2-iso3166
111 (package-with-python2 python-iso3166))