gnu: Add ht.
[jackhill/guix/guix.git] / gnu / packages / hexedit.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
3 ;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages hexedit)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages compression)
25 #:use-module (gnu packages ncurses)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu))
28
29 (define-public hexedit
30 (package
31 (name "hexedit")
32 (version "1.2.13")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "http://rigaux.org/"
36 name "-" version ".src.tgz"))
37 (sha256
38 (base32
39 "1mwdp1ikk64cqmagnrrps5jkn3li3n47maiqh2qc1xbp1ains4ka"))))
40 (build-system gnu-build-system)
41 (arguments '(#:tests? #f)) ; no check target
42 (inputs `(("ncurses" ,ncurses)))
43 (synopsis "View and edit files or devices in hexadecimal or ASCII")
44 (description "hexedit shows a file both in ASCII and in hexadecimal. The
45 file can be a device as the file is read a piece at a time. You can modify
46 the file and search through it.")
47 (home-page "http://rigaux.org/hexedit.html")
48 (license license:gpl2+)))
49
50 (define-public ht
51 (package
52 (name "ht")
53 (version "2.1.0")
54 (source (origin
55 (method url-fetch)
56 (uri (string-append
57 "https://sourceforge.net/projects/hte/files/ht-source/"
58 name "-" version ".tar.bz2"))
59 (sha256
60 (base32
61 "0w2xnw3z9ws9qrdpb80q55h6ynhh3aziixcfn45x91bzrbifix9i"))))
62 (build-system gnu-build-system)
63 (inputs
64 `(("lzo" ,lzo)
65 ("ncurses" ,ncurses)))
66 (synopsis "Viewer, editor, and analyzer for executable binaries")
67 (description
68 "ht is a terminal-based program to view, edit, and analyze any file, but
69 with a special focus on executable binaries. Its goal is to combine the
70 low-level functionality of a debugger with the usability of an @dfn{Integrated
71 Development Environment} (IDE).")
72 (home-page "http://hte.sourceforge.net/")
73 (license license:gpl2)))