gnu: Add go-github-com-ipfs-go-ipfs-cmdkit-files.
[jackhill/guix/guix.git] / gnu / packages / ipfs.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages ipfs)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix git-download)
23 #:use-module (guix build-system go)
24 #:use-module (gnu packages golang))
25
26 (define-public go-github-com-ipfs-go-ipfs-cmdkit-files
27 (let ((commit
28 "386fcf8f18a185ec121676665fe2d9574496048d")
29 (revision "0"))
30 (package
31 (name "go-github-com-ipfs-go-ipfs-cmdkit-files")
32 (version (git-version "1.1.3" revision commit))
33 (source
34 (origin
35 (method git-fetch)
36 (uri (git-reference
37 (url "https://github.com/ipfs/go-ipfs-cmdkit.git")
38 (commit commit)))
39 (file-name (git-file-name name version))
40 (sha256
41 (base32
42 "0qk6fshgdmhp8dip2ksm13j6nywi41m9mn0czkvmw6b697z85l2r"))))
43 (build-system go-build-system)
44 (arguments
45 '(#:unpack-path "github.com/ipfs/go-ipfs-cmdkit"
46 #:import-path "github.com/ipfs/go-ipfs-cmdkit/files"))
47 (home-page "https://github.com/ipfs/go-ipfs-cmdkit")
48 (synopsis "Shared types, functions and values for go-ipfs")
49 (description "@command{cmdkit} offers some types, functions and values
50 that are shared between @command{go-ipfs/commands} and its rewrite
51 @command{go-ipfs-cmds}.")
52 (license license:expat))))