Merge remote-tracking branch 'origin/master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / calcurse.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages calcurse)
21 #:use-module (guix packages)
22 #:use-module (guix licenses)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages base)
27 #:use-module (gnu packages ncurses))
28
29 (define-public calcurse
30 (package
31 (name "calcurse")
32 (version "4.2.2")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "http://calcurse.org/files/calcurse-"
37 version ".tar.gz"))
38 (sha256
39 (base32
40 "0il0y06akdqgy0f9p40m4x6arn66nh7sr1w1i41bszycs7div266"))))
41 (build-system gnu-build-system)
42 (inputs `(("ncurses" ,ncurses)))
43 (native-inputs `(("tzdata" ,tzdata-for-tests)))
44 (arguments
45 ;; The ical tests all want to create a ".calcurse" directory, and may
46 ;; fail with "cannot create directory '.calcurse': File exists" if run
47 ;; concurently.
48 `(#:parallel-tests? #f
49 ;; Since this tzdata is only used for tests and not referenced by the
50 ;; built package, used the "fixed" obsolete version of tzdata and ensure
51 ;; it does not sneak in to the closure.
52 #:disallowed-references (,tzdata-for-tests)
53 #:phases (modify-phases %standard-phases
54 (add-before 'check 'check-setup
55 (lambda* (#:key inputs #:allow-other-keys)
56 (setenv "TZDIR" ;for test/ical-007.sh
57 (string-append (assoc-ref inputs "tzdata")
58 "/share/zoneinfo")))))))
59 (home-page "http://www.calcurse.org")
60 (synopsis "Text-based calendar and scheduling")
61 (description
62 "Calcurse is a text-based calendar and scheduling application. It helps
63 keep track of events, appointments and everyday tasks. A configurable
64 notification system reminds user of upcoming deadlines, and the curses based
65 interface can be customized to suit user needs. All of the commands are
66 documented within an online help system.")
67 (license bsd-2)))