gnu: aspell: Update to 0.60.8.
[jackhill/guix/guix.git] / gnu / packages / aspell.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
4 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
5 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 Christopher Andersson <christopher@8bits.nu>
7 ;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
8 ;;; Copyright © 2016, 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
10 ;;;
11 ;;; This file is part of GNU Guix.
12 ;;;
13 ;;; GNU Guix is free software; you can redistribute it and/or modify it
14 ;;; under the terms of the GNU General Public License as published by
15 ;;; the Free Software Foundation; either version 3 of the License, or (at
16 ;;; your option) any later version.
17 ;;;
18 ;;; GNU Guix is distributed in the hope that it will be useful, but
19 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
20 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
21 ;;; GNU General Public License for more details.
22 ;;;
23 ;;; You should have received a copy of the GNU General Public License
24 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
25
26 (define-module (gnu packages aspell)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu)
30 #:use-module (guix licenses)
31 #:use-module (guix utils)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages base)
34 #:use-module (gnu packages compression)
35 #:use-module (gnu packages perl)
36 #:use-module (ice-9 match))
37
38 (define-public aspell
39 (package
40 (name "aspell")
41 (version "0.60.8")
42 (source
43 (origin
44 (method url-fetch)
45 (uri (string-append "mirror://gnu/aspell/aspell-"
46 version ".tar.gz"))
47 (sha256
48 (base32
49 "1wi60ankalmh8ds7nplz434jd7j94gdvbahdwsr539rlad8pxdzr"))
50 (patches (search-patches "aspell-default-dict-dir.patch"))))
51 (build-system gnu-build-system)
52 (arguments
53 `(#:phases
54 (modify-phases %standard-phases
55 (add-before 'build 'set-filter-path
56 (lambda* (#:key outputs #:allow-other-keys)
57 ;; Change the default value of 'filter-path' so that filters such
58 ;; as 'tex-filter.so' can be found. By default none of the
59 ;; filters would be found.
60 (let* ((out (assoc-ref outputs "out"))
61 (libdir (string-append out "/lib/aspell-"
62 ,(version-major+minor version))))
63 (substitute* "common/config.cpp"
64 (("\"filter-path(.*)DICT_DIR" _ middle)
65 (string-append "\"filter-path" middle
66 "\"" libdir "\"")))
67 #t))))))
68 (inputs `(("perl" ,perl)))
69
70 (native-search-paths
71 ;; This is a Guix-specific environment variable that takes a single
72 ;; entry, not an actual search path.
73 (list (search-path-specification
74 (variable "ASPELL_DICT_DIR")
75 (separator #f)
76 (files '("lib/aspell")))))
77
78 (home-page "http://aspell.net/")
79 (synopsis "Spell checker")
80 (description
81 "Aspell is a spell-checker which can be used either as a library or as
82 a standalone program. Notable features of Aspell include its full support of
83 documents written in the UTF-8 encoding and its ability to use multiple
84 dictionaries, including personal ones.")
85 (license lgpl2.1+)))
86
87 ;;;
88 ;;; Dictionaries.
89 ;;;
90 ;;; Use 'export ASPELL_CONF="dict-dir $HOME/.guix-profile/lib/aspell"' to use
91 ;;; them, or set the Guix-specific 'ASPELL_DICT_DIR', or just do nothing (as
92 ;;; long as 'HOME' is set, that's fine!).
93 ;;;
94
95 (define* (aspell-dictionary dict-name full-name
96 #:key version sha256 (prefix "aspell6-"))
97 (package
98 (name (string-append
99 "aspell-dict-"
100 ;; Downcase and replace underscore in package names
101 ;; to follow Guix naming conventions.
102 (string-map (match-lambda
103 (#\_ #\-)
104 (chr chr))
105 (string-downcase dict-name))))
106 (version version)
107 (source (origin
108 (method url-fetch)
109 (uri (string-append "mirror://gnu/aspell/dict/" dict-name
110 "/" prefix dict-name "-"
111 version ".tar.bz2"))
112 (sha256 sha256)))
113 (build-system gnu-build-system)
114 (arguments
115 `(#:phases
116 (modify-phases %standard-phases
117 (replace 'configure
118 (lambda* (#:key outputs #:allow-other-keys)
119 (let ((out (assoc-ref outputs "out")))
120 (invoke "./configure")))))
121 #:make-flags
122 (let ((out (assoc-ref %outputs "out")))
123 (list (string-append "dictdir=" out "/lib/aspell")
124 (string-append "datadir=" out "/lib/aspell")))
125 #:tests? #f))
126 (native-inputs `(("aspell" ,aspell)
127 ("which" ,which)))
128 (synopsis (string-append full-name " dictionary for GNU Aspell")) ; XXX: i18n
129 (description
130 "This package provides a dictionary for the GNU Aspell spell checker.")
131 (license gpl2+)
132 (home-page "http://aspell.net/")))
133
134
135 (define-public aspell-dict-ar
136 (aspell-dictionary "ar" "Arabic"
137 #:version "1.2-0"
138 #:prefix "aspell6-"
139 #:sha256
140 (base32
141 "1avw40bp8yi5bnkq64ihm2rldgw34lk89yz281q9bmndh95a47h4")))
142
143 (define-public aspell-dict-be
144 (aspell-dictionary "be" "Belarusian"
145 #:version "0.01"
146 #:prefix "aspell5-"
147 #:sha256
148 (base32
149 "1svls9p7rsfi3hs0afh0cssj006qb4v1ik2yzqgj8hm10c6as2sm")))
150
151 (define-public aspell-dict-ca
152 (aspell-dictionary "ca" "Catalan"
153 #:version "2.1.5-1"
154 #:sha256
155 (base32
156 "1fb5y5kgvk25nlsfvc8cai978hg66x3pbp9py56pldc7vxzf9npb")))
157
158 (define-public aspell-dict-de
159 (aspell-dictionary "de" "German"
160 #:version "20030222-1"
161 #:sha256
162 (base32
163 "01p92qj66cqb346gk7hjfynaap5sbcn85xz07kjfdq623ghr8v5s")))
164
165 (define-public aspell-dict-da
166 (aspell-dictionary "da" "Danish"
167 #:version "1.4.42-1"
168 #:prefix "aspell5-"
169 #:sha256
170 (base32
171 "1hfkmiyhgrx5lgrb2mffjbdn1hivrm73wcg7x0iid74p2yb0fjpp")))
172
173 (define-public aspell-dict-el
174 (aspell-dictionary "el" "Greek"
175 #:version "0.08-0"
176 #:prefix "aspell6-"
177 #:sha256
178 (base32
179 "1ljcc30zg2v2h3w5h5jr5im41mw8jbsgvvhdd2cii2yzi8d0zxja")))
180
181 (define-public aspell-dict-en
182 (aspell-dictionary "en" "English"
183 #:version "2018.04.16-0"
184 #:sha256
185 (base32
186 "0bxxdzkk9g27plg22y9qzsx9cfjw3aa29w5bmzs561qc9gkp247i")))
187
188 (define-public aspell-dict-eo
189 (aspell-dictionary "eo" "Esperanto"
190 #:version "2.1.20000225a-2"
191 #:sha256
192 (base32
193 "09vf0mbiicbmyb4bwb7v7lgpabnylg0wy7m3hlhl5rjdda6x3lj1")))
194
195 (define-public aspell-dict-es
196 (aspell-dictionary "es" "Spanish"
197 #:version "1.11-2"
198 #:sha256
199 (base32
200 "1k5g328ac1hdpp6fsg57d8md6i0aqcwlszp3gbmp5706wyhpydmd")))
201
202 (define-public aspell-dict-fi
203 (aspell-dictionary "fi" "Finnish"
204 #:version "0.7-0"
205 #:prefix "aspell6-"
206 #:sha256
207 (base32
208 "07d5s08ba4dd89cmwy9icc01i6fjdykxlb9ravmhdrhi8mxz1mzq")))
209
210 (define-public aspell-dict-fr
211 (aspell-dictionary "fr" "French"
212 #:version "0.50-3"
213 #:prefix "aspell-"
214 #:sha256
215 (base32
216 "14ffy9mn5jqqpp437kannc3559bfdrpk7r36ljkzjalxa53i0hpr")))
217
218 (define-public aspell-dict-grc
219 (aspell-dictionary "grc" "Ancient Greek"
220 #:version "0.02-0"
221 #:sha256
222 (base32
223 "1zxr8958v37v260fkqd4pg37ns5h5kyqm54hn1hg70wq5cz8h512")))
224
225 (define-public aspell-dict-he
226 (aspell-dictionary "he" "Hebrew"
227 #:version "1.0-0"
228 #:sha256
229 (base32
230 "13bhbghx5b8g0119g3wxd4n8mlf707y41vlf59irxjj0kynankfn")))
231
232 (define-public aspell-dict-hi
233 (aspell-dictionary "hi" "Hindi"
234 #:version "0.02-0"
235 #:prefix "aspell6-"
236 #:sha256
237 (base32
238 "0drs374qz4419zx1lf2k281ydxf2750jk5ailafj1x0ncz27h1ys")))
239
240 (define-public aspell-dict-it
241 (let ((version "2.4-20070901-0")
242 (sha256
243 (base32 "0d6ypii3jblprpibazb6ypady536jz62rwxlss1x1raq07rhvvqn")))
244 (package
245 (inherit (aspell-dictionary "it" "Italian"
246 #:version version
247 #:sha256 sha256))
248
249 ;; The version hosted at <https://ftp.gnu.org/gnu/aspell/dict> is even
250 ;; more out of date.
251 (source
252 (origin
253 (method url-fetch)
254 (uri (string-append "mirror://sourceforge/linguistico/"
255 "Dizionario%20italiano%20per%20Aspell/" version "/"
256 "aspell6-it-" version ".tar.bz2"))
257 (sha256 sha256)))
258 (home-page
259 "http://linguistico.sourceforge.net/pages/dizionario_italiano.html"))))
260
261 (define-public aspell-dict-mi
262 (aspell-dictionary "mi" "Maori"
263 #:version "0.50-0"
264 #:sha256
265 (base32
266 "12bxplpd348yx8d2q8qvahi9dlp7qf28qmanzhziwc7np8rixvmy")))
267
268 (define-public aspell-dict-nl
269 (aspell-dictionary "nl" "Dutch"
270 #:version "0.50-2"
271 #:prefix "aspell-"
272 #:sha256
273 (base32
274 "0ffb87yjsh211hllpc4b9khqqrblial4pzi1h9r3v465z1yhn3j4")))
275
276 (define-public aspell-dict-nn
277 (aspell-dictionary "nn" "Norwegian Nynorsk"
278 #:version "0.50.1-1"
279 #:sha256
280 (base32
281 "0w2k5l5rbqpliripgqwiqixz5ghnjf7i9ggbrc4ly4vy1ia10rmc")))
282
283 (define-public aspell-dict-pt-br
284 (aspell-dictionary "pt_BR" "Brazilian Portuguese"
285 #:version "20090702-0"
286 #:prefix "aspell6-"
287 #:sha256
288 (base32
289 "1y09lx9zf2rnp55r16b2vgj953l3538z1vaqgflg9mdvm555bz3p")))
290
291 (define-public aspell-dict-pt-pt
292 (aspell-dictionary "pt_PT" "Portuguese"
293 #:version "20070510-0"
294 #:prefix "aspell6-"
295 #:sha256
296 (base32
297 "1mnr994cwlag6shy8865ky99lymysiln07mbldcncahg90dagdxq")))
298
299 (define-public aspell-dict-ru
300 (aspell-dictionary "ru" "Russian"
301 #:version "0.99f7-1"
302 #:sha256
303 (base32
304 "0ip6nq43hcr7vvzbv4lwwmlwgfa60hrhsldh9xy3zg2prv6bcaaw")))
305
306 (define-public aspell-dict-sv
307 (aspell-dictionary "sv" "Swedish"
308 #:version "0.51-0"
309 #:prefix "aspell-"
310 #:sha256
311 (base32
312 "02jwkjhr32kvyibnyzgx3smbnm576jwdzg3avdf6zxwckhy5fw4v")))
313
314 (define-public aspell-dict-uk
315 (aspell-dictionary "uk" "Ukrainian"
316 #:version "1.4.0-0"
317 #:sha256
318 (base32
319 "137i4njvnslab6l4s291s11xijr5jsy75lbdph32f9y183lagy9m")))
320
321 \f
322 ;;;
323 ;;; Hunspell packages made from the Aspell word lists.
324 ;;;
325
326 (define* (aspell-word-list language synopsis
327 #:optional
328 (nick (string-map (lambda (chr)
329 (if (char=? #\_ chr)
330 #\-
331 chr))
332 (string-downcase language))))
333 (package
334 (name (string-append "hunspell-dict-" nick))
335 (version "2018.04.16")
336 (source (origin
337 (method url-fetch)
338 (uri (string-append
339 "http://downloads.sourceforge.net/wordlist/scowl-"
340 version ".tar.gz"))
341 (sha256
342 (base32
343 "11lkrnhwrf5mvrrq45k4mads3n9aswgac8dc25ba61c75alxb5rs"))))
344 (native-inputs
345 `(("tar" ,tar)
346 ("gzip" ,gzip)
347 ("perl" ,perl)
348 ("aspell" ,aspell)))
349 (build-system gnu-build-system)
350 (arguments
351 `(#:phases
352 (modify-phases %standard-phases
353 (delete 'configure)
354 (delete 'check)
355 (replace 'build
356 (lambda _
357 (substitute* "speller/make-hunspell-dict"
358 (("zip -9 .*$")
359 "return\n"))
360 (mkdir "speller/hunspell")
361
362 ;; XXX: This actually builds all the dictionary variants.
363 (invoke "make" "-C" "speller" "hunspell")))
364 (replace 'install
365 (lambda* (#:key outputs #:allow-other-keys)
366 (let* ((out (assoc-ref %outputs "out"))
367 (hunspell (string-append out "/share/hunspell"))
368 (myspell (string-append out "/share/myspell"))
369 (doc (string-append out "/share/doc/"
370 ,name))
371 (dot-dic ,(string-append "speller/" language ".dic")))
372 (mkdir-p myspell)
373
374 ;; Usually there's only a 'LANGUAGE.dic' file, but for the "en"
375 ;; dictionary, there no 'en.dic'. Instead, there's a set of
376 ;; 'en*.dic' files, hence the 'find-files' call below.
377 (if (file-exists? dot-dic)
378 (install-file dot-dic hunspell)
379 (for-each (lambda (dic)
380 (install-file dic hunspell))
381 (find-files "speller"
382 ,(string-append language ".*\\.dic$"))))
383
384 (install-file ,(string-append "speller/" language ".aff")
385 hunspell)
386 (symlink hunspell (string-append myspell "/dicts"))
387 (for-each (lambda (file)
388 (install-file file doc))
389 (find-files "."
390 "^(Copyright|.*\\.(txt|org|md))$"))
391 #t))))))
392 (synopsis synopsis)
393 (description
394 "This package provides a dictionary for the Hunspell spell-checking
395 library.")
396 (home-page "http://wordlist.aspell.net/")
397 (license (non-copyleft "file://Copyright"
398 "Word lists come from several sources, all
399 under permissive licensing terms. See the 'Copyright' file."))))
400
401 (define-syntax define-word-list-dictionary
402 (syntax-rules (synopsis)
403 ((_ name language (synopsis text))
404 (define-public name
405 (aspell-word-list language text)))
406 ((_ name language nick (synopsis text))
407 (define-public name
408 (aspell-word-list language text nick)))))
409
410 (define-word-list-dictionary hunspell-dict-en
411 "en"
412 (synopsis "Hunspell dictionary for English"))
413
414 (define-word-list-dictionary hunspell-dict-en-au
415 "en_AU"
416 (synopsis "Hunspell dictionary for Australian English"))
417
418 (define-word-list-dictionary hunspell-dict-en-ca
419 "en_CA"
420 (synopsis "Hunspell dictionary for Canadian English"))
421
422 (define-word-list-dictionary hunspell-dict-en-gb
423 "en_GB-ise" "en-gb"
424 (synopsis "Hunspell dictionary for British English, with -ise endings"))
425
426 (define-word-list-dictionary hunspell-dict-en-gb-ize
427 "en_GB-ize"
428 (synopsis "Hunspell dictionary for British English, with -ize endings"))
429
430 (define-word-list-dictionary hunspell-dict-en-us
431 "en_US"
432 (synopsis "Hunspell dictionary for United States English"))