gnu: python2-fastlmm: Disable tests.
[jackhill/guix/guix.git] / gnu / packages / machine-learning.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
5 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
6 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
8 ;;; Copyright © 2018 Mark Meyer <mark@ofosos.org>
9 ;;; Copyright © 2018 Ben Woodcroft <donttrustben@gmail.com>
10 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
11 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
12 ;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages machine-learning)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix packages)
32 #:use-module (guix utils)
33 #:use-module (guix download)
34 #:use-module (guix svn-download)
35 #:use-module (guix build-system cmake)
36 #:use-module (guix build-system gnu)
37 #:use-module (guix build-system ocaml)
38 #:use-module (guix build-system python)
39 #:use-module (guix build-system r)
40 #:use-module (guix git-download)
41 #:use-module (gnu packages)
42 #:use-module (gnu packages algebra)
43 #:use-module (gnu packages autotools)
44 #:use-module (gnu packages boost)
45 #:use-module (gnu packages check)
46 #:use-module (gnu packages compression)
47 #:use-module (gnu packages cran)
48 #:use-module (gnu packages dejagnu)
49 #:use-module (gnu packages gcc)
50 #:use-module (gnu packages image)
51 #:use-module (gnu packages maths)
52 #:use-module (gnu packages mpi)
53 #:use-module (gnu packages ocaml)
54 #:use-module (gnu packages onc-rpc)
55 #:use-module (gnu packages perl)
56 #:use-module (gnu packages pkg-config)
57 #:use-module (gnu packages python)
58 #:use-module (gnu packages python-xyz)
59 #:use-module (gnu packages statistics)
60 #:use-module (gnu packages swig)
61 #:use-module (gnu packages xml)
62 #:use-module (gnu packages xorg))
63
64 (define-public fann
65 ;; The last release is >100 commits behind, so we package from git.
66 (let ((commit "d71d54788bee56ba4cf7522801270152da5209d7"))
67 (package
68 (name "fann")
69 (version (string-append "2.2.0-1." (string-take commit 8)))
70 (source (origin
71 (method git-fetch)
72 (uri (git-reference
73 (url "https://github.com/libfann/fann.git")
74 (commit commit)))
75 (file-name (string-append name "-" version "-checkout"))
76 (sha256
77 (base32
78 "0ibwpfrjs6q2lijs8slxjgzb2llcl6rk3v2ski4r6215g5jjhg3x"))))
79 (build-system cmake-build-system)
80 (arguments
81 `(#:phases
82 (modify-phases %standard-phases
83 (replace 'check
84 (lambda* (#:key outputs #:allow-other-keys)
85 (let* ((out (assoc-ref outputs "out")))
86 (with-directory-excursion (string-append (getcwd) "/tests")
87 (invoke "./fann_tests"))))))))
88 (home-page "http://leenissen.dk/fann/wp/")
89 (synopsis "Fast Artificial Neural Network")
90 (description
91 "FANN is a free open source neural network library, which implements
92 multilayer artificial neural networks in C with support for both fully
93 connected and sparsely connected networks.")
94 (license license:lgpl2.1))))
95
96 (define-public libsvm
97 (package
98 (name "libsvm")
99 (version "3.22")
100 (source
101 (origin
102 (method url-fetch)
103 (uri (string-append "https://www.csie.ntu.edu.tw/~cjlin/libsvm/"
104 name "-" version ".tar.gz"))
105 (sha256
106 (base32
107 "0zd7s19y5vb7agczl6456bn45cj1y64739sslaskw1qk7dywd0bd"))))
108 (build-system gnu-build-system)
109 (arguments
110 `(#:tests? #f ;no "check" target
111 #:phases (modify-phases %standard-phases
112 (delete 'configure)
113 (replace
114 'install ; no ‘install’ target
115 (lambda* (#:key outputs #:allow-other-keys)
116 (let* ((out (assoc-ref outputs "out"))
117 (bin (string-append out "/bin/")))
118 (mkdir-p bin)
119 (for-each (lambda (file)
120 (copy-file file (string-append bin file)))
121 '("svm-train"
122 "svm-predict"
123 "svm-scale")))
124 #t)))))
125 (home-page "http://www.csie.ntu.edu.tw/~cjlin/libsvm/")
126 (synopsis "Library for Support Vector Machines")
127 (description
128 "LIBSVM is a machine learning library for support vector
129 classification, (C-SVC, nu-SVC), regression (epsilon-SVR, nu-SVR) and
130 distribution estimation (one-class SVM). It supports multi-class
131 classification.")
132 (license license:bsd-3)))
133
134 (define-public python-libsvm
135 (package (inherit libsvm)
136 (name "python-libsvm")
137 (build-system gnu-build-system)
138 (arguments
139 `(#:tests? #f ;no "check" target
140 #:make-flags '("-C" "python")
141 #:phases
142 (modify-phases %standard-phases
143 (delete 'configure)
144 (replace
145 'install ; no ‘install’ target
146 (lambda* (#:key inputs outputs #:allow-other-keys)
147 (let ((site (string-append (assoc-ref outputs "out")
148 "/lib/python"
149 (string-take
150 (string-take-right
151 (assoc-ref inputs "python") 5) 3)
152 "/site-packages/")))
153 (substitute* "python/svm.py"
154 (("../libsvm.so.2") "libsvm.so.2"))
155 (mkdir-p site)
156 (for-each (lambda (file)
157 (copy-file file (string-append site (basename file))))
158 (find-files "python" "\\.py"))
159 (copy-file "libsvm.so.2"
160 (string-append site "libsvm.so.2")))
161 #t)))))
162 (inputs
163 `(("python" ,python)))
164 (synopsis "Python bindings of libSVM")))
165
166 (define-public ghmm
167 ;; The latest release candidate is several years and a couple of fixes have
168 ;; been published since. This is why we download the sources from the SVN
169 ;; repository.
170 (let ((svn-revision 2341))
171 (package
172 (name "ghmm")
173 (version (string-append "0.9-rc3-0." (number->string svn-revision)))
174 (source (origin
175 (method svn-fetch)
176 (uri (svn-reference
177 (url "http://svn.code.sf.net/p/ghmm/code/trunk")
178 (revision svn-revision)))
179 (file-name (string-append name "-" version))
180 (sha256
181 (base32
182 "0qbq1rqp94l530f043qzp8aw5lj7dng9wq0miffd7spd1ff638wq"))))
183 (build-system gnu-build-system)
184 (arguments
185 `(#:imported-modules (,@%gnu-build-system-modules
186 (guix build python-build-system))
187 #:phases
188 (modify-phases %standard-phases
189 (add-after 'unpack 'enter-dir
190 (lambda _ (chdir "ghmm") #t))
191 (delete 'check)
192 (add-after 'install 'check
193 (assoc-ref %standard-phases 'check))
194 (add-before 'check 'fix-PYTHONPATH
195 (lambda* (#:key inputs outputs #:allow-other-keys)
196 (let ((python-version ((@@ (guix build python-build-system)
197 get-python-version)
198 (assoc-ref inputs "python"))))
199 (setenv "PYTHONPATH"
200 (string-append (getenv "PYTHONPATH")
201 ":" (assoc-ref outputs "out")
202 "/lib/python" python-version
203 "/site-packages")))
204 #t))
205 (add-after 'enter-dir 'fix-runpath
206 (lambda* (#:key outputs #:allow-other-keys)
207 (substitute* "ghmmwrapper/setup.py"
208 (("^(.*)extra_compile_args = \\[" line indent)
209 (string-append indent
210 "extra_link_args = [\"-Wl,-rpath="
211 (assoc-ref outputs "out") "/lib\"],\n"
212 line
213 "\"-Wl,-rpath="
214 (assoc-ref outputs "out")
215 "/lib\", ")))
216 #t))
217 (add-after 'enter-dir 'disable-broken-tests
218 (lambda _
219 (substitute* "tests/Makefile.am"
220 ;; GHMM_SILENT_TESTS is assumed to be a command.
221 (("TESTS_ENVIRONMENT.*") "")
222 ;; Do not build broken tests.
223 (("chmm .*") "")
224 (("read_fa .*") "")
225 (("mcmc .*") "")
226 (("label_higher_order_test.*$")
227 "label_higher_order_test\n"))
228
229 ;; These Python unittests are broken as there is no gato.
230 ;; See https://sourceforge.net/p/ghmm/support-requests/3/
231 (substitute* "ghmmwrapper/ghmmunittests.py"
232 (("^(.*)def (testNewXML|testMultipleTransitionClasses|testNewXML)"
233 line indent)
234 (string-append indent
235 "@unittest.skip(\"Disabled by Guix\")\n"
236 line)))
237 #t))
238 (add-after 'disable-broken-tests 'autogen
239 (lambda _
240 (invoke "bash" "autogen.sh"))))))
241 (inputs
242 `(("python" ,python-2) ; only Python 2 is supported
243 ("libxml2" ,libxml2)))
244 (native-inputs
245 `(("pkg-config" ,pkg-config)
246 ("dejagnu" ,dejagnu)
247 ("swig" ,swig)
248 ("autoconf" ,autoconf)
249 ("automake" ,automake)
250 ("libtool" ,libtool)))
251 (home-page "http://ghmm.org")
252 (synopsis "Hidden Markov Model library")
253 (description
254 "The General Hidden Markov Model library (GHMM) is a C library with
255 additional Python bindings implementing a wide range of types of @dfn{Hidden
256 Markov Models} (HMM) and algorithms: discrete, continuous emissions, basic
257 training, HMM clustering, HMM mixtures.")
258 (license license:lgpl2.0+))))
259
260 (define-public mcl
261 (package
262 (name "mcl")
263 (version "14.137")
264 (source (origin
265 (method url-fetch)
266 (uri (string-append
267 "http://micans.org/mcl/src/mcl-"
268 (string-replace-substring version "." "-")
269 ".tar.gz"))
270 (sha256
271 (base32
272 "15xlax3z31lsn62vlg94hkm75nm40q4679amnfg13jm8m2bnhy5m"))))
273 (build-system gnu-build-system)
274 (arguments
275 `(#:configure-flags (list "--enable-blast")))
276 (inputs
277 `(("perl" ,perl)))
278 (home-page "http://micans.org/mcl/")
279 (synopsis "Clustering algorithm for graphs")
280 (description
281 "The MCL algorithm is short for the @dfn{Markov Cluster Algorithm}, a
282 fast and scalable unsupervised cluster algorithm for graphs (also known as
283 networks) based on simulation of (stochastic) flow in graphs.")
284 ;; In the LICENCE file and web page it says "The software is licensed
285 ;; under the GNU General Public License, version 3.", but in several of
286 ;; the source code files it suggests GPL3 or later.
287 ;; http://listserver.ebi.ac.uk/pipermail/mcl-users/2016/000376.html
288 (license license:gpl3)))
289
290 (define-public ocaml-mcl
291 (package
292 (name "ocaml-mcl")
293 (version "12-068oasis4")
294 (source
295 (origin
296 (method url-fetch)
297 (uri (string-append
298 "https://github.com/fhcrc/mcl/archive/"
299 version ".tar.gz"))
300 (file-name (string-append name "-" version ".tar.gz"))
301 (sha256
302 (base32
303 "1l5jbhwjpsj38x8b9698hfpkv75h8hn3kj0gihjhn8ym2cwwv110"))))
304 (build-system ocaml-build-system)
305 (arguments
306 `(#:ocaml ,ocaml-4.02
307 #:findlib ,ocaml4.02-findlib
308 #:phases
309 (modify-phases %standard-phases
310 (add-before 'configure 'patch-paths
311 (lambda _
312 (substitute* "configure"
313 (("SHELL = /bin/sh") (string-append "SHELL = "(which "sh"))))
314 (substitute* "setup.ml"
315 (("LDFLAGS=-fPIC")
316 (string-append "LDFLAGS=-fPIC\"; \"SHELL=" (which "sh"))))
317 #t)))))
318 (home-page "https://github.com/fhcrc/mcl")
319 (synopsis "OCaml wrappers around MCL")
320 (description
321 "This package provides OCaml bindings for the MCL graph clustering
322 algorithm.")
323 (license license:gpl3)))
324
325 (define-public randomjungle
326 (package
327 (name "randomjungle")
328 (version "2.1.0")
329 (source
330 (origin
331 (method url-fetch)
332 (uri (string-append
333 "https://www.imbs.uni-luebeck.de/fileadmin/files/Software"
334 "/randomjungle/randomjungle-" version ".tar_.gz"))
335 (patches (search-patches "randomjungle-disable-static-build.patch"))
336 (sha256
337 (base32
338 "12c8rf30cla71swx2mf4ww9mfd8jbdw5lnxd7dxhyw1ygrvg6y4w"))))
339 (build-system gnu-build-system)
340 (arguments
341 `(#:configure-flags
342 (list "--disable-static"
343 (string-append "--with-boost="
344 (assoc-ref %build-inputs "boost")))
345 #:phases
346 (modify-phases %standard-phases
347 (add-before
348 'configure 'set-CXXFLAGS
349 (lambda _
350 (setenv "CXXFLAGS" "-fpermissive ")
351 #t)))))
352 (inputs
353 `(("boost" ,boost)
354 ("gsl" ,gsl)
355 ("libxml2" ,libxml2)
356 ("zlib" ,zlib)))
357 (native-inputs
358 `(("gfortran" ,gfortran)
359 ("gfortran:lib" ,gfortran "lib")))
360 ;; Non-portable assembly instructions are used so building fails on
361 ;; platforms other than x86_64 or i686.
362 (supported-systems '("x86_64-linux" "i686-linux"))
363 (home-page "https://www.imbs.uni-luebeck.de/forschung/software/details.html#c224")
364 (synopsis "Implementation of the Random Forests machine learning method")
365 (description
366 "Random Jungle is an implementation of Random Forests. It is supposed to
367 analyse high dimensional data. In genetics, it can be used for analysing big
368 Genome Wide Association (GWA) data. Random Forests is a powerful machine
369 learning method. Most interesting features are variable selection, missing
370 value imputation, classifier creation, generalization error estimation and
371 sample proximities between pairs of cases.")
372 (license license:gpl3+)))
373
374 (define-public shogun
375 (package
376 (name "shogun")
377 (version "6.1.3")
378 (source
379 (origin
380 (method url-fetch)
381 (uri (string-append
382 "ftp://shogun-toolbox.org/shogun/releases/"
383 (version-major+minor version)
384 "/sources/shogun-" version ".tar.bz2"))
385 (sha256
386 (base32
387 "1rn9skm3nw6hr7mr3lgp2gfqhi7ii0lyxck7qmqnf8avq349s5jp"))
388 (modules '((guix build utils)
389 (ice-9 rdelim)))
390 (snippet
391 '(begin
392 ;; Remove non-free sources and files referencing them
393 (for-each delete-file
394 (find-files "src/shogun/classifier/svm/"
395 "SVMLight\\.(cpp|h)"))
396 (for-each delete-file
397 (find-files "examples/undocumented/libshogun/"
398 (string-append
399 "(classifier_.*svmlight.*|"
400 "evaluation_cross_validation_locked_comparison).cpp")))
401 ;; Remove non-free functions.
402 (define (delete-ifdefs file)
403 (with-atomic-file-replacement file
404 (lambda (in out)
405 (let loop ((line (read-line in 'concat))
406 (skipping? #f))
407 (if (eof-object? line)
408 #t
409 (let ((skip-next?
410 (or (and skipping?
411 (not (string-prefix?
412 "#endif //USE_SVMLIGHT" line)))
413 (string-prefix?
414 "#ifdef USE_SVMLIGHT" line))))
415 (when (or (not skipping?)
416 (and skipping? (not skip-next?)))
417 (display line out))
418 (loop (read-line in 'concat) skip-next?)))))))
419 (for-each delete-ifdefs
420 (append
421 (find-files "src/shogun/classifier/mkl"
422 "^MKLClassification\\.cpp")
423 (find-files "src/shogun/classifier/svm"
424 "^SVMLightOneClass\\.(cpp|h)")
425 (find-files "src/shogun/multiclass"
426 "^ScatterSVM\\.(cpp|h)")
427 (find-files "src/shogun/kernel/"
428 "^(Kernel|CombinedKernel|ProductKernel)\\.(cpp|h)")
429 (find-files "src/shogun/regression/svr"
430 "^(MKLRegression|SVRLight)\\.(cpp|h)")
431 (find-files "src/shogun/transfer/domain_adaptation"
432 "^DomainAdaptationSVM\\.(cpp|h)")))
433 #t))))
434 (build-system cmake-build-system)
435 (arguments
436 '(#:tests? #f ;no check target
437 #:phases
438 (modify-phases %standard-phases
439 (add-after 'unpack 'delete-broken-symlinks
440 (lambda _
441 (for-each delete-file '("applications/arts/data"
442 "applications/asp/data"
443 "applications/easysvm/data"
444 "applications/msplicer/data"
445 "applications/ocr/data"
446 "examples/meta/data"
447 "examples/undocumented/data"))
448 #t))
449 (add-after 'unpack 'change-R-target-path
450 (lambda* (#:key outputs #:allow-other-keys)
451 (substitute* '("src/interfaces/r/CMakeLists.txt"
452 "examples/meta/r/CMakeLists.txt")
453 (("\\$\\{R_COMPONENT_LIB_PATH\\}")
454 (string-append (assoc-ref outputs "out")
455 "/lib/R/library/")))
456 #t))
457 (add-after 'unpack 'fix-octave-modules
458 (lambda* (#:key outputs #:allow-other-keys)
459 (substitute* "src/interfaces/octave/CMakeLists.txt"
460 (("^include_directories\\(\\$\\{OCTAVE_INCLUDE_DIRS\\}")
461 "include_directories(${OCTAVE_INCLUDE_DIRS} ${OCTAVE_INCLUDE_DIRS}/octave")
462 ;; change target directory
463 (("\\$\\{OCTAVE_OCT_LOCAL_API_FILE_DIR\\}")
464 (string-append (assoc-ref outputs "out")
465 "/share/octave/packages")))
466 (substitute* '("src/interfaces/octave/swig_typemaps.i"
467 "src/interfaces/octave/sg_print_functions.cpp")
468 ;; "octave/config.h" and "octave/oct-obj.h" deprecated in Octave.
469 (("octave/config\\.h") "octave/octave-config.h")
470 (("octave/oct-obj.h") "octave/ovl.h"))
471 #t))
472 (add-after 'unpack 'move-rxcpp
473 (lambda* (#:key inputs #:allow-other-keys)
474 (let ((rxcpp-dir "shogun/third-party/rxcpp"))
475 (mkdir-p rxcpp-dir)
476 (install-file (assoc-ref inputs "rxcpp") rxcpp-dir)
477 #t)))
478 (add-before 'build 'set-HOME
479 ;; $HOME needs to be set at some point during the build phase
480 (lambda _ (setenv "HOME" "/tmp") #t)))
481 #:configure-flags
482 (list "-DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE"
483 "-DUSE_SVMLIGHT=OFF" ;disable proprietary SVMLIGHT
484 "-DBUILD_META_EXAMPLES=OFF" ;requires unpackaged ctags
485 ;;"-DINTERFACE_JAVA=ON" ;requires unpackaged jblas
486 ;;"-DINTERFACE_RUBY=ON" ;requires unpackaged ruby-narray
487 ;;"-DINTERFACE_PERL=ON" ;"FindPerlLibs" does not exist
488 ;;"-DINTERFACE_LUA=ON" ;fails because lua doesn't build pkgconfig file
489 "-DINTERFACE_OCTAVE=ON"
490 "-DINTERFACE_PYTHON=ON"
491 "-DINTERFACE_R=ON")))
492 (inputs
493 `(("python" ,python)
494 ("numpy" ,python-numpy)
495 ("r-minimal" ,r-minimal)
496 ("octave" ,octave-cli)
497 ("swig" ,swig)
498 ("eigen" ,eigen)
499 ("hdf5" ,hdf5)
500 ("atlas" ,atlas)
501 ("arpack" ,arpack-ng)
502 ("lapack" ,lapack)
503 ("glpk" ,glpk)
504 ("libxml2" ,libxml2)
505 ("lzo" ,lzo)
506 ("zlib" ,zlib)))
507 (native-inputs
508 `(("pkg-config" ,pkg-config)
509 ("rxcpp" ,rxcpp)))
510 ;; Non-portable SSE instructions are used so building fails on platforms
511 ;; other than x86_64.
512 (supported-systems '("x86_64-linux"))
513 (home-page "http://shogun-toolbox.org/")
514 (synopsis "Machine learning toolbox")
515 (description
516 "The Shogun Machine learning toolbox provides a wide range of unified and
517 efficient Machine Learning (ML) methods. The toolbox seamlessly allows to
518 combine multiple data representations, algorithm classes, and general purpose
519 tools. This enables both rapid prototyping of data pipelines and extensibility
520 in terms of new algorithms.")
521 (license license:gpl3+)))
522
523 (define-public rxcpp
524 (package
525 (name "rxcpp")
526 (version "4.0.0")
527 (source
528 (origin
529 (method url-fetch)
530 (uri (string-append "https://github.com/ReactiveX/RxCpp/archive/v"
531 version ".tar.gz"))
532 (sha256
533 (base32
534 "0y2isr8dy2n1yjr9c5570kpc9lvdlch6jv0jvw000amwn5d3krsh"))
535 (file-name (string-append name "-" version ".tar.gz"))))
536 (build-system cmake-build-system)
537 (arguments
538 `(#:phases
539 (modify-phases %standard-phases
540 (add-after 'unpack 'remove-werror
541 (lambda _
542 (substitute* (find-files ".")
543 (("-Werror") ""))
544 #t))
545 (replace 'check
546 (lambda _
547 (invoke "ctest"))))))
548 (native-inputs
549 `(("catch" ,catch-framework)))
550 (home-page "http://reactivex.io/")
551 (synopsis "Reactive Extensions for C++")
552 (description
553 "The Reactive Extensions for C++ (RxCpp) is a library of algorithms for
554 values-distributed-in-time. ReactiveX is a library for composing asynchronous
555 and event-based programs by using observable sequences.
556
557 It extends the observer pattern to support sequences of data and/or events and
558 adds operators that allow you to compose sequences together declaratively while
559 abstracting away concerns about things like low-level threading,
560 synchronization, thread-safety, concurrent data structures, and non-blocking
561 I/O.")
562 (license license:asl2.0)))
563
564 (define-public r-adaptivesparsity
565 (package
566 (name "r-adaptivesparsity")
567 (version "1.6")
568 (source (origin
569 (method url-fetch)
570 (uri (cran-uri "AdaptiveSparsity" version))
571 (sha256
572 (base32
573 "0imr5m8mll9j6n4icsv6z9rl5kbnwsp9wvzrg7n90nnmcxq2cz91"))))
574 (properties
575 `((upstream-name . "AdaptiveSparsity")))
576 (build-system r-build-system)
577 (arguments
578 `(#:phases
579 (modify-phases %standard-phases
580 (add-after 'unpack 'link-against-armadillo
581 (lambda _
582 (substitute* "src/Makevars"
583 (("PKG_LIBS=" prefix)
584 (string-append prefix "-larmadillo"))))))))
585 (propagated-inputs
586 `(("r-mass" ,r-mass)
587 ("r-matrix" ,r-matrix)
588 ("r-rcpp" ,r-rcpp)
589 ("r-rcpparmadillo" ,r-rcpparmadillo)))
590 (inputs
591 `(("armadillo" ,armadillo)))
592 (home-page "https://cran.r-project.org/web/packages/AdaptiveSparsity")
593 (synopsis "Adaptive sparsity models")
594 (description
595 "This package implements the Figueiredo machine learning algorithm for
596 adaptive sparsity and the Wong algorithm for adaptively sparse gaussian
597 geometric models.")
598 (license license:lgpl3+)))
599
600 (define-public r-kernlab
601 (package
602 (name "r-kernlab")
603 (version "0.9-27")
604 (source
605 (origin
606 (method url-fetch)
607 (uri (cran-uri "kernlab" version))
608 (sha256
609 (base32
610 "1m0xqf6gyvwayz7w3c83y32ayvnlz0jicj8ijk808zq9sh7dbbgn"))))
611 (build-system r-build-system)
612 (home-page "https://cran.r-project.org/web/packages/kernlab")
613 (synopsis "Kernel-based machine learning tools")
614 (description
615 "This package provides kernel-based machine learning methods for
616 classification, regression, clustering, novelty detection, quantile regression
617 and dimensionality reduction. Among other methods @code{kernlab} includes
618 Support Vector Machines, Spectral Clustering, Kernel PCA, Gaussian Processes
619 and a QP solver.")
620 (license license:gpl2)))
621
622 (define-public dlib
623 (package
624 (name "dlib")
625 (version "19.7")
626 (source (origin
627 (method url-fetch)
628 (uri (string-append
629 "http://dlib.net/files/dlib-" version ".tar.bz2"))
630 (sha256
631 (base32
632 "1mljz02kwkrbggyncxv5fpnyjdybw2qihaacb3js8yfkw12vwpc2"))
633 (modules '((guix build utils)))
634 (snippet
635 '(begin
636 ;; Delete ~13MB of bundled dependencies.
637 (delete-file-recursively "dlib/external")
638 (delete-file-recursively "docs/dlib/external")
639 #t))))
640 (build-system cmake-build-system)
641 (arguments
642 `(#:phases
643 (modify-phases %standard-phases
644 (add-after 'unpack 'disable-asserts
645 (lambda _
646 ;; config.h recommends explicitly enabling or disabling asserts
647 ;; when building as a shared library. By default neither is set.
648 (substitute* "dlib/config.h"
649 (("^//#define DLIB_DISABLE_ASSERTS") "#define DLIB_DISABLE_ASSERTS"))
650 #t))
651 (add-after 'disable-asserts 'disable-failing-tests
652 (lambda _
653 ;; One test times out on MIPS, so we need to disable it.
654 ;; Others are flaky on some platforms.
655 (let* ((system ,(or (%current-target-system)
656 (%current-system)))
657 (disabled-tests (cond
658 ((string-prefix? "mips64" system)
659 '("object_detector" ; timeout
660 "data_io"))
661 ((string-prefix? "armhf" system)
662 '("learning_to_track"))
663 ((string-prefix? "i686" system)
664 '("optimization"))
665 (else '()))))
666 (for-each
667 (lambda (test)
668 (substitute* "dlib/test/makefile"
669 (((string-append "SRC \\+= " test "\\.cpp")) "")))
670 disabled-tests)
671 #t)))
672 (replace 'check
673 (lambda _
674 ;; No test target, so we build and run the unit tests here.
675 (let ((test-dir (string-append "../dlib-" ,version "/dlib/test")))
676 (with-directory-excursion test-dir
677 (invoke "make" "-j" (number->string (parallel-job-count)))
678 (invoke "./dtest" "--runall"))
679 #t)))
680 (add-after 'install 'delete-static-library
681 (lambda* (#:key outputs #:allow-other-keys)
682 (delete-file (string-append (assoc-ref outputs "out")
683 "/lib/libdlib.a"))
684 #t)))))
685 (native-inputs
686 `(("pkg-config" ,pkg-config)
687 ;; For tests.
688 ("libnsl" ,libnsl)))
689 (inputs
690 `(("giflib" ,giflib)
691 ("lapack" ,lapack)
692 ("libjpeg" ,libjpeg)
693 ("libpng" ,libpng)
694 ("libx11" ,libx11)
695 ("openblas" ,openblas)
696 ("zlib" ,zlib)))
697 (synopsis
698 "Toolkit for making machine learning and data analysis applications in C++")
699 (description
700 "Dlib is a modern C++ toolkit containing machine learning algorithms and
701 tools. It is used in both industry and academia in a wide range of domains
702 including robotics, embedded devices, mobile phones, and large high performance
703 computing environments.")
704 (home-page "http://dlib.net")
705 (license license:boost1.0)))
706
707 (define-public python-scikit-learn
708 (package
709 (name "python-scikit-learn")
710 (version "0.20.1")
711 (source
712 (origin
713 (method git-fetch)
714 (uri (git-reference
715 (url "https://github.com/scikit-learn/scikit-learn.git")
716 (commit version)))
717 (file-name (git-file-name name version))
718 (sha256
719 (base32
720 "0fkhwg3xn1s7ln9q1szq6kwc4jhwvjh8w4kmv9wcrqy7cq3lbv0d"))))
721 (build-system python-build-system)
722 (arguments
723 `(#:phases
724 (modify-phases %standard-phases
725 (add-after 'build 'build-ext
726 (lambda _ (invoke "python" "setup.py" "build_ext" "--inplace") #t))
727 (replace 'check
728 (lambda _
729 ;; Restrict OpenBLAS threads to prevent segfaults while testing!
730 (setenv "OPENBLAS_NUM_THREADS" "1")
731
732 ;; Some tests require write access to $HOME.
733 (setenv "HOME" "/tmp")
734
735 (invoke "pytest" "sklearn" "-m" "not network")))
736 ;; FIXME: This fails with permission denied
737 (delete 'reset-gzip-timestamps))))
738 (inputs
739 `(("openblas" ,openblas)))
740 (native-inputs
741 `(("python-pytest" ,python-pytest)
742 ("python-pandas" ,python-pandas) ;for tests
743 ("python-cython" ,python-cython)))
744 (propagated-inputs
745 `(("python-numpy" ,python-numpy)
746 ("python-scipy" ,python-scipy)))
747 (home-page "http://scikit-learn.org/")
748 (synopsis "Machine Learning in Python")
749 (description
750 "Scikit-learn provides simple and efficient tools for data mining and
751 data analysis.")
752 (license license:bsd-3)))
753
754 (define-public python2-scikit-learn
755 (package-with-python2 python-scikit-learn))
756
757 (define-public python-autograd
758 (let* ((commit "442205dfefe407beffb33550846434baa90c4de7")
759 (revision "0")
760 (version (git-version "0.0.0" revision commit)))
761 (package
762 (name "python-autograd")
763 (home-page "https://github.com/HIPS/autograd")
764 (source (origin
765 (method git-fetch)
766 (uri (git-reference
767 (url home-page)
768 (commit commit)))
769 (sha256
770 (base32
771 "189sv2xb0mwnjawa9z7mrgdglc1miaq93pnck26r28fi1jdwg0z4"))
772 (file-name (git-file-name name version))))
773 (version version)
774 (build-system python-build-system)
775 (native-inputs
776 `(("python-nose" ,python-nose)
777 ("python-pytest" ,python-pytest)))
778 (propagated-inputs
779 `(("python-future" ,python-future)
780 ("python-numpy" ,python-numpy)))
781 (arguments
782 `(#:phases (modify-phases %standard-phases
783 (replace 'check
784 (lambda _
785 (invoke "py.test" "-v"))))))
786 (synopsis "Efficiently computes derivatives of NumPy code")
787 (description "Autograd can automatically differentiate native Python and
788 NumPy code. It can handle a large subset of Python's features, including loops,
789 ifs, recursion and closures, and it can even take derivatives of derivatives
790 of derivatives. It supports reverse-mode differentiation
791 (a.k.a. backpropagation), which means it can efficiently take gradients of
792 scalar-valued functions with respect to array-valued arguments, as well as
793 forward-mode differentiation, and the two can be composed arbitrarily. The
794 main intended application of Autograd is gradient-based optimization.")
795 (license license:expat))))
796
797 (define-public python2-autograd
798 (package-with-python2 python-autograd))
799
800 (define-public lightgbm
801 (package
802 (name "lightgbm")
803 (version "2.0.12")
804 (source (origin
805 (method url-fetch)
806 (uri (string-append
807 "https://github.com/Microsoft/LightGBM/archive/v"
808 version ".tar.gz"))
809 (sha256
810 (base32
811 "132zf0yk0545mg72hyzxm102g3hpb6ixx9hnf8zd2k55gas6cjj1"))
812 (file-name (string-append name "-" version ".tar.gz"))))
813 (native-inputs
814 `(("python-pytest" ,python-pytest)
815 ("python-nose" ,python-nose)))
816 (inputs
817 `(("openmpi" ,openmpi)))
818 (propagated-inputs
819 `(("python-numpy" ,python-numpy)
820 ("python-scipy" ,python-scipy)))
821 (arguments
822 `(#:configure-flags
823 '("-DUSE_MPI=ON")
824 #:phases
825 (modify-phases %standard-phases
826 (replace 'check
827 (lambda* (#:key outputs #:allow-other-keys)
828 (with-directory-excursion ,(string-append "../LightGBM-" version)
829 (invoke "pytest" "tests/c_api_test/test_.py")))))))
830 (build-system cmake-build-system)
831 (home-page "https://github.com/Microsoft/LightGBM")
832 (synopsis "Gradient boosting framework based on decision tree algorithms")
833 (description "LightGBM is a gradient boosting framework that uses tree
834 based learning algorithms. It is designed to be distributed and efficient with
835 the following advantages:
836
837 @itemize
838 @item Faster training speed and higher efficiency
839 @item Lower memory usage
840 @item Better accuracy
841 @item Parallel and GPU learning supported (not enabled in this package)
842 @item Capable of handling large-scale data
843 @end itemize\n")
844 (license license:expat)))
845
846 (define-public vowpal-wabbit
847 ;; Language bindings not included.
848 (package
849 (name "vowpal-wabbit")
850 (version "8.5.0")
851 (source (origin
852 (method url-fetch)
853 (uri (string-append
854 "https://github.com/JohnLangford/vowpal_wabbit/archive/"
855 version ".tar.gz"))
856 (sha256
857 (base32
858 "0clp2kb7rk5sckhllxjr5a651awf4s8dgzg4659yh4hf5cqnf0gr"))
859 (file-name (string-append name "-" version ".tar.gz"))))
860 (inputs
861 `(("boost" ,boost)
862 ("zlib" ,zlib)))
863 (arguments
864 `(#:configure-flags
865 (list (string-append "--with-boost="
866 (assoc-ref %build-inputs "boost")))))
867 (build-system gnu-build-system)
868 (home-page "https://github.com/JohnLangford/vowpal_wabbit")
869 (synopsis "Fast machine learning library for online learning")
870 (description "Vowpal Wabbit is a machine learning system with techniques
871 such as online, hashing, allreduce, reductions, learning2search, active, and
872 interactive learning.")
873 (license license:bsd-3)))
874
875 (define-public python2-fastlmm
876 (package
877 (name "python2-fastlmm")
878 (version "0.2.21")
879 (source
880 (origin
881 (method url-fetch)
882 (uri (pypi-uri "fastlmm" version ".zip"))
883 (sha256
884 (base32
885 "1q8c34rpmwkfy3r4d5172pzdkpfryj561897z9r3x22gq7813x1m"))))
886 (build-system python-build-system)
887 (arguments
888 `(#:tests? #f ; some test files are missing
889 #:python ,python-2)) ; only Python 2.7 is supported
890 (propagated-inputs
891 `(("python2-numpy" ,python2-numpy)
892 ("python2-scipy" ,python2-scipy)
893 ("python2-matplotlib" ,python2-matplotlib)
894 ("python2-pandas" ,python2-pandas)
895 ("python2-scikit-learn" ,python2-scikit-learn)
896 ("python2-pysnptools" ,python2-pysnptools)))
897 (native-inputs
898 `(("unzip" ,unzip)
899 ("python2-cython" ,python2-cython)
900 ("python2-mock" ,python2-mock)
901 ("python2-nose" ,python2-nose)))
902 (home-page "http://research.microsoft.com/en-us/um/redmond/projects/mscompbio/fastlmm/")
903 (synopsis "Perform genome-wide association studies on large data sets")
904 (description
905 "FaST-LMM, which stands for Factored Spectrally Transformed Linear Mixed
906 Models, is a program for performing both single-SNP and SNP-set genome-wide
907 association studies (GWAS) on extremely large data sets.")
908 (license license:asl2.0)))