Merge branch 'staging' into wip-lisp
[jackhill/guix/guix.git] / gnu / packages / gl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013 Joshua Grant <tadni@riseup.net>
4 ;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
5 ;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2016 Nikita <nikita@n0.is>
7 ;;; Copyright © 2016, 2017, 2018, 2020 Ricardo Wurmus <rekado@elephly.net>
8 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
9 ;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
10 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
11 ;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
12 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
13 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
14 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
15 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
16 ;;;
17 ;;; This file is part of GNU Guix.
18 ;;;
19 ;;; GNU Guix is free software; you can redistribute it and/or modify it
20 ;;; under the terms of the GNU General Public License as published by
21 ;;; the Free Software Foundation; either version 3 of the License, or (at
22 ;;; your option) any later version.
23 ;;;
24 ;;; GNU Guix is distributed in the hope that it will be useful, but
25 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
26 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
27 ;;; GNU General Public License for more details.
28 ;;;
29 ;;; You should have received a copy of the GNU General Public License
30 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
31
32 (define-module (gnu packages gl)
33 #:use-module (gnu packages)
34 #:use-module (gnu packages autotools)
35 #:use-module (gnu packages bison)
36 #:use-module (gnu packages compression)
37 #:use-module (gnu packages documentation)
38 #:use-module (gnu packages elf)
39 #:use-module (gnu packages flex)
40 #:use-module (gnu packages fontutils)
41 #:use-module (gnu packages freedesktop)
42 #:use-module (gnu packages gettext)
43 #:use-module (gnu packages guile)
44 #:use-module (gnu packages image)
45 #:use-module (gnu packages linux)
46 #:use-module (gnu packages llvm)
47 #:use-module (gnu packages mono)
48 #:use-module (gnu packages pkg-config)
49 #:use-module (gnu packages python)
50 #:use-module (gnu packages python-xyz)
51 #:use-module (gnu packages tls)
52 #:use-module (gnu packages video)
53 #:use-module (gnu packages vulkan)
54 #:use-module (gnu packages xdisorg)
55 #:use-module (gnu packages xml)
56 #:use-module (gnu packages xorg)
57 #:use-module (guix download)
58 #:use-module (guix git-download)
59 #:use-module (guix hg-download)
60 #:use-module (guix build-system gnu)
61 #:use-module (guix build-system cmake)
62 #:use-module (guix build-system meson)
63 #:use-module ((guix licenses) #:prefix license:)
64 #:use-module (guix packages)
65 #:use-module (guix utils)
66 #:use-module (ice-9 match)
67 #:use-module ((srfi srfi-1) #:hide (zip)))
68
69 (define-public glu
70 (package
71 (name "glu")
72 (version "9.0.1")
73 (source (origin
74 (method url-fetch)
75 (uri (string-append "ftp://ftp.freedesktop.org/pub/mesa/glu/glu-"
76 version ".tar.gz"))
77 (sha256
78 (base32
79 "1xqhk9bn10nbvffw3r4p4rjslwz1l7gaycc0x2pqkr2irp7q9x7n"))))
80 (build-system gnu-build-system)
81 (propagated-inputs
82 `(("mesa" ,mesa))) ; according to glu.pc
83 (home-page "http://www.opengl.org/archives/resources/faq/technical/glu.htm")
84 (synopsis "Mesa OpenGL Utility library")
85 (description
86 "GLU, or OpenGL Utility Library provides some higher-level functionality
87 not provided by just OpenGL itself. Some of GLU's Features
88 include: Scaling of 2D images and creation of mipmap pyramids,
89 Transformation of object coordinates into device coordinates and
90 vice versa, Support for NURBS surfaces, Support for tessellation
91 of concave or bow tie polygonal primitives, Specialty transformation
92 matrices for creating perspective and orthographic projections,
93 positioning a camera, and selection/picking, Rendering of disk,
94 cylinder, and sphere primitives, Interpreting OpenGL error values
95 as ASCII text.")
96 (license (license:x11-style "http://directory.fsf.org/wiki/License:SGIFreeBv2"))))
97
98 (define-public freeglut
99 (package
100 (name "freeglut")
101 (version "3.2.1")
102 (source (origin
103 (method url-fetch)
104 (uri (string-append
105 "mirror://sourceforge/freeglut/freeglut/"
106 version "/freeglut-" version ".tar.gz"))
107 (sha256
108 (base32
109 "0s6sk49q8ijgbsrrryb7dzqx2fa744jhx1wck5cz5jia2010w06l"))))
110 (build-system cmake-build-system)
111 (arguments
112 '(#:tests? #f ;no test target
113 #:configure-flags '("-DFREEGLUT_BUILD_STATIC_LIBS=OFF")))
114 (inputs `(("libx11" ,libx11)
115 ("libxi" ,libxi)
116 ("libxrandr" ,libxrandr)
117 ("libxxf86vm" ,libxxf86vm)))
118 (propagated-inputs
119 ;; Headers from Mesa and GLU are needed.
120 `(("glu" ,glu)
121 ("mesa" ,mesa)))
122 (home-page "http://freeglut.sourceforge.net/")
123 (synopsis "Alternative to the OpenGL Utility Toolkit (GLUT)")
124 (description
125 "Freeglut is a completely Free/OpenSourced alternative to
126 the OpenGL Utility Toolkit (GLUT) library. GLUT was originally
127 written by Mark Kilgard to support the sample programs in the
128 second edition OpenGL @code{RedBook}. Since then, GLUT has been used
129 in a wide variety of practical applications because it is simple,
130 widely available and highly portable.
131
132 GLUT (and hence freeglut) allows the user to create and manage windows
133 containing OpenGL contexts on a wide range of platforms and also read
134 the mouse, keyboard and joystick functions. Freeglut is released under
135 the X-Consortium license.")
136 (license license:x11)))
137
138 ;; Needed for "kiki".
139 (define-public freeglut-2.8
140 (package (inherit freeglut)
141 (name "freeglut")
142 (version "2.8.1")
143 (source (origin
144 (method url-fetch)
145 (uri (string-append
146 "mirror://sourceforge/freeglut/freeglut/"
147 version "/freeglut-" version ".tar.gz"))
148 (sha256
149 (base32
150 "16lrxxxd9ps9l69y3zsw6iy0drwjsp6m26d1937xj71alqk6dr6x"))))
151 (build-system gnu-build-system)
152 (arguments
153 '(#:configure-flags '("--disable-static")))))
154
155 (define-public ftgl
156 (package
157 (name "ftgl")
158 (version "2.4.0")
159 (home-page "https://github.com/frankheckenbach/ftgl")
160 (source (origin
161 (method git-fetch)
162 (uri (git-reference (url home-page)
163 (commit (string-append "v" version))))
164 (file-name (git-file-name name version))
165 (sha256
166 (base32
167 "0zjs1h9w30gajq9lndzvjsa26rsmr1081lb1fbpbj10yhcdcsc79"))))
168 (build-system gnu-build-system)
169 (arguments
170 `(#:configure-flags '("--disable-static")))
171 ;; The pkg-config file lists "freetype2" as Requires.private.
172 (propagated-inputs `(("freetype" ,freetype)))
173 (inputs `(("libx11" ,libx11)
174 ("mesa" ,mesa)
175 ("glu" ,glu)))
176 (native-inputs
177 `(("pkg-config" ,pkg-config)
178 ("autoconf" ,autoconf)
179 ("automake" ,automake)
180 ("libtool" ,libtool)))
181 (synopsis "Font rendering library for OpenGL applications")
182 (description
183 "FTGL is a font rendering library for OpenGL applications. Supported
184 rendering modes are: Bitmaps, Anti-aliased pixmaps, Texture maps, Outlines,
185 Polygon meshes, and Extruded polygon meshes.")
186 (license license:x11)))
187
188 (define-public s2tc
189 (package
190 (name "s2tc")
191 (version "1.0")
192 (source
193 (origin
194 (method git-fetch)
195 (uri (git-reference
196 (url "https://github.com/divVerent/s2tc")
197 (commit (string-append "v" version))))
198 (file-name (git-file-name name version))
199 (sha256
200 (base32 "1fg323fk7wlv2xh6lw66wswgcv6qi8aaadk7c28h2f2lj1s7njnf"))))
201 (build-system gnu-build-system)
202 (native-inputs
203 `(("autoconf" ,autoconf)
204 ("automake" ,automake)
205 ("libtool" ,libtool)))
206 (inputs
207 `(("mesa-headers" ,mesa-headers)))
208 (home-page "https://github.com/divVerent/s2tc")
209 (synopsis "S3 Texture Compression implementation")
210 (description
211 "S2TC is a patent-free implementation of S3 Texture Compression (S3TC,
212 also known as DXTn or DXTC) for Mesa.")
213 (license license:expat)))
214
215 ;;; Mesa needs LibVA headers to build its Gallium-based VA API implementation;
216 ;;; LibVA itself depends on Mesa. We use the following to solve the circular
217 ;;; dependency.
218 (define libva-without-mesa
219 ;; Delay to work around circular import problem.
220 (delay
221 (package
222 (inherit libva)
223 (name "libva-without-mesa")
224 (inputs `(,@(fold alist-delete (package-inputs libva)
225 '("mesa" "wayland"))))
226 (arguments
227 (strip-keyword-arguments
228 '(#:make-flags)
229 (substitute-keyword-arguments (package-arguments libva)
230 ((#:configure-flags flags)
231 '(list "--disable-glx" "--disable-egl"))))))))
232
233 (define-public mesa
234 (package
235 (name "mesa")
236 (version "20.1.4")
237 (source
238 (origin
239 (method url-fetch)
240 (uri (list (string-append "https://mesa.freedesktop.org/archive/"
241 "mesa-" version ".tar.xz")
242 (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
243 "mesa-" version ".tar.xz")
244 (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
245 version "/mesa-" version ".tar.xz")))
246 (sha256
247 (base32
248 "1zlrczmmkcy42w332rfmlicihlnrxmkrnkpb21sl98725cf2f038"))
249 (patches
250 (search-patches "mesa-skip-disk-cache-test.patch"))))
251 (build-system meson-build-system)
252 (propagated-inputs
253 `(;; The following are in the Requires.private field of gl.pc.
254 ("libdrm" ,libdrm)
255 ("libvdpau" ,libvdpau)
256 ("libx11" ,libx11)
257 ("libxdamage" ,libxdamage)
258 ("libxfixes" ,libxfixes)
259 ("libxshmfence" ,libxshmfence)
260 ("libxxf86vm" ,libxxf86vm)
261 ("xorgproto" ,xorgproto)))
262 (inputs
263 `(("expat" ,expat)
264 ("libelf" ,elfutils) ;required for r600 when using llvm
265 ("libva" ,(force libva-without-mesa))
266 ("libxml2" ,libxml2)
267 ;; TODO: Add 'libxml2-python' for OpenGL ES 1.1 and 2.0 support
268 ("libxrandr" ,libxrandr)
269 ("libxvmc" ,libxvmc)
270 ,@(match (%current-system)
271 ((or "x86_64-linux" "i686-linux")
272 ;; Note: update the 'clang' input of mesa-opencl when bumping this.
273 `(("llvm" ,llvm-10)))
274 (_
275 `()))
276 ("wayland" ,wayland)
277 ("wayland-protocols" ,wayland-protocols)))
278 (native-inputs
279 `(("bison" ,bison)
280 ("flex" ,flex)
281 ("gettext" ,gettext-minimal)
282 ,@(match (%current-system)
283 ((or "x86_64-linux" "i686-linux")
284 `(("glslang" ,glslang)))
285 (_
286 `()))
287 ("pkg-config" ,pkg-config)
288 ("python" ,python-wrapper)
289 ("python-mako" ,python-mako)
290 ("which" ,(@ (gnu packages base) which))))
291 (outputs '("out" "bin"))
292 (arguments
293 `(#:configure-flags
294 '(,@(match (%current-system)
295 ((or "armhf-linux" "aarch64-linux")
296 ;; TODO: Fix svga driver for aarch64 and armhf.
297 '("-Dgallium-drivers=etnaviv,freedreno,kmsro,lima,nouveau,panfrost,r300,r600,swrast,tegra,v3d,vc4,virgl"))
298 (_
299 '("-Dgallium-drivers=iris,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
300 ;; Enable various optional features. TODO: opencl requires libclc,
301 ;; omx requires libomxil-bellagio
302 "-Dplatforms=x11,drm,surfaceless,wayland"
303 "-Dglx=dri" ;Thread Local Storage, improves performance
304 ;; "-Dopencl=true"
305 ;; "-Domx=true"
306 "-Dosmesa=gallium"
307 "-Dgallium-xa=true"
308
309 ;; features required by wayland
310 "-Dgles2=true"
311 "-Dgbm=true"
312 "-Dshared-glapi=true"
313
314 ;; Enable Vulkan on i686-linux and x86-64-linux.
315 ,@(match (%current-system)
316 ((or "i686-linux" "x86_64-linux")
317 '("-Dvulkan-drivers=intel,amd"))
318 (_
319 '("-Dvulkan-drivers=auto")))
320
321 ;; Enable the Vulkan overlay layer on i686-linux and x86-64-linux.
322 ,@(match (%current-system)
323 ((or "x86_64-linux" "i686-linux")
324 '("-Dvulkan-overlay-layer=true"))
325 (_
326 '()))
327
328 ;; Also enable the tests.
329 "-Dbuild-tests=true"
330
331 ;; on non-intel systems, drop i915 and i965
332 ;; from the default dri drivers
333 ,@(match (%current-system)
334 ((or "x86_64-linux" "i686-linux")
335 '("-Ddri-drivers=i915,i965,nouveau,r200,r100"
336 "-Dllvm=true")) ; default is x86/x86_64 only
337 (_
338 '("-Ddri-drivers=nouveau,r200,r100"))))
339
340 ;; XXX: 'debugoptimized' causes LTO link failures on some drivers. The
341 ;; documentation recommends using 'release' for performance anyway.
342 #:build-type "release"
343
344 #:modules ((ice-9 match)
345 (srfi srfi-1)
346 (guix build utils)
347 (guix build meson-build-system))
348 #:phases
349 (modify-phases %standard-phases
350 ,@(if (string-prefix? "i686" (or (%current-target-system)
351 (%current-system)))
352 ;; Disable new test from Mesa 19 that fails on i686. Upstream
353 ;; report: <https://bugs.freedesktop.org/show_bug.cgi?id=110612>.
354 `((add-after 'unpack 'disable-failing-test
355 (lambda _
356 (substitute* "src/util/tests/format/meson.build"
357 (("'u_format_test',") ""))
358 #t)))
359 '())
360 (add-before 'configure 'fix-dlopen-libnames
361 (lambda* (#:key inputs outputs #:allow-other-keys)
362 (let ((out (assoc-ref outputs "out")))
363 ;; Remain agnostic to .so.X.Y.Z versions while doing
364 ;; the substitutions so we're future-safe.
365 (substitute* "src/glx/meson.build"
366 (("-DGL_LIB_NAME=\"lib@0@\\.so\\.@1@\"")
367 (string-append "-DGL_LIB_NAME=\"" out
368 "/lib/lib@0@.so.@1@\"")))
369 (substitute* "src/gbm/backends/dri/gbm_dri.c"
370 (("\"libglapi\\.so")
371 (string-append "\"" out "/lib/libglapi.so")))
372 (substitute* "src/gbm/main/backend.c"
373 ;; No need to patch the gbm_gallium_drm.so reference;
374 ;; it's never installed since Mesa removed its
375 ;; egl_gallium support.
376 (("\"gbm_dri\\.so")
377 (string-append "\"" out "/lib/dri/gbm_dri.so")))
378 #t)))
379 (add-after 'install 'split-outputs
380 (lambda* (#:key outputs #:allow-other-keys)
381 (let ((out (assoc-ref outputs "out"))
382 (bin (assoc-ref outputs "bin")))
383 ,@(match (%current-system)
384 ((or "i686-linux" "x86_64-linux")
385 ;; Install the Vulkan overlay control script to a separate
386 ;; output to prevent a reference on Python, saving ~70 MiB
387 ;; on the closure size.
388 '((copy-recursively (string-append out "/bin")
389 (string-append bin "/bin"))
390 (delete-file-recursively (string-append out "/bin"))))
391 (_
392 ;; XXX: On architectures without the Vulkan overlay layer
393 ;; just create an empty file because outputs can not be
394 ;; added conditionally.
395 '((mkdir-p (string-append bin "/bin"))
396 (call-with-output-file (string-append bin "/bin/.empty")
397 (const #t)))))
398 #t)))
399 (add-after 'install 'symlinks-instead-of-hard-links
400 (lambda* (#:key outputs #:allow-other-keys)
401 ;; All the drivers and gallium targets create hard links upon
402 ;; installation (search for "hardlink each megadriver instance"
403 ;; in the makefiles). This is no good for us since we'd produce
404 ;; nars that contain several copies of these files. Thus, turn
405 ;; them into symlinks, which saves ~124 MiB.
406 (let* ((out (assoc-ref outputs "out"))
407 (lib (string-append out "/lib"))
408 (files (find-files lib
409 (lambda (file stat)
410 (and (string-contains file ".so")
411 (eq? 'regular
412 (stat:type stat))))))
413 (inodes (map (compose stat:ino stat) files)))
414 (for-each (lambda (inode)
415 (match (filter-map (match-lambda
416 ((file ino)
417 (and (= ino inode) file)))
418 (zip files inodes))
419 ((_)
420 #f)
421 ((reference others ..1)
422 (format #t "creating ~a symlinks to '~a'~%"
423 (length others) reference)
424 (for-each delete-file others)
425 (for-each (lambda (file)
426 (if (string=? (dirname file)
427 (dirname reference))
428 (symlink (basename reference)
429 file)
430 (symlink reference file)))
431 others))))
432 (delete-duplicates inodes))
433 #t))))))
434 (home-page "https://mesa3d.org/")
435 (synopsis "OpenGL and Vulkan implementations")
436 (description "Mesa is a free implementation of the OpenGL and Vulkan
437 specifications - systems for rendering interactive 3D graphics. A variety of
438 device drivers allows Mesa to be used in many different environments ranging
439 from software emulation to complete hardware acceleration for modern GPUs.")
440 (license license:x11)))
441
442 (define-public mesa-opencl
443 (package/inherit mesa
444 (name "mesa-opencl")
445 (arguments
446 (substitute-keyword-arguments (package-arguments mesa)
447 ((#:configure-flags flags)
448 `(cons "-Dgallium-opencl=standalone" ,flags))))
449 (inputs
450 `(("libclc" ,libclc)
451 ,@(package-inputs mesa)))
452 (native-inputs
453 `(("clang" ,clang-10)
454 ,@(package-native-inputs mesa)))))
455
456 (define-public mesa-opencl-icd
457 (package/inherit mesa-opencl
458 (name "mesa-opencl-icd")
459 (arguments
460 (substitute-keyword-arguments (package-arguments mesa)
461 ((#:configure-flags flags)
462 `(cons "-Dgallium-opencl=icd"
463 ,(delete "-Dgallium-opencl=standalone" flags)))))))
464
465 (define-public mesa-headers
466 (package/inherit mesa
467 (name "mesa-headers")
468 (propagated-inputs '())
469 (inputs '())
470 (native-inputs '())
471 (outputs '("out"))
472 (arguments
473 '(#:phases
474 (modify-phases %standard-phases
475 (delete 'configure)
476 (delete 'build)
477 (delete 'check)
478 (replace 'install
479 (lambda* (#:key outputs #:allow-other-keys)
480 (copy-recursively "include" (string-append
481 (assoc-ref outputs "out")
482 "/include"))
483 #t)))))))
484
485 ;;; The mesa-demos distribution contains non-free files, many files with no
486 ;;; clear license information, and many demos that aren't useful for most
487 ;;; people, so we just use this for the mesa-utils package below, and possibly
488 ;;; other packages in the future. This is modeled after Debian's solution.
489 (define (mesa-demos-source version)
490 (origin
491 (method url-fetch)
492 (uri (string-append "ftp://ftp.freedesktop.org/pub/mesa/demos"
493 "/mesa-demos-" version ".tar.bz2"))
494 (sha256 (base32 "0zgzbz55a14hz83gbmm0n9gpjnf5zadzi2kjjvkn6khql2a9rs81"))))
495
496 (define-public mesa-utils
497 (package
498 (name "mesa-utils")
499 (version "8.4.0")
500 (source (mesa-demos-source version))
501 (build-system gnu-build-system)
502 (inputs
503 `(("mesa" ,mesa)
504 ("glut" ,freeglut)
505 ("glew" ,glew)))
506 (native-inputs
507 `(("pkg-config" ,pkg-config)))
508 (arguments
509 '(#:phases
510 (modify-phases %standard-phases
511 (replace
512 'install
513 (lambda* (#:key outputs #:allow-other-keys)
514 (let ((out (assoc-ref outputs "out")))
515 (mkdir-p (string-append out "/bin"))
516 (for-each
517 (lambda (file)
518 (copy-file file (string-append out "/bin/" (basename file))))
519 '("src/xdemos/glxdemo" "src/xdemos/glxgears"
520 "src/xdemos/glxinfo" "src/xdemos/glxheads"))
521 #t))))))
522 (home-page "https://mesa3d.org/")
523 (synopsis "Utility tools for Mesa")
524 (description
525 "The mesa-utils package contains several utility tools for Mesa: glxdemo,
526 glxgears, glxheads, and glxinfo.")
527 ;; glxdemo is public domain; others expat.
528 (license (list license:expat license:public-domain))))
529
530 (define-public glew
531 (package
532 (name "glew")
533 (version "2.1.0")
534 (source (origin
535 (method url-fetch)
536 (uri (string-append "mirror://sourceforge/glew/glew/" version
537 "/glew-" version ".tgz"))
538 (sha256
539 (base32
540 "159wk5dc0ykjbxvag5i1m2mhp23zkk6ra04l26y3jc3nwvkr3ph4"))
541 (modules '((guix build utils)))
542 (snippet
543 '(begin
544 (substitute* "config/Makefile.linux"
545 (("= cc") "= gcc")
546 (("/lib64") "/lib"))
547 #t))))
548 (build-system gnu-build-system)
549 (arguments
550 '(#:phases (modify-phases %standard-phases (delete 'configure))
551 #:make-flags (list (string-append "GLEW_PREFIX="
552 (assoc-ref %outputs "out"))
553 (string-append "GLEW_DEST="
554 (assoc-ref %outputs "out")))
555 #:tests? #f)) ;no 'check' target
556 (inputs
557 `(("libxi" ,libxi)
558 ("libxmu" ,libxmu)
559 ("libx11" ,libx11)
560 ("mesa" ,mesa)))
561
562 ;; <GL/glew.h> includes <GL/glu.h>.
563 (propagated-inputs `(("glu" ,glu)))
564
565 (home-page "http://glew.sourceforge.net/")
566 (synopsis "OpenGL extension loading library for C and C++")
567 (description
568 "The OpenGL Extension Wrangler Library (GLEW) is a C/C++ extension
569 loading library. GLEW provides efficient run-time mechanisms for determining
570 which OpenGL extensions are supported on the target platform. OpenGL core and
571 extension functionality is exposed in a single header file.")
572 (license license:bsd-3)))
573
574 (define-public guile-opengl
575 (package
576 (name "guile-opengl")
577 (version "0.1.0")
578 (source (origin
579 (method url-fetch)
580 (uri (string-append "mirror://gnu/guile-opengl/guile-opengl-"
581 version ".tar.gz"))
582 (sha256
583 (base32
584 "13qfx4xh8baryxqrv986l848ygd0piqwm6s2s90pxk9c0m9vklim"))))
585 (build-system gnu-build-system)
586 (native-inputs `(("pkg-config" ,pkg-config)))
587 (inputs `(("guile" ,guile-2.2)
588 ("mesa" ,mesa)
589 ("glu" ,glu)
590 ("freeglut" ,freeglut)))
591 (arguments
592 '(#:phases (modify-phases %standard-phases
593 (add-after 'configure 'patch-makefile
594 (lambda _
595 ;; Install compiled Guile files in the expected place.
596 (substitute* '("Makefile")
597 (("^godir = .*$")
598 "godir = $(moddir)\n"))))
599 (add-before 'build 'patch-dynamic-link
600 (lambda* (#:key inputs outputs #:allow-other-keys)
601 (define (dynamic-link-substitute file lib input)
602 (substitute* file
603 (("dynamic-link \"lib([a-zA-Z]+)\"" _ lib)
604 (string-append "dynamic-link \""
605 (assoc-ref inputs input)
606 "/lib/lib" lib "\""))))
607 ;; Replace dynamic-link calls for libGL, libGLU, and
608 ;; libglut with absolute paths to the store.
609 (dynamic-link-substitute "glx/runtime.scm" "GL" "mesa")
610 (dynamic-link-substitute "glu/runtime.scm" "GLU" "glu")
611 (dynamic-link-substitute "glut/runtime.scm" "glut"
612 "freeglut"))))))
613 (home-page "https://gnu.org/s/guile-opengl")
614 (synopsis "Guile binding for the OpenGL graphics API")
615 (description
616 "Guile-OpenGL is a library for Guile that provides bindings to the
617 OpenGL graphics API.")
618 (license license:lgpl3+)))
619
620 (define-public guile3.0-opengl
621 (package
622 (inherit guile-opengl)
623 (name "guile3.0-opengl")
624 (arguments
625 (substitute-keyword-arguments (package-arguments guile-opengl)
626 ((#:phases phases)
627 `(modify-phases ,phases
628 (add-after 'unpack 'build-with-guile-3.0
629 (lambda _
630 (substitute* "configure"
631 (("_guile_versions_to_search=\"")
632 "_guile_versions_to_search=\"3.0 "))
633 #t))))))
634 (inputs
635 `(("guile" ,guile-3.0)
636 ("mesa" ,mesa)
637 ("glu" ,glu)
638 ("freeglut" ,freeglut)))))
639
640 (define-public libepoxy
641 (package
642 (name "libepoxy")
643 (version "1.5.4")
644 (source (origin
645 (method url-fetch)
646 (uri (string-append
647 "https://github.com/anholt/libepoxy/releases/download/"
648 version "/libepoxy-" version ".tar.xz"))
649 (sha256
650 (base32
651 "1ll9fach4v30dsyd47s5ial4gaiwihzr2afb77vxxzzy3mlcrlhb"))))
652 (arguments
653 `(#:phases
654 (modify-phases %standard-phases
655 (delete 'bootstrap)
656 (add-before
657 'configure 'patch-paths
658 (lambda* (#:key inputs #:allow-other-keys)
659 (let ((python (assoc-ref inputs "python"))
660 (mesa (assoc-ref inputs "mesa")))
661 (substitute* "src/gen_dispatch.py"
662 (("/usr/bin/env python") python))
663 (substitute* (find-files "." "\\.[ch]$")
664 (("libGL.so.1") (string-append mesa "/lib/libGL.so.1"))
665 (("libEGL.so.1") (string-append mesa "/lib/libEGL.so.1")))
666 #t))))))
667 (build-system meson-build-system)
668 (native-inputs
669 `(("pkg-config" ,pkg-config)
670 ("python" ,python)))
671 (inputs
672 `(("mesa" ,mesa)))
673 (home-page "https://github.com/anholt/libepoxy/")
674 (synopsis "A library for handling OpenGL function pointer management")
675 (description
676 "A library for handling OpenGL function pointer management.")
677 (license license:x11)))
678
679 (define-public libglvnd
680 (package
681 (name "libglvnd")
682 (version "1.3.2")
683 (home-page "https://gitlab.freedesktop.org/glvnd/libglvnd")
684 (source (origin
685 (method git-fetch)
686 (uri (git-reference
687 (url home-page)
688 (commit (string-append "v" version))))
689 (file-name (git-file-name name version))
690 (sha256
691 (base32
692 "10x7fgb114r4gikdg6flszl3kwzcb9y5qa7sj9936mk0zxhjaylz"))))
693 (build-system meson-build-system)
694 (arguments
695 '(#:configure-flags '("-Dx11=enabled")
696 #:phases (modify-phases %standard-phases
697 (add-after 'unpack 'disable-glx-tests
698 (lambda _
699 ;; This package is meant to be used alongside Mesa.
700 ;; To avoid a circular dependency, disable tests that
701 ;; require a running Xorg server.
702 (substitute* "tests/meson.build"
703 (("if with_glx")
704 "if false"))
705 #t)))))
706 (native-inputs
707 `(("pkg-config" ,pkg-config)))
708 (inputs
709 `(("libx11" ,libx11)
710 ("libxext" ,libxext)
711 ("xorgproto" ,xorgproto)))
712 (synopsis "Vendor-neutral OpenGL dispatch library")
713 (description
714 "libglvnd is a vendor-neutral dispatch layer for arbitrating OpenGL
715 API calls between multiple vendors. It allows multiple drivers from
716 different vendors to coexist on the same filesystem, and determines which
717 vendor to dispatch each API call to at runtime.
718
719 Both GLX and EGL are supported, in any combination with OpenGL and OpenGL ES.")
720 ;; libglvnd is available under a custom X11-style license, and incorporates
721 ;; code with various other licenses. See README.md for details.
722 (license (list (license:x11-style "file://README.md")
723 license:x11
724 license:expat))))
725
726 (define-public soil
727 (package
728 (name "soil")
729 (version "1.0.7")
730 (source (origin
731 (method url-fetch)
732 ;; No versioned archive available.
733 (uri "http://www.lonesock.net/files/soil.zip")
734 (sha256
735 (base32
736 "00gpwp9dldzhsdhksjvmbhsd2ialraqbv6v6dpikdmpncj6mnc52"))))
737 (build-system gnu-build-system)
738 (arguments
739 '(#:tests? #f ; no tests
740 #:phases (modify-phases %standard-phases
741 (delete 'configure)
742 (add-before 'build 'init-build
743 (lambda* (#:key outputs #:allow-other-keys)
744 (let ((out (assoc-ref outputs "out")))
745 (setenv "CFLAGS" "-fPIC") ; needed for shared library
746 ;; Use alternate Makefile
747 (copy-file "projects/makefile/alternate Makefile.txt"
748 "src/Makefile")
749 (chdir "src")
750 (substitute* '("Makefile")
751 (("INCLUDEDIR = /usr/include/SOIL")
752 (string-append "INCLUDEDIR = " out "/include/SOIL"))
753 (("LIBDIR = /usr/lib")
754 (string-append "LIBDIR = " out "/lib"))
755 ;; Remove these flags from 'install' commands.
756 (("-o root -g root") ""))))))))
757 (native-inputs
758 `(("unzip" ,unzip)))
759 (inputs
760 `(("mesa" ,mesa)))
761 (home-page "https://www.lonesock.net/soil.html")
762 (synopsis "OpenGL texture loading library")
763 (description
764 "SOIL is a tiny C library used primarily for uploading textures into
765 OpenGL.")
766 (license license:public-domain)))
767
768 (define-public glfw
769 (package
770 (name "glfw")
771 (version "3.2.1")
772 (source (origin
773 (method url-fetch)
774 (uri (string-append "https://github.com/glfw/glfw"
775 "/releases/download/" version
776 "/glfw-" version ".zip"))
777 (sha256
778 (base32
779 "09kk5yc1zhss9add8ryqrngrr16hdmc94rszgng135bhw09mxmdp"))))
780 (build-system cmake-build-system)
781 (arguments
782 '(#:tests? #f ; no test target
783 #:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
784 (native-inputs
785 `(("doxygen" ,doxygen)
786 ("unzip" ,unzip)))
787 (propagated-inputs
788 `(("mesa" ,mesa) ;included in public headers
789
790 ;; These are in 'Requires.private' of 'glfw3.pc'.
791 ("libx11" ,libx11)
792 ("libxrandr" ,libxrandr)
793 ("libxinerama" ,libxinerama)
794 ("libxcursor" ,libxcursor)
795 ("libxxf86vm" ,libxxf86vm)))
796 (home-page "https://www.glfw.org")
797 (synopsis "OpenGL application development library")
798 (description
799 "GLFW is a library for OpenGL, OpenGL ES and Vulkan development for
800 desktop computers. It provides a simple API for creating windows, contexts
801 and surfaces, receiving input and events.")
802 (license license:zlib)))
803
804 (define-public nanovg-for-extempore
805 (let ((version "0.7.1")
806 (revision "0")
807 (commit "3c60175fcc2e5fe305b04355cdce35d499c80310"))
808 (package
809 (name "nanovg-for-extempore")
810 (version (git-version version revision commit))
811 (source (origin
812 (method git-fetch)
813 (uri (git-reference
814 (url "https://github.com/extemporelang/nanovg")
815 (commit commit)))
816 (file-name (git-file-name name version))
817 (sha256
818 (base32
819 "0ddn3d3mxqn8hj9967v3pss7lz1wn08pcdnqzc118g7yjkq7hxzy"))))
820 (build-system cmake-build-system)
821 (arguments `(#:tests? #f)) ; no tests included
822 (inputs
823 `(("mesa" ,mesa)))
824 ;; Extempore refuses to build on architectures other than x86_64
825 (supported-systems '("x86_64-linux"))
826 (home-page "https://github.com/extemporelang/nanovg")
827 (synopsis "2D vector drawing library on top of OpenGL")
828 (description "NanoVG is small antialiased vector graphics rendering
829 library for OpenGL. It has lean API modeled after HTML5 canvas API. It is
830 aimed to be a practical and fun toolset for building scalable user interfaces
831 and visualizations.")
832 (license license:zlib))))
833
834 (define-public gl2ps
835 (package
836 (name "gl2ps")
837 (version "1.4.2")
838 (source
839 (origin
840 (method url-fetch)
841 (uri (string-append
842 "http://geuz.org/gl2ps/src/gl2ps-"
843 version ".tgz"))
844 (sha256
845 (base32 "1sgzv547h7hrskb9qd0x5yp45kmhvibjwj2mfswv95lg070h074d"))))
846 (build-system cmake-build-system)
847 (inputs
848 `(("libpng" ,libpng)
849 ("mesa" ,mesa)
850 ("zlib" ,zlib)))
851 (arguments
852 `(#:tests? #f)) ; no tests
853 (home-page "http://www.geuz.org/gl2ps/")
854 (synopsis "OpenGL to PostScript printing library")
855 (description "GL2PS is a C library providing high quality vector
856 output for any OpenGL application. GL2PS uses sorting algorithms
857 capable of handling intersecting and stretched polygons, as well as
858 non-manifold objects. GL2PS provides many features including advanced
859 smooth shading and text rendering, culling of invisible primitives and
860 mixed vector/bitmap output.")
861 ;; GL2PS is dual-licenced and can be used under the terms of either.
862 (license (list license:lgpl2.0+
863 (license:fsf-free "http://www.geuz.org/gl2ps/COPYING.GL2PS"
864 "GPL-incompatible copyleft license")))))
865
866 (define-public virtualgl
867 (package
868 (name "virtualgl")
869 (version "2.6.2")
870 (source
871 (origin
872 (method git-fetch)
873 (uri (git-reference
874 (url "https://github.com/VirtualGL/virtualgl")
875 (commit version)))
876 (file-name (git-file-name name version))
877 (sha256
878 (base32 "0yyc553xsb5n0rx7jp9p4wdbd7md07b3qrkf3ssyjavqqg908qg9"))))
879 (arguments
880 `(#:tests? #f ; no tests are available
881 #:configure-flags (list
882 (string-append "-DCMAKE_INSTALL_LIBDIR="
883 (assoc-ref %outputs "out") "/lib")
884 "-DVGL_USESSL=1"))) ; use OpenSSL
885 (build-system cmake-build-system)
886 (inputs `(("glu" ,glu)
887 ("libjpeg-turbo" ,libjpeg-turbo)
888 ("libxtst" ,libxtst)
889 ("mesa" ,mesa)
890 ("openssl" ,openssl)))
891 (native-inputs `(("pkg-config" ,pkg-config)))
892 (home-page "https://www.virtualgl.org")
893 (synopsis "Redirects 3D commands from an OpenGL application onto a 3D
894 graphics card")
895 (description "VirtualGL redirects the 3D rendering commands from OpenGL
896 applications to 3D accelerator hardware in a dedicated server and displays the
897 rendered output interactively to a thin client located elsewhere on the
898 network.")
899 (license license:wxwindows3.1+)))
900
901 (define-public mojoshader
902 (let ((changeset "5887634ea695"))
903 (package
904 (name "mojoshader")
905 (version (string-append "20190825" "-" changeset))
906 (source
907 (origin
908 (method hg-fetch)
909 (uri (hg-reference
910 (url "https://hg.icculus.org/icculus/mojoshader/")
911 (changeset changeset)))
912 (file-name (git-file-name name version))
913 (sha256
914 (base32 "0ibl4z1696jiifv9j5drir7jm0b5px0vwkwckbi7cfd46p7p6wcy"))))
915 (arguments
916 ;; Tests only for COMPILER_SUPPORT=ON.
917 `(#:tests? #f
918 #:configure-flags '("-DBUILD_SHARED=ON"
919 "-DFLIP_VIEWPORT=ON"
920 "-DDEPTH_CLIPPING=ON")
921 #:phases
922 (modify-phases %standard-phases
923 (replace 'install
924 (lambda* (#:key outputs #:allow-other-keys)
925 (let* ((out (assoc-ref outputs "out"))
926 (lib (string-append out "/lib"))
927 (header (string-append out "/include")))
928 (install-file "libmojoshader.so" lib)
929 (for-each (lambda (f)
930 (install-file f header))
931 (find-files "../source" "mojoshader.*\\.h$"))
932 (let ((profiles-header (string-append header "/profiles")))
933 (mkdir-p profiles-header)
934 (rename-file (string-append header "/mojoshader_profile.h")
935 (string-append profiles-header "/mojoshader_profile.h"))))
936 #t)))))
937 (build-system cmake-build-system)
938 (home-page "https://www.icculus.org/mojoshader/")
939 (synopsis "Work with Direct3D shaders on alternate 3D APIs")
940 (description "MojoShader is a library to work with Direct3D shaders on
941 alternate 3D APIs and non-Windows platforms. The primary motivation is moving
942 shaders to OpenGL languages on the fly. The developer deals with \"profiles\"
943 that represent various target languages, such as GLSL or ARB_*_program.
944
945 This allows a developer to manage one set of shaders, presumably written in
946 Direct3D HLSL, and use them across multiple rendering backends. This also
947 means that the developer only has to worry about one (offline) compiler to
948 manage program complexity, while MojoShader itself deals with the reduced
949 complexity of the bytecode at runtime.
950
951 MojoShader provides both a simple API to convert bytecode to various profiles,
952 and (optionally) basic glue to rendering APIs to abstract the management of
953 the shaders at runtime.")
954 (license license:zlib))))
955
956 (define-public mojoshader-with-viewport-flip
957 ;; Changeset c586d4590241 replaced glProgramViewportFlip with
958 ;; glProgramViewportInfo.
959 ;; https://hg.icculus.org/icculus/mojoshader/rev/c586d4590241
960 (let ((changeset "2e37299b13d8"))
961 (package
962 (inherit mojoshader)
963 (name "mojoshader-with-viewport-flip")
964 (version (string-append "20190725" "-" changeset))
965 (source
966 (origin
967 (method hg-fetch)
968 (uri (hg-reference
969 (url "https://hg.icculus.org/icculus/mojoshader/")
970 (changeset changeset)))
971 (file-name (git-file-name name version))
972 (sha256
973 (base32 "0ffws7cqbskxwc3hjsnnzq4r2bbf008kdr3b11pa3kr7dsi50y6i"))))
974 (synopsis "Work with Direct3D shaders on alternate 3D APIs (with viewport flip)")
975 (description "This is the last version of the mojoshader library with
976 the glProgramViewportFlip before it was replaced with glProgramViewportInfo.")
977 (license license:zlib))))
978
979 (define-public mojoshader-cs
980 (let ((commit "10d0dba21ff1cfe332eb7de328a2adce01286bd7"))
981 (package
982 (name "mojoshader-cs")
983 (version (git-version "20191205" "1" commit))
984 (source (origin
985 (method git-fetch)
986 (uri (git-reference
987 (url "https://github.com/FNA-XNA/MojoShader")
988 (commit commit)))
989 (file-name (git-file-name name version))
990 (sha256
991 (base32
992 "11mdhf3fmb9rsn2iv753gmb596j4dh5j2iipgw078vg0lj23rml7"))))
993 (build-system gnu-build-system)
994 (arguments
995 '(#:tests? #f ; No tests.
996 #:phases
997 (modify-phases %standard-phases
998 (delete 'configure)
999 (replace 'build
1000 (lambda _
1001 (invoke "make" "-C" "csharp")))
1002 (replace 'install
1003 (lambda* (#:key outputs #:allow-other-keys)
1004 (let ((out (assoc-ref outputs "out")))
1005 (install-file "csharp/bin/MojoShader-CS.dll" (string-append out "/lib"))
1006 #t))))))
1007 (native-inputs
1008 `(("mono" ,mono)))
1009 (home-page "https://github.com/FNA-XNA/MojoShader")
1010 (synopsis "C# wrapper for MojoShader")
1011 (description
1012 "Mojoshader-CS provides C# bindings for the Mojoshader library.
1013 The C# wrapper was written to be used for FNA's platform support. However, this
1014 is written in a way that can be used for any general C# application.")
1015 (license license:zlib))))