gnu: Add groff.
[jackhill/guix/guix.git] / gnu / packages / attr.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages attr)
21 #:use-module (guix licenses)
22 #:use-module (gnu packages perl)
23 #:use-module ((gnu packages gettext)
24 #:renamer (symbol-prefix-proc 'guix:))
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu))
28
29 (define-public attr
30 (package
31 (name "attr")
32 (version "2.4.46")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://savannah/attr/attr-"
37 version ".src.tar.gz"))
38 (sha256
39 (base32
40 "07qf6kb2zk512az481bbnsk9jycn477xpva1a726n5pzlzf9pmnw"))))
41 (build-system gnu-build-system)
42 (arguments
43 `(#:phases
44 (alist-cons-after
45 'configure 'patch-makefile-SHELL
46 (lambda _
47 (patch-makefile-SHELL "include/buildmacros"))
48 (alist-replace
49 'install
50 (lambda _
51 (zero? (system* "make"
52 "install"
53 "install-lib"
54 "install-dev")))
55 (alist-replace
56 'check
57 (lambda _
58 ;; Use the right shell.
59 (substitute* "test/run"
60 (("/bin/sh")
61 (which "bash")))
62
63 (system* "make" "tests" "-C" "test")
64
65 ;; XXX: Ignore the test result since this is dependent on the
66 ;; underlying file system.
67 #t)
68 %standard-phases)))))
69 (inputs `(("perl" ,perl)
70 ("gettext" ,guix:gettext)))
71 (home-page
72 "http://savannah.nongnu.org/projects/attr/")
73 (synopsis
74 "Library and tools for manipulating extended attributes")
75 (description
76 "Portable library and tools for manipulating extended attributes.")
77 (license '(gpl2+ lgpl2.1+))))