gnu: libical: Correct zoneinfo search path.
[jackhill/guix/guix.git] / gnu / packages / scanner.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages scanner)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages pkg-config)
25 #:use-module (gnu packages libusb)
26 #:use-module ((guix licenses)
27 #:prefix licence:))
28
29 (define-public sane-backends
30 (package
31 (name "sane-backends")
32 (version "1.0.24")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append
36 "https://alioth.debian.org/frs/download.php/file/3958/"
37 name "-" version ".tar.gz"))
38 (sha256
39 (base32
40 "0ba68m6bzni54axjk15i51rya7hfsdliwvqyan5msl7iaid0iir7"))))
41 (build-system gnu-build-system)
42 (native-inputs
43 `(("pkg-config" ,pkg-config)))
44 (inputs
45 `(("libusb-compat" ,libusb-compat)))
46 (arguments
47 `(#:tests? #f
48 #:phases
49 (modify-phases %standard-phases
50 (add-after
51 'install 'install-udev-rules
52 (lambda* (#:key outputs #:allow-other-keys)
53 (let ((out (assoc-ref outputs "out")))
54 (mkdir-p (string-append out "/lib/udev/rules.d"))
55 (copy-file "tools/udev/libsane.rules"
56 (string-append out
57 "/lib/udev/rules.d/"
58 "60-libsane.rules"))))))))
59 ;; It would seem that tests are not maintained - fails with
60 ;; the following:
61 ;;
62 ;; < This page was last updated on Wed Jul 31 07:52:48 2013
63 ;; < by sane-desc 3.5 from sane-backends 1.0.24git
64 ;; ---
65 ;; > This page was last updated on Sun Oct 19 15:41:39 2014
66 ;; > by sane-desc 3.5 from sane-backends 1.0.24
67 ;; **** File generated for html-backends-split mode is different from reference
68 ;; Makefile:501: recipe for target 'check.local' failed
69 (home-page "http://www.sane-project.org")
70 (synopsis "Raster image scanner library and drivers")
71 (description "SANE stands for \"Scanner Access Now Easy\" and is an API
72 proving access to any raster image scanner hardware (flatbed scanner,
73 hand-held scanner, video- and still-cameras, frame-grabbers, etc.). The
74 package contains the library and drivers.")
75 (license licence:gpl2+))) ; plus linking exception
76