Update name for Kei Kebreau.
[jackhill/guix/guix.git] / gnu / packages / dillo.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages dillo)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages compression)
24 #:use-module (gnu packages fltk)
25 #:use-module (gnu packages fontutils)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages image)
29 #:use-module (gnu packages tls)
30 #:use-module (gnu packages xorg)
31 #:use-module (guix download)
32 #:use-module (guix build-system gnu))
33
34 (define-public dillo
35 (package
36 (name "dillo")
37 (version "3.0.5")
38 (source (origin
39 (method url-fetch)
40 (uri (string-append "http://www.dillo.org/download/"
41 name "-" version ".tar.bz2"))
42 (sha256
43 (base32
44 "12ql8n1lypv3k5zqgwjxlw1md90ixz3ag6j1gghfnhjq3inf26yv"))))
45 (build-system gnu-build-system)
46 (arguments `(#:configure-flags '("--enable-ssl" "--enable-ipv6")))
47 (native-inputs `(("pkg-config" ,pkg-config)))
48 (inputs `(("fltk" ,fltk)
49 ("fontconfig" ,fontconfig)
50 ("libjpeg" ,libjpeg)
51 ("libpng" ,libpng)
52 ("libxcursor" ,libxcursor)
53 ("libxft" ,libxft)
54 ("libxi" ,libxi)
55 ("libxinerama" ,libxinerama)
56 ("openssl" ,openssl)
57 ("perl" ,perl)
58 ("zlib" ,zlib)))
59 (synopsis "Very small and fast graphical web browser")
60 (description "Dillo is a minimalistic web browser particularly intended for
61 older or slower computers and embedded systems.")
62 (home-page "http://www.dillo.org")
63 (license license:gpl3+)))