gnu: glib: Fix CVE-2021-27218 and CVE-2021-27219.
[jackhill/guix/guix.git] / gnu / packages / patches / cpufrequtils-fix-aclocal.patch
1 Add an extra layer of quoting to ltmain.sh sanity check.
2
3 --- a/configure 2005-05-07 14:19:31.000000000 +0200
4 +++ b/configure 2015-02-10 11:16:32.456146934 +0100
5 @@ -6266,7 +6266,7 @@
6 exit 1
7 fi
8 gentoo_lt_version="1.5.16"
9 -gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
10 +gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
11 if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
12 echo "$as_me:$LINENO: result: no" >&5
13 echo "${ECHO_T}no" >&6
14 --- a/aclocal.m4 2005-05-07 14:19:25.000000000 +0200
15 +++ b/aclocal.m4 2015-02-10 11:16:15.352030318 +0100
16 @@ -246,7 +246,7 @@
17 exit 1
18 fi
19 gentoo_lt_version="1.5.16"
20 -gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
21 +gentoo_ltmain_version=`[grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||']`
22 if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
23 AC_MSG_RESULT(no)
24 echo
25 --- a/libcpufreq/configure 2005-05-07 14:19:31.000000000 +0200
26 +++ b/libcpufreq/configure 2015-02-10 11:16:32.456146934 +0100
27 @@ -6266,7 +6266,7 @@
28 exit 1
29 fi
30 gentoo_lt_version="1.5.16"
31 -gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
32 +gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
33 if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
34 echo "$as_me:$LINENO: result: no" >&5
35 echo "${ECHO_T}no" >&6
36 --- a/libcpufreq/aclocal.m4 2005-05-07 14:19:25.000000000 +0200
37 +++ b/libcpufreq/aclocal.m4 2015-02-10 11:16:15.352030318 +0100
38 @@ -246,7 +246,7 @@
39 exit 1
40 fi
41 gentoo_lt_version="1.5.16"
42 -gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
43 +gentoo_ltmain_version=`[grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||']`
44 if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
45 AC_MSG_RESULT(no)
46 echo