gnu: glib: Fix CVE-2021-27218 and CVE-2021-27219.
[jackhill/guix/guix.git] / gnu / packages / patches / anki-mpv-args.patch
1 Modified from upstream commit:
2 https://github.com/ankitects/anki/commit/ccd715013609133c55e83924734efa78abc03326
3 Fixes mpv argument syntax (support for old syntax removed in mpv 0.31):
4 https://anki.tenderapp.com/discussions/ankidesktop/38186-mpvprocesserror-unable-to-start-process
5 Necessary because we are currently unable to upgrade anki to the
6 latest version in guix (NPM dependencies currently unpackaged).
7 ---
8 anki/mpv.py | 4 ++--
9 anki/sound.py | 1 -
10 2 files changed, 2 insertions(+), 3 deletions(-)
11
12 diff --git a/anki/mpv.py b/anki/mpv.py
13 index f53d9d0..563fddc 100644
14 --- a/anki/mpv.py
15 +++ b/anki/mpv.py
16 @@ -104,9 +104,9 @@ class MPVBase:
17 """
18 self.argv = [self.executable]
19 self.argv += self.default_argv
20 - self.argv += ["--input-ipc-server", self._sock_filename]
21 + self.argv += ["--input-ipc-server="+self._sock_filename]
22 if self.window_id is not None:
23 - self.argv += ["--wid", str(self.window_id)]
24 + self.argv += ["--wid="+str(self.window_id)]
25
26 def _start_process(self):
27 """Start the mpv process.
28 diff --git a/anki/sound.py b/anki/sound.py
29 index aa3431b..a5fce44 100644
30 --- a/anki/sound.py
31 +++ b/anki/sound.py
32 @@ -124,7 +124,6 @@ class MpvManager(MPV):
33 def setMpvConfigBase(base):
34 mpvConfPath = os.path.join(base, "mpv.conf")
35 MpvManager.default_argv += [
36 - "--no-config",
37 "--include="+mpvConfPath,
38 ]
39
40 --
41 2.25.1
42